17:00:16 <sergmelikyan> #startmeeting murano
17:00:17 <openstack> Meeting started Tue Feb  2 17:00:16 2016 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:20 <openstack> The meeting name has been set to 'murano'
17:00:46 <sergmelikyan> o/
17:00:47 <ativelkov> o/
17:00:51 <nikolay_st_holo> Hi
17:01:33 <kzaitsev_mb> o/
17:01:34 <freerunner> \o/
17:02:17 <kzaitsev_mb> o/
17:03:25 <sergmelikyan> Let's start with action items as usual? :)
17:04:31 <sergmelikyan> I assume this as yes :)
17:04:36 <sergmelikyan> #topic Action Items
17:04:39 <sergmelikyan> #1 kzaitsev_mb ask around packaging folks — how we should handle murano-glare plugin and murano-specific plugins packaging-wise
17:04:51 <kzaitsev_mb> yep, asked around
17:05:27 <kzaitsev_mb> the thing is — the way we currently have our plugin is perfectly fine
17:06:03 <kzaitsev_mb> just we should probably have those well documented for the packaging folks to know, that installing murano should also install the plugin
17:06:11 <kzaitsev_mb> (for glare for example)
17:06:40 <kzaitsev_mb> but otherwise no problem with having it the way we have it
17:07:06 <sergmelikyan> so we just leaving it as is? :)
17:07:37 <kzaitsev_mb> yep. we just need to have good docs
17:07:48 <kzaitsev_mb> Actually
17:08:06 <kzaitsev_mb> I've just (20 mins ago) thought, that we should ask around the kolla folks
17:08:52 <sergmelikyan> I guess they storing details regarding each package as part of they repo
17:08:57 <kzaitsev_mb> like if they run murano and glance in a separate container — how would they install murano-glare plugin
17:09:06 <sergmelikyan> kzaitsev_mb: or what actual question you are planning to ask?
17:09:17 <kzaitsev_mb> is that even possible
17:09:46 <sergmelikyan> kzaitsev_mb: I guess they would install murano-glare plugin alongside with murano to GLance container
17:09:56 <sergmelikyan> where murano will be used as a library
17:10:06 <sergmelikyan> and separate container with Murano itself
17:10:12 <kzaitsev_mb> sergmelikyan: doesn't it defeat the whole idea of kolla?
17:10:14 <kzaitsev_mb> huh
17:10:36 <sergmelikyan> kzaitsev_mb: I don't know what is whole idea of Kolla you are talking about
17:10:42 <kzaitsev_mb> well, to be more precise — iyozhikov told me that current situation is ok
17:10:43 <sergmelikyan> if running in container - then no
17:10:53 <sergmelikyan> if strict separation - they probably yes
17:10:54 <kzaitsev_mb> and zigo suggested we push our plugin into glare somehow
17:11:03 <kzaitsev_mb> I think that I actually see the point now )
17:12:08 <kzaitsev_mb> Anyway we should really start with documenting that thing
17:12:20 <kzaitsev_mb> the way murano-glare plugin should be installed
17:12:25 <kzaitsev_mb> and where it resides
17:12:58 <kzaitsev_mb> hm
17:12:59 <sergmelikyan> For sure - especcialy if we want to have it enabled by default in Newton
17:13:14 <kzaitsev_mb> I kind of see the problem zigo mentioned now
17:13:51 <zigo> :)
17:14:01 <kzaitsev_mb> if the plugin is not in glare package — we whould need to somehow install it to the env glare runs in.
17:14:15 <kzaitsev_mb> unless they-re all global — this might be a problem
17:14:40 <kzaitsev_mb> anyway. I suggest we start with documenting the whole installation and reasoning and stuff
17:15:21 <kzaitsev_mb> and then approach pacaging folks once again with it. =) as long as everything is not installed in it's onw venv — current approach looks fine to me
17:15:39 <kzaitsev_mb> also I'd like to approach kolla folks on that one
17:16:02 <kzaitsev_mb> #action ask kolla folks about murano-glare situation
17:16:20 <sergmelikyan> I was just about to ask you to add action item :)
17:17:02 <kzaitsev_mb> sergmelikyan: 2d AI then? =)
17:17:10 <sergmelikyan> yeah :)
17:18:31 <kzaitsev_mb> I've sent a mail to openstack-infra on that one, like AJaegar suggested, but got no response
17:18:42 <kzaitsev_mb> #link http://lists.openstack.org/pipermail/openstack-infra/2016-January/003704.html
17:18:53 <sergmelikyan> #2 verify that all tags are present in master, and check how we would be able to access juno code before deleting juno branch
17:18:59 <kzaitsev_mb> gotta ping around the #infra guys on that
17:19:19 <kzaitsev_mb> so the situation is the following — we do not have anything unreleased in juno
17:19:31 <kzaitsev_mb> everything *will* be accessible through tags
17:19:36 <freerunner> kzaitsev_mb Looks like you forgot to add [murano] tag into title =(
17:19:41 <kzaitsev_mb> so it's safe to remove the branches
17:19:42 <sergmelikyan> and we don't have rights to remove the branch by ourselvs
17:19:50 <kzaitsev_mb> yep. this.
17:20:02 <kzaitsev_mb> freerunner: it's a different ML, not openstack-dev
17:20:09 <kzaitsev_mb> you're probab;y not subscribed to ir
17:20:23 * kzaitsev_mb types a bit too fast =)
17:20:53 <kzaitsev_mb> sergmelikyan: I'll ping infra folks on the topic of the mail )
17:21:08 <kzaitsev_mb> AJ told me most of admins were travelling last week )
17:21:18 <kzaitsev_mb> anyway. it's safe to remove juno )
17:21:55 <sergmelikyan> still sad about that :)
17:22:04 <sergmelikyan> I mean about deletion of the branch :)
17:22:30 <sergmelikyan> But I see the point about expectations of users when they see the branch
17:23:08 <sergmelikyan> freerunner: guys what is the difference between #2 and #3?
17:23:11 <sergmelikyan> http://eavesdrop.openstack.org/meetings/murano/2016/murano.2016-01-26-17.00.html
17:23:15 <sergmelikyan> I mean action items
17:23:34 <kzaitsev_mb> sergmelikyan: nope. I think bot whent a bit crazy
17:23:56 <sergmelikyan> than moving to third:
17:24:01 <sergmelikyan> ops
17:24:04 <sergmelikyan> fourth
17:24:13 <kzaitsev_mb> maybe I tried to undo something and it didn't get me right last time
17:24:24 <sergmelikyan> put info on six usage to http://docs.openstack.org/developer/murano/contributing.html
17:24:27 <sergmelikyan> #4 ^
17:24:35 <sergmelikyan> stan_lagun:
17:25:34 <kzaitsev_mb> stan_lagun: had you had a chance to update the docs with your guideline suggestions? =)
17:25:51 <stan_lagun> kzaitsev_mb: I've put the items in etherpad https://www.anonymox.net/clients/clientarea.php?action=productdetails&id=70192
17:26:00 <stan_lagun> but still hasn't converted it to a document
17:26:24 <kzaitsev_mb> it requires auth О_о
17:26:41 <stan_lagun> sorry wrong link :)
17:26:46 <stan_lagun> https://etherpad.openstack.org/p/murano-contributors-rules
17:26:58 <nikolay_st_holo> Nice o_O
17:27:10 <kzaitsev_mb> #link https://etherpad.openstack.org/p/murano-contributors-rules
17:27:27 <kzaitsev_mb> awesome! =)
17:28:00 <stan_lagun> also i wrote a document about core library design guidelines
17:28:02 <stan_lagun> https://docs.google.com/document/d/108NAkuzT9eZ5AC1Rkw-p1eOiRbkICWQTPqpW0GVb8nw/edit#
17:28:09 <stan_lagun> It should be publicly open
17:28:15 <kzaitsev_mb> I'd actually vote for waiting maybe another week, before asking someone to transfer those to contributing guide
17:28:32 <stan_lagun> We may use parts of it for the contributing guide as well
17:29:05 <kzaitsev_mb> those two are awesome =) should form a solid base for murano-specific contribution guide =)
17:29:15 <sergmelikyan> agree!
17:30:06 <kzaitsev_mb> #idea Think about more contribution rules and add them to https://etherpad.openstack.org/p/murano-contributors-rules
17:30:28 <kzaitsev_mb> this way ^^ we'll remember about the document without specific AIs =)
17:31:49 <sergmelikyan> Let's move to the main agenda?
17:31:51 <kzaitsev_mb> (first time I used #idea =)))
17:31:56 <kzaitsev_mb> sergmelikyan: +1
17:32:17 <sergmelikyan> kzaitsev_mb: I guess you are also first who used it on Murano meeting ever
17:32:20 <sergmelikyan> :)
17:32:36 <sergmelikyan> #topic Drop Babel from agents requirements and do not use i18n tools in agent
17:32:40 <kzaitsev_mb> yep, haven't seen it used anywhere, tbh
17:32:41 <sergmelikyan> I support this
17:32:57 <sergmelikyan> I mean, support removal translation from the murano-agent
17:33:06 <kzaitsev_mb> ok so the rationale is that we have Babel as 1 of the requirements for murano agent, but
17:33:13 <sergmelikyan> murano-agent is a daemon, so I don't see a reason to have a translation there
17:33:20 <kzaitsev_mb> there are only like 5 lines that are eligible for translation
17:33:21 <ativelkov> +1
17:33:30 <kzaitsev_mb> and we do not use oslo_i18n there yet
17:33:35 <stan_lagun> +1. Now that we download murano-agent with cloud-init Babel that is the largest Python package agent uses (6.5Mb) just slows down the installation
17:33:38 <kzaitsev_mb> and I haven't yet setup translation jobs )
17:33:47 <kzaitsev_mb> and babel weights like 6mb
17:33:53 <nikolay_st_holo> +1
17:33:55 <kzaitsev_mb> #link https://pypi.python.org/pypi/Babel
17:34:22 <kzaitsev_mb> ok, so I suggest we put it in the contribution guide, then and remove babel from requirements =)
17:34:41 <sergmelikyan> kzaitsev_mb: why to contribution guys?
17:34:44 <kzaitsev_mb> I think, that there is no need for voting )
17:34:53 <sergmelikyan> today I ready bad with typing
17:35:03 <sergmelikyan> why to put it to contribution guide?
17:35:11 <sergmelikyan> kzaitsev_mb: +1
17:35:17 <kzaitsev_mb> sergmelikyan: I suggest, that we put in the contributing guide, that we do not want i18n suite in murano-agent
17:35:37 <kzaitsev_mb> so that someone would not attempt to add it
17:35:38 <sergmelikyan> kzaitsev_mb: yeah, why do you think it should be there?
17:35:41 <stan_lagun> doesn't seem like it belongs there
17:35:41 <sergmelikyan> Ah
17:35:52 <kzaitsev_mb> might be somewhere
17:35:55 <kzaitsev_mb> else
17:36:14 <kzaitsev_mb> I just think, it would be a good idea to document todays decision
17:36:42 <kzaitsev_mb> probably — we could add it in murano-agent doc article
17:37:56 <kzaitsev_mb> it's just that I can imagine random people coming to murano-agent adding oslo_i18n (and thus babel back), linking to OS i18n guidelines and such. =)
17:38:24 <nikolay_st_holo> :-D
17:38:38 <sergmelikyan> kzaitsev_mb: don't remember people doing that with other projects so far :)
17:38:48 <enthurohini> kzaitsev_mb, is it possible to write code without any link to bug or spec or BP?
17:39:04 <kzaitsev_mb> enthurohini: sure. =)
17:39:10 <kzaitsev_mb> although usually discouraged
17:39:17 <enthurohini> ok
17:39:28 <sergmelikyan> enthurohini: some small improvements, but I think kzaitsev_mb expected to have code with a BP like "add translation to murano-agent"
17:39:39 <kzaitsev_mb> sergmelikyan: do you agree, that it's a good idea to document this decision? =)
17:40:51 <sergmelikyan> kzaitsev_mb: still no :)
17:41:01 <kzaitsev_mb> #agree remove babel from murano-agent
17:41:01 <enthurohini> kzaitsev_mb, i think, if anyone will do this, will discuss first
17:41:08 <kzaitsev_mb> ok, then )
17:41:17 <kzaitsev_mb> let's just remove babel, then
17:41:50 <kzaitsev_mb> #agreed to remove babel from murano-agent
17:42:01 <kzaitsev_mb> oops, it's agreed, not agree (=
17:42:35 <sergmelikyan> :)
17:42:50 <sergmelikyan> #topic Call to gather ideas for GSOC (kzaitsev)
17:43:03 <kzaitsev_mb> ok, so there's been a letter from vkmc lately
17:43:12 <kzaitsev_mb> about call for ideas for GSOC
17:43:33 <kzaitsev_mb> we had a very nice outreachy experience (thanks enthurohini =))
17:44:11 <enthurohini> my pleasure :). want to part of GSoC ase well
17:44:16 <kzaitsev_mb> So I suggest, that we collectively would throuw ideas, about features we can give as 3-4 months ideas for GSOC
17:44:53 <kzaitsev_mb> #link https://etherpad.openstack.org/p/murano-2016-gsoc-ideas
17:45:10 <kzaitsev_mb> #idea let's add some ideas for GSOC to https://etherpad.openstack.org/p/murano-2016-gsoc-ideas
17:45:35 <kzaitsev_mb> GSOC stans for Google Summer of Code, if that's not obvious )
17:46:12 <sergmelikyan> kzaitsev_mb: do I understand correctly that it's some new cool feature, same as Outreachy?
17:46:13 <enthurohini> and GSOC is a 3 month internship as outreachy
17:46:17 <sergmelikyan> (at least close to that)
17:46:32 <ativelkov> it's not that new
17:46:35 <stan_lagun> stans for :)
17:46:43 <kzaitsev_mb> #link http://lists.openstack.org/pipermail/openstack-dev/2016-February/085508.html
17:46:59 <kzaitsev_mb> sergmelikyan: not necessarily )
17:47:13 <enthurohini> sergmelikyan, it is like oytreachy, but it allows to participate both male nd female
17:47:47 <kzaitsev_mb> looks like "The deadline for mentoring organizations applications is 19/02/2016"
17:48:14 <kzaitsev_mb> so I'm going to take an AI and check if we (murano) needs to do anything to have registered
17:48:34 <kzaitsev_mb> #action check with GSOC folks if murano need some official registration for GSOC
17:50:03 <sergmelikyan> kzaitsev_mb: thank you :)
17:51:28 <kzaitsev_mb> anyway that's my request for you folsk — to think of features, similar to the ones we had for outreachy, that we would want to see implemented during GSOC =) I hope we'll have a couple =)
17:51:50 * kzaitsev_mb types waaay too fast )
17:52:34 <sergmelikyan> #topic Open Discussion
17:52:47 <kzaitsev_mb> like we could dig that muranoPL debugger back from the dead, or maybe YAQL.js thingy )
17:54:39 <ativelkov> Folks, what about asking the community about the potential interest for having a midcycle meetup?
17:57:06 <nikolay_st_holo> Ativelkov: good point
17:57:20 <kzaitsev_mb> ativelkov: is there really a point in that? =)
17:57:55 <ativelkov> well, we may estimate the posssible attendance and make a decision if we need it or not
17:58:04 <stan_lagun> +1 for meetup anyway
17:58:12 <kzaitsev_mb> It'd be nice to meet with telefonica guys, but I haven't seen henar around for a while
17:58:44 <stan_lagun> I'm sure she's going to be at N summit
17:58:52 <kzaitsev_mb> would be nice to see zhurong also ) (at least to make sure he doesn't hold a grudge against me ))
17:59:07 <sergmelikyan> :D
17:59:08 <freerunner> kzaitsev_mb: What about zhurong and lin_a_yang? Nt only Telefonica guys contributed to murano ;)
17:59:13 <kzaitsev_mb> ativelkov: who would you like to meet
17:59:26 <freerunner> kzaitsev_mb: Nah, quick typing kzaitsev_mb
17:59:31 <sergmelikyan> I guess we are almost out of time, I will take AI to send e-mail regarding that
17:59:47 <kzaitsev_mb> the think is I suggest we reach out to specific folks (most active in murano) alongside with just writing an email to openstack-dev ML
18:00:06 <ativelkov> kzaitsev_mb: anybody interested in long-term murano's roadmap planning
18:00:12 <sergmelikyan> #action sergmelikyan ask community about the potential interest for having a midcycle meetup?
18:00:17 <sergmelikyan> #endmeeting