17:00:55 <sergmelikyan> #startmeeting murano
17:00:56 <openstack> Meeting started Tue Feb 23 17:00:55 2016 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:59 <openstack> The meeting name has been set to 'murano'
17:01:00 <sergmelikyan> o/
17:01:12 <slagun> o/
17:01:14 <enthurohini> o/
17:01:20 <tlashchova_> o/
17:01:39 <sergmelikyan> Hi folks :)
17:02:19 <kzaitsev_mb> \o
17:02:24 <DmytroDovbii> o/
17:02:32 <freerunner> o/
17:03:49 <sergmelikyan> left hand hi vs right hand hi :D
17:06:12 <sergmelikyan> #topic Action Items Review
17:06:14 <sergmelikyan> #1 kzaitsev_mb ask kolla folks about murano-glare plugin situation
17:07:10 <kzaitsev_mb> yep
17:07:28 <kzaitsev_mb> so current situation is very uncomfortable for packaging folks
17:07:38 <kzaitsev_mb> both kolla and regular ones
17:07:59 <kzaitsev_mb> the best option packaging-wise would be to move the plugin to a separate repo
17:08:17 <kzaitsev_mb> 2d best approach would be to move all the plugins to the repository the plug into
17:08:47 <kzaitsev_mb> Sort of like searchlight does
17:08:58 <sergmelikyan> didn't get second approach
17:09:07 <sergmelikyan> you mean gather all plugins in the one repo>
17:09:08 <sergmelikyan> ?
17:09:41 <kzaitsev_mb> if glare plugin for murano would live besides glare — it would be easy for packagers to package/apply it
17:10:43 <kzaitsev_mb> after all the code would need some glare-common dependencies (since it doesn't really import anything murano-specific, but does import a bunch of code from glance)
17:11:00 <kzaitsev_mb> sergmelikyan: no i mean gather plugins in a repo they plug into
17:11:12 <sergmelikyan> kzaitsev_mb: but it will import something Murano specific at somepoint....
17:11:26 <sergmelikyan> got it...
17:11:55 <sergmelikyan> I am ok with first approach, kzaitsev_mb what do you prefer?
17:12:02 <kzaitsev_mb> sergmelikyan: then a separate repo would probably be the best option, when that happens, since it would depend on murano-code and glance code
17:12:08 <kzaitsev_mb> sergmelikyan: I'm not sure, tbh
17:12:50 <kzaitsev_mb> the cons of the separate repo is that it feels like a giant overkill for such a small piece of code
17:12:52 <sergmelikyan> I am wondering what mfedosin and ativelkov think about that
17:13:43 <sergmelikyan> kzaitsev_mb: I guess this part will grow substantially when we will switch by default to the glare and will start to increase our catalog capabilities
17:13:53 <kzaitsev_mb> We wouldn;t be able to change anything for kolla folks in M, but the problem is a bit wieder than just that
17:14:17 <kzaitsev_mb> also kolla folks wanted to have a fishbowl in Austin
17:14:21 <kzaitsev_mb> regarding plugins
17:14:43 <kzaitsev_mb> to figure out if there is a single "right" way to do plugins in openstack
17:14:58 <kzaitsev_mb> since plugins is a bit of a pain for them apparently =)
17:15:22 <kzaitsev_mb> sergmelikyan: afaik glare currently doesn't allow any custom logic in plugins
17:15:45 <kzaitsev_mb> not validation anyway. and custom db logic is also a WIP
17:15:58 <kzaitsev_mb> so probably won't grow untill newton.
17:16:04 <sergmelikyan> than it's really super small piece of code :(
17:17:23 <kzaitsev_mb> I think, that we should go to the whiteboard and write out all the pros/cons of each option
17:17:29 <kzaitsev_mb> and wight them somehow
17:19:00 <kzaitsev_mb> maybe having a murano-glare-plugin repo, is not that bad after all
17:19:14 <kzaitsev_mb> let's draft an etherpad?
17:19:32 <sergmelikyan> +
17:20:09 <sergmelikyan> agree, tho I have a feeling that having them in Glance tree is not an option
17:20:22 <sergmelikyan> so we actually down to only one option anyway
17:20:35 <sergmelikyan> but nothing bad in asking
17:21:18 <kzaitsev_mb> sergmelikyan: I'll drop by artifacts-sub-team meeting next monday
17:21:29 <kzaitsev_mb> mfedosin and nikhil might have some ideas )
17:21:33 <sergmelikyan> kzaitsev_mb: thank you, appreciate that
17:22:07 <sergmelikyan> #action kzaitsev_mb drop by artifacts-sub-team meeting next Monday ad ask about storing murano-plugin with glare
17:22:17 <kzaitsev_mb> (I try to attend it anyway, to get their attention at app-cat glare plugin =))
17:22:40 <sergmelikyan> #topic Open Discussion
17:23:08 <kzaitsev_mb> #link https://etherpad.openstack.org/p/murano-glare-plugin-location
17:23:22 <kzaitsev_mb> I'll fill it in later today/tomorrow
17:23:38 <kzaitsev_mb> just so it's in the logs
17:25:18 <sergmelikyan> thx
17:25:32 <sergmelikyan> I will try to take a look :)
17:33:48 <sergmelikyan> looks like we out topic for today :)
17:33:54 <sergmelikyan> #endmeeting