17:00:49 <kzaitsev_mb> #startmeeting murano
17:00:50 <openstack> Meeting started Tue Jun 14 17:00:49 2016 UTC and is due to finish in 60 minutes.  The chair is kzaitsev_mb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:54 <openstack> The meeting name has been set to 'murano'
17:01:19 <kzaitsev_mb> #topic rollcall
17:01:20 <kzaitsev_mb> o/
17:01:22 <vakovalchuk_> o/
17:01:26 <Nikolay_St> o/
17:01:29 <tlashchova_> o/
17:01:34 <lin_yang> o/
17:02:21 <ddovbii__> o/
17:02:34 <kzaitsev_mb> we have pretty thin agenda for today )
17:02:52 <kzaitsev_mb> #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:03:40 <freerunner> o/
17:04:47 <lexplua> o/
17:05:20 <kzaitsev_mb> #topic Action Items review
17:05:27 <kzaitsev_mb> 1) Nikolay_St ping heat team if it's a good idea to enable convergence on our CI
17:05:38 <kzaitsev_mb> Nikolay_St: have you had a chance? =)
17:06:19 <kzaitsev_mb> or would it be enabled by default in devstack anyways? And since our CI installs heat from devstack — it would be enabled automatically
17:07:09 <Nikolay_St> kzaitsev_mb: I have a discussion with Sergey
17:07:20 <Nikolay_St> he said that we can do it for free :)
17:07:48 <Nikolay_St> personally, I plan to enable convergence on our CI on 'experimental' host
17:07:48 <kzaitsev_mb> for free — you mean it would be turned on automatically, or that we're free to do it?
17:07:52 <ativelkov> o/
17:07:54 <ativelkov> sorry bor being late
17:07:58 <Nikolay_St> kzaitsev_mb: we are free to do it
17:08:46 <kzaitsev_mb> cool, let's enable it before n2 then )
17:08:59 <kzaitsev_mb> 2) kzaitsev_mb vakovalchuk see that backports from prev review iteration are merged
17:09:30 <kzaitsev_mb> we still have 2 patches not up on review from last time, but that activity is blocked by stable/mitaka being red.
17:09:35 <kzaitsev_mb> so gotta fix that first
17:10:07 <kzaitsev_mb> #action Nikolay_St test convergence on our CI and get ready to enable it
17:10:25 <kzaitsev_mb> #action kzaitsev_mb vakovalchuk see that backports from prev review iteration are merged after stable/mitaka is unlocked
17:10:38 <kzaitsev_mb> k. guess that's all with the action items
17:10:45 <kzaitsev_mb> #topic Open Discussion
17:11:21 <kzaitsev_mb> I have a couple of updates, I can share =)
17:11:45 <kzaitsev_mb> #link https://pypi.python.org/pypi/yaql/1.1.1
17:12:31 <kzaitsev_mb> 1.1.1 yaql is released with py3 fixes. meaning that soon it's going to be updated in the upper-constraints and allowing us to enable a lot of our py3 tests blocked by it
17:12:38 <kzaitsev_mb> thanks ativelkov =)
17:13:27 <kzaitsev_mb> #link http://lists.openstack.org/pipermail/openstack-dev/2016-June/097287.html
17:14:32 <kzaitsev_mb> I'd also like to bring this email to the teams attention. Continuing the initiative led by Sergey Kraynev on separating murano-apps into a separate team.
17:16:27 <kzaitsev_mb> I've got a couple more email drafts, that I'm about to write later today =)
17:16:49 <sergmelikyan> I talked with infra team regarding taking ownership of murano.io by foundation/community, we need approval from foundation and that openstack-infra team can move domain and than we can talk what we should host on that domain (openstack specific page?)
17:17:14 <kzaitsev_mb> #link http://murano.io
17:17:25 <kzaitsev_mb> seen that happening just couple of minutes ago =)
17:19:41 <kzaitsev_mb> sergmelikyan: don't really know. Should it be just a collection of links to pages involving murano? i.e docs, releasenotes, apps.openstack.org, project navigator, etc?
17:20:30 <sergmelikyan> kzaitsev_mb: I am ok with anything, main point is domain is taken by our project and we safely use that in namespaces
17:24:14 <kzaitsev_mb> sergmelikyan: haven't we planned to change it to murano.examples or smth similar to give devs visual hints, that FQNs are actually not magic at all
17:24:42 <kzaitsev_mb> io.murano should only probably stay in the core library itself
17:25:05 <kzaitsev_mb> still a valid point to use it there =)
17:25:13 <sergmelikyan> :)
17:26:16 <kzaitsev_mb> I'm planning to get a letter on fqn usages soon and it's really nice, that murano.io is up again. Would make a simple point about how and why we have it in our class names =)
17:26:35 <kzaitsev_mb> thanks for bringing this up =)
17:27:03 <kzaitsev_mb> ok. I think I'm out of news/updates. Does anyone have anything to add/ask? =)
17:28:02 <kzaitsev_mb> lin_yang: lexplua: maybe you gyus? =)
17:28:49 <lexplua> I don`t think so
17:28:56 <lin_yang> kzaitsev_mb: no more from me.thanks for asking
17:30:42 <kzaitsev_mb> ok then, I'll wait 5-10 more mins in case anyone has anything for discussion and would end the meeting early
17:37:12 <lexplua> I have 1 question
17:37:47 <lexplua> Do we force python2.7 usage on murano-spawned instances in some way ?
17:38:34 <lexplua> ativelkov ?
17:38:36 <kzaitsev_mb> lexplua: nope, I don't think we force it in any way
17:39:17 <ativelkov> we don't. But in py26 environments murano-agent may not get installed properly, afair
17:39:35 <ativelkov> for the cases when the image has no pre-installed agent
17:40:32 <kzaitsev_mb> true — as a workaround — you can make an image with pre-built murano-agent, that still supports py26
17:40:44 <kzaitsev_mb> gotta check which version still supported it though )
17:41:35 <lexplua> Ok, thank you
17:46:38 <kzaitsev_mb> ok, thanks everyone for attending!
17:46:44 <kzaitsev_mb> #endmeeting