17:00:26 <kzaitsev_mb> #startmeeting murano
17:00:27 <openstack> Meeting started Tue Jun 21 17:00:26 2016 UTC and is due to finish in 60 minutes. The chair is kzaitsev_mb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:31 <openstack> The meeting name has been set to 'murano'
17:00:38 <Nikolay_St> o/
17:00:43 <kzaitsev_mb> o/
17:00:54 <oshykhkerimov> o/
17:01:11 <ddovbii__> o/
17:01:30 <vakovalchuk> o/
17:01:39 <zhurong> o/
17:01:39 <freerunner> \o/
17:02:06 <StanLagun> o/
17:02:07 <kzaitsev_mb> #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:02:12 <sergmelikyan> :)
17:02:18 <kzaitsev_mb> #topic Action Items Review
17:02:29 <kzaitsev_mb> I think we had a couple, didn't we?
17:02:49 <kzaitsev_mb> 1) kzaitsev_mb vakovalchuk see that backports from prev review iteration are merged after stable/mitaka is unlocked
17:03:09 <kzaitsev_mb> they're on the review last time i checked
17:03:37 <vakovalchuk> I guess they are merged already
17:03:42 <kzaitsev_mb> oh, cool
17:03:47 <kzaitsev_mb> so done then
17:03:50 <kzaitsev_mb> 2) Nikolay_St test convergence on our CI and get ready to enable it
17:04:12 <Nikolay_St> not ready yet
17:04:28 <kzaitsev_mb> Nikolay_St: is it time to turn the switch?
17:05:15 <Nikolay_St> I don't test it on second host as I want to do, but we can switch and just be prepared for troubles
17:05:26 <Nikolay_St> if any
17:05:50 <kzaitsev_mb> hah )
17:06:21 <kzaitsev_mb> it's not n2 yet, so I'm ok with waiting a bit longer
17:06:55 <Nikolay_St> kzaitsev_mb: I'll try to do my best for enabling it on test host this week
17:07:32 <Nikolay_St> just realized that blocked dashboard is not really blocker for that
17:07:40 <kzaitsev_mb> #action Nikolay_St check convergence on 2d CI host and enable it
17:07:44 <kzaitsev_mb> np )
17:08:09 <kzaitsev_mb> like I said we're not in a hurry here, just good to remember that we have this task on the horizon
17:08:22 <kzaitsev_mb> ok, on to our 1st topic
17:08:48 <kzaitsev_mb> #topic Migration to Glance V2 API
17:08:57 <Nikolay_St> ok
17:09:01 <kzaitsev_mb> Nikolay_St: can you share a link to the bp you've created
17:09:02 <kzaitsev_mb> ?
17:09:25 <Nikolay_St> #link: https://blueprints.launchpad.net/murano/+spec/migrate-to-glance-v2
17:10:21 <Nikolay_St> I added this topic and created this bp because now it's clear that glance community won't add 'copy-from' operation to V2 API
17:10:31 <kzaitsev_mb> so my real problem with it is that this is a *huge* degrading of the UX
17:11:03 <kzaitsev_mb> However we would be forsed to abandon v1 at some point =(
17:11:40 <Nikolay_St> mfedosin: are you here?
17:11:48 <kzaitsev_mb> So for the CLI I would suggest to not download the images y default and have a switch for that
17:12:08 <mfedosin> Nikolay_St: o/
17:12:23 <kzaitsev_mb> like --download-images={yes,no}
17:12:29 <Nikolay_St> mfedosin: we discuss migration to Glance v2 for murano
17:12:33 <kzaitsev_mb> sergmelikyan: StanLagun: ^^^
17:12:45 <Nikolay_St> Nikolay_St: looks valid for me
17:12:51 <Nikolay_St> kzaitsev_mb: ^^
17:13:33 <kzaitsev_mb> and keep v1 behaviour untouched (i.e. still use copy-from)
17:14:15 <mfedosin> I'm not sure, but saving data to temporary folder is not necessary
17:14:22 <kzaitsev_mb> because well, downloading a 5 GB image and then uploading it to glance would take a lot of time
17:14:35 <mfedosin> you just can open stream from given location and pass it to glance
17:14:42 <mfedosin> it should work
17:15:02 <Nikolay_St> mfedosin: what do you mean under 'open stream'?
17:15:25 <StanLagun> It will still download it locally. You cannot transfer stream hadle over the wire
17:15:26 <kzaitsev_mb> mfedosin: I'm not sure it's a good idea, since it would mean any error on any side would break the transfer
17:16:01 <kzaitsev_mb> StanLagun: true, although we can do it chunk by chunk
17:16:12 <kzaitsev_mb> but that is still a very error-prone way IMO
17:16:15 <mfedosin> we wanted to implement it in glanceclient, but the idea was rejected
17:16:26 <kzaitsev_mb> sad =(
17:16:36 <mfedosin> I mean when you use copy-from in glance v1 it doesn't store any data locally
17:16:37 <StanLagun> yes. I don't think it is a big deal. Local machine acts as a proxy in this scheme
17:17:36 <kzaitsev_mb> StanLagun: the biggest deal is that the process of importing a package suddenly takes 5 mins or more, depending on the image size/bandwidth
17:18:08 <StanLagun> That's okay. I hate the fact that we report that everything is imported when in fact it is not
17:18:30 <kzaitsev_mb> StanLagun: we don't =) we say, that we've scheduled them for reporting
17:18:34 <StanLagun> So as long as we don't consume gigs of hdd space locally I'm okay with that
17:18:36 <sergmelikyan> We report that we started downloading image, and you can't deploy app until it's uploaded
17:18:43 <kzaitsev_mb> StanLagun: and I disagree with you that it's ok
17:18:47 <kzaitsev_mb> it's a UX killer
17:18:52 <sergmelikyan> +1
17:19:20 <sergmelikyan> this will require to change a lot's of staff in Murano to make this acceptable
17:19:28 <kzaitsev_mb> Also this doesn't solve the dashboard at all, but
17:19:41 <kzaitsev_mb> I think I saw tsufiev's commit on that
17:19:48 <kzaitsev_mb> mfedosin: do you have a link at hand?
17:20:04 <mfedosin> kzaitsev_mb: unfortunately no
17:20:07 <StanLagun> if you cannot deploy apps that you need to wait anyway. I mean it is the matter of implementation. Of you block user from navigating to other pages then it's not good. If this is a background task with a progress bar in murano UI then nothing wrong here
17:20:35 <mfedosin> at least you can use glance v1 way and use glance_store to get data and pass it local storage
17:21:07 <kzaitsev_mb> #link https://review.openstack.org/#/c/320039/12
17:21:53 <kzaitsev_mb> mfedosin: that doesn't sound like a viable solution to me
17:22:14 <mfedosin> anyway...
17:22:17 <mfedosin> #link https://github.com/openstack/glance/blob/b9de463ee8c37c27e834a219367732b2177411a9/glance/api/v1/images.py#L654-L658
17:22:38 <mfedosin> and then just
17:22:40 <mfedosin> #link https://github.com/openstack/glance/blob/b9de463ee8c37c27e834a219367732b2177411a9/glance/api/v1/images.py#L689-L690
17:22:44 <kzaitsev_mb> there is a reason it starts with _ you know
17:23:25 <mfedosin> kzaitsev_mb: and I think you shouldn't expose it to public as well :)
17:24:20 <mfedosin> I'll review tsufiev's solution and provide a feedback
17:24:59 <kzaitsev_mb> We can also fork a new process for downloading/proxying the image in the CLI
17:25:10 <kzaitsev_mb> how bad does that sound?
17:26:51 <kzaitsev_mb> just asked tsufiev — he just removed copy-from in horizon
17:26:56 <kzaitsev_mb> =(
17:28:21 <kzaitsev_mb> yeah, that doesn't really leave us much option
17:29:17 <Nikolay_St> kzaitsev_mb: yeah, i discussed it with him
17:30:46 <kzaitsev_mb> I wonder how uploading huge images works in horizon though
17:31:03 <kzaitsev_mb> mfedosin: hey, does glare solve that in any form? =)
17:31:47 <kzaitsev_mb> like can I instruct glare to upload a BLOG from a http location?
17:33:44 <kzaitsev_mb> I believe tsufiev has implemented uploading of huge images without blocking the UI somehow
17:33:50 <kzaitsev_mb> gotta ask him on that )
17:34:33 <kzaitsev_mb> #action kzaitsev_mb ask tsufiev/horizon team about the possibility to upload huge images without blocking the UI
17:34:36 <kzaitsev_mb> as for the CLI
17:34:48 <sergmelikyan> this whole thing really can make implementation in Murano much more complex that it was before
17:35:20 <kzaitsev_mb> I tend to agree with StanLagun's idea that proxying an image is better then downloading
17:35:20 <sergmelikyan> I am wondering what was the reason behind so handy feature of removing this from glance v2
17:35:30 <kzaitsev_mb> althoug it will make code more complex
17:35:38 <kzaitsev_mb> any objections to that?
17:36:11 <kzaitsev_mb> sergmelikyan: personally I wonder what was the reason to deprecate an API that provided better functionality )
17:37:48 <kzaitsev_mb> I also suggest to add a --download images switch
17:37:55 <kzaitsev_mb> oh, that's actually a lot
17:38:11 <kzaitsev_mb> I guess we can write a spec for this
17:38:31 <Nikolay_St> kzaitsev_mb: that's a good idea
17:38:34 <sergmelikyan> is there a way to use glance_store directly?
17:38:45 <sergmelikyan> to upload staff?
17:38:57 <sergmelikyan> to upload staff and than point glance to it?
17:39:28 <StanLagun> I thought it is what glance client does
17:39:39 <kzaitsev_mb> sergmelikyan: sure, but that would mean we have to re-write part of the v1 client and I'm not sure that it would help us
17:40:09 <kzaitsev_mb> it would still be muranoclient, that handles the long-term communication, right?
17:40:37 <kzaitsev_mb> meaning the CLI/dashboard would be blocked, unless we fork/thread-out
17:42:15 <kzaitsev_mb> ok, I suggest Nikolay_St and I would draft a spec and we would list all the possible solutions there
17:42:19 <StanLagun> we could have import written in MuranoPL similar to long running deployments with reporting etc.
17:42:53 <kzaitsev_mb> because I doubt we would get to any meaningfull conclusion right now (=
17:43:20 <Nikolay_St> kzaitsev_mb: I agrre on that
17:44:14 <kzaitsev_mb> #action Nikolay_St kzaitsev_mb draft a spec with all the options we have considering swtiching from glance v1 to glance v2
17:44:30 <kzaitsev_mb> Nikolay_St, thanks for bringing this up
17:45:43 <kzaitsev_mb> ok, it's 2 weeks already since we last checked backports
17:46:21 <kzaitsev_mb> we haven't added anything regarding that to Murano Agenda, but I'll use #topic )
17:46:26 <kzaitsev_mb> #topic backports
17:46:40 <kzaitsev_mb> vakovalchuk: can you share a link to the etherpad? =)
17:46:53 <vakovalchuk> just a sec
17:47:06 <vakovalchuk> #link https://etherpad.openstack.org/p/murano-stable-backports
17:47:53 <kzaitsev_mb> I haven't really had time to check the list yet )
17:49:30 <kzaitsev_mb> So let's follow the usual procedure here — we have a couple of days to write comments, if you think we've missed something or that some patch is not worthy of being backported (i.e. too low or actualy is a feature) — please write that as comments to the etherpad =)
17:50:13 <kzaitsev_mb> vakovalchuk and I would get to backporting those by the end of the week =)
17:50:48 <kzaitsev_mb> I think there are a couple of low bugs there, that can be skipped, but like I said I haven't really checked those yet )
17:51:02 <kzaitsev_mb> vakovalchuk, thanks a lot for keeping this procedure going =)
17:51:09 <kzaitsev_mb> #topic Open Discussion
17:52:29 <Nikolay_St> long meeting today :D
17:52:37 <kzaitsev_mb> I think the only piece of news I have is — https://review.openstack.org/#/c/332093/
17:54:23 <kzaitsev_mb> thanks to haypo for his work on that ) now we gotta push those through the gerrit, as the gate check doesn't start for some reason )
17:54:39 <Nikolay_St> woohoo
17:54:39 <kzaitsev_mb> Nikolay_St: well, you've raised a really tough question this time =)
18:00:51 <kzaitsev_mb> ok, we're out of time. thanks everyone for joining today
18:00:54 <kzaitsev_mb> #endmeeting