17:00:39 <kzaitsev_mb> #startmeeting murano
17:00:40 <openstack> Meeting started Tue Jul 19 17:00:39 2016 UTC and is due to finish in 60 minutes.  The chair is kzaitsev_mb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:44 <openstack> The meeting name has been set to 'murano'
17:01:17 <kzaitsev_mb> #topic rollcall
17:01:24 <freerunner> \o/
17:01:24 <kzaitsev_mb> o/
17:01:29 <ddovbii> o/
17:01:32 <osh> \o/
17:01:35 <vakovalchuk> o//
17:02:34 <freerunner> ¯\_(ツ)_/¯
17:02:56 <kzaitsev_mb> d-_-b
17:04:54 <kzaitsev_mb> We didn't have any AI's from the past meeting
17:04:55 <kzaitsev_mb> yay
17:05:34 <Nikolay_St> hei
17:06:11 <kzaitsev_mb> so let's move straight to the agenda
17:06:15 <Nikolay_St> d^_^b
17:06:38 <kzaitsev_mb> #topic Backports
17:06:48 <kzaitsev_mb> it's that time of the month again
17:06:58 <vakovalchuk> yey
17:07:15 <kzaitsev_mb> vakovalchuk: do you have a new set of things ready for review? =)
17:07:28 <vakovalchuk> just a couple of them this time
17:07:30 <vakovalchuk> https://etherpad.openstack.org/p/murano-stable-backports
17:07:38 <vakovalchuk> #link https://etherpad.openstack.org/p/murano-stable-backports
17:07:45 <kzaitsev_mb> the usual place )
17:08:16 <kzaitsev_mb> I love how these things stack
17:08:22 <kzaitsev_mb> gives us some perspective )
17:08:41 <vakovalchuk> maybe not everybody added it to favorite sites yet :)
17:10:06 <kzaitsev_mb> vakovalchuk: actually I really like how we've built this process
17:10:19 <vakovalchuk> and good news that all items from previous time are merged
17:10:31 <kzaitsev_mb> comparing to previous cycles — we have a steady supply of things to backport
17:10:59 <kzaitsev_mb> now we only need to make distro packages out of those, to increase murano adoption %)
17:11:04 <vakovalchuk> kzaitsev_mb: thank you for the tool you've found
17:11:09 <kzaitsev_mb> I'll save that for open discussion
17:11:16 <kzaitsev_mb> %)
17:12:01 <kzaitsev_mb> ok, as usual — folks, take a look, if you feel some of the items do not belong there — comment. We'll make cherry-pick by the end of the week
17:12:26 <kzaitsev_mb> ok, done here
17:12:30 <kzaitsev_mb> #topic Convergence
17:12:40 <kzaitsev_mb> Nikolay_St: how is it going on the CI side? =)
17:14:14 <kzaitsev_mb> I guess he's AFK %)
17:14:33 <Nikolay_St> yeah
17:14:36 <Nikolay_St> I'm here
17:14:43 <Nikolay_St> just was a way for a minute
17:14:57 <kzaitsev_mb> sorry for choosing the unfortunate timing =)
17:15:18 <kzaitsev_mb> so both of our CI servers are running heat with convergence now, right?
17:15:29 <Nikolay_St> as far as we have both our servers reinstalled recently we have *fresh* heat in which convergence engine is enabled by default
17:15:41 <kzaitsev_mb> great!
17:15:46 <Nikolay_St> so, everythin works well =)
17:15:51 <kzaitsev_mb> any dowsides or problems so far?
17:15:55 <freerunner> wow, congrats Nikolay_St :)
17:16:26 <kzaitsev_mb> cool!
17:16:45 <Nikolay_St> freerunner: I have nothing to do with that ¯\_(ツ)_/¯
17:16:57 <kzaitsev_mb> keep us updated if anything would break =)
17:17:17 <kzaitsev_mb> but I guess we can safely forget about the thing for some time ))
17:17:51 <kzaitsev_mb> ok, all good with convergence
17:17:59 <kzaitsev_mb> #topic Mascot
17:18:21 <kzaitsev_mb> #link https://etherpad.openstack.org/p/murano-mascot
17:18:47 <kzaitsev_mb> the rules are here if you haven't read it
17:18:50 <kzaitsev_mb> #link http://www.openstack.org/project-mascots
17:19:20 <kzaitsev_mb> pls visit it today/tomorrow and leave your votes ;)
17:20:18 <kzaitsev_mb> we have time up to July 27th Also I think you can vote for multiple options if you're really torn between those =)
17:21:09 <kzaitsev_mb> I guess everyone on the meeting today has already seen the list %) So I'm not going to spend much time here
17:21:27 <kzaitsev_mb> #topic Open Discussion
17:22:52 <kzaitsev_mb> I'm going on vacation next week, folks, so I'm going to someone to take my place
17:23:02 <LanceHaig> I just wanted to introduce myself to the team. I am interested in the project and I am still seeing where I can get involved
17:23:18 <kzaitsev_mb> it would be from 25th to 3d of August
17:23:46 <kzaitsev_mb> I'm going to be eventually available, but obviously not as active as usual +)
17:24:23 <kzaitsev_mb> #action Write a letter appointing my deputies (kzaitsev_mb)
17:24:23 <vakovalchuk> hello, LanceHaig. welcome!
17:24:31 <kzaitsev_mb> LanceHaig: hello and welcome!
17:24:38 <kzaitsev_mb> feel free to hangout in #murano
17:24:49 <LanceHaig> I do :-)
17:24:55 <LanceHaig> Thanks
17:25:08 <kzaitsev_mb> also I'm planning to strap together a list of entry level tasks for murano
17:25:23 <Nikolay_St> sorry, I need to break. see you all, guys
17:25:24 <kzaitsev_mb> and share it sooner rather than later )
17:25:25 <freerunner> LanceHaig: Cool :) Nice to meet you :)
17:25:32 <kzaitsev_mb> Nikolay_St: np, thanks for the update!
17:26:05 <LanceHaig> kzaitsev_mb, cool when you have them I can see how I can help
17:26:09 <NanKe> it my first time to join the meeting ,too hello everyone Murano is a wonderful project ,we can make it better ;-)
17:26:55 <vakovalchuk> NanKe: hi!
17:26:56 <kzaitsev_mb> as usual you can look at https://bugs.launchpad.net/murano/+bugs?field.tag=low-hanging-fruit
17:27:19 <LanceHaig> kzaitsev_mb, Thanks I will take a look
17:27:30 <kzaitsev_mb> the list is short unfortunatelly, but we try to have some low-hangin-fruit bugs
17:27:31 <LanceHaig> Hey NanKe
17:28:10 <NanKe> hi LanceHaig
17:28:12 <kzaitsev_mb> you can help out with https://bugs.launchpad.net/murano/+bugs?field.tag=documentation doc's bugs, although they're usually a bit trickier
17:29:07 <kzaitsev_mb> also I'can share a couple of blueprints, where work would be appreciated and not really hard )
17:29:12 <DmytroDovbii> NanKe, LanceHaig, hi folks! Welome
17:29:20 <LanceHaig> As I don't write code for a living <i think the documentation is up my street for now. Until I get more knowledgeable on how Murano works
17:29:31 <freerunner> NanKe: \o/
17:29:46 <LanceHaig> is there a lace where this info is listed?
17:29:49 <kzaitsev_mb> #link https://blueprints.launchpad.net/python-muranoclient/+spec/openstack-client-plugin-support
17:30:00 <LanceHaig> then We can grab this off the list as an when we have time
17:30:06 <LanceHaig> haha
17:30:20 <kzaitsev_mb> I'd love to have some more hands on porting our client to OSC plugin, so feel free to grab some of those tasks
17:30:25 * LanceHaig was beaten tot he keyboard by kzaitsev_mb
17:30:56 <LanceHaig> great that looks like some good things to start with.
17:30:56 <kzaitsev_mb> also this bp
17:31:00 <kzaitsev_mb> #link https://blueprints.launchpad.net/murano/+spec/murano-unit-test-coverage
17:31:23 <kzaitsev_mb> we have an ambitious goal to have 95% coverage by newton )
17:31:34 <kzaitsev_mb> should be not hard to start ;)
17:32:28 <LanceHaig> ok good
17:32:37 <LanceHaig> some nice work to get my teeth into
17:32:50 <kzaitsev_mb> yep =)
17:32:51 <LanceHaig> Thanks
17:33:00 <kzaitsev_mb> I guess that should be enough for a start ))
17:33:17 <kzaitsev_mb> I'll share a list of entry-level tasks some time soon ;)
17:33:44 <kzaitsev_mb> for a general list of priorities you can refer to
17:33:51 <kzaitsev_mb> #link https://etherpad.openstack.org/p/murano-newton-priorities
17:35:01 <kzaitsev_mb> LanceHaig: NanKe: if you have any questions/problems — come ask in #murano
17:35:14 <LanceHaig> will do
17:36:41 <NanKe> I have recently started to use Murano
17:37:06 <NanKe> if i have any question  i will ask here thanks
17:38:18 <NanKe> in #murano  ;-)
17:38:37 <kzaitsev_mb> sure, please do )
17:39:24 <kzaitsev_mb> ok, so I wanted to say (I don't remember syaing that on prev meetings), that I'm slowly working towards getting murano packages for all the repos uptodate
17:39:45 <kzaitsev_mb> debian is currently the only one that has up-to-date murano
17:40:26 <kzaitsev_mb> so I'm in the process of getting updates to ubuntu (they have outdated packages) and RDO (they miss dashboard completely =( )
17:40:45 <kzaitsev_mb> this is a side task of mine, so it goes slow, but steady )
17:41:31 <kzaitsev_mb> if anyone wants to spend some of their free time, say on RDO packages — ping me, I'll share contacts
17:41:37 <kzaitsev_mb> although no pressure here )
17:42:59 <kzaitsev_mb> Or if anyone is a packaging expert by chance )
17:43:39 <LanceHaig> I used to package years ago so I don't think I would be much use
17:43:44 <LanceHaig> :-)
17:44:28 <NanKe> if there any patch about these job? i don't know how to do the job ,but maybe i can have have a try
17:44:41 <kzaitsev_mb> NanKe: we already have coverage job
17:44:49 <kzaitsev_mb> the thing is — we need more tests
17:45:29 <vakovalchuk> I feel some misunderstanding here
17:46:14 <kzaitsev_mb> `tox -e cover` will give you percentages and files, that we need to test more )
17:46:34 <kzaitsev_mb> vakovalchuk: what kind of misunderstanding? =)
17:47:17 <vakovalchuk> I'm not sure that NanKe was asking about that job. I think it was a question related to packaging job or something
17:47:44 <kzaitsev_mb> ah, never mind the packaging — It's a complicated topic anyways )
17:48:33 <LanceHaig> I will ask more questions about dev environments etc.. on the #murano channel
17:48:39 <NanKe> Some of the conversations I missed ......sorry
17:49:15 <kzaitsev_mb> ok, I think we've discussed most of the things we wanted
17:50:16 <kzaitsev_mb> So I suggest to save 10 mins of our time, unless anyone has anything to add =)
17:53:05 <kzaitsev_mb> ok, thanks everyone, see you in #murano and looking forward to helping you make new contributions!
17:53:11 <kzaitsev_mb> thanks for joining today
17:53:17 <kzaitsev_mb> #endmeeting