17:01:09 <kzaitsev_mb> #startmeeting murano
17:01:10 <openstack> Meeting started Tue Aug  9 17:01:09 2016 UTC and is due to finish in 60 minutes.  The chair is kzaitsev_mb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:13 <openstack> The meeting name has been set to 'murano'
17:01:17 <Nikolay_St> hi all
17:01:18 <kzaitsev_mb> o/
17:01:26 <kzaitsev_mb> hi folks I'm back =)
17:01:30 <Nikolay_St> sorry, I need to skip todays meetinh :(
17:01:53 <osh> \o/
17:02:06 <HoloIRCUser5> O/
17:02:32 <HoloIRCUser5> O/ 😃
17:02:54 <lexplua> o/
17:04:39 <ddovbii_> 0/
17:05:06 <kzaitsev_mb> let's see if there were any AI's from the last meeting
17:06:20 <kzaitsev_mb> 1) vakovalchuk Talk to the horizon team to finish the bugfix https://review.openstack.org/#/c/344871/
17:06:23 <kzaitsev_mb> just this one
17:06:50 <vakovalchuk_> hi folks. sorry for being late
17:07:08 <vakovalchuk_> and my app on the phone refused to change the nick
17:07:40 <kzaitsev_mb> np =) I've just been trying to reasch you with other means )
17:07:46 <kzaitsev_mb> so you had an AI from last time =)
17:07:52 <vakovalchuk_> the horizon team had merged that patch before I managed to talk to them :)
17:07:55 <kzaitsev_mb> btw thanks for handling the meeting ;)
17:07:58 <kzaitsev_mb> yay
17:08:33 <kzaitsev_mb> yep, I think I've just updated my horizon without seeing the bug, so I was wondering if it's gone
17:08:37 <kzaitsev_mb> good to hear that it is
17:08:59 <kzaitsev_mb> ok, our agenda for today is empty
17:09:01 <kzaitsev_mb> #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:09:08 <kzaitsev_mb> so let's hop right int open discussion
17:09:13 <kzaitsev_mb> #topic Open Discussion
17:09:49 <ddovbii_> folks, I have a topic to discuss
17:10:02 <kzaitsev_mb> I've actually wanted to discuss a couple of things (and I guess I should add them to our agenda next time to get more attention)
17:10:42 <ddovbii_> last week I prepared a doc with my proposal to restructure murano-apps repo
17:11:07 <kzaitsev_mb> ddovbii_: and you forgot to add the topic to agenda ;)
17:11:14 <ddovbii_> kzaitsev_mb, yep ((
17:11:33 <kzaitsev_mb> can you share a link to the etherpad?
17:11:41 <ddovbii_> ofc
17:11:42 <ddovbii_> https://etherpad.openstack.org/p/restructure-murano-apps
17:11:54 <kzaitsev_mb> #link https://etherpad.openstack.org/p/restructure-murano-apps
17:13:14 <ddovbii_> so folks, could you look at it and please share your thoughts
17:13:25 <kzaitsev_mb> ddovbii_: why is bind on the murano-apps?
17:14:12 <ddovbii_> do you think we should place it into separate repo?
17:14:49 <kzaitsev_mb> ah it's needed by the clearwater, right?
17:14:59 <lexplua> why not ? it's independent app
17:15:01 <kzaitsev_mb> so demoting it to an example would be a bad idea
17:15:25 <kzaitsev_mb> lexplua: because it brings little value on it's own and we can just say, that it's an example )
17:16:14 <ddovbii_> > ah it's needed by the clearwater, right? - yes
17:16:27 <kzaitsev_mb> lexplua: basically the idea is to clean up murano-apps repo. Some apps are simple and have little value, other than examples — those would be deleted or would go to murano repo under examples directory
17:16:58 <kzaitsev_mb> 2) some apps are important, but small enough for a separate repo — we'll leave them in murano-apps and would let the murano-apps handle them
17:17:21 <lexplua> Sure
17:17:46 <kzaitsev_mb> 3) and few are big enough to have repos of their own (namely k8s) — separate repo means independant release cycle, but also more responsibility and more effort to support
17:18:54 <kzaitsev_mb> ddovbii_: I would keep ActiveDirectory in murano-apps (since murano and murano-apps teams currently do not have plans to develop and support it independently)
17:19:11 <kzaitsev_mb> and I don't think we have a lot of Active Directory experts for that part )
17:19:59 <ddovbii_> kzaitsev_mb, yes, you are right. also, maybe we should create separate repo for all dockerized little apps?
17:20:23 <ddovbii_> murano-docker-hub =)
17:20:37 <kzaitsev_mb> not really sure it's a good idea =)
17:20:51 <kzaitsev_mb> maybe a sub-directory in k8s suite repo?
17:21:12 <kzaitsev_mb> If I could — I'd rather keep 2 or 3 of them, since they're all the same, tbh
17:21:46 <ddovbii_> in murano-apps?
17:23:06 <kzaitsev_mb> ddovbii_: nope, those in k8s
17:23:18 <ddovbii_> hm
17:23:19 <ddovbii_> ok
17:23:20 <kzaitsev_mb> in the k8s repository, I mean
17:24:07 <ddovbii_> that others think? ;)
17:24:12 <StanLagun> we should have example Windows apps. At least in order to see execution plan format because it differs
17:24:14 <ddovbii_> *what
17:26:19 <ddovbii_> StanLagun, well this app is quite difficult. I'm not sure that we should put it to murano-examples. maybe let's leave it in murano-apps?
17:26:29 <ddovbii_> ActiveDirectory I mean
17:26:42 <kzaitsev_mb> I'd also like to keep wordpress suite more or less intact, but actually it migth be ok to keep it in examples
17:26:51 <kzaitsev_mb> StanLagun: noted in https://etherpad.openstack.org/p/restructure-murano-apps
17:27:32 <StanLagun> well then we should spend some time on a better windows example which might take more time :)
17:30:16 <ddovbii_> we already have apache for linux. lets create some web server for windows =)
17:30:37 <kzaitsev_mb> ddovbii_: so this leaves us with only 2 separate repos for murano apps (if we rule out AD)
17:31:17 <kzaitsev_mb> I suggest you update the etherpad and we start implementing the changes )
17:32:08 <ddovbii_> kzaitsev_mb, yes. At least while the rest of the application is not started to rise =)
17:33:23 <kzaitsev_mb> ddovbii_: lets start slowly, this would bring some attention both from murano-team and murano-apps-team =) In case anyone would want to iterfere )
17:33:53 <ddovbii_> agree
17:34:04 <kzaitsev_mb> #agreed follow the plan described in https://etherpad.openstack.org/p/restructure-murano-apps
17:34:26 <kzaitsev_mb> ok, thanks for doing this ddovbii_! =)
17:34:42 <ddovbii_> no problem)
17:34:47 <kzaitsev_mb> there should be a #thanks or #praise tag %)
17:35:24 <kzaitsev_mb> ok, I wanted to discuss a couple of things, but would probably leave it to ML/next meeting, to put that on agenda
17:35:51 <kzaitsev_mb> #idea should we make gate-tempest-dsvm-murano-glare-backend voting
17:36:36 <kzaitsev_mb> Given that glare is moving to a separate project — there would certainly be some transition period
17:37:11 <kzaitsev_mb> i've pinged mfedosin and he promised, that the code would be intact, at least untill newton
17:37:47 <kzaitsev_mb> however last time it broke — it actually caught a bug
17:38:02 <kzaitsev_mb> (that should be fixed now that 0.10.0 is out)
17:40:31 <kzaitsev_mb> #action kzaitsev_mb move discussion about gate-tempest-dsvm-murano-glare-backend (and upcoming CI jobs) voting to ML
17:41:42 <kzaitsev_mb> 2) I'm going to write another letter to see if anyone uses our congress and mistrall integrations
17:42:15 <kzaitsev_mb> the job was broken for quite some time and no one expressed any interest in it =( which makes me a bit sad
17:42:41 <kzaitsev_mb> but then again this might mean that we have some dead code, that no one uses and dead code == tech debt
17:43:39 <kzaitsev_mb> I'd suggest to move the integration to contrib in the form of plugins (both congress and mistral), unless there is demand to use it in the current state from someone
17:43:55 <ddovbii_> +1
17:44:13 <kzaitsev_mb> if any of you guys know someone, who uses mistrall or congress integration in murano — pls ping them =)
17:44:36 <kzaitsev_mb> while I'm going to ask on ML )
17:45:24 <kzaitsev_mb> #action kzaitsev_mb ask on ML about congress/mistrall integrations and whether there are folks, who need/use them
17:46:31 <kzaitsev_mb> ok, that's all from my side
17:46:57 <kzaitsev_mb> anyone of you folks has anything to discuss/ask? =)
17:49:54 <kzaitsev_mb> ok, I assome not )
17:50:22 <kzaitsev_mb> thanks everyone for joining today, going to end the meeting 10mins earlier to save you guys some time )
17:50:28 <kzaitsev_mb> see you in #murano
17:50:31 <kzaitsev_mb> =)
17:50:39 <kzaitsev_mb> #endmeeting