17:00:34 <felipemonteiro> #startmeeting murano
17:00:35 <openstack> Meeting started Tue Feb 14 17:00:34 2017 UTC and is due to finish in 60 minutes.  The chair is felipemonteiro. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:38 <openstack> The meeting name has been set to 'murano'
17:00:59 <felipemonteiro> #topic Roll Call
17:01:05 <felipemonteiro> o/
17:01:15 <learnmore_> o/
17:01:30 <felipemonteiro> Hi learnmore_
17:01:55 <learnmore_> Hello
17:02:33 <learnmore_> No one else joining?
17:03:34 <kzaitsev_mb> o/
17:03:40 <kzaitsev_mb> hi folks )
17:03:55 <felipemonteiro> kzaitsev_mb: Hi
17:04:07 <learnmore_> kzaitsev_mb:  Hi
17:05:39 <felipemonteiro> #topic Open Discussion
17:06:02 <felipemonteiro> Thanks kzaitsev_mb for creating the stable/ocata release for murano: #link https://review.openstack.org/433604
17:06:52 <learnmore_> I have a question.   On the blueprints page for the new UI, there are 3 reviews listed.  I noticed all of them have been abandoned.  Does anyone know why?
17:06:54 <kzaitsev_mb> felipemonteiro: https://review.openstack.org/#/admin/groups/251,members here's the group for ptl
17:07:07 <kzaitsev_mb> I'm not sure it does anything though =)
17:07:19 <kzaitsev_mb> have just deleted myself from there
17:07:46 <kzaitsev_mb> also pls ping me for any  l-pad groups you want me to add you to
17:08:33 <felipemonteiro> learnmore_: Do you mean for example #link https://blueprints.launchpad.net/murano/+spec/dynamic-fields-on-service-details
17:09:18 <felipemonteiro> kzaitsev_mb: Thanks, will do. Did you see AJaeger's message to you yesterday? Asked about disabling python34 Jenkins gate for stable/mitaka
17:09:21 <felipemonteiro> #link https://review.openstack.org/#/c/429051/
17:09:50 <kzaitsev_mb> #link https://review.openstack.org/433604
17:10:05 <kzaitsev_mb> link only works if it's at the begining of the line )
17:10:18 <felipemonteiro> Thanks :)
17:10:23 <kzaitsev_mb> nope, did not see that one.
17:10:30 <kzaitsev_mb> would do so today
17:10:34 <kzaitsev_mb> let me fetch the logs
17:10:51 <kzaitsev_mb> my workstation got disconnected so I again lost my bot =(
17:11:16 <kzaitsev_mb> should probably launch a VM somewhere with the bot
17:11:31 <learnmore_> felipemonteiro:  this is the one I was referring to:  https://blueprints.launchpad.net/murano/+spec/schema-driven-ui
17:11:55 <felipemonteiro> There's also an issue with KeystoneV2AuthProvider in the tempest gate for stable/mitaka
17:12:04 <felipemonteiro> #link http://logs.openstack.org/51/429051/1/check/gate-tempest-dsvm-murano-api-ubuntu-trusty/e3d0fde/console.html.gz
17:14:58 <kzaitsev_mb> felipemonteiro: so we need to investigate py34 job, or is it a known issue and we should just disable it right away?
17:16:18 <felipemonteiro> learnmore_: That would be for the client-side. I wasn't around when development for that took place, so not sure. I would reach out to Timur Sufiev
17:16:26 <felipemonteiro> #link https://launchpad.net/~tsufiev-x
17:17:12 <learnmore_> felipemonteiro:  Thanks.  I will do that.
17:17:12 <kzaitsev_mb> #link http://eavesdrop.openstack.org/irclogs/%23murano/%23murano.2017-02-13.log.html#t2017-02-13T18:56:49
17:17:16 <felipemonteiro> kzaitsev_mb: I'm wondering when py34 support was added to stable/mitaka. It's been causing issues for a while.
17:18:19 <felipemonteiro> learnmore_: A lot of the server-side commits were merged though
17:18:20 <felipemonteiro> #link https://blueprints.launchpad.net/murano/+spec/muranopl-forms
17:19:09 <kzaitsev_mb> ugh there's a surge of stable/ocata patches )))
17:19:27 <learnmore_> felipemonteiro:  Yes, It is very good that the server-side commits were done.  That gives us a good start.
17:20:02 <kzaitsev_mb> #action kzaitsev_mb look into  https://review.openstack.org/#/c/429051/ and py34 job for stable/mitaka
17:20:21 <kzaitsev_mb> I'll see what's wrong with the gates and whether we can fix it
17:21:23 <felipemonteiro> kzaitsev_mb: I need to look into py27 bug I see in stable/ocata release for murano too
17:21:30 <felipemonteiro> #link https://review.openstack.org/#/c/433723/
17:21:57 <felipemonteiro> It might be a very deceptive bug, having to do with mock (in another test file) mocking out something in a different test file
17:23:57 <kzaitsev_mb> felipemonteiro: that one looks straightforward
17:24:20 <kzaitsev_mb> wouldn't a simple 'http://foo_glare_url' fix the issue?
17:25:04 <felipemonteiro> kzaitsev_mb: Yes, I thought so too. Like I said, I'll look into it. It may be very easy to fix, or require chasing down a mock conflict like I said.
17:25:20 <kzaitsev_mb> oh, ok )
17:25:44 <kzaitsev_mb> gates have this tendency to start falling apart around release time %)
17:26:04 <felipemonteiro> kzaitsev_mb: Also wanted to bring up what I think an Oracle dev wanted to remove:
17:26:07 <felipemonteiro> #link https://review.openstack.org/#/c/429889/
17:26:47 <felipemonteiro> They want to remove this, couldn't find any info on it. If we remove unsupported packages, then I don't see the problem.
17:28:20 <kzaitsev_mb> well yep
17:28:49 <felipemonteiro> I just think the timing is strange b/c it was merged in about 10 - 11 months ago
17:28:55 <kzaitsev_mb> the only thing is this was an example of integrating with an external service
17:28:57 <felipemonteiro> #link https://review.openstack.org/#/c/266521/
17:29:56 <kzaitsev_mb> but well, if folks don't want to support it anymore. I see little harm in actually removing the thing
17:30:09 <kzaitsev_mb> it's still in git history you know
17:30:19 <kzaitsev_mb> but having some rationale would be great though
17:30:40 <kzaitsev_mb> oh, it's in the commit message
17:31:00 <felipemonteiro> He came into #murano last week and kept asking that it be removed
17:31:41 <kzaitsev_mb> yep saw that, but was busy unfortunatelly =(
17:32:04 <felipemonteiro> Any other open discussion items? Otherwise wanted to talk about PTG
17:33:10 <learnmore_> So do you both agree that the package should be removed and will be?
17:33:56 <learnmore_> Just saw the +2 from Kirill.
17:34:28 <felipemonteiro> learnmore_: Yeah, I just wanted advice, because this would be the first time for me removing a large chunk of code from murano
17:35:19 <learnmore_> Onto the PTG, then
17:35:42 <felipemonteiro> #topic Atlanta PTG
17:36:17 <felipemonteiro> Most other teams are cancelling the IRC meeting next week, if there weren't any objections, I think we should do the same?
17:36:52 <kzaitsev_mb> sure
17:37:10 <kzaitsev_mb> that's usual thing around summit/ptg events
17:38:36 <felipemonteiro> Ok, I'll send out an openstack-dev reminder about that
17:40:05 <felipemonteiro> kzaitsev_mb: So far you and Stan Lagun said you'd meet in an unofficial capacity at the PTG. Was wondering what this would entail.
17:40:21 <kzaitsev_mb> ok, I actually have a bunch of things I'd love to discus on ptg as part of ptl transition and general direction )
17:40:34 <kzaitsev_mb> 1) release model/schedule
17:40:57 <kzaitsev_mb> we switched to cycle-with-intermediary in hopes of having faster, shorter releases
17:41:01 <kzaitsev_mb> but that didn't happen =(
17:41:11 <kzaitsev_mb> so maybe it would be a good idea to switch back?
17:41:18 <kzaitsev_mb> we only have untill p-1 to do so
17:41:51 <kzaitsev_mb> 2) we had an initiative that ensured, that murano would be runnable on a prev version of openstack
17:42:12 <learnmore_> what is p-1?
17:42:33 <kzaitsev_mb> part of that is gate-murano-tox-py27-mitaka branch
17:42:41 <kzaitsev_mb> p-1 is for pike-1
17:42:55 <kzaitsev_mb> https://releases.openstack.org/pike/schedule.html
17:42:59 <kzaitsev_mb> pike-1 milestone
17:43:13 <learnmore_> Thanks.  I am hoping that Pike will be released later this year.
17:43:27 <kzaitsev_mb> hm. I thought I saw an email today with a compiled schedule
17:43:46 <felipemonteiro> Do you mind updating https://etherpad.openstack.org/p/murano-atlanta-ptg
17:43:53 <kzaitsev_mb> well yeah. the other option is cycle-with-milestones
17:44:05 <felipemonteiro> #link https://releases.openstack.org/reference/release_models.html
17:44:07 <kzaitsev_mb> sure, would do
17:45:22 <kzaitsev_mb> so the question is — do we add tox-newton, delete tox-mitaka, leave both or delete both. It's an open question — on whether we would like to persue that idea
17:45:35 <learnmore_> We are depending on some features in Pike and would like to see this released this year.
17:46:59 <kzaitsev_mb> well I wouldn't have any hard feelings about the jobs )
17:47:14 <kzaitsev_mb> just want to have a consolidated opinion )
17:47:28 <kzaitsev_mb> I think I'll explain the rationale we had behind them at the PTG
17:47:29 <felipemonteiro> learnmore_: Which features? Could you be more specific :) If you attending the PTG, you could include your items on the etherpad too
17:48:11 <felipemonteiro> kzaitsev_mb: I'll need to look at the difference between tox-mitaka and tox-newton jobs first.
17:48:16 <kzaitsev_mb> learnmore_: it's not about not adding new features. It's about being able to run murano code on -1 version of openstack code
17:48:43 <kzaitsev_mb> or -2 =)
17:48:52 <kzaitsev_mb> felipemonteiro: that's the catch =) there is no such job )
17:48:58 <kzaitsev_mb> now is the time to create it
17:49:05 <kzaitsev_mb> or update the tox-mitaka
17:49:15 <felipemonteiro> Do you meangate-murano-tox-py27-mitaka-ubuntu-xenial?
17:49:15 <kzaitsev_mb> or decide that we don't want it anymore )
17:49:56 <kzaitsev_mb> yeah. it's not a universal job, that everyone has. We added it to murano to get some guarantee that it can run using only mitaka requirements
17:50:31 <kzaitsev_mb> my number 3 is glare related, but it's already on the list )
17:50:35 <kzaitsev_mb> #link https://etherpad.openstack.org/p/murano-atlanta-ptg
17:50:38 <kzaitsev_mb> btw
17:50:40 <felipemonteiro> kzaitsev_mb: I believe Tempest has both newton and mitaka gates.
17:50:52 <kzaitsev_mb> mfedosin: is going to attend =) the glare de-facto PTL )
17:50:52 <felipemonteiro> Thanks!
17:51:31 <kzaitsev_mb> felipemonteiro: gate-murano-tox-py27-mitaka is a job, that runs tox -e py27-mitaka, not tempest ) nobody has it but us I believe )
17:51:51 <kzaitsev_mb> oh, you probably meant that tempest has similar gate jobs
17:52:19 <felipemonteiro> kzaitsev_mb: I meant the Tempest project has gate-tempest-dsvm-neutron-full-ubuntu-trusty-mitaka and gate-tempest-dsvm-neutron-full-ubuntu-xenial-newton
17:52:34 <kzaitsev_mb> yeah, got that a minute too late =)
17:52:54 <felipemonteiro> So if I understood you, you want to add a new job for newton as well as mitaka to Murano? To check whether it runs correctly on -1 and -2?
17:54:24 <kzaitsev_mb> I want to discuss if we need an old one, actually )
17:54:34 <felipemonteiro> Btw, we have about 5 minutes left, so just wanted to ask about schedule. Even if we meet unofficially, I think we need to figure one out, otherwise I will email openstack-dev about scheduling.
17:54:52 <felipemonteiro> For me it doesn't matter since I live in Atlanta, but for everyone else, it does.
17:55:14 <kzaitsev_mb> I'd suggest to crash into the community-app-catalog area )
17:55:28 <kzaitsev_mb> I'd like to meet the new PTL anyway
17:56:09 <kzaitsev_mb> is there a schedule with rooms assigned, or smth like that anywhere?
17:56:54 <felipemonteiro> Yes, there's even one for cross-project collaboration, let me find it
17:58:30 <felipemonteiro> I'll forward it to you after the meeting, can't find it with the time we have left.
17:59:51 <felipemonteiro> Thanks everyone for meeting, I'll send out an email with more details
18:00:08 <kzaitsev_mb> thanks!
18:00:12 <felipemonteiro> #endmeeting