17:00:28 <cathy_> #startmeeting network_common_flow_classifier
17:00:29 <openstack> Meeting started Tue Jun 14 17:00:28 2016 UTC and is due to finish in 60 minutes. The chair is cathy_. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:32 <openstack> The meeting name has been set to 'network_common_flow_classifier'
17:00:41 <davidsha> Hi
17:00:41 <cathy_> Hi everyone
17:00:48 <s3wong> hello
17:00:50 <LouisF> hi cathy_
17:00:55 <ihrachys> o/
17:00:57 <jlibosva> o/
17:01:17 <asselin_> is this meeting time double-booked?
17:01:31 <cathy_> I have posted the agenda in the wiki page https://wiki.openstack.org/wiki/Neutron/CommonFlowClassifier#Contributors
17:01:43 <mohankumar_> Hi cathy_
17:01:44 <cathy_> asselin_: not as far as I know
17:01:44 <mmedvede> this was usually third-party meeting spot
17:01:48 <ja3> asselin: looking that way
17:02:04 <jlibosva> asselin_: is third-party weekly mtg?
17:02:22 <jlibosva> or bi-weekly?
17:02:26 <mmedvede> jlibosva: it is bi-weekly
17:02:44 <asselin_> mabye it's that biweekly bug?
17:02:45 <s3wong> this is approved at openstack-infra, which the software would ensure no double booking
17:02:48 <asselin_> for ical
17:03:32 <asselin_> link?
17:03:40 <mohankumar_> Neutron Common Classifier meeting booked for odd weeks
17:03:54 <mmedvede> ok, for third-party folks, lets convene in #openstack-third-party-ci channel
17:04:17 <cathy_> mmedvede: sorry about this. Thanks. We will check the time slot again
17:04:18 <mmedvede> and figure it out after, as we do not have a big agenda
17:04:20 <ihrachys> looking at http://eavesdrop.openstack.org/#Neutron_Service_Chaining_meeting
17:04:28 <ihrachys> I see that it's Thursdays for SFC
17:04:47 <cathy_> ihrachys: this is not for service chaining specific
17:04:59 <ihrachys> oh sorry
17:05:01 <cathy_> ihrachys: it is for the Neutron Common Flow Classifier
17:05:02 <jlibosva> ihrachys: it;s Neutron Common Classifier meeting
17:05:16 <cathy_> ihrachys: np
17:05:29 <cathy_> OK, let's start
17:05:32 <ihrachys> as per .ical file, it's next week
17:06:26 <mohankumar_> ihrachys , yes , classifier meeting on odd weeks .. there is some confusion
17:06:40 <cathy_> ihrachys: yes, some confusion here. how is it considered odd week?
17:06:57 <cathy_> This is the 3rd week of June, isn't it?
17:06:58 <asselin_> i remember and even/odd week bug for ical where jan 2016 was 2 odd weeks in a row
17:07:04 <ihrachys> cathy_: how do you count? from the start of the year?
17:07:12 <ihrachys> cathy_: it's annual, not monthly
17:07:31 <mohankumar_> This is Week 24 in this year
17:07:38 <cathy_> So count from the start of the year?
17:07:44 <ihrachys> aha
17:08:00 <ihrachys> or just rely on .ical to calculate it for you
17:08:14 <cathy_> ihrachys: OK, my bad. Sorry folks. I will correct this starting from next meeting
17:08:54 <cathy_> ihrachys: what do you mean by .ical?
17:09:13 <ihrachys> cathy_: http://eavesdrop.openstack.org/#Neutron_Common_Classifier_meeting
17:09:14 <davidsha> cathy_: file for outlook that saves an appoinment
17:09:20 <ihrachys> see the "ICS file for this specific meeting"
17:09:28 <ihrachys> download it and add to your calendar app
17:09:50 <ihrachys> it's .ics actually, sorry
17:09:52 <cathy_> ihrachys: got it. Thanks!
17:10:06 <mohankumar_> cathy_ , you can download @ http://eavesdrop.openstack.org/#Neutron_Common_Classifier_meeting
17:10:17 <cathy_> mohankumar_: yes, thanks
17:10:30 <cathy_> now let's start with the first topic
17:10:35 <ihrachys> +1
17:10:39 <cathy_> #topic Bug Status: developed as a RFE over neutron-core?
17:11:23 <cathy_> there are two bugs associated with this feature
17:11:30 <cathy_> #link https://bugs.launchpad.net/neutron/+bug/1583299
17:11:30 <openstack> Launchpad bug 1476527 in neutron "duplicate for #1583299 [RFE] Add common classifier resource" [Wishlist,In progress]
17:11:45 <cathy_> #link https://bugs.launchpad.net/neutron/+bug/1476527
17:11:45 <openstack> Launchpad bug 1476527 in neutron "[RFE] Add common classifier resource" [Wishlist,In progress]
17:11:51 <cathy_> one is duped to the other
17:12:27 <cathy_> In our last meeting, the consensus is to developed this feature as a RFE over neutron-core.
17:13:27 <cathy_> Does anyone know whether the neutron team had re-take a look at this bug which has been there for quite some time? https://bugs.launchpad.net/neutron/+bug/1476527
17:13:27 <openstack> Launchpad bug 1476527 in neutron "[RFE] Add common classifier resource" [Wishlist,In progress]
17:13:37 <cathy_> ihrachys: Do you know?
17:14:23 <ihrachys> hm, it's approved so what is missing?
17:14:53 <ihrachys> note that as per armax, "but eventually this would end up being its own neutron stadium repo/LP project, and *not* the Neutron/Neutron-specs repos."
17:15:47 <ihrachys> if you want drivers to get back to it for some reason, we probably need to tag it as rfe again
17:15:53 <ihrachys> but I would better talk to armax
17:16:02 <ihrachys> so, is the latest resolution not in line with your vision?
17:17:20 <cathy_> ihrachys: per our discussion in last meeting, we would like it to be tagged as rfe-approved, not as a new stadium project
17:17:40 <ihrachys> cathy_: then I guess we need to run the RFE bug thru drivers team again
17:17:52 <cathy_> similar to the way L2 agent feature is handled
17:18:12 <ihrachys> I agree it's core to the project goals
17:18:39 <cathy_> ihrachys: Anything we need to do for "run the RFE bug thru drivers team again"?
17:18:55 <ihrachys> I think we should just replace rfe-approved tag with rfe
17:19:03 <ihrachys> lemme handle it
17:19:11 <cathy_> ihrachys: OK, thanks!
17:19:14 <igordcard> what about neutron-classifier?
17:19:27 <cathy_> This is the neutron-classifier feature
17:19:38 <cathy_> igordcard: This is the neutron-classifier feature
17:20:23 <cathy_> #action ihrachys will run the RFE bug thru drivers team again
17:20:28 <igordcard> neutron-classifier can still be core even if it is in its own repo
17:20:49 <igordcard> this common classifier seems like a new effort that doesn't use neutron-classifier at all
17:21:19 <ihrachys> not that there is much to use there, right?
17:21:22 <cathy_> igordcard: we will only have one classifier for the Neutron and the team will work together for that goal
17:21:32 <cathy_> ihrachys: I think so
17:21:51 <cathy_> ihrachys: but we will try to reuse existing implementation as much as possible
17:21:52 <sean-k-mooney> cathy_: there is a datamodle
17:22:17 <cathy_> sean-k-mooney: yes.
17:22:45 <igordcard> cathy_: but the model proposed in the CC wiki looks completely different from openstack/neutron-classifier
17:22:54 <sean-k-mooney> the implementation in the neutron-classifyer is type based so it is different form what exists in the security group api and networking-sfc
17:23:06 <cathy_> I think we need to first agree on the API, data model design, then we can evaluate existing cdoe
17:23:38 <sean-k-mooney> cathy_: yes i think that is a better first step
17:23:57 <LouisF> cathy_: agree
17:24:20 <s3wong> cathy_: true
17:24:32 <mohankumar_> cathy_ : +1
17:24:47 <sean-k-mooney> so in terms of design i see two different proposals for the api
17:25:22 <sean-k-mooney> form the security group api and networking sfc the l1-7 classifcaion exist withing a singel api resource
17:26:13 <cathy_> #topic API design discussion
17:26:20 <sean-k-mooney> in the neutron-classifier the classification is a compostion
17:27:01 <cathy_> sean-k-mooney: good point.
17:27:43 <LouisF> sean-k-mooney: can you elaborate
17:27:44 <igordcard> sean-k-mooney: cathy_ : this second approach is also described in more detail at https://bugs.launchpad.net/neutron/+bug/1476527/comments/26
17:27:44 <openstack> Launchpad bug 1476527 in neutron "[RFE] Add common classifier resource" [Wishlist,In progress]
17:28:00 <cathy_> how about someone evaluate the pros and cons of the two ways
17:28:52 <cathy_> anyone would like to take this evaluation work?
17:29:12 <sean-k-mooney> cathy_: i think it would be better to dicuss in a spec rather then one person evaluating
17:29:26 <ihrachys> + for a spec
17:29:32 <igordcard> I'll post a spec
17:29:51 <cathy_> igordcard: thanks!
17:30:32 <igordcard> sorry I need to leave the meeting now - will catchup afterwards with the logs
17:30:33 <cathy_> #action igordcard will post a spec on the pros and cons of the two classification ways
17:30:38 <igordcard> cya, thanks
17:31:00 <davidsha> bye
17:31:17 <sean-k-mooney> well should the spec not capture the implentation approch rather then the pros and cons
17:31:31 <sean-k-mooney> ie discribe the datamodels and api for both solutions
17:32:08 <cathy_> sean-k-mooney: yes, that should be included otherwise people can not evaluate whether the pros and cons make sense
17:32:10 <sean-k-mooney> as the spec is reviewed we can then converge on one implenttion that meets the contraitns
17:32:52 <cathy_> sean-k-mooney: I would think before we decide on one approach, no need to dive into very detail
17:33:18 <cathy_> after the team reaches consensus on one way, we can have another spec detailing the API, data model etc.
17:33:58 <cathy_> I think we first need to agree on the high level which way to go (with enough detail for the team to make decision)
17:34:54 <sean-k-mooney> sure though at least a preliminay defintion of the api and data model will be needed but i will not neet to be complete
17:35:17 <cathy_> sean-k-mooney: yes, agree.
17:35:47 <sean-k-mooney> something akin to https://review.openstack.org/#/c/318317/5/doc/source/devref/openvswitch_agent.rst i think would be a good guide
17:35:48 <cathy_> I think we have completed the second topic on the agenda:-)
17:36:53 <LouisF> sean-k-mooney: yes that is a good example for the spec
17:37:34 <cathy_> sean-k-mooney: This is "implementation detail", which should be the spec. But for evaluation, we probably do not need this detail.
17:37:59 <ihrachys> you can always start with a less detailed draft and then fill it in with details
17:38:53 <LouisF> there should be sufficient to be able to identify the pros/cons of each approach
17:39:11 <sean-k-mooney> cathy_: yes that was the implentation but i was using it to illistrate how both options are compared rather then present one as the solution and the other as an alternitive
17:39:15 <LouisF> sufficient detail
17:39:32 <cathy_> sean-k-mooney: OK, Sure
17:40:07 <cathy_> sean-k-mooney: I think it is important not to present one as the solution and the other as alternative
17:40:41 <cathy_> I will work with igordcard on this comparison spec
17:40:57 <cathy_> anyone else would like to contribute to this spec?
17:41:23 <cathy_> ihrachys: yes
17:41:57 <cathy_> We are done with the topics on the agenda. Any other topic you would like to discuss?
17:42:28 <davidsha> cathy_: I've made some PoC code for the Flow manager if people would like to give their opinions
17:42:55 <davidsha> #link https://review.openstack.org/#/c/323963/
17:43:19 <cathy_> davidsha: that is related to L2 agent extension, not quite the flow classifier, right?
17:43:50 <jlibosva> davidsha: is it implementing the draft that ajo proposed?
17:44:01 <LouisF> cathy_: I can help with spec also
17:44:11 <cathy_> LouisF: great, thanks!
17:44:34 <cathy_> #action Louis and Cathy will work with igordcard on the spec
17:44:48 <davidsha> cathy_, jlibosva : kinda, it's a bit out of date now but I'm working on it.
17:45:08 <ihrachys> davidsha: not related to the meeting, but looks less scary than I thought :)
17:45:30 <davidsha> ihrachys: You haven't seen the prioritization yet @.@
17:45:54 <cathy_> davidsha: yes not related to the meeting since this meeting is specific to FC:-)
17:46:18 <cathy_> davidsha: but I will take a look after you update it. Could you add me as reviewer?
17:46:19 <ihrachys> ok folks, I need to run. ciao.
17:46:34 <cathy_> ihrachys: ok, thanks for joining
17:46:40 <davidsha> cathy_: kk, I'll do that now.
17:46:49 <cathy_> davidsha: thanks.
17:47:08 <cathy_> I will end this meeting if no other topic on FC.
17:47:15 <cathy_> 5
17:47:16 <cathy_> 4
17:47:19 <cathy_> 3
17:47:21 <cathy_> 2
17:47:23 <cathy_> 1
17:47:36 <cathy_> thanks everyone
17:47:40 <davidsha> thanks
17:47:42 <mohankumar__> bye
17:47:45 <cathy_> bye for now
17:47:52 <cathy_> we will start the next meeting in 3 weeks
17:48:04 <cathy_> #endmeeting