17:01:00 <igordcard> #startmeeting network_common_flow_classifier
17:01:01 <openstack> Meeting started Tue Dec 6 17:01:00 2016 UTC and is due to finish in 60 minutes. The chair is igordcard. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:05 <openstack> The meeting name has been set to 'network_common_flow_classifier'
17:01:08 <igordcard> hi all
17:01:10 <davidsha> Hi
17:01:11 <igordcard> let's wait 3 minutes to improve the chances of everyone being around
17:01:49 <davidsha> kk
17:04:15 <igordcard> agenda:
17:04:18 <igordcard> #link https://wiki.openstack.org/wiki/Neutron/CommonFlowClassifier#Discussion_Topic_6_December_2016
17:04:30 <igordcard> #topic Continue discussion on user-facing API vs. Classification mixins.
17:04:34 <igordcard> #link https://review.openstack.org/#/c/333993
17:05:11 <igordcard> alright, I am supposed to update the current spec to add more information to the api-based approach and the mixin-based approach
17:05:52 <igordcard> it's in progress and should get an update soon this week
17:06:18 <davidsha> kk
17:06:31 <igordcard> meanwhile I will start working on a PoC for the api-based approach
17:07:09 <davidsha> Kk, I can try and help.
17:07:14 <igordcard> thanks davidsha
17:07:43 <igordcard> anyone free feel to join the effort - I'm always on IRC so just ping me
17:08:11 <igordcard> it would also be interesting to have a PoC for the mixin-based approach, but I am focusing on the api-based approach
17:08:47 <igordcard> besides the PoCs, I will try to keep the spec up to date with the latest efforts, both from the IRC discussions and the PoC(s)
17:09:30 <davidsha> It could be included as well, though it was intended for neutron_lib if I recall, but for testing we could include it in that repo
17:10:00 <davidsha> in the neutron_classifier repo I mean
17:10:16 <igordcard> davidsha: +1
17:10:35 <ralonsoh> which set of protocols are you going to include in this POC?
17:10:54 <ralonsoh> how future new protocols are going to be accepted?
17:10:57 <igordcard> davidsha: the models part is already aligned with most of what is common to either the api-based approach or mixin-based approach
17:11:58 <igordcard> ralonsoh: initially for the PoC I'm thinking about something extremely simple, e.g. a "L1" classification type which would allow us to match on neutron ports or neutron networks
17:12:07 <davidsha> Will we refer to api/mixin as resource/descriptive? just to stay consistent from last meeting.
17:12:44 <igordcard> ralonsoh: then we could extend QoS to consume these classifications and demonstrate how the classifications are telling the QoS service where the policy should be applied
17:12:59 <ralonsoh> igordcard: thanks!
17:13:14 <igordcard> ralonsoh: or likewise for networking-sfc for example... for logical source ports or logical destination ports
17:13:22 <igordcard> something simple like that
17:14:57 <igordcard> adding protocols in the future would be done by adding more types to the list of models underneath the classification framework... and consuming services would become compatible with the new protocols whenever they need (after the protocols are added to the framework/API)
17:15:51 <igordcard> davidsha: right david, resource-based and definition-based
17:16:01 <davidsha> igordcard: thats the one!
17:16:54 <igordcard> so resource-based classification approach is the one where there is a single API for classification resources (api-based as I said earlier)
17:17:11 <davidsha> An an extension would consume that resource
17:17:17 <davidsha> And an*
17:17:42 <igordcard> definition-based classification approach is the one where the services inherit the definitions of classifications and expose them in their own API, potentially by the use of mixins in their respective extensions (mixin-based as I said earlier)
17:18:22 <igordcard> davidsha: yes, an extension would consume resources from the single, common classifications API in the resource-based approach
17:18:47 <igordcard> any questions or thoughts about the duality of approaches and next-steps around them?
17:19:26 <davidsha> No, I'm good
17:19:57 <igordcard> moving on...
17:20:00 <igordcard> #topic Call for contributors
17:20:11 <igordcard> I guess I've already gone through this topic
17:20:28 <davidsha> So do I need to withdraw my earlier application and resubmit it? :P
17:20:59 <igordcard> no no, you can officially submit it now, like this: :p
17:21:09 <davidsha> :O
17:21:16 <igordcard> #action igordcard will contribute to the resource-based (api-based) approach PoC
17:21:51 <davidsha> :P
17:22:21 <igordcard> anyone else can just join
17:22:27 <igordcard> any questions or thoughts?
17:23:04 <davidsha> kk, no I'm good, the neutron_classifier repo already has the database definitions so we just need to make the service plugin.
17:23:35 <igordcard> exactly
17:23:40 <davidsha> Maybe make a patch for an extension that could use it to test it out too.
17:23:57 <igordcard> yeah
17:24:39 <igordcard> alright team
17:24:45 <igordcard> moving on...
17:24:47 <igordcard> #topic Open discussion
17:24:49 <igordcard> anything else we need to discuss?
17:25:23 <davidsha> I'm good, we have a good Idea what we need to do.
17:26:04 <igordcard> alright! I guess it's all for today then
17:26:09 <igordcard> thank you all
17:26:16 <davidsha> Thanks, cya!
17:26:18 <igordcard> bye
17:26:45 <ralonsoh> bye
17:27:18 <igordcard> #endmeeting