21:01:12 <markmcclain> #startmeeting Networking
21:01:13 <openstack> Meeting started Mon May  6 21:01:12 2013 UTC.  The chair is markmcclain. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:16 <openstack> The meeting name has been set to 'networking'
21:01:19 <mestery> Welcome back gongysh
21:01:21 <nati_ueno> me too (back from vacation)
21:01:27 <mestery> you too nati_ueno :)
21:01:41 <garyk> i want to go on vacation
21:01:42 <nati_ueno> mestery: thx
21:01:57 <gongysh> me too.
21:01:59 <markmcclain> here's our agenda
21:02:02 <markmcclain> #link https://wiki.openstack.org/wiki/Network/Meetings
21:02:25 <markmcclain> danwent: I forgot to add time for docs
21:02:32 <markmcclain> so we''ll insert it
21:02:48 <markmcclain> #topic Announcements/Reminders
21:03:05 <markmcclain> #info Havana-1 is three weeks away
21:03:22 <markmcclain> We've got a full list of items to be completed
21:03:28 <danwent> markmcclain: tis ok, can do it at end
21:03:33 <markmcclain> #link https://launchpad.net/quantum/+milestone/havana-1
21:03:42 <markmcclain> danwent: ok
21:04:35 <markmcclain> We currently have 27 blueprints targeted which seems high
21:05:11 <gongysh> seems too much.
21:05:35 <mestery> Agree, there is a lot there for the next 3 weeks.
21:05:49 <salv-orlando> for the blueprints from my team: we have made a provisional allocation. Will rearrange during this week.
21:06:32 <markmcclain> Thanks salv-orlando.  You were reading my mind
21:07:24 <markmcclain> Which is to let me or the sub-team know if there is blueprint that is not realistically going to make it in H1.  We can move it back to H2 to make the plan more realistic
21:08:21 <markmcclain> I do want to note the one essential blueprint for H1.  Renaming will be a bit disruptive, but once we have the final plan I share with everyone so that we can work to minimize the disruptions.
21:08:43 <markmcclain> #link https://blueprints.launchpad.net/quantum/+spec/remove-use-of-quantum
21:09:04 <enikanorov_> does this imply getting rid of all "quantum" in the code?
21:09:06 <nati_ueno> When we decide new name?
21:09:11 <Samuel_> we have the blue print targeting multivendor driver for LBaaS which I do not see as part of H1
21:10:03 <markmcclain> enikanorov_: It will involve some changes to comply with agreement we made to stop using Quantum.  I'm still working out the final list of changes required.
21:10:38 <markmcclain> nati_ueno: We have not settled on a final name.  I'm still accepting alternatives as the legal team will vet a few before we as a team select one.
21:10:44 <dkehn> has a name been determined to replace the old one?
21:10:49 <enikanorov_> just wondering. getting rid of the name in the source tree is quite disruptive...
21:11:04 <nati_ueno> markmcclain: Are there candidates?
21:11:13 <enikanorov_> affects imports, deployment
21:11:34 <markmcclain> current candidate is Quasar
21:11:38 <mestery> The name change will require some amount of coordination with distributions as well I suspect.
21:11:42 <nati_ueno> markmcclain: Thanks!
21:11:59 <markmcclain> yeah.. name changing will involve multiple changes
21:12:00 <Samuel_> In regards to the name, is there a guidline to use a descriptive name such as os_network or to use an opaque name?
21:12:05 <mestery> Let the legal team know Quasar is the name of a Marvel Comics superhero. :)
21:12:36 <danwent> damn you mestery
21:12:37 <gongysh> :)
21:12:43 <enikanorov_> =)
21:12:45 <mestery> danwent: I know my comic books.
21:13:01 <mestery> And I would hate to have to rename twice.
21:13:03 <mestery> Ugh.
21:13:13 <markmcclain> so if any one else has suggestions, send them to me offline
21:13:25 <markmcclain> vetting by legal is to ensure we don't have to rename twice
21:13:55 <nati_ueno> there is company in australia http://www.reverseaustralia.com/lookup/0412013398/
21:14:20 <Samuel_> What about "flux"
21:14:28 <Samuel_> ?
21:14:33 <markmcclain> interesting
21:14:51 <sthakkar> but its stable :)
21:14:54 <salv-orlando> my insurance company is called flux :)
21:15:04 <mestery> OpenStack Flux seems oddly appropriate. :)
21:15:15 <nati_ueno> may be we should use mkpasswd to generate safe project name
21:15:24 <markmcclain> haha
21:15:26 <mestery> nati_ueno. Heh, I like it.
21:15:26 <salv-orlando> uuid.uuidgen()
21:15:28 <Samuel_> lol
21:15:44 <markmcclain> there's always the dark horse: mutnauq
21:16:00 <nati_ueno> asdfasdf is easy to type
21:16:13 <mestery> mutnauq #ftw
21:16:18 <haleyb> qnetwork if you still want the q
21:16:20 <danwent> i am the mutnauq… hear me roar
21:16:27 <garyk> how about quantim
21:16:37 <alexpilotti> mestery: don't forget MTV's Aeon Flux ;-)
21:16:38 <nati_ueno> garyk: easy to migrate!
21:16:41 <Samuel_> kuantom
21:16:45 <markmcclain> lol.. so send me your suggestions for names and clear them before voting
21:16:49 <sthakkar> i dont know what a mutnauq is but im scared to google it at work
21:17:05 <markmcclain> Any other questions before moving on?
21:17:29 <markmcclain> Samuel_: I'll add the blueprint to H1
21:17:30 <garyk> sthakkar: i think that either danwent or salv-orlando or markmcclain were in favor of that at some stage
21:18:04 <salv-orlando> you need a mirror to get mutnauq
21:18:19 <markmcclain> #topic Bugs
21:18:50 <markmcclain> This was the high importance bug from last week
21:18:50 <nati_ueno> salv-orlando: a-ha
21:19:09 <markmcclain> Thanks to garyk for looking into the issue
21:19:17 <garyk> markmcclain: np.
21:19:32 <markmcclain> Any other bugs that the team should be aware of?
21:20:00 <markmcclain> #topic API
21:20:01 <salv-orlando> Bug 1174293
21:20:03 <uvirtbot> Launchpad bug 1174293 in quantum "Network creation does not notify DHCP agent" [High,In progress] https://launchpad.net/bugs/1174293
21:20:20 <salv-orlando> Is that one bug you were mentioning? it did not show up on my client
21:20:35 <markmcclain> salv-orlando: you're right.. I forgot to paste it
21:20:38 <gongysh> This is behavior by design
21:20:39 <markmcclain> that is the bug
21:20:45 <garyk> i am currently looking into the issue of the gre and 3 nodes - https://bugs.launchpad.net/quantum/+bug/1154383
21:20:47 <uvirtbot> Launchpad bug 1154383 in quantum "Invalid entries in OVS flow table on a 3 node install using GRE Tunnels" [Undecided,Confirmed]
21:20:48 <salv-orlando> so perhaps you might want to discuss it a little
21:21:09 <salv-orlando> gongysh think it's not a bug (and I remember I did in this way on purpose)
21:21:14 <salv-orlando> I -> he
21:21:54 <gongysh> salv-orlando: yes (bug 1174293)
21:21:55 <uvirtbot> Launchpad bug 1174293 in quantum "Network creation does not notify DHCP agent" [High,In progress] https://launchpad.net/bugs/1174293
21:22:04 <markmcclain> If I understand correctly, there is a chance that the agent never gets selected if the conditions are right
21:23:06 <gongysh> makrmcclain: what do u mean by 'never get selected'?
21:23:14 <markmcclain> garyk: can you elaborate?
21:23:28 <gongysh> when port is created, we will schedule the network auto.
21:24:03 <garyk> markmcclain: maybe i missed the part of the port creation. i'll go back and check again (maybe it was a misunderstanding on my side)
21:24:27 <markmcclain> ok.. gongysh can you add that to the bug report so that others have that info too?
21:24:38 <gongysh> sure
21:24:41 <markmcclain> thanks
21:24:41 <garyk> i'l try and reproduce.
21:24:54 <markmcclain> sounds good
21:24:57 <markmcclain> #topic API
21:25:00 <markmcclain> salv-orlando: hi
21:25:02 <salv-orlando> hi
21:25:20 <salv-orlando> I wanted to spend some more time on API today, but things are getting tight
21:25:37 <salv-orlando> so let's be quick. Blueprints targeted for H-1 are still on target
21:25:39 <garyk> salv-orlando: you can take the stables time (we are in freeze and i have updated the wiki with the status) :)
21:26:09 <salv-orlando> however, no significant progress happened over the last week
21:26:23 <salv-orlando> markmcclain: what's your estimate for the router port API?
21:26:37 <salv-orlando> https://blueprints.launchpad.net/quantum/+spec/l3-router-port-relationship
21:27:27 <salv-orlando> on the other blueprints,
21:27:29 <markmcclain> we've been testing internally and need to fix a bug before pushing up for review
21:27:38 <salv-orlando> ok, thanks.
21:28:02 <salv-orlando> I have asked for feedback about how to handle a peculiar authZ problem in configurable-ext-gw-modes
21:28:23 <salv-orlando> it seems the best thing to do is to match policies against sub attributes. Should be easy,
21:28:34 <salv-orlando> Then https://blueprints.launchpad.net/quantum/+spec/api-core-for-services
21:28:58 <enikanorov_> i believe i have a patch for the last one
21:29:46 <salv-orlando> I have not yet completed my work, but I am happy to throw away what I have done if you're complete with it
21:30:08 <salv-orlando> please if you feel you want to own a blueprint, tell people in advance so there won't be duplicate work :)
21:30:34 <salv-orlando> This is for blueprints
21:30:45 <markmcclain> yeah… we should avoid duplicate work whenever possible
21:31:02 <salv-orlando> there are no high importance bugs, but the ones in the agenda are worth some discussion
21:31:13 <enikanorov_> sure. api-core-for-services is 3 days old so i hope there hasn't been duplicate work yet
21:31:16 <salv-orlando> especially bug 1165002
21:31:17 <uvirtbot> Launchpad bug 1165002 in quantum "tenant lists the external network of other tenants" [Medium,Confirmed] https://launchpad.net/bugs/1165002
21:31:52 <salv-orlando> This is because we are treating external networks as shared networks from an authZ perspective. They can be seen by anyone, but nobody can operate on them
21:32:12 <salv-orlando> this means we don't have a concept of "private external network"
21:32:50 <gongysh> does it lead to problem for nova to create a instance on it?
21:32:55 <salv-orlando> imho we should not invent a new concept, but leverage existing facilities. Hence I think the new logic should be that an external network should be shared too to be seen by everybody, but this will break bw compatibility
21:33:11 <salv-orlando> gongysh: no problem for nova AFAIK
21:33:34 <salv-orlando> so to keep a long story short, I will post a patch at some point during this week. You are welcome to express your opinion and/or ideas on the bug report
21:33:46 <salv-orlando> Before finishing
21:33:58 <markmcclain> ok.. makes sense to discuss there so everyone can follow along
21:34:08 <salv-orlando> one more pledge: please help with API doc reviews: https://review.openstack.org/#/q/status:open+project:openstack/netconn-api,n,z
21:34:16 <salv-orlando> that is all from the API side
21:35:07 <markmcclain> thanks for the update
21:35:20 <markmcclain> #topic VPNaaS
21:35:26 <markmcclain> nati_ueno:
21:35:38 <nati_ueno> Ok
21:35:49 <nati_ueno> we agreed the first step is IPsec + Amazon VPC model
21:35:59 <nati_ueno> now we are discussion models in IPSec
21:36:11 <nati_ueno> Note first step must be pretty simple
21:36:23 <nati_ueno> we will have meeting today 5pm PST on conf call
21:36:47 <sthakkar> See the mailer for details on the call if you're interested
21:37:02 <nati_ueno> This is Meeting Agenda and Note https://docs.google.com/presentation/d/1J7k1eI13-3pQVwp5XgZDWPfzUvuSqczRdK0lEZKQOKk/edit#slide=id.p
21:37:14 <nati_ueno> This is draft bp https://docs.google.com/a/ntti3.com/document/d/1Jphcvnn7PKxqFEFFZQ1_PYkEx5J4aO5J5Q74R_PwgV8/edit
21:37:24 <nati_ueno> thats all from me
21:37:38 <markmcclain> ok.. thanks for the update
21:37:53 <markmcclain> #topic Nova Integeration
21:38:31 <markmcclain> garyk: any update or still investigating?
21:38:34 <garyk> markmcclain: sorry no updates on my side
21:38:38 <garyk> still investigating
21:38:41 <markmcclain> no problem
21:38:58 <markmcclain> #topic Security/Firewalling
21:39:01 <markmcclain> arosen: hi
21:39:01 <arosen> hi, only update is this one bug (https://bugs.launchpad.net/quantum/+bug/1171997)  around the creation of a default security group when doing list-security groups.
21:39:03 <uvirtbot> Launchpad bug 1171997 in quantum "For networks shared beetwen multiple tenants (net-create --shared) there's no 'default' security group" [Undecided,In progress]
21:39:06 <arosen> There has been a good amount of discussion on the bug report. I think we are close to reaching consensus though.
21:39:21 * arosen on the review i mean.
21:39:25 <arosen> That's it from me though.
21:39:32 <markmcclain> https://review.openstack.org/#/c/27792/
21:40:13 <arosen> yup that's it. This should hopefully land shortly.
21:40:21 <markmcclain> ok
21:40:42 <arosen> SumitNaiksatam:  anything on fwaas?
21:40:52 <SumitNaiksatam> #topic FWaaS
21:40:57 <SumitNaiksatam> yeah, nothing major
21:41:08 <SumitNaiksatam> proceeding along the lines of what we laid out in the plan
21:41:24 <SumitNaiksatam> couple of BPs targeted for H1
21:41:46 <SumitNaiksatam> any questions/thoughts?
21:42:23 <markmcclain> I thought the blueprints were focused fairly well
21:42:33 <markmcclain> and the dependencies between them made sense
21:42:34 <SumitNaiksatam> markmcclain: ok
21:42:52 <SumitNaiksatam> background discussion going on the driver implementation
21:43:03 <SumitNaiksatam> we are starting on that right away in parallel
21:43:09 <SumitNaiksatam> iptables and ipsets for now
21:43:32 <markmcclain> great
21:43:56 <markmcclain> Any Security Groups/Firewall discussions?
21:43:58 <gongysh> what is ipsets?
21:44:20 <SumitNaiksatam> gongysh: helps to define named objects
21:44:30 <gongysh> ok, thanks
21:44:31 <SumitNaiksatam> so that you can reference them in iptables rules
21:44:37 <SumitNaiksatam> and then late bind
21:45:16 <SumitNaiksatam> there is also an abstraction called shorewall, which we can use on top of ipsets and iptables
21:45:30 <SumitNaiksatam> rather than using iptables/ipsets directly
21:46:10 <SumitNaiksatam> still investigating/exploring (rajesh/dell working on these)
21:46:26 <markmcclain> ok.. I like that you've started working on it early
21:46:37 <markmcclain> Thanks arosen and SumitNaiksatam for the update
21:46:45 <markmcclain> #topic LBaaS
21:46:48 <enikanorov_> i'll update
21:46:58 <markmcclain> Thanks.. sorry I missed the meeting today
21:47:02 <enikanorov_> there is several key items in progress on lbaas
21:47:18 <enikanorov_> 1) ServiceType framework 'rework'
21:47:36 <enikanorov_> redefined some terms and agreed on iplementation steps
21:48:16 <enikanorov_> 2) Some renaming/moving of lbaas files.
21:48:38 <enikanorov_> i'm going to create wiki page on final directory structure for the service and propose it for other services
21:48:59 <enikanorov_> question to discuss: whether to move services directory one lvel up ffrom plugins
21:49:13 <markmcclain> ok.. I know you started discussion, but I'm sure we have consensus yet across the full team
21:49:19 <markmcclain> *I'm not sure*
21:49:51 <enikanorov_> i know. I hope there will be more clarity once wikipage is created
21:50:16 <markmcclain> yeah.. the wiki will help a bunch
21:50:24 <SumitNaiksatam> enikanorov-w: seems like moving "services" one level up is a good idea
21:50:54 <enikanorov_> SumitNaiksatam: the sooner the better (if we ever decide to)
21:50:54 <nati_ueno> IMO, "Services" discussion should be managed in this meeting
21:50:57 <SumitNaiksatam> sorry, don't mean to spark the debate here :-)
21:51:02 <nati_ueno> it affects many sub projects
21:51:05 <salv-orlando> time is tight
21:51:08 <enikanorov_> ok
21:51:10 <enikanorov_> so
21:51:18 <enikanorov_> 3) two patches on "multivendor support"
21:51:41 <markmcclain> how about enikanorov_ post the wiki and we can discuss on mailing list and then I'll make it a topic for next week
21:52:08 <enikanorov_> markmcclain: sure
21:52:12 <markmcclain> that way everyone can be informed for we dive into the issue
21:52:23 <enikanorov_> regarding (3) - I hope some core will take a look at those patches
21:52:47 <enikanorov_> at least for some brief design review
21:53:03 <enikanorov_> and 4) LBaaS subteam meeting
21:53:10 <Samuel_> I do not understand why we have two patches
21:53:11 <enikanorov_> I feel we might need one.
21:53:47 <markmcclain> enikanorov_: I know last cycle the sub-team held ad-hoc meetings early on to organize
21:53:59 <markmcclain> and I think makes sense again this cycle too
21:54:14 <salv-orlando> I think enikanorov_ is proposing regular ones this time
21:55:01 <markmcclain> yeah.. that's certainly workable
21:55:34 <markmcclain> some sub-teams of nova meet regularly to facilitate communication
21:55:40 <Samuel_> should we do it 1 H before this meeting?
21:55:48 <enikanorov_> i think everyone involved in writing code/reviewing should attend
21:56:06 <Samuel_> of if most of the team is not in US, we might be able to do it earlier ;-)
21:56:51 <markmcclain> ok.. look at the main openstack meetings wiki
21:57:08 <markmcclain> to find an open time and then suggest options on the mailing list
21:57:21 <enikanorov_> markmcclain: a question
21:57:34 <markmcclain> sure
21:57:40 <enikanorov_> (1) and (2) is not bound to any blueprint right now, i believe
21:57:57 <enikanorov_> but they are necesssary to impl before moving to (3)
21:58:07 <markmcclain> ok.. we need to make sure that work is tracked by a blueprint or bug
21:58:17 <salv-orlando> we missed the deadline as we had the meeting today
21:58:32 <markmcclain> we can coordinate offline to fix those up
21:58:32 <Samuel_> I disagree. we can complete 3 very quick and then do the reordering
21:58:47 <enikanorov_> markmcclain: ok
21:58:53 <danwent> got to run folks, see you next week!
21:59:04 <garyk> danwent: thanks
21:59:32 <markmcclain> ok.. we're running short on time so I want to highlight one CLI review
21:59:43 <markmcclain> #topic CLI
22:00:02 <gongysh> https://launchpad.net/python-quantumclient/+milestone/2.2.1
22:00:29 <gongysh> ssl is in the progress ( if I am right)
22:00:35 <markmcclain> the next release will actually be 2.2.2
22:00:47 <markmcclain> #action fix CLI milestone
22:01:29 <markmcclain> some deployers have run into problems with adminURL, publicURL in the catalogs
22:01:30 <gongysh> I am confused too. :)
22:01:37 <markmcclain> https://review.openstack.org/#/c/28057/
22:02:00 <markmcclain> seeks address those issues.. I don't want to discuss here, but I would like everyone to look at this review
22:02:14 <markmcclain> #topic Stable
22:02:28 <garyk> markmcclain: i updated wiki.3release is 9 may
22:02:46 <garyk> we are in freeze at the moment
22:03:08 <markmcclain> Right.. we did get an exception for the fix Windows metadata support
22:03:16 <garyk> correct.
22:03:30 <garyk> i am backporting a few fixes at the moment - for the next release cycle
22:04:00 <markmcclain> That's great you're getting a jump on the next cycle
22:04:25 <markmcclain> #topic Docs
22:04:35 <markmcclain> https://bugs.launchpad.net/openstack-manuals/+bugs?field.tag=quantum
22:05:05 <markmcclain> Dan had to leave early but we've got three review in progress and three more we need to complete.
22:05:47 <markmcclain> Works in progress will be posted for migration and db and then we can fix those update as a community vs funneling the changes through one person.
22:06:37 <markmcclain> As salv-orlando ask earlier, please take a look at the doc reviews so we can close these out.
22:06:49 <markmcclain> #topic Other Reports
22:06:56 <salv-orlando> https://review.openstack.org/#/q/status:open+project:openstack/netconn-api,n,z
22:07:12 <markmcclain> salv-orlando: Thanks for the link
22:07:42 <garyk> i am going to crash. good night guys. sorry
22:07:44 <gongysh> maybe we need to give some bonus for reviewing.
22:08:01 <markmcclain> garyk: Night.. sorry we ran over on time
22:08:14 <emagana> will review some docs with bonus of course!
22:08:16 <emagana> :-)
22:08:23 <markmcclain> gongysh: You offering to pay :)
22:08:32 <enikanorov_> bonuses awake ppl
22:08:36 <salv-orlando> I think you have kind of a duty to do that, don't you :)
22:08:36 <enikanorov_> ^_^
22:08:37 <uvirtbot> enikanorov_: Error: "_^" is not a valid command.
22:08:42 <enikanorov_> ops
22:09:35 <markmcclain> #Open Discussion
22:09:44 <markmcclain> #topic Open Discussion
22:09:45 <rkukura> See meeting agenda for open source plugin items (ml2, vxlan, hardware drivers, etc.)
22:10:04 <markmcclain> rkukura: Thanks for updating the agenda
22:10:10 <gongysh> where is the agent for ml2?
22:10:27 <gongysh> agent -> agenda
22:10:38 <rkukura> ml2 uses the linuxbridge, openvswitch, and hyperv agents
22:10:51 <markmcclain> gongysh: https://wiki.openstack.org/wiki/Network/Meetings#Other_team_reports_.28e.g._Open_Source_Plugins.29
22:11:16 <markmcclain> Here's the associated review: https://wiki.openstack.org/wiki/Network/Meetings#Other_team_reports_.28e.g._Open_Source_Plugins.29
22:11:35 <markmcclain> https://review.openstack.org/#/c/20105/
22:11:35 <gongysh> do we have a patch for ml2 now?
22:11:41 <rkukura> posted update WIP patch set for ml2
22:12:02 <rkukura> this works with the linuxbridge agent, adding support for other agents this week
22:12:26 <markmcclain> We're over time, but everyone can discuss and provide feedback via the review and mailing list
22:12:39 <gongysh> I will join to review it today.
22:12:40 <markmcclain> Anything else before we wrap up?
22:12:50 <rkukura> gongysh: this 1st ml2 phase overlaps https://blueprints.launchpad.net/quantum/+spec/merge-plugin-codes-into-one - lets not duplicate effort
22:13:03 <gongysh> yes,
22:13:29 <gongysh> I will not do it. I like to reivew instead of code myself. :)
22:13:47 <salv-orlando> cool. Then make that blueprint superseded and untarget it.
22:13:52 <rkukura> gongysh: either one beats meetings!
22:14:10 <salv-orlando> This way markmcclain will be slapped one time less by ttx
22:14:23 <gongysh> rkukura, can u give me the chance to help with other plugin porting?
22:14:29 <enikanorov_> ok, bye folks
22:14:53 <rkukura> gongysh: thanks!
22:14:59 <markmcclain> salv-orlando: haha.. thanks for the reminder to tidy up the old BPs
22:15:30 <markmcclain> ok.. I've got to run.  Thanks everyone.  Talk you all on the mailing list or next week back here.
22:15:35 <markmcclain> #endmeeting