21:02:44 <markmcclain> #startmeeting Networking
21:02:45 <openstack> Meeting started Mon Jul 22 21:02:44 2013 UTC.  The chair is markmcclain. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:47 <SumitNaiksatam> hi All
21:02:49 <danwent> hi
21:02:49 <openstack> The meeting name has been set to 'networking'
21:02:53 <rkukura> hi
21:03:15 <markmcclain> Ok very different agenda this week
21:03:18 <markmcclain> #link https://wiki.openstack.org/wiki/Network/Meetings
21:03:52 <markmcclain> I want to spend the bulk of the meeting this week discussing 3 things: bugs, docs, and H3
21:04:01 <markmcclain> #topic Announcements
21:04:10 <markmcclain> #link http://tarballs.openstack.org/neutron/neutron-milestone-proposed.tar.gz
21:04:28 <markmcclain> H2 was released last week.  Great job by the entire team
21:04:41 <Swami> Hi all
21:05:04 <markmcclain> we completed 21 blueprints and fixed 99 bugs
21:05:36 <markmcclain> #topic bugs
21:05:53 <markmcclain> We've got two critical bugs that we're tracking this week
21:06:14 <markmcclain> https://bugs.launchpad.net/neutron/+bug/1194026
21:06:16 <uvirtbot> Launchpad bug 1194026 in neutron "check_public_network_connectivity fails with timeout" [Critical,In progress]
21:06:36 <markmcclain> nati_ueno has put a lot of effort into this bug and submitted two patches for it
21:06:52 <markmcclain> the first reduced some of the problems but not all of them
21:07:41 <markmcclain> until we can fix the false negatives the Infra team will keep the job as non-voting in the gate which less than ideal
21:08:13 <markmcclain> nati_ueno has proposed a 2nd fix: https://review.openstack.org/#/c/37576/
21:08:29 <salv-orlando> false negatives - you mean the test is succeeding whereas it should fail?
21:08:45 <markmcclain> no.. the test is failing when it should succeed
21:09:28 <markmcclain> actually false negative is the wrong way to classify it
21:09:36 <markmcclain> the test found a race condition
21:09:46 <salv-orlando> so it's not a false at all
21:09:46 <nati_ueno> it may not be false negatives .. because floating ip configuration is not finished in 60 sec.. it sounds problem
21:10:16 <markmcclain> yeah.. my brain is moving slow today
21:11:02 <salv-orlando> markmcclain: as slow as it might be, it will still be fast enough to pass and lap mine
21:11:15 <markmcclain> haha
21:11:34 <markmcclain> I'd really like folks to review and test this fix as it is critical to getting the gating restored
21:12:00 <nati_ueno> my lap time is third times.. so I need someone's help.
21:12:18 <nati_ueno> looping call looks sometimes stopped.. I'm not sure why, and I can't reproduce
21:12:48 <mestery> nati_ueno: I'll have a look at this with you.
21:12:56 <nati_ueno> mestery: Thanks!
21:13:01 <markmcclain> mestery: thanks
21:13:02 <salv-orlando> nati_ueno: if it looks like it's looked, it might be because of some other green thread blocking it (rpc from server perhaps)?
21:13:15 <nati_ueno> I dislike eventlet really nowadays..
21:13:38 <markmcclain> nati_ueno: I'm with you on that one.. but that's something we'll have to wait to Icehouse summit to talk about
21:13:38 <nati_ueno> salv-orlando: it could be possible
21:13:51 <nati_ueno> markmcclain: I agree.
21:14:40 <markmcclain> the other bug I'd like ot highlight involves recycling of IPs
21:14:40 <markmcclain> Another critical bug is this one: https://bugs.launchpad.net/neutron/+bug/1201692
21:14:41 <uvirtbot> Launchpad bug 1201692 in neutron "can not create port after some port update operations" [Critical,In progress]
21:14:56 <markmcclain> https://review.openstack.org/#/c/37384/
21:15:03 <markmcclain> we're short one core to review it
21:15:21 <salv-orlando> I claim it
21:15:25 <markmcclain> salv-orlando: thanks
21:15:49 <markmcclain> Any other bugs that should be brought up to the team?
21:16:35 <markmcclain> #topic Docs
21:16:40 <markmcclain> #link https://wiki.openstack.org/wiki/Network/Meetings#Docs_.28emagana.29
21:17:37 <markmcclain> We have both doc blueprints for the manuals and I've added new bugs for the netconn-api changes too
21:18:10 <markmcclain> Good docs are critical for new features and it is best that we start writing them now
21:18:28 <salv-orlando> just pushed this for netconn-api: https://review.openstack.org/#/c/38199/
21:18:53 <markmcclain> salv-orlando: awesome
21:19:25 <salv-orlando> markmcclain: did you tag the netconnapi bugs you filed on openstack-api-site?
21:19:32 <markmcclain> yes
21:20:05 <markmcclain> https://bugs.launchpad.net/openstack-api-site/+bug/1203864
21:20:07 <uvirtbot> Launchpad bug 1203864 in openstack-api-site "Neutron FWaaS API docs" [Undecided,New]
21:20:14 <markmcclain> https://bugs.launchpad.net/openstack-api-site/+bug/1203865
21:20:15 <uvirtbot> Launchpad bug 1203865 in openstack-api-site "Neutron VPNaaS API Docs" [Undecided,New]
21:20:58 <salv-orlando> markmcclain: thanks. I am not just slow, but blind too.
21:21:32 <markmcclain> no worries it is late there
21:22:18 <markmcclain> The docs segment will be a regular item on our agenda so if there are major doc items we need to track feel to add to agenda
21:22:49 <nati_ueno> I assigned the vpn docs for me
21:23:00 <markmcclain> nachi/sumit: can you make sure there is a member of your subteams assigned to the netconn-api bugs?
21:23:27 <SumitNaiksatam> markmcclain: yeah, i assigned it to me (for now at least)
21:23:34 <markmcclain> SumitNaiksatam: thanks
21:23:36 <pcm_> nati_ueno: I can help with VPN docs... just let me know what to do :)
21:24:00 <nati_ueno> pcm_: Ah Thanks! Ok could you take this task?
21:24:11 <pcm_> nati_ueno: yes
21:24:21 <markmcclain> pcm_: thanks for taking it on
21:24:23 <nati_ueno> pcm_: OK I'll reassign it for you
21:24:31 <markmcclain> Any question on docs before we move on?
21:24:49 <markmcclain> #topic H3
21:24:52 <pcm_> nati_ueno: Offline we can talk about what I need to do
21:25:02 <nati_ueno> pcm_: surew
21:25:10 <markmcclain> #info Last milestone to add features to the Havana release
21:25:24 <markmcclain> #info H3 release date is Sept 5th
21:25:52 <markmcclain> #info Neutron feature cutoff is end of day August 23rd
21:26:14 <markmcclain> H3 follows a long holiday weekend here in the US
21:27:11 <markmcclain> so I've move the cutoff to ensure we have the same number of review days as we had for Grizzly
21:27:53 <markmcclain> The third milestone is usually the most taxing on the gate and gating/merges can take much longer than normal
21:28:52 <markmcclain> we have 31 days and that time will fly by, so try not to wait until the deadline to propose code
21:29:45 <markmcclain> Any questions on H3 scheduling?
21:30:15 <markmcclain> #link https://wiki.openstack.org/wiki/Network/Meetings#Havana_Design_Summit_Priorities_Reminder
21:30:45 <markmcclain> I wanted to reminder everyone of where we stand on the major priorities that were developed at the Portland sumit
21:30:51 <salv-orlando> I'm fine with it. Shall we try and enforce a blueprint cap?
21:31:01 <markmcclain> salv-orlando: getting to that :)
21:31:05 <salv-orlando> k
21:31:32 <nati_ueno> markmcclain: Are we going to deplicate linuxbridge and ovs in this release?
21:32:05 <markmcclain> nati_ueno: I'd like to, but want to make sure that ML2 is ready as a drop in replacement
21:32:05 <mestery> nati_ueno: I thought that would happen in Icehouse?
21:32:27 <mestery> markmcclain: By deprecate, would LB and OVS still be around for Icehouse?
21:32:33 <mestery> Or gone completely?
21:33:01 <markmcclain> mestery: we'd originally talked about deprecating in Havana and removing in Icehouse
21:33:22 <mestery> markmcclain: OK, that makes sense, I agree with that. We'll work with that assumption on the ML2 team for the next 31 days then. :)
21:33:23 <markmcclain> the nice thing about deprecating is that we can make that decision during the RC phase
21:33:30 <mestery> markmcclain: Perfect.
21:33:38 <nati_ueno> Ok thanks. I got it
21:33:42 <rkukura> sounds good
21:34:12 <markmcclain> the warning will be such that it will be remove at the earliest in Icehouse, but if a show stopper pops up we can delay until J
21:35:12 <markmcclain> Now as salv-orlando pointed out we probably need to start considering a cap of blueprints for H3
21:35:34 <markmcclain> currently have 63 blueprints targets and we only completed 21 during H2
21:36:27 <markmcclain> #link https://launchpad.net/neutron/+milestone/havana-3
21:36:43 <salv-orlando> considering that we typically land more blueprints in the 3rd milestone, I respectfully wish to suggest 35 blueprints as a reasonable target
21:36:53 <salv-orlando> (on the optimistic side)
21:37:04 <markmcclain> salv-orlando: you were reading my mind :)
21:38:38 <markmcclain> our velocity will be aided somewhat by the fact that we have several blueprints (VPN, FW, service types) that are in progress from H2 and should land relatively soon
21:38:42 <mestery> Looking at that page, salv-orlando is currently assigned almost half of his own specified target quota. :)
21:38:57 <salv-orlando> I will cleanup
21:39:24 <markmcclain> mestery: you're noticing another trend
21:39:47 <markmcclain> which is a lot of the blueprints are for vendor plugin features
21:39:57 <salv-orlando> the trend of me postponing the stuff from one milestone to another and never getting it done? :)
21:40:58 <mestery> markmcclain: What are your thoughts on the vendor plugin situation?
21:41:09 <mestery> with regard to all the BPs in H3?
21:41:15 <markmcclain> I'll be reaching out to the vendor contacts looking for their priorities
21:41:23 <markmcclain> some we can mark as medium
21:41:38 <markmcclain> some we will mark as low which means if they make it great if not that ok
21:41:55 <markmcclain> and others we'll assign to the next milestone which are items for Icehouse
21:42:14 <mestery> markmcclain: That makes sense.
21:42:54 <markmcclain> vendor blueprints are really a random mix of patch set sizes.. some are small and easy to review and others are large
21:43:30 <nati_ueno> may be it is good to let them report expected patch size
21:44:21 <markmcclain> nati_ueno: that will definitely be one of the factors
21:45:01 <markmcclain> but there are also business factors too, so I want to be a collaborative process
21:45:08 <nati_ueno> also I'm not sure all of proposer is still working on the bps.
21:45:38 <nati_ueno> markmcclain: I agree
21:46:13 <markmcclain> the end goal is by next week to have ~35 blueprints that are medium and above
21:46:21 <mestery> markmcclain: Pragmatism is a great goal to have here.
21:47:04 <markmcclain> those are the items that we will track for release planning
21:47:29 <markmcclain> items marked low will still be accepted but it will all depend on reviewer bandwidth
21:48:20 <salv-orlando> I think blueprint owners should also explicitly note whether they expect to drop huge commits.
21:48:52 <salv-orlando> in that case - either split the blueprint or pull the deadline forward (i.e. : one week before)
21:49:45 <markmcclain> salv-orlando: that's a good idea too
21:50:18 <markmcclain> Any questions about the H3 plans?
21:50:20 <salv-orlando> I know because I have one which is huge and I'm considering what to do with it...
21:51:25 <markmcclain> yeah.. I get the feeling we'll have a few in that situation
21:51:34 <markmcclain> #topic Open Discussion
21:52:21 <markmcclain> so we spent a lot of time on planning any items that need to be brought up, but were skipped because of the special agenda today?
21:53:37 <dkehn> would like to understand where we are on https://review.openstack.org/#/c/30441/ & https://review.openstack.org/#/c/30447/, would love to get them merged
21:54:15 <markmcclain> dkehn: I've been traveling and will go back and look at the latest revision
21:54:25 <dkehn> markmcclain, thx
21:54:36 <markmcclain> I'll also ping amotoki to take another look since he's the 2nd core on it
21:55:00 <dkehn> thx again
21:55:35 <ivarlazzaro> Hello, as I anticipated in the mailing list I'm going to request a review for the first part of the Embrane's Neutron plugin soon (by today maybe)... Your feedback will be extremely appreciated when you have some time :) (I see that you really are full of work to do!!)
21:56:30 <salv-orlando> markmcclain, ivarlazzaro: we would still need a core maintainer right?
21:56:31 <ivarlazzaro> I'm using the open discussion of this meeting just to "anticipate" this and answering any question if any :)
21:56:54 <markmcclain> salv-orlando: correct
21:57:28 <markmcclain> ivarlazzaro: we can talk offline, but plugins submitted by non-core team members require a core team member to sponsor
21:57:40 <ivarlazzaro> markmcclain, salv-orlando: I red in the wiki that the company could propose the plugin developer itself for maintaining it
21:57:56 <salv-orlando> pointer?
21:58:12 <mestery> proposed core developers?
21:58:29 <mestery> Seems like a mistake on the wiki if it's there.
21:58:51 * markmcclain searches for link too
21:59:18 <ivarlazzaro> markmcclain, salv-orlando: https://wiki.openstack.org/wiki/NeutronDevelopment
21:59:35 <ivarlazzaro> at Adding a Plugin to the Public Quantum Repository
22:00:15 <markmcclain> ivarlazzaro: thanks
22:00:22 <rkukura> ivarlazzaro: You may also want to consider the option of developing drivers for the ml2 plugin as an alternative to a new monolithic plugin
22:00:40 <ivarlazzaro> markmcclain salv-orlando: "or by having one of the developers of the plugin become a member of the core developer team" its probably a misunderstanding then :)
22:00:40 <mestery> ivarlazzaro: I think there is confusion there, that means you can become core by doing all the duties a core dev does, not by proposing to be a core dev. markmcclain, please correct me if I'm wrong.
22:01:17 <mestery> ivarlazzaro rkukura: I think this plugin is an L3 plugin, not an L2 plugin, based on a mailing list thread I remember reading.
22:01:29 <ivarlazzaro> mestery: that's correct
22:02:07 <salv-orlando> well let's at least glance at blueprint spec and code first
22:02:27 <mestery> salv-orlando ivarlazzaro: I think this also depends on Bob Melander's patch, no?
22:02:28 <markmcclain> ivarlazzaro: that person has been acceptable as a core team member in the general sense first which is why we require a current team sponsor first
22:02:55 <markmcclain> because nearly all new plugin contribs do not have a developer in house who is already a core team member
22:02:58 <ivarlazzaro> salv-orlando: I agree, anyway I'm willing to improve it a lot as we go on
22:03:12 <markmcclain> #action markmcclain to clarify working on plugin contribution
22:03:31 <markmcclain> Anything else for this week?
22:04:18 <markmcclain> Thanks again for everyone's hardwork on H2 and I'm really excited on the Havana release is shaping up
22:04:25 <markmcclain> #endemeeting
22:04:44 <salv-orlando> adieu
22:04:53 <markmcclain> #endmeeting