21:01:31 <markmcclain> #startmeeting Networking
21:01:32 <openstack> Meeting started Mon Aug  5 21:01:31 2013 UTC and is due to finish in 60 minutes.  The chair is markmcclain. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:36 <openstack> The meeting name has been set to 'networking'
21:01:57 <markmcclain> #link https://wiki.openstack.org/wiki/Network/Meetings
21:02:16 <emagana_> hello all!
21:02:22 <markmcclain> #topic Announcements
21:02:39 <SumitNaiksatam> hi
21:02:40 <markmcclain> #info Bug Day August 8th
21:02:42 <enikanorov_> hi
21:03:37 <markmcclain> The number of open unresolved open bugs is currently hovering around 200
21:04:24 <markmcclain> Thursday will be a good time to work on closing some
21:04:49 <med_> so more if a Bug Squashing Day than Bug Generating Day
21:05:02 <med_> s/if a/of a/
21:05:10 <armax> are all of the 200 unassigned?
21:05:13 <markmcclain> med_: If we find add new bugs that ok too
21:05:30 <markmcclain> armax:  it is a mix
21:05:45 <armax> k
21:05:46 <markmcclain> some of the unassigned bugs need to be reviewed to make sure they still apply
21:06:08 <markmcclain> The other quickly approaching deadline is August 23rd
21:07:11 <markmcclain> That is the last day to propose code for Havana
21:07:15 <markmcclain> #link https://wiki.openstack.org/wiki/FeatureProposalFreeze
21:07:30 * salv-orlando I fainted as I read "this is" instead of "that is"
21:07:52 <markmcclain> haha… we still have a bit of work to do
21:08:44 <markmcclain> #info End of day August 23rd is Feature Proposal Freeze
21:08:54 <markmcclain> https://launchpad.net/neutron/+milestone/havana-3
21:09:05 <markmcclain> Overall for H3 we're looking ok
21:09:28 <markmcclain> 9 implemented and another 20 in some state of review
21:10:03 <markmcclain> we've got 15 or so that need code
21:10:50 <markmcclain> #topic Bugs
21:11:15 <markmcclain> Thanks to nati_ueno for working on the gate problem test
21:11:51 <nati_ueno> it is start vorting again
21:11:53 <markmcclain> The infra team changed the neutron devstack gate to voting
21:11:59 <mestery> Great work nati_ueno!
21:12:06 <nati_ueno> mestery: Thanks
21:12:13 <markmcclain> which helps to prevent bit rot
21:12:34 <lifeless> markmcclain: speaking of deadlines, what about dkehn's bare metal support patches ?
21:13:03 <markmcclain> lifeless: those patches have been set of a high priority item for H3
21:13:37 <markmcclain> last I checked there were outstanding comment on the server patchset
21:13:44 <lifeless> markmcclain: cool! dkehn keeps running into hiccups and issues; -really- keen to get it landed ;)
21:13:52 <markmcclain> same here
21:13:54 <lifeless> ah! dkehn ^
21:14:24 <markmcclain> We currently don
21:14:34 <markmcclain> 't have any critical bugs to talk about
21:14:47 <markmcclain> any bugs that need to brought up to the team?
21:15:14 <lifeless> markmcclain: I have a non-critical that I need to ping you about; not sure if the meeting is the right place.
21:15:14 <markmcclain> #topic Docs
21:15:35 <emagana_> 2nd round of name changes has been completed and successfully merged
21:15:37 <markmcclain> lifeless: we chat offline about it
21:15:40 <lifeless> markmcclain: ack
21:16:05 <nati_ueno> emagana_: great job!
21:16:06 <emagana_> I am now chasing individuals bugs and also reading the whole guide making sure everything make sense
21:16:20 <emagana_> I may bother people asking for links update
21:16:48 <emagana_> There are plenty of externals links in the manuals pointing to un-updated wikis
21:17:07 <markmcclain> thanks for looking for those
21:17:37 <emagana_> VPNaaS and FWaaS can be reported by nati_ueno and SumitNaiksatam
21:17:43 <emagana_> nati_ueno: Thanks!
21:17:55 <emagana_> Thats all from my side!
21:18:15 <markmcclain> nati_ueno: how are the VPN docs progressing?
21:18:26 <nati_ueno> markmcclain: no update for docs yet.
21:18:53 <pcm_> markmcclain: I'm working on API for VPN
21:19:11 <markmcclain> pcm_: cool
21:19:17 <nati_ueno> pcm_: Thanks
21:19:22 <pcm_> np
21:19:26 <markmcclain> SumitNaiksatam: Any updates on the FWaaS docs?
21:19:30 <emagana_> nati_ueno: I can help if you need it!
21:19:40 <SumitNaiksatam> markmcclain: i am just getting started
21:19:55 <markmcclain> ok
21:20:00 <nati_ueno> emagana_: Thanks. I'm waiting the driver patch is merged. Because it may be changed
21:20:14 <markmcclain> Any other questions on docs?
21:20:23 <markmcclain> #topic API
21:20:24 <rkukura> we need to get ml2 info into the docs at some point soon
21:20:31 <markmcclain> #undo
21:20:32 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x25918d0>
21:20:46 <markmcclain> rkukura: correct
21:21:00 <mestery> rkukura: I can help with that.
21:21:03 <markmcclain> I'll add that as a major doc item we'll be tracking the rest of this cycle
21:21:24 <rkukura> sounds good - thanks mestery and markmcclain
21:22:16 <markmcclain> #topic API
21:22:23 <markmcclain> salv-orlando: hi
21:22:27 <salv-orlando> hi
21:22:56 <salv-orlando> Mostly quiet today. We've merged FW and VPN extensions.
21:23:05 <salv-orlando> We still have a few extensions outstanding
21:23:19 <salv-orlando> but all the API-related items are already under review
21:23:40 <salv-orlando> any question?
21:23:50 <markmcclain> great to hear
21:24:04 <markmcclain> # topic VPN
21:24:15 <nati_ueno> OK Thanks. DB part is merged.
21:24:24 <nati_ueno> so waiting ipsec driver is meged
21:24:41 <nati_ueno> I got +2 from Akihiro.
21:24:51 <nati_ueno> markmcclain: Do you have some concerns fro the patch?
21:25:16 <markmcclain> nati_ueno: I need to circle back on the driver now that ctypes was replaced with mount
21:25:36 <nati_ueno> markmcclain: gotcha Thanks
21:25:40 <nati_ueno> That's all from my side
21:25:49 <markmcclain> Thanks for updating
21:26:07 <markmcclain> #topic FWaaS
21:26:40 <SumitNaiksatam> hi
21:26:45 <SumitNaiksatam> Driver patch is ready, agent patch needs to add one more response to an outstanding comment, CLI (needs one more +2) and Horizon are also ready
21:27:27 <SumitNaiksatam> we have SridarK and RajeshMohan today (back from India)
21:27:31 <markmcclain> SumitNaiksatam: great looks like we have plenty of core coverage on the open reviews
21:27:57 <SumitNaiksatam> markmcclain: yes, in my opinion the CLI is ready to right away
21:28:14 <SumitNaiksatam> agent should be ready by tomorrow or so
21:28:24 <SumitNaiksatam> driver is already ready but will need to wait for agent
21:28:37 <SumitNaiksatam> i sent out the proposal on the explicit commit on firewall
21:28:43 <SumitNaiksatam> got positive feedback
21:28:55 <SumitNaiksatam> are we all fine in making this change?
21:29:09 <SumitNaiksatam> that is changing from the current implicit commit to explicit commit?
21:29:22 <mestery> SumitNaiksatam: The explicit commit model is fine with me.
21:29:32 <SumitNaiksatam> mestery: thanks
21:29:45 <salv-orlando> we're adding a bit of state management in restful APIS
21:29:49 <salv-orlando> which should be stateless
21:29:52 <salv-orlando> but that said
21:30:02 <salv-orlando> we've violated principles so many times
21:30:13 <salv-orlando> that I just risk sounding pedant
21:30:20 <enikanorov_> haha
21:30:21 <salv-orlando> and also I don't have a viable alternative
21:30:29 <salv-orlando> so I should shut up
21:30:32 <SumitNaiksatam> salv-orlando: :-)
21:30:32 * salv-orlando doing that now
21:30:45 <SumitNaiksatam> any thoughts from others?
21:31:01 <SumitNaiksatam> should we submit a patch?
21:31:14 <nati_ueno> SumitNaiksatam: I wanna know implementation plan
21:31:22 <markmcclain> the details are always the big hangup
21:31:29 <nati_ueno> WTF, the agent restareted with uncomit change?
21:31:45 <SumitNaiksatam> nati_ueno: WTF? :-)
21:31:57 <nati_ueno> aaa sorry typo
21:32:00 <nati_ueno> What's if
21:32:01 <SumitNaiksatam> nati_ueno: that can be handled
21:32:12 <SumitNaiksatam> i will put this in a spec
21:32:26 <nati_ueno> so server side keeps previous state?
21:32:27 <markmcclain> SumitNaiksatam: I think writing a BP is a logical next step
21:32:29 <jjthesuperviser> can I assign to the driver api implantation?
21:32:30 <SumitNaiksatam> i will add it to the existing google doc
21:32:46 <SumitNaiksatam> nati_ueno: yes, it has both pending and committed changes
21:32:51 <SumitNaiksatam> it -> server
21:33:02 <markmcclain> given the late stage in the cycle.. I'd rather track this separately
21:33:28 <SumitNaiksatam> markmcclain: separately as in a different blueprint?
21:33:32 <markmcclain> yes
21:33:36 <SumitNaiksatam> markmcclain: yeah sure
21:33:56 <jjthesuperviser> can I?
21:34:14 <SumitNaiksatam> i am fine not putting this change for H, however i think its something that is required, so better have it before people really start using this
21:34:26 <SumitNaiksatam> hence this suggestion
21:34:34 <SumitNaiksatam> i will put the blueprint out
21:34:54 <SumitNaiksatam> SridarK, RajeshMohan anything else to add?
21:35:05 <RajeshMohan> Nothing from side...
21:35:15 <SridarK> will push out review comments responses in the next day
21:35:19 <SridarK> for Agent
21:35:24 <markmcclain> SumitNaiksatam: agreed… timing is my biggest concern… three weeks is a real short timeline
21:35:33 <salv-orlando> SumitNaiksatam: If I get the proposal right, this would change the API in a backward incompatible way. So better have a blueprint soon.
21:35:35 <SumitNaiksatam> markmcclain: i am fine either way
21:35:46 <SumitNaiksatam> salv-orlando: yes, sure
21:35:51 <salv-orlando> as we'd rather avoid a bw incompatible change after Havana is released
21:36:00 <markmcclain> +1
21:36:07 <SumitNaiksatam> salv-orlando: thats right, hence the suggestion to do now, versus later
21:36:17 <SumitNaiksatam> that is assuming we want to do it this way
21:37:00 <markmcclain> #action SumitNaiksatam to file BP on rule commit changes
21:37:10 <markmcclain> Any other questions for FWaaS team/
21:37:53 <markmcclain> #topic LBaaS
21:38:04 <enikanorov_> hi
21:38:44 <markmcclain> Looks like most of the changes have just minor clean up items
21:38:44 <enikanorov_> there is one major patch on review - integration of lbaas plugin with service types.
21:38:57 <enikanorov_> Akihiro did initial review
21:39:08 <enikanorov_> I'd like salv-orlando and nati_ueno to take a look also
21:39:08 <markmcclain> https://review.openstack.org/#/c/38120/
21:39:20 <enikanorov_> as they participated in service types discussion a lot
21:39:29 <markmcclain> salv-orlando: do you have cycles to look at this?
21:39:34 <salv-orlando> I will find cycles
21:39:42 <markmcclain> thanks
21:40:04 <nati_ueno> enikanorov_: gotcha
21:40:27 <markmcclain> Anything else?
21:40:35 <enikanorov_> there are two outstanding items - some driver/agent infrastructure refactoring made by obondarev to simplify plugin-driver implementation for vendors
21:40:50 <enikanorov_> to be pushed on review this week
21:40:59 <enikanorov_> and delegating port creation to driver
21:41:31 <enikanorov_> that one is a part of 'multiple vips per pool' BP which full impl could be postponed to I
21:42:14 <enikanorov_> that's all from lbaas side
21:43:10 <markmcclain> thanks for the update
21:43:16 <markmcclain> #topic ML2
21:43:22 <markmcclain> mestery, rkukura: hi
21:43:46 <mestery> My only update here is that support for ML2 with OVS/LB agents is now in devstack.
21:43:56 <markmcclain> great work
21:44:00 <mestery> It would be great to have people try this out and report any issues (ML2 related).
21:44:09 <rkukura> this include gre and vxlan support
21:44:17 <mestery> Yes, VLAN, VXLAN, and GRE support.
21:44:30 <markmcclain> nice
21:44:34 <nati_ueno> rkukura: mestery: awesome work!
21:44:38 <med_> woot.
21:44:42 <mestery> On the MechanismDriver front, we're starting to see some MechanismDrivers show up now in BPs and code.
21:44:44 <gongysh> mestery: do we have wiki page about how to use devstack for ml2?
21:45:01 <nati_ueno> I wanna know localrc
21:45:06 <mestery> gongysh: Yes: https://wiki.openstack.org/wiki/Neutron/ML2#Using_ML2_in_Devstack
21:45:28 <gongysh> thanks
21:45:31 <nati_ueno> When we make ML2 as default in devstack?
21:45:33 <mestery> We're working on an OpenDaylight MechanismDriver now as well, and hope to get that in for H3 yet.
21:45:49 <mestery> nati_ueno: Soon, I hope. I need to talk to Dean and Troy this week about that.
21:46:00 <mestery> ^^^ Dean and Sean
21:46:02 <uvirtbot> mestery: Error: "^^" is not a valid command.
21:46:03 <nati_ueno> mestery: Thanks
21:46:44 <markmcclain> Any other questions for ML2 team?
21:46:49 <rkukura> At this point, I suggest we require all new merges to include support for ml2 for anything they do to openvswitch or linuxbridge
21:46:50 <nati_ueno> mestery: may be, if neutron-team agrees to let ML2 as default,
21:47:00 <nati_ueno> mestery: we can do it just changing default plugin on devstack
21:47:16 <mestery> nati_ueno: Yes, but I'd still like to get their input and blessing. :)
21:47:26 <nati_ueno> mestery: gotcha :)
21:47:26 <mestery> rkukura: I agree, and I've been noting that in review already too.
21:47:44 <markmcclain> rkukura: I'm fine enforcing that policy
21:47:59 <rkukura> I noticed we missed ext-gw-mode extension for ml2, so will file bug for that
21:48:17 <mestery> rkukura: Good catch, thanks!
21:48:19 <salv-orlando> rkukura: It was merged before ML2
21:48:34 <salv-orlando> it should be super-trivail because
21:48:37 <salv-orlando> it's L3
21:48:39 <markmcclain> rkukura: thanks for filing it
21:48:39 <rkukura> agreed
21:49:08 <markmcclain> #topic Stable Branch
21:49:25 <markmcclain> garyk couldn't make it today
21:49:40 <markmcclain> The stable branch is currently frozen
21:50:41 <markmcclain> If something is missing please let me and garyk know.
21:51:18 <markmcclain> #topic Open Discussion
21:51:38 <salv-orlando> I wanted to give you an heads up on Bug 1207402
21:51:40 <uvirtbot> Launchpad bug 1207402 in neutron "neutron should automatically stamp the database version when it is deployed" [High,In progress] https://launchpad.net/bugs/1207402
21:52:11 <salv-orlando> Basically now that we have migrations, the mechanism that auto-generates the schema is superfluous if not dangerous
21:52:24 <markmcclain> agreed
21:52:26 <salv-orlando> dangerous because it does not stamp to any version
21:52:59 <salv-orlando> and also because it does not perform table deletion or update (like when you add an attribute)
21:53:02 <salv-orlando> so we're removing it
21:53:09 <salv-orlando> or at least… we're proposing to remove it!
21:53:21 <salv-orlando> if you have a reason for not removing it, please speak up!
21:53:27 <salv-orlando> We have 3 patches
21:53:55 <salv-orlando> the devstack patch is the first that should go in: https://review.openstack.org/#/c/40243/
21:53:57 <dkehn> salv-orlando, I haven't seen the test_extension_ext_gw_mode.py tearDown fix merge yet, nay news
21:54:31 <dkehn> s/nay/any
21:54:43 <salv-orlando> dkehn: I put it in WIP as the problem is a bit more general with test_config. I'm trying to do something which is not a workaround if I can find some cycles for it
21:55:04 <salv-orlando> The other two patches are neutron, and are currently in draft as they cannot be merged if the devstack patch does not go in
21:55:05 <dkehn> salv-orlando, k, I'll leave it in my pathc then for now
21:55:15 <ivar-lazzaro> After Sumit and Salvatore's advice I've drastically cut the size of the embrane's neutron plugin patch, furthermore we now have a core-dev sponsor (Thanks SumitNaiksatam). Please give a look to it if you have some cycles :)
21:55:17 <ivar-lazzaro> #link https://review.openstack.org/#/c/38222/
21:56:04 <markmcclain> salv-orlando: +1 removing the auto generated db schema
21:56:06 <salv-orlando> patch 1: https://review.openstack.org/#/c/40241/ and patch 2 (the real deal is here): https://review.openstack.org/#/c/40296/
21:56:57 <nati_ueno> salv-orlando: is that draft mode?
21:57:09 <salv-orlando> draft mode for both patches
21:57:14 <salv-orlando> do you get access denied?
21:57:18 <nati_ueno> salv-orlando: yes
21:57:19 <mestery> salv-orlando: Permission denied.
21:57:20 <markmcclain> yes
21:57:28 <mestery> On both patches
21:57:49 <salv-orlando> I always forget about it. Instead of adding all of you as reviewers, I'll put them in wip
21:58:01 <nati_ueno> salv-orlando: Thanks
21:58:12 <salv-orlando> done
21:58:59 <mestery> salv-orlando: Thanks.
21:59:04 <med_> tick-tock.
22:00:09 <markmcclain> salv-orlando: thanks for working on this change
22:00:31 <markmcclain> ivar-lazzaro: thanks for reducing the size of the patch
22:00:46 <markmcclain> Any of other items for open discussion?
22:01:00 <ivar-lazzaro> It'd be great if the blueprint could be accepted in H3, given that the code seem easy enough for you yo review ofc... please consider that
22:01:14 <ivar-lazzaro> yo/to
22:01:45 <markmcclain> Ok we're out of time…
22:02:16 <markmcclain> Remember Thursday is a bug day
22:02:19 <markmcclain> #endmeeting