21:01:14 <markmcclain> #startmeeting Networking
21:01:15 <openstack> Meeting started Mon Oct 14 21:01:14 2013 UTC and is due to finish in 60 minutes.  The chair is markmcclain. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:18 <openstack> The meeting name has been set to 'networking'
21:01:28 <markmcclain> #link https://wiki.openstack.org/wiki/Network/Meetings
21:01:40 <markmcclain> #topic Announcements
21:01:46 <markmcclain> RC2 is now available
21:01:51 <markmcclain> #link http://tarballs.openstack.org/neutron/neutron-2013.2.rc2.tar.gz
21:02:06 <mestery> Awesome! Great work on RC2 everyone!
21:02:21 <amotoki> hi
21:02:32 <gregr_3456> hi
21:02:35 <markmcclain> Right now this will be our final release version later this week
21:03:01 <markmcclain> Please test.  If you find any critical bugs, please let me know.
21:03:12 <emagana> markmcclain: no more bug fixes will be included?
21:03:40 <markmcclain> emagana: not unless the bug fix addresses a release critical bug
21:03:48 <emagana> markmcclain: good!
21:04:57 <markmcclain> #info RC2 is the last planned version prior to release
21:05:06 <markmcclain> #info TC elections are now open
21:05:11 <markmcclain> #link http://lists.openstack.org/pipermail/openstack-dev/2013-October/016432.html
21:05:42 <markmcclain> If you have ATC status and did not receive a ballot, please contact one of the election officials.
21:06:00 <markmcclain> #topic Bugs
21:06:22 <salv-orlando> hi
21:06:36 <markmcclain> #link https://bugs.launchpad.net/neutron/+bugs?search=Search&field.importance=Critical&field.status=New&field.status=Confirmed&field.status=Triaged&field.status=In+Progress
21:06:49 <markmcclain> salv-orlando: we were in the process of assigning you bugs :p
21:07:13 <markmcclain> we currently have 2 critical bugs
21:07:18 <markmcclain> https://bugs.launchpad.net/neutron/+bug/1230407
21:07:20 <uvirtbot> Launchpad bug 1230407 in neutron "VMs can't progress through state changes because Neutron is deadlocking on it's database queries, and thus leaving networks in inconsistent states" [Critical,Confirmed]
21:07:46 <markmcclain> is a race that pops up from time to time
21:07:57 <markmcclain> we still haven't fully closed
21:08:10 <markmcclain> I'm also investigating another bug: https://bugs.launchpad.net/neutron/+bug/1236439
21:08:13 <uvirtbot> Launchpad bug 1236439 in neutron "switch to use hostnames like nova breaks upgrades of l3-agent" [High,New]
21:09:09 <markmcclain> Are there any other critical potential release blockers that we need to know about?
21:09:38 <amotoki> https://bugs.launchpad.net/neutron/+bug/1211915
21:09:40 <uvirtbot> Launchpad bug 1211915 in neutron "Connection to neutron failed: Maximum attempts reached" [Critical,Fix committed]
21:09:51 <amotoki> is it still open? the review is avaialable.
21:10:55 <markmcclain> salv-orlando proposed a fix last week that at the time we thought was a parital fix
21:11:04 <salv-orlando> bug 1224001 pops up from time to time; I've looked at the logs and root cause this time seems that the instance was failing to boot
21:11:06 <uvirtbot> Launchpad bug 1224001 in neutron "test_network_basic_ops fails waiting for network to become available" [Critical,Fix released] https://launchpad.net/bugs/1224001
21:11:12 <salv-orlando> I did not push a fix for bug 1211915
21:11:13 <uvirtbot> Launchpad bug 1211915 in neutron "Connection to neutron failed: Maximum attempts reached" [Critical,Fix committed] https://launchpad.net/bugs/1211915
21:11:31 <salv-orlando> that is the bug that "went away by itself" if I recall correctly
21:12:27 * markmcclain looking
21:13:47 <markmcclain> yes
21:13:47 <markmcclain> http://logstash.openstack.org/#eyJzZWFyY2giOiJcIkNvbm5lY3Rpb24gdG8gbmV1dHJvbiBmYWlsZWQ6IE1heGltdW0gYXR0ZW1wdHMgcmVhY2hlZFwiIiwiZmllbGRzIjpbXSwib2Zmc2V0IjowLCJ0aW1lZnJhbWUiOiJjdXN0b20iLCJncmFwaG1vZGUiOiJjb3VudCIsInRpbWUiOnsiZnJvbSI6IjIwMTMtMTAtMDFUMjA6NTg6MDIrMDA6MDAiLCJ0byI6IjIwMTMtMTAtMTRUMjE6MTM6MDIrMDA6MDAiLCJ1c2VyX2ludGVydmFsIjoiMCJ9LCJzdGFtcCI6MTM4MTc4NTE5Njk5NH0=
21:14:14 <dims> salv-orlando, the bug that went away by itself was because we patched python neutron client's httpclient2 pool every call
21:14:40 <salv-orlando> dims: makes sense
21:15:09 <gongysh> dims: can u show us the patch URL?
21:15:45 <dims> gongysh, https://review.openstack.org/#/c/49210/
21:16:09 <dims> gongysh, got ninja-merged
21:16:14 <salv-orlando> so looks like bug 1211915 is not happening anymore (it has not been seen for about 10 days)
21:16:15 <uvirtbot> Launchpad bug 1211915 in neutron "Connection to neutron failed: Maximum attempts reached" [Critical,Fix committed] https://launchpad.net/bugs/1211915
21:17:06 <nati_ueno> cool!
21:17:37 <markmcclain> Any other bugs we need to talk about?
21:18:09 <markmcclain> #topic API Docs
21:18:10 <markmcclain> salv-orlando: hi
21:18:40 <salv-orlando> https://review.openstack.org/#/q/status:open+project:openstack/netconn-api,n,z
21:19:07 <salv-orlando> most patches have already a +2
21:19:19 <salv-orlando> the others are not far from being good to merge
21:19:34 <markmcclain> Ok.. I'll make sure to add these to my review queue
21:20:03 <salv-orlando> Also, I don't think we heard from the authors of the metering service for API doc; that is a gap at the moment
21:20:06 <salv-orlando> I will track it
21:20:15 <markmcclain> k
21:20:38 <markmcclain> #action markmcclain to check into metering docs
21:20:54 <markmcclain> Anything else for api docs?
21:21:04 <salv-orlando> not from me
21:21:18 <markmcclain> Thanks for updating
21:21:21 <markmcclain> #topic Docs
21:21:24 <markmcclain> emagana: hi
21:21:42 <emagana> Hi there!  ML2 installation guide is still WIP
21:22:12 <emagana> I promise Cisco folks to help with changes on Cisco plug-in documentation and it will be completed before Wednesday
21:22:35 <markmcclain> Great
21:22:41 <emagana> still have the same problem that salv-orlando, the metering part is not completed
21:22:57 <markmcclain> I'll follow up on both
21:23:25 <markmcclain> Any other doc items?
21:23:27 <emagana> The docs team fixed an important issues with the tables references with Neutron, now they look much more better and accurate!  :-)
21:23:38 <markmcclain> awesoem
21:24:10 <emagana> nothing else from my side, not sure if Anne or someone else wants to add something
21:24:16 <amotoki> emagana: which document? i haven't really caught up the document change.
21:24:41 <markmcclain> annegentle: feel free to chime if you got any new info
21:24:52 <fifieldt> we're also looking for some help with neutron install guide
21:24:56 <emagana> amotoki: https://review.openstack.org/#/c/50715/
21:24:57 <fifieldt> if anyone was interested
21:25:08 <fifieldt> as in the neutron bit of the install guide*
21:25:44 <markmcclain> emagana: did we have a contact assigned for that?
21:25:44 <amotoki> emagana: thanks.
21:25:57 <gongysh> emagana: do the patch for neutron doc belong to the neutron admin guide or new cloud admin guide?
21:26:13 <emagana> markmcclain: I think it will be me!
21:26:20 <emagana> I already signed as reviewer
21:26:32 <emagana> gongysh: cloud admin guide
21:26:36 <amotoki> gongysh: the neutron admin guide no longer exists.
21:26:43 <markmcclain> emagana: thanks
21:26:46 <emagana> amotoki +1
21:26:48 <gongysh> ok.  thanks
21:27:23 <emagana> fifieldt: check with me offline for the install guide
21:27:30 <fifieldt> yessir
21:28:18 <markmcclain> #topic FWaaS
21:28:28 <markmcclain> SumitNaiksatam: there's a meeting this Wednesday?
21:28:40 <SumitNaiksatam> yeah, i proposed one
21:29:00 <SumitNaiksatam> IRC #openstack-meeting 18:00 UTC
21:29:11 <SumitNaiksatam> pre-summit prep
21:29:26 <mestery> This is for more than FWaaS right SumitNaiksatam?
21:29:37 <mestery> Is this the service VM meeting?
21:29:48 <SumitNaiksatam> mestery: wednesday only for fwaas
21:30:03 <mestery> SumitNaiksatam: OK, thanks!
21:30:06 <SumitNaiksatam> mestery: common service requirements including service VM is today
21:30:13 <SumitNaiksatam> after neutron meeting
21:30:18 <mestery> Ah, yes! Thanks for the clarification. :)
21:30:21 <markmcclain> ok
21:30:29 <SumitNaiksatam> mean to call that out in the open discussion
21:31:05 <SumitNaiksatam> mean -> meant
21:31:09 <gongysh> SumitNaiksatam:  can we propose a time friendly for China guys?
21:31:13 <SumitNaiksatam> nothing more for FWaaS
21:31:24 <markmcclain> thanks for updating
21:31:24 <SumitNaiksatam> gongysh: sorry about that, sure
21:31:36 <gongysh> SumitNaiksatam: thanks
21:31:48 <markmcclain> #topic Horizon
21:32:04 <markmcclain> The patch to enable DB Quotas landed during the RC period
21:32:10 <amotoki> no topic for havana release.
21:32:25 <amotoki> AFAIK horizon RC2 will be avaialble soon.
21:33:24 <amotoki> thanks everyone for DB quotas patch.
21:33:26 <gongysh> amotoki: u did a great jog on horizon for neutron. I tested all of the features.
21:33:42 <gongysh> jog -> job. :)
21:33:47 <markmcclain> amotoki: thanks for updating
21:33:51 <markmcclain> #topic Summit
21:34:01 <markmcclain> #link http://summit.openstack.org/
21:34:15 <markmcclain> #info: Submission deadline is Oct 17th
21:34:55 <salv-orlando> is the total number of session slots reserved to Neutron already known?
21:35:10 <markmcclain> Yes and we're already oversubscribed
21:35:23 <enikanorov> as usual?
21:35:52 <markmcclain> We have the same number as we had in Portland
21:36:05 <salv-orlando> which is? 24 - I can't remember
21:36:20 <mestery> markmcclain: rkukura and I would like to congregate all the ML2 sessions into 1-2 "ML2 Super Sessions", which hopefuilly helps you with the numbers. :)
21:36:38 <nati_ueno> vpnaas as well
21:36:49 <marun> i'll brow beat everyone on testing in every session instead of having a testing-focused session
21:36:55 <markmcclain> we'll have 23 slots
21:37:02 * mestery thanks marun for spreading the testing love.
21:37:08 <marun> :)
21:37:18 <markmcclain> marun: we'll also be holding a joint session with the tempest team
21:37:23 <marun> sweet
21:38:07 <SumitNaiksatam> same for fwaas ("super session(s)")
21:38:17 <markmcclain> I'll be going through the submissions this week in advance of the deadline.
21:38:57 <markmcclain> if your proposal is vague please update it to include more specifics
21:39:23 <markmcclain> for the sub-teams that need super sessions
21:39:35 <markmcclain> would like the main areas to be filed
21:39:43 <geoffarnold> Can we make the deadline COB on Thursday, to allow the results of the Thursday get-together at BigSwitch to be factored in?
21:39:44 <mestery> I've been tagging my ML2 sessions with notes to make it easier for your markmcclain. :)
21:39:46 <markmcclain> I can combine them into the same block
21:39:58 <enikanorov> markmcclain: what is supersession? two slots in series?
21:40:26 <markmcclain> geoffarnold: yes… as long as it is Oct 17th somewhere in the world you can file
21:40:29 <mestery> enikanorov: "super sessions" are for things like ML2, VPN, FW which have many small ticket items which can be combined into a "super session"
21:41:03 <enikanorov> yeah. does 'super' mean more time?
21:41:11 <markmcclain> the super sessions do help a little, but we still need to spec out sub areas those sessions will cover
21:41:11 <mestery> enikanorov: No
21:41:21 <mestery> markmcclain: Understood.
21:41:45 <samuelbercovici> so will we have at least 1 slot for lbaas?
21:42:16 <emagana> Let's just submit the proposal and let PTL to organize the schedule properly!
21:42:47 <samuelbercovici> k
21:43:03 <markmcclain> samuelbercovici: yes.. we've currently only have 2 proposed
21:44:03 <markmcclain> The plan is to release the proposed schedule earlier than last time
21:44:32 <markmcclain> this will provide some time to work out the inevitable cross track conflicts where folks need to be in 2 rooms at once
21:44:39 <samuelbercovici> markmcclain: started to review the relevant proposals, i think there are more than 2, i will aslo submit one tomorrow
21:45:00 <markmcclain> samuelbercovici: I was just doing the quick search by title
21:45:05 <markmcclain> there might be more
21:45:37 <markmcclain> Any other summit questions?
21:45:44 <salv-orlando> markmcclain: the guidelines for prioritising session are on a project basis or are they set community-wide?
21:45:50 <salv-orlando> ie: how to pick a session and reject another one
21:46:18 <markmcclain> The priorities are per project
21:46:41 <salv-orlando> I think we said we'll give priority to items that are beneficial for the whole community, is that right?
21:47:34 <markmcclain> correct
21:48:38 <markmcclain> #topic Open Discussion
21:49:50 <mtreinish> markmcclain: I had a quick one, this afternoon I was looking at the set of tempest tests that work with neutron enabled. It looks like everything (except for 10 tests will work)
21:50:08 <mtreinish> so I think we might want to gate on these tests too, the issue is that without parallel it takes a long time to run
21:50:11 <mtreinish> like >1hr
21:50:27 <markmcclain> mtreinish: great
21:50:38 <salv-orlando> mtreinish: can you quickly refresh us on what we need to enable parallelisms?
21:50:43 <markmcclain> we need to ensure that we've got bugs to fix the remaining 10
21:51:02 <mtreinish> salv-orlando: the first step is tenant isolation (which I think is mostly done)
21:51:14 <mtreinish> salv-orlando: then it's debugging the races that pop up until its stable
21:51:22 <salv-orlando> mtreinish: yeah that alone unleashed hell
21:51:31 <mtreinish> markmcclain: ok, I can open bugs for them
21:51:53 <markmcclain> mtreinish: can you make sure to add a common tag so they're easy to find in launchpad?
21:51:57 <mtreinish> markmcclain: sure
21:52:12 <mtreinish> the open question I had was it ok to add a long run like that to the gate time, or should we just wait until parallel is ready?
21:52:35 <salv-orlando> mtreinish: I think we still have the issue of needing a solution for filtering on ip addresses expressed as regexes?
21:52:42 <markmcclain> we already have one of the longer running unit test suites in the gate
21:53:01 <mtreinish> salv-orlando: this is the filter I've got now: https://review.openstack.org/#/c/51275/
21:53:11 <salv-orlando> yeah, even if longer it's probably still going to be shorter than the py26 job
21:53:43 <markmcclain> mtreinish: I'd like to discuss the run time in the joint session
21:53:45 <mtreinish> salv-orlando: well right now I'm not even sure how long it's going to take, I had to up the timeout because jenkins was killing it at 1 hr
21:53:50 <markmcclain> with the temptest team
21:54:05 <mtreinish> markmcclain: ok sure, so hold off until then?
21:54:30 <mtreinish> markmcclain: with parallel runtime becomes less of an issue (it takes about half the time)
21:54:34 <markmcclain> yes.. it's only 2.5 weeks away from discussing it
21:54:45 <markmcclain> long term parallel is the way to go
21:55:07 <markmcclain> I just want to make sure we go about it in a way that does not create lots of pain for the community
21:55:39 <mtreinish> yeah, I agree we don't want a repeat of when I greenlit tenant isolation with neutron
21:55:56 <markmcclain> mtreinish: I don't think we were expecting the kernel bug we fond
21:55:58 <markmcclain> *found
21:56:30 <mtreinish> heh, yeah that's true
21:57:05 <markmcclain> Any other open discussion items?
21:57:57 <markmcclain> Thanks for stopping in this week.  If you're interested in Service VMs, please stick around.
21:58:02 <markmcclain> #endmeeting