21:00:56 <markmcclain> #startmeeting Networking
21:00:56 <marun> hi
21:00:56 <openstack> Meeting started Mon Dec  2 21:00:56 2013 UTC and is due to finish in 60 minutes.  The chair is markmcclain. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:00 <openstack> The meeting name has been set to 'networking'
21:01:11 <markmcclain> #link https://wiki.openstack.org/wiki/Network/Meetings
21:01:12 <nati_ueno> hi!
21:01:18 <markmcclain> #topic Announcements/Reminders
21:01:33 <markmcclain> #link https://launchpad.net/neutron/+milestone/icehouse-1
21:01:53 <markmcclain> The Icehouse-1 deadline is tomorrow end of day
21:02:37 <markmcclain> For the most part I-1 will be bug fixes and few features that didn't make Havana
21:02:59 <markmcclain> #topic Bugs
21:03:19 <markmcclain> We have several critical bugs targeted for I-1 that are open
21:03:21 <markmcclain> https://bugs.launchpad.net/neutron/+bugs?search=Search&field.importance=Critical&field.status=New&field.status=Confirmed&field.status=Triaged&field.status=In+Progress
21:03:45 <markmcclain> anteaya has gone through and cataloged them
21:03:57 <markmcclain> anteaya: around to cover them?
21:04:42 <Makdaam> he had some flight trouble as far as I heard on #openstack-neutron
21:04:53 <markmcclain> right.. she's flying today, so we'll keep going
21:04:53 <enikanorov> *she
21:05:00 <Makdaam> she*
21:05:08 <markmcclain> her takeoff time was right at the start of this meeting
21:05:14 <markmcclain> salv-orlando: want to update on https://bugs.launchpad.net/swift/+bug/1224001
21:05:18 <uvirtbot> Launchpad bug 1224001 in neutron "test_network_basic_ops fails waiting for network to become available" [High,In progress]
21:05:48 <salv-orlando> occurrences have been reduced since we reverted a patch for ml2. The root cause is the same as bug 125396
21:05:48 <uvirtbot> Launchpad bug 125396 in vte "Xorg 100% CPU during scrolling gnome-terminal" [Low,Incomplete] https://launchpad.net/bugs/125396
21:05:56 <salv-orlando> bug 1253896
21:05:59 <uvirtbot> Launchpad bug 1253896 in neutron "test_minimum_basic_scenario fails with SSHException: Error reading SSH protocol banner" [High,In progress] https://launchpad.net/bugs/1253896
21:06:52 <beagles> I posted a patch to the tempest test scenario for the network basic ops scenario that holds off on trying to connect until the info shows up in nova
21:07:26 <salv-orlando> thanks beagles, I will checkout this patch
21:07:37 <markmcclain> beagles: great...thanks
21:07:56 <beagles> I was mucking around and was desperate to see happy tests
21:08:12 <markmcclain> happy tests are a good thing
21:08:17 <markmcclain> mlavalle: want to update on https://bugs.launchpad.net/neutron/+bug/1251448
21:08:19 <uvirtbot> Launchpad bug 1251448 in neutron "BadRequest: Multiple possible networks found, use a Network ID to be more specific. " [High,New]
21:08:37 <mlavalle> markmcclain: yes
21:08:59 <armax> I am still working on bug #1243726
21:09:01 <uvirtbot> Launchpad bug 1243726 in neutron "tempest failure: No more IP addresses available on network" [Critical,Confirmed] https://launchpad.net/bugs/1243726
21:09:10 <markmcclain> mlavalle: what's the update?
21:09:21 <markmcclain> armax: thanks for continuing to work on that that bug
21:09:34 <mlavalle> the debugging i've done indicates that a test fails to delete a network because there are ports still busy in the subnet
21:09:39 <armax> the failure mode underlies multiple root causes
21:10:17 <rkukura> markmcclain, mlavalle: The cases of this I've looked at seem to result from DB lock timeouts.
21:10:24 <beagles> mlavalle: I've got something that might be good for you to look at
21:10:36 <markmcclain> rkukura: good to know
21:10:38 <beagles> mlavalle, but I'm waiting for the local tests to run
21:11:03 <beagles> mlavalle, basically it adds some sanity to sync_state operations... might mitigate a bunch of that stuff
21:11:21 <markmcclain> beagles: awesome you and mlavalle can sync up after the meeting
21:11:25 * beagles nods
21:11:54 <markmcclain> armax: since there are multiple causes
21:12:03 <markmcclain> should we create bugs for the different causes?
21:12:24 <mlavalle_> so it seems to me we have a race condition
21:12:48 <armax> markcclain: good point
21:13:01 <armax> I'll do that
21:13:15 <mlavalle_> the tempest test actually waits to verify that the vm has been deleted before attempting to delete the subnet
21:13:18 <markmcclain> armax: thanks!
21:13:52 <mlavalle_> that's where i am in regards to that bug
21:14:09 <markmcclain> mlavalle_: thanks for the update.. hopefully beagles work will help to the bottom of it
21:14:32 <mlavalle_> i'll ping beagles after the meeting to see how can i help
21:14:39 <markmcclain> perfect
21:14:48 <markmcclain> All- Any other critical/high priority bugs the team should be tracking this week?
21:15:18 <nati_ueno> markmcclain: how about https://review.openstack.org/#/c/21946/ ?
21:15:28 <nati_ueno> This patch is needed for fixing security group issue
21:15:47 <mestery> nati_ueno: +1 to that patch, that is a critical one.
21:15:55 <nati_ueno> Akihiro set this as critical, but I'm not sure nova side is merged in I1
21:16:03 <nati_ueno> so I'm ok to target this for I2 also
21:16:28 <steven-weston> nati_ueno: I can review 21946
21:16:31 <salv-orlando> is there consensus that the way of restoring security groups is to add all those binding attributes?
21:16:55 <salv-orlando> and I was wondering if there is a nova patch too, but these are things best discussed on gerrit
21:16:55 <nati_ueno> salv-orlando: There was a consensus, but I'm not sure current status.
21:17:11 <markmcclain> please link the nova review in teh comments
21:17:16 <nati_ueno> salv-orlando: nova side patch is https://review.openstack.org/#/c/44596/
21:17:23 <steven-weston> ok
21:17:29 <markmcclain> nati_ueno: thanks
21:17:33 <nati_ueno> markmcclain: We have comment for nova side patch https://review.openstack.org/#/c/44596/
21:17:46 <markmcclain> ok
21:17:55 <markmcclain> Any other bugs the team needs to track?
21:17:57 <nati_ueno> We have also discussion log in the bug report
21:18:05 <markmcclain> perfect
21:18:25 <markmcclain> #topic docs
21:18:27 <markmcclain> emagana: hi
21:18:36 <emagana> Hello
21:18:47 <markmcclain> looks like you've updated the doc bug list
21:18:49 <emagana> Let's start with Neutron wiki
21:18:52 <markmcclain> any you'd like to highlight?
21:18:54 <emagana> I have updated the wiki with the High Priority tickets in Docs related to Neutron:
21:19:03 <emagana> https://wiki.openstack.org/wiki/Network/Meetings#Docs_.28emagana.29
21:19:20 <emagana> markmcclain: Will keep this section updated
21:19:46 <markmcclain> ok.. thanks
21:19:49 <emagana> only one bug is unassigned: https://bugs.launchpad.net/openstack-manuals/+bug/1252131
21:19:51 <uvirtbot> Launchpad bug 1252131 in openstack-manuals "Neutron settings for Pacemaker out-of-date" [High,Confirmed]
21:20:16 <emagana> uvirtbot: that one! in deed
21:20:18 <uvirtbot> emagana: Error: "that" is not a valid command.
21:20:53 <markmcclain> I don't recall who wrote the original docs
21:21:02 <markmcclain> do we have a volunteer to tackle this one?
21:21:10 <emagana> There no new features in Icehouse-1, so no more new tickets
21:21:14 <markmcclain> if not we can work offline to find one
21:21:15 <emagana> sorry, bugs!
21:21:23 <emagana> markmcclain: sure!
21:21:27 <markmcclain> emagana: thanks for updating
21:21:31 <markmcclain> #topic Nova Parity
21:21:33 <markmcclain> beagles: hi
21:21:36 <beagles> Hi!
21:22:09 <markmcclain> looks like the holiday week slowed us down a bit last week
21:22:10 <beagles> So I was a little dumb last week thinking I was going to get some time on the nova meeting...
21:22:20 <beagles> it didn't happen because there wasn't a meeting because of the holiday
21:22:32 <markmcclain> no worries happens this time of year as folks are in and out
21:22:47 <beagles> so there is stuff that holds over from the previous things...
21:23:19 <beagles> it would be good if we could get one or more volunteers to document/spec out how nova deployments can be mimic'd in neutron
21:23:33 <markmcclain> yeah agreed
21:23:39 <beagles> I've done some rough leg work on this but I think we'll need some fine tuned stories
21:23:52 <markmcclain> ok.. these are doc items?
21:23:53 <sc68cal> The main problem is going to be the multi_host setups - no equivalent in neutron
21:24:00 <beagles> sc68cal, agreed
21:24:09 <markmcclain> sc68cal: right.. for now let's work on all cases but that one
21:24:17 <markmcclain> that's going to require some other development
21:24:28 <sc68cal> I think aveiga and I can possibly document our delpoyment, from essex & nova to our neutron based setup
21:24:35 <beagles> sweet
21:24:50 <sc68cal> we have some paperwork in progress for that for ipv6 reasons
21:25:10 <markmcclain> sc68cal: great
21:25:22 <markmcclain> beagles: any other items to raise?
21:25:23 <sc68cal> put an action item up for me to follow up
21:25:40 <markmcclain> #action sc68cal to follow up on User Stories with beagles
21:25:55 <sc68cal> thx
21:27:06 <markmcclain> beagles: thanks for working on this.. feel free to post new action items to mailing list
21:27:21 <beagles> not really, just that tempest is kind of in the way :) so I'll be a little obnoxious with the reaching out to help ;)
21:27:47 <markmcclain> great it's good we raise these issues early
21:27:50 <markmcclain> #topic Tempest
21:27:52 <markmcclain> mlavalle: hi
21:27:53 <beagles> Sure. If no-one objects I will post a link to the milestones etherpads
21:27:56 <mlavalle> I have updated in https://etherpad.openstack.org/p/icehouse-summit-qa-neutron in the API section, the gap analysis I've done for API tests. The idea is that people interested in helping us to develop tests will pick from that list features they want to test
21:28:03 <markmcclain> looks like there are lots of new reveiws this week
21:28:36 <mlavalle> I am taking the position that we want vVERY comprehensive API test
21:28:47 <markmcclain> we do
21:28:47 <beagles> mlavalle, +1
21:28:52 <salv-orlando> We could use more neutron devs, not necessarily core, reviewing these patches
21:29:08 <mlavalle> so i'm specifying that we need as many attributes and errors as possible
21:29:11 <markmcclain> more eyes is a good thing
21:29:13 <mlavalle> also negative tests
21:29:38 <roaet> I will step up my reviews on the patches.
21:29:41 <Sukhdev> Foks, I can help out with the reviews
21:29:43 <mlavalle> i've made it so far through the core API and half L3
21:29:43 * salv-orlando reiterates that on positive tests state transitions should be verified when applicable
21:30:00 <marun> ?
21:30:12 <dkehn> I can help as well
21:30:13 <marun> salv-orlando: eg?
21:30:29 <mlavalle> salv-orlando: absolutely….. the only observation there is that those verifications will be done through the api itself
21:30:32 <salv-orlando> the router interface goes up when you attach it to a router
21:30:48 <marun> salv-orlando: gotcha
21:30:54 <salv-orlando> that means the l3 agent has actually picked up the API command and implemented it
21:31:05 <mlavalle> by tonight I expect to finish floating ip's
21:31:30 <markmcclain> yeah.. having some positive steps will help to narrow down the failure causes
21:31:35 <markmcclain> mlavalle: great
21:31:51 <markmcclain> any other tempest items to discuss this week?
21:32:03 <mlavalle> I am also going to create in the neutron and tempest wiki's a how to guide for people interested in helping with API tests
21:32:21 <markmcclain> Awesome that will be super helpful for new contributors
21:32:24 <mlavalle> that will be done by early next week
21:32:26 <salv-orlando> I've provided an update on the mailing list for parallel and isolated testing
21:32:34 <mestery> mlavalle: That will be great!
21:32:36 <markmcclain> salv-orlando: thanks for sending out that update
21:32:36 <salv-orlando> I'm here if anybody wants to know more.
21:32:39 <roaet> mlavalle: ping me if you need help with any of that, I'd like to help you
21:32:51 <mlavalle> roast; perfect
21:32:56 <mlavalle> roaet
21:33:17 <mlavalle> that's all i have this week
21:33:25 <enikanorov> i'd like to ask about tempest scenario tests
21:33:31 <enikanorov> we're working on adding some for lbaas
21:33:34 <markmcclain> enikanorov: go ahead
21:33:41 <enikanorov> the first one is on review
21:34:09 <markmcclain> enikanorov: link?
21:34:21 <enikanorov> I think it's better to have at least some basic one merged in early i-2 since we try to push vendors to setup their third-patry testing
21:34:36 <markmcclain> enikanorov: agreed
21:34:44 <enikanorov> looking for the link
21:34:46 <markmcclain> ok
21:34:49 <Sukhdev> Can I ask a question regarding vendor plugin/ML2 driver testing?
21:34:55 <markmcclain> Sukhdev: sure
21:35:04 <enikanorov> https://review.openstack.org/#/c/58697/
21:35:10 <markmcclain> enikanorov: thanks
21:35:38 <Sukhdev> I am getting ready to put together testing for ML2 drivers and want to know if there is a precedence alreay in place which I can leverage from?
21:36:38 <markmcclain> Sukhdev: currently no one has published anything outside of the infra wiki
21:37:04 <Sukhdev> what would be a good staring point for me?
21:38:26 <mestery> Sukhdev: Want to chat offline? Ping me if so. We can share notes here.
21:38:45 <mestery> Sukhdev: IMHO, a good starting point is getting existing Tempest tests running with your MechanismDriver.
21:38:50 <markmcclain> mestery: can you make sure those notes make it online?
21:38:58 <Sukhdev> mestery: thanks - will ping you offline
21:39:01 <mestery> markmcclain: Yes, I will make sure to do that.
21:39:08 <markmcclain> mestery: thanks
21:39:16 <markmcclain> ok we're starting to run short on time
21:39:18 <markmcclain> #topic API
21:39:34 <enikanorov> question on API
21:39:35 <markmcclain> salv-orlando: I'm guessing with the critical bug work nothing new to add here?
21:39:42 <markmcclain> enikanorov: what's your question?
21:40:00 <enikanorov> the previous meeting there was something about 'API deprecation cycle' or something
21:40:07 <markmcclain> enikanorov: correct
21:40:12 <enikanorov> can't remember exactly. was said about lbas
21:40:15 <enikanorov> could you explain?
21:40:45 <markmcclain> enikanorov: when we make changes
21:40:47 <enikanorov> in fact i'm asking because I'd like to know our abilities to change the API in incompatible way
21:40:54 <enikanorov> (sure i know that we better to avoid that)
21:41:25 <markmcclain> we need to provide compatibility for at least one release for both variants
21:41:40 <enikanorov> i see. makes sense
21:41:53 <markmcclain> this will enable deployers and users to have time to update their tooling
21:42:06 <markmcclain> will this be an isse?
21:42:10 <markmcclain> *issue?
21:42:28 <enikanorov> no, i dont think so
21:42:34 <markmcclain> cool
21:42:41 <markmcclain> salv-orlando: anything else?
21:42:42 <enikanorov> at this point it looks like this requirement can be satisfied
21:43:02 <geoffarnold> I assume that "at least one release" implies that longer is better...
21:43:05 <markmcclain> enikanorov: good to know.. make the commit message includes the DocImpact flag
21:43:15 <gongysh> I think for experimental features, such as fwaas, we can have some big change  on API, cann't we?
21:43:17 <markmcclain> geoffarnold: where possible yes
21:43:19 <enikanorov> markmcclain: ok
21:43:20 <salv-orlando> nothing else
21:43:37 <markmcclain> gongysh: yes.. anything released as preview or experimental is subject to change
21:43:53 <markmcclain> #topic ML2
21:44:08 <markmcclain> mestery or rkukura: any update?
21:44:25 <rkukura> not much new except our patches getting backed out (temporarily I hope)
21:44:36 <rkukura> no meeting last week
21:44:41 <mestery> Only update I have is that I've started looking into multi-node devstack testing, which ML2 will require to really be tested thorougly.
21:44:54 <mestery> I spoke to the qa folks in their meeting last week, will continue that tomorrow.
21:44:56 <rkukura> weekly meetings are now Wednesday's 16:00 UTC on #openstack-meeting-alt
21:45:07 <mestery> I guess there is no multi-node testing done for the gate at the moment, so we're blazing a new path forward here.
21:45:15 <markmcclain> rkukura: do we have an assignee to work on addressing the problem that required the revert?
21:45:20 <markmcclain> mestery: great
21:45:53 <markmcclain> mestery: yeah it's only single node… the addition of multi node is a good thing
21:46:15 <mestery> markmcclain: I think tripleo also requires it, so hoping to leverage work between us and them.
21:46:21 <salv-orlando> markmcclain: the patch I pushed the revert for?
21:46:27 <markmcclain> salv-orlando: yes
21:46:36 <mestery> markmcclain: Do you have the link for that patch?
21:46:39 <markmcclain> mestery: awesome win for everyone
21:46:58 <salv-orlando> I think we can repush again once the patches for suppressing unnecessary notifications are merged, but I am not an ML2 expert.
21:47:04 <rkukura> https://review.openstack.org/#/c/58827/
21:47:19 <markmcclain> salv-orlando: ok.. good to know
21:47:25 <mestery> thanks rkukura
21:47:31 <markmcclain> rkukura: thanks
21:47:37 <markmcclain> Any other ML2 items this week?
21:47:45 <armax> btw I can confirm that one of the problems that that patch meant to address went away
21:47:47 <rkukura> salv-orlando: Do you feel backing this out actually helped?
21:47:53 <armax> as soon as the revert patch landed
21:47:56 <salv-orlando> I assume you feel not
21:48:11 <armax> so at least it wasn't for nothing :)
21:48:11 <mlavalle> armax: what issue is that?
21:48:23 <armax> https://review.openstack.org/#/c/58827/
21:48:28 <armax> second bug on the commit message
21:48:34 <mlavalle> thanks
21:48:42 <rkukura> I'm not doubting notifications are an issue in the agent, but am not clear on why that patch reduces the notifications
21:48:48 <armax> mlavalle: sure  np
21:49:20 <armax> the patch that reduces notification is not 58827
21:49:30 <armax> salv-orlando:  do you have them at hand?
21:49:56 <rkukura> looks like the DB lock timeout issue
21:50:29 <salv-orlando> The patch we reverte included a call to update_port for each port in a network being deleted. due to some issues recently observed update_port always notifies the agent. But I was thinking at occurrences of bug #1253896
21:50:30 <uvirtbot> Launchpad bug 1253896 in neutron "test_minimum_basic_scenario fails with SSHException: Error reading SSH protocol banner" [High,In progress] https://launchpad.net/bugs/1253896
21:51:19 <salv-orlando> And I do not understand enough of ML2 for making any assertion on what is good and what is bad for it. On the proposed revert we observed 5% failure rate compared with 33% of neutron jobs
21:51:52 <rkukura> I'm thinking the correct code (the patch) is helping expose the underlying issue that needs to be fixed
21:52:10 <markmcclain> ok.. we're running short on time so we can continue on the ML
21:52:14 <rkukura> salv-orlando: Lets followup on this offline
21:52:18 <markmcclain> thanks for the ML2 update
21:52:20 <mlavalle> salv-orlando: I also noticed that the nature of the exceptions in 1251448 changed when the patch was reverted
21:52:23 <markmcclain> #topic IPv6
21:52:28 <sc68cal> Hello
21:52:30 <markmcclain> sc68cal: meeting this week right?
21:53:05 <sc68cal> IPv6 work - mostly been focusing on short term needs - provider networking w/ instances configured via SLAAC, with RAs coming from a switch north of OpenStack. Required changes to iptables was merged today, and I'm working on getting the patch to disable hairpinning on the Nova side, in the VIF driver.
21:53:17 <salv-orlando> for the future, it would be good to know if the core team advises review of a ML2 core team member before approvals.
21:53:35 <sc68cal> Meeting this thursday, plan to discuss more medium term blueprints
21:53:49 <markmcclain> great.. 2100UTC in #openstack-meeting-alt
21:54:03 <markmcclain> #topic Open Discussion
21:54:14 <enikanorov> wanted to ask about ssl certificates
21:54:28 <enikanorov> nati_ueno has pushed a patch that adds certificate resource
21:54:42 <enikanorov> i wanted to know if there is a consensus on storing certs in neutron DB
21:54:55 <mlavalle> I want to get a sense as to how confident we feel the neutron tempest sprint will actually take place in January in Montreal. I want to make reservations ASAP to save my employer some money
21:54:55 <enikanorov> we're discussing the same among lbaas folks
21:54:58 <nati_ueno> enikanorov: may be we should have meeting on this
21:55:13 <enikanorov> nati_ueno: would be good
21:55:28 <markmcclain> yeah we discuss this more on the mailing list
21:55:30 <nati_ueno> enikanorov: when is your preference?
21:55:48 <nati_ueno> markmcclain: ok I'll send a mail for the openstack-dev
21:55:58 <enikanorov> nati_ueno: i need to think more about this
21:56:20 <nati_ueno> enikanorov: could you share attributes for ssl certificate for LB?
21:56:25 <markmcclain> nati_ueno: thanks.. I'd like to make discussions like this open because there security minded folks who might not attend our meetings
21:56:50 <markmcclain> here's the thread: http://lists.openstack.org/pipermail/openstack-dev/2013-December/020785.html
21:56:51 <nati_ueno> markmcclain: That's make sense, let's dicuss on the mailing list
21:57:04 <enikanorov> security-minded olks are most welcomed in such discussions for their cons :)
21:57:05 <nati_ueno> markmcclain: Thanks
21:57:22 <markmcclain> Any other open discussion items?
21:57:26 <Makdaam> just wanted to say hi, I'm new here and trying to understand how Neutron>ML2>ML2-agent works, so I'll probably add some PEP257 docstrings along the way
21:57:35 <EmilienM> markmcclain: grenade status : we are working on that with jlibosva. Infra patch under review https://review.openstack.org/#/c/59039/ which blocks Grenade patch: https://review.openstack.org/#/c/58695/
21:57:39 <mestery> markmcclain: See mlavalle's question too :)
21:57:53 <markmcclain> Makdaam: awesome good docstrings helpful
21:57:58 <jlibosva> maybe it's more related to infra, isn't it?
21:58:08 <jlibosva> the new job I mean
21:58:15 <markmcclain> EmilienM: awesome thanks for updating
21:58:17 <mlavalle> mestery: thanks buddy ;-)
21:58:21 <sc68cal> Makdaam: Probably should do a wiki page - I could help - hard to learn the hard way :)
21:58:34 * mestery is looking at the same thing as mlavelle here. :)
21:59:06 <markmcclain> mlavalle: it is a go
21:59:08 <Makdaam> sc68cal: I'll ping you later for some help, right now I'm at linuxbridge/ovs level and it's quite clear
21:59:26 <mlavalle> cool, i'll make my reservations to be in Montreal January 15
21:59:36 <markmcclain> anteaya: knows more info, so you've got questions feel free to reach out to here
21:59:37 <markmcclain> *her
22:00:12 * mestery wonders if Montreal will have more snow than Minnesota in January ...
22:00:20 <Makdaam> anteaya already offered me some help :)
22:00:42 * markmcclain doesn't deal with snow well
22:00:46 <dkehn> mestery: I'm still pondering Montreal in the winter at all
22:00:47 <mlavalle> mestery: I think it will….
22:01:05 * mestery will bring hats and gloves for folks from more tropical climate zones. :)
22:01:14 <mlavalle> markmcclain; those Californians…..
22:01:29 <markmcclain> mlavalle: I'm actually Southeast US
22:01:42 <dkehn> mlavalle: colorado rockies
22:01:45 <mlavalle> oh!!!
22:01:48 <markmcclain> Ok we're at time for this week.. thanks to everyone to stopping in
22:01:53 <dkehn> I just understand my limits in the snow
22:01:56 * mestery has snow falling outside his window right now.
22:01:57 <roaet> I love colorado!
22:01:59 <roaet> thanks markmcclain
22:02:02 <salv-orlando> I think it a good chance to try and see whether the things about alcohol keeping you warm is true.
22:02:03 <markmcclain> Have a great week and talk to everyone on teh ML and IRC
22:02:05 <Sukhdev> BTW, I am scared of Montreal weather as well :-) but, considering going :-)
22:02:10 <markmcclain> #endmeeting