21:01:40 <mestery> #startmeeting networking
21:01:41 <openstack> Meeting started Mon May 26 21:01:40 2014 UTC and is due to finish in 60 minutes. The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:44 <openstack> The meeting name has been set to 'networking'
21:01:48 <markmcclain> we have quorum of cores?
21:02:09 <mestery> markmcclain: You, me, rkukura, salv-orlando, armax ... we may be one short. :)
21:02:31 <mestery> SumitNaiksatam amotoki carl_baldwin arosen1: ping
21:02:39 <carl_baldwin> pong, hi.
21:02:48 <banix> the new core to the rescue :)
21:02:49 <markmcclain> mestery: carl counts now :)
21:02:58 <ajo> :-)
21:03:04 <mestery> #link https://wiki.openstack.org/wiki/Network/Meetings Agenda
21:03:07 <mestery> #topic Announcements
21:03:24 <mestery> markmcclain: You gave Carl's promotion to core away early on me. :)
21:03:32 <mestery> I'd like to welcome carl_baldwin to Neutron core!
21:03:40 <armax> carl_baldwin: congrats
21:03:53 <markmcclain> mestery: oops
21:03:57 <markmcclain> carl_baldwin: congrats
21:03:59 <carl_baldwin> Thanks, I’m very glad to be on the team. It is a great team.
21:04:19 <mestery> carl_baldwin: The team is excited to have you onboard!
21:04:33 <mestery> I'd also like to highlight the two mid-cycles sprints in the agenda for people as well.
21:04:48 <mestery> Ideally, it would be good to get one more core other than markmcclain and myself at hte LBaaS sprint in SAT in June.
21:05:07 <mestery> Looks like we have a good number of people attending the nova-networking parity sprint in MN in July as well!
21:05:42 <mestery> Any other announcements for the team from anyone?
21:06:05 <TheDamkot> First meeting ever... Does that count?
21:06:19 <mestery> TheDamkot: Absolutely! Welcome!
21:06:27 <TheDamkot> Thanks
21:06:46 <mestery> #topic Bugs
21:07:11 <mestery> Per the discussion from last week, I still need to get with jaypipes to document the MySQL Galera issue being discussed on the mailing list.
21:07:38 <mestery> Are there any other bugs the team should be aware of at the moment?
21:07:51 <enikanorov> https://bugs.launchpad.net/neutron/+bug/1322945 ?
21:07:52 <uvirtbot> Launchpad bug 1322945 in neutron "Attaching a IPv6 private subnet to a L3 Router, breaks it and its IPv4 Floating IPs" [High,New]
21:08:39 <mestery> Thanks for bringing that one up enikanorov, I have not read it yet.
21:09:19 <LLKCKfan> Hello
21:09:20 <LLKCKfan> How can someone who is almost 30 and never had a job get one? I have been applying just to be told I am not what they are looking for or they are not hiring.
21:10:02 <mestery> I also wanted to mention in this section of hte meeting that we have a new "Neutron Bug Czar". enikanorov has volunteered for this role.
21:10:16 <mestery> enikanorov: Thank you for doing this, this will be nice to have someone taking this on!
21:10:22 <markmcclain> so in regards to 1322945 it is not going to work anyway
21:10:32 <markmcclain> we do not activate v4 forwarding
21:10:45 <markmcclain> oops… v6
21:11:01 <mestery> markmcclain: Can you put those notes in the bug?
21:11:16 <markmcclain> mestery: yes will do
21:11:28 <mestery> markmcclain: Thanks!
21:11:29 <markmcclain> sc68cal and team should be addressing this
21:12:23 <mestery> OK, any other bugs to discuss right now before we move on?
21:13:01 <enikanorov> not yet
21:13:06 <mestery> thanks enikanorov
21:13:22 <mestery> emagana is out today, so we'll skip Docs updates for this week.
21:13:29 <mestery> #topic Nova Network Parity
21:13:39 <mestery> markmcclain: Hi!
21:13:45 <markmcclain> hi
21:14:01 <mestery> I see one update in the agenda here around the DB migration meeting
21:14:08 <markmcclain> right
21:14:23 <mestery> Cool, anything else?
21:14:25 <markmcclain> the team is meeting Tuesday at 1300UTC for the next two weeks
21:14:37 <mestery> Great!
21:14:47 <markmcclain> that work should enable us to get grenade working properly
21:15:06 <markmcclain> that's all I have since a few other contributors were on post summit holiday
21:15:14 <mestery> markmcclain: Thank you!
21:15:26 <mestery> #topic Tempest
21:15:37 <mestery> mlavalle: Hi, you wanted to update us on some tempest items today?
21:15:39 <mlavalle> markmcclain: I just updated https://etherpad.openstack.org/p/neutron-nova-parity with the latest status of api tests
21:15:54 <markmcclain> mlavalle: great
21:16:12 <mlavalle> mestery: to keep it short and sweet, just to let you know that over the past week we merged another 3 api tests
21:16:22 <mestery> mlavalle: Great news!
21:16:38 <mlavalle> I am also writing the spec in qa-specs for the scenarios we will implement in JKuno
21:17:07 <mestery> mlavalle: That's great! Once that's posted, please share in our meeting so Neutron people can review that as well.
21:17:09 <mlavalle> and I will keep and eye on nova parity to see how else I can help
21:17:25 <mlavalle> that's all for today
21:17:32 <mestery> Thanks mlavalle!
21:18:33 <mestery> I'm unsure if the other sub-teams have updated their agendas just yet, so I was thinking we could move into Open Discussion now unless someone has something from a sub-team they want to share today.
21:18:50 <carl_baldwin> mestery: One thing.
21:19:02 <mestery> carl_baldwin: Yes, please do!
21:19:10 * mestery also realizes carl_baldwin did update his section. :)
21:19:19 <carl_baldwin> DVR is heavy on my mind. We’ve created a how-to page.
21:19:27 <mestery> #topic DVR
21:19:31 <carl_baldwin> #link https://wiki.openstack.org/wiki/Neutron/DVR/HowTo
21:19:35 <markmcclain> carl_baldwin: awesome
21:19:37 <mestery> carl_baldwin: Awesome!
21:19:51 <ajo> carl_baldwin, nice :-)
21:19:53 <carl_baldwin> It doesn’t have much yet but I’m going to be working with Swami’s team on it this week.
21:19:55 <mestery> carl_baldwin: I'd like to try this out in practice as well, thanks for sharing!
21:20:20 <carl_baldwin> Anyone interested in getting their hands dirty can contact us to pitch in.
21:20:45 <carl_baldwin> That’s all I had. Everything else is up on the team wiki page.
21:20:52 <mestery> carl_baldwin: Thanks!
21:20:58 <carl_baldwin> Thank you.
21:21:04 <mestery> #topic Open Discussion
21:21:21 <mestery> I know ihrachyshka had something on osl.messaging to discuss here.
21:21:30 <mestery> *oslo.messaging
21:21:36 <ihrachyshka> oslo.messaging port stuff, I wanted to inform you about it and have some questions
21:21:46 <mestery> ihrachyshka: Please go ahead.
21:22:04 <LLKCKfan> How can someone who is almost 30 and never had a job get one? I have been applying just to be told I am not what they are looking for or they are not hiring.
21:22:24 <ihrachyshka> so the patch is at https://review.openstack.org/#/c/75861/ , it's still WIP though mostly working (I have two issues unsolved - one with extensions not unloaded during UTs, another one about RPC version in LBAAS set incorrect)
21:22:45 <ihrachyshka> we've discussed the patch with markmcclain today, he had some ideas re: future review
21:23:02 <ihrachyshka> currently the patch is unreviewable because it's too large (+1981, -7816)
21:23:39 <ihrachyshka> so that's about information (if anyone want to help me with debugging the remaining issues, don't hesitate to ask for details in person)
21:23:46 <ihrachyshka> as for questions:
21:24:21 <ihrachyshka> 1. this is a blueprint based patch, so does it mean we'll need to have a detailed spec pushed first? salv-orlando talked about possible exception for this
21:25:09 <markmcclain> seems like a very lightweight one would be possible
21:25:20 * markmcclain offers to assist writing
21:25:29 <mestery> I agree with markmcclain, I think a small BP would be good to have for this.
21:25:38 <ihrachyshka> ok
21:25:41 <ihrachyshka> markmcclain: thanks!
21:26:07 <mestery> #action markmcclain to help ihrachyshka write the oslo.messaging spec.
21:26:11 <ihrachyshka> 2. oslo.messaging does not have fake executor, so when we run UTs, we really invoke rpc listeners, and neutron currently does not have a way to stop listeners, so they probably sit there slowing down the whole run
21:26:37 <LLKCKfan> How can someone who is almost 30 and never had a job get one? I have been applying just to be told I am not what they are looking for or they are not hiring.+
21:26:44 <ihrachyshka> markmcclain said before that we are going to revisit plugins api to handle this among other things, but I don't know the current status
21:27:15 <ihrachyshka> there was an idea to stop listeners on class destruction, but I guess that's not the best thing to do since python does not guarantee much in case of __del__
21:27:27 <markmcclain> ihrachyshka: yep we will put in the interim we should determine a solution since this will impact icehouse testing too
21:27:34 <kevinbenton> ihrachyshka: why can’t the calls to invoke the listeners be mocked out?
21:28:00 <markmcclain> kevinbenton: +1
21:28:05 <mandeep> kevinbenton: +1
21:28:31 <ihrachyshka> kevinbenton: good idea. by changing BaseTestCase, right?
21:28:41 <kevinbenton> ihrachyshka: yeah
21:28:43 <ihrachyshka> we don't want this to be per-test case, right
21:28:59 <kevinbenton> ihrachyshka: because this will be used in many cases
21:29:14 <ihrachyshka> yes, I know, that's why I clarify :)
21:29:18 <markmcclain> most plugins have a base test class
21:29:25 <markmcclain> so we should be able to add it there
21:29:31 <ihrachyshka> ok, good, I'll check the approach this week and update you on the matter
21:29:48 <ihrachyshka> this would make stop_rpc_listener() not needed
21:30:12 <ihrachyshka> markmcclain: you mean, not the VERY base class? some plugin specific?
21:30:32 <markmcclain> yes not all plugins use RPC
21:30:39 <ihrachyshka> or you mean we should strive isolating mocking to plugins tests if possible
21:31:09 <ihrachyshka> good, I see. so that's a very valuable idea, thanks again kevinbenton
21:31:43 <ihrachyshka> so basically that's all for oslo.messaging. again, if anyone wants to help me with remaining stuff, I would be glad :)
21:32:02 <mestery> ihrachyshka: Thanks for the update on oslo.messging!
21:32:12 <SumitNaiksatam> mestery: as regards to sub team updates, for the advanced services framework, and fwaas, the progress is mostly waiting on review of blueprint specs
21:32:28 <mestery> SumitNaiksatam: Got it, thanks!
21:32:36 <SumitNaiksatam> also on group policy, we will reorder the patches
21:32:48 <SumitNaiksatam> so that endpoint groups lands first
21:32:57 <SumitNaiksatam> and that way it can be tested to the driver layer
21:33:10 <SumitNaiksatam> you should see it shortly - just FYI
21:33:54 <mestery> Thanks for the update on GBP SumitNaiksatam!
21:34:10 <SumitNaiksatam> sure
21:34:20 <mestery> I was hoping to keep today's meeting a bit shorter than normal, looks as if I may have succeeded. :)
21:34:30 <mestery> Unless anyone has anything else, I will give you all 26 minutes back!
21:34:39 <mandeep> mestery: +1 ;-)
21:34:47 <kevinbenton> sounds like a good reason to discuss flavors! ;-)
21:34:48 <salv-orlando> I’d gladly head off to bed
21:34:52 <markmcclain> mestery: thanks for the extra halt hour of sleep
21:34:59 <mestery> Ha!
21:35:01 <SumitNaiksatam> kebray: ha! :-)
21:35:05 * ihrachyshka rushes to my bed ;)
21:35:06 <SumitNaiksatam> kevinbenton: :-)
21:35:11 <mestery> OK, thanks everyone! Keep up the reviews and remember to signup for a mid-cycle sprintg!
21:35:14 <mestery> #endmeeting