21:01:44 <mestery> #startmeeting networking
21:01:45 <openstack> Meeting started Mon Jul 21 21:01:44 2014 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:48 <openstack> The meeting name has been set to 'networking'
21:02:09 <mestery> #link https://wiki.openstack.org/wiki/Network/Meetings Agenda
21:02:16 <dougwig> o/
21:02:22 <mestery> #topic Juno-2
21:02:41 <mestery> Per email today, I'd like to have a focused 30 minute meeting, focusing mainly on the remaining Juno-2 BPs and bugs which are left to merge.
21:02:56 <mestery> The Juno-2 tag will be made anytime between tomorrow and Thursday at hte latest.
21:03:05 <mestery> #link https://launchpad.net/neutron/+milestone/juno-2
21:03:16 <mestery> We have 3 BPs left which have a shot at Juno-2.
21:03:42 <mestery> Some need some turnaround from contributors yet, but some could use some more reviews.
21:03:53 <mestery> We also have 15 bugs left which are not completed.
21:03:58 <mestery> So there is plenty to review here.
21:04:06 * mestery notes the gate hasn't melted down yet either.
21:04:55 <mestery> The first BP which is left is the SR-IOV ML2 driver: https://blueprints.launchpad.net/neutron/+spec/ml2-sriov-nic-switch
21:05:06 <mestery> Seems this one needs some owrk on the patches yet, and IMHO, is the least likely to make Juno-2.
21:05:24 <mestery> ZZelle has the providernetwork partial specs one: https://blueprints.launchpad.net/neutron/+spec/provider-network-partial-specs
21:05:28 <mestery> This one is close.
21:05:35 <mestery> And the ofagent l2pop one: https://blueprints.launchpad.net/neutron/+spec/ofagent-l2pop
21:05:47 <mestery> That one may need a respin on the patches as well.
21:06:04 <mestery> So, any questions on Juno-2 items from anyone?
21:06:43 <salv-orlando> I can have a look at the rest of zzelle patches for partial specs before bedtime
21:06:51 <mestery> salv-orlando: Thank you sir!
21:06:54 <salv-orlando> I think we should be able to merge that.
21:07:04 <armax> mestery: I’ll have a look at the ofagent-l2pop one
21:07:04 <markmcclain> I can look too
21:07:08 <mestery> salv-orlando: Agreed, ZZelle and I found an issue with the first one which we merged a fix for already.
21:07:13 <mestery> armax: Thank you!
21:07:14 <mestery> markmcclain: Awesome!
21:07:32 <markmcclain> the l2pop will need respins
21:07:42 <mestery> markmcclain: Yes, per your review earlier I believe :)
21:07:47 <markmcclain> a few test setUps to cleanup
21:08:03 <mestery> #info ofagent l2pop needs a respin due to a few test setUps to cleanup
21:08:24 <mestery> OK, so thanks to volunteers here at the end of Juno-2!
21:08:33 <mestery> I think it's in good shape, and we're on track to merge 10-13 BPs or so, and around 80-90 bugs.
21:08:41 <mestery> Great work by everyone!
21:08:52 <mestery> Anything else on Juno-2 from anyone?
21:09:29 <rkukura> sorry I’m late
21:09:43 <mestery> #info A large number of BPs moved from Juno-2 to Juno-3 over the weekend.
21:09:52 <mestery> I moved things which I didn't feel had a chance at merging early this week.
21:10:05 <mestery> #info The DB migration BP is officially merged and complete.
21:10:17 <mestery> Thanks to HenryG for leading that charge!
21:10:21 <markmcclain> ++
21:10:30 * salv-orlando has not yet had the guts to look at the juno-3 list
21:10:35 <mestery> salv-orlando: It's huge.
21:10:37 <mestery> Really huge.
21:10:46 * mestery will trim it as Juno-3 goes along.
21:10:48 <armax> mestery: apologies for my ignorance, what would it take now for the grenade test to pass?
21:10:58 <mestery> armax: markmcclain is working on that now. :)
21:11:02 <salv-orlando> mestery: it might be huge, but we have an experience of what we might be able to do as a core team.
21:11:04 <regXboi> mestery: huge is in "by the kilo?" (sorry, couldn't resist)
21:11:05 <markmcclain> armax: we've got to make some changes to devstack
21:11:15 <salv-orlando> So I’d say to identify 25 important blueprints asap
21:11:19 <armax> mestery, markmcclain: gotcha
21:11:28 <salv-orlando> and ensure a good chunk of the core team works on those reviews
21:11:29 <mestery> salv-orlando: Yes, most of what was approved were vendor BPs.
21:11:37 <salv-orlando> the others, treat them as best effort
21:11:45 <mestery> #action mestery to highlight 20-25 community BPs for Juno-3 and focus cores on those.
21:11:57 <mestery> salv-orlando: I've indicated in all vendor BP approvals that they are best effort.
21:12:01 <mestery> salv-orlando: But a good reminder.
21:12:07 <salv-orlando> makes sense.
21:12:28 <mestery> OK, anything else for Juno-2?
21:12:34 <test12334rte> Question: Any tasks/mentors/hackathons for beginners for juno-2/3 (apologize if not right forum to ask) ?
21:12:50 <mestery> test12334rte: I'd ask in #openstack-neutron after this meeting.
21:13:03 <mestery> OK, lets move on to the last topic I wanted to quickly cover for today.
21:13:09 <mestery> #topic Juno-3 / SPD / SAD
21:13:18 <mestery> As mentioned ealrier, SAD has now passed.
21:13:25 * mestery notes not everyone ended up being SAD.
21:13:58 <mestery> A bjunch of things were approved o ver the weekend.
21:14:12 <enikanorov_> is there a notion of SAD exceptions?
21:15:01 <mestery> There is, on a case by case basis.
21:15:07 <mestery> #info for an exeption, send emails to the openstack-dev ML
21:15:35 <enikanorov_> ok, because i have a candidate :)
21:15:50 <mestery> enikanorov_: Send an email to the lsit. :)
21:16:01 <mestery> We're already way oversubscribed, but we'll take htem on a case by case basis.
21:16:02 <enikanorov_> sure, thanks
21:16:06 <mestery> Thanks enikanorov_.
21:16:22 <Sukhdev> enikanorov_: wrap the email in $20.00 bill :-)
21:16:34 <mestery> Sukhdev: :P
21:16:46 * regXboi thinks it might take more than that
21:16:52 <enikanorov_> haha, glad good it's not 20 btc!
21:17:00 <enikanorov_> -glad
21:17:40 <mestery> Anything else rom anyone on Juno-3?
21:17:51 <salv-orlando> rom?
21:18:03 <mestery> *from
21:18:11 * salv-orlando begs forgiveness for stupid question
21:18:18 <regXboi> salv-orlando: yeah - we're oversubscribed, so it's now read-only
21:18:25 <mestery> regXboi: Ha!
21:19:06 <amotoki> Are bp-specs without -2 candidates for J-3 or do we need to check SAD in dev list?
21:19:59 <mestery> amotoki: If it's not approved, an email should be sent requesting an exeption to the ML
21:20:02 <mestery> amotoki: Make sense?
21:20:11 <amotoki> mestery: yes
21:21:31 <mestery> #topic Open Discussion
21:21:38 <mestery> In keeping this short, lets have 10 minutes of open discussion :)
21:21:40 <mestery> Anything ?
21:21:54 <pcm_> Have question on my L3 validation BP. Ref. impl for VPN is in, Cisco impl is out for review (low pty).
21:21:58 <pcm_> https://review.openstack.org/#/c/107473/
21:22:17 <mestery> pcm_: Is that BP approved?
21:22:21 <pcm_> yes
21:22:34 <pcm_> one commit is upstream already.
21:22:57 <mestery> OK, so people can review that.
21:23:04 <pcm_> thanks
21:23:46 <Sukhdev> mestery: what is the deadline to get any bug into Juno-2?
21:24:09 <mestery> Sukhdev: Tomorrow
21:24:09 <Sukhdev> s/any/a
21:24:18 <Sukhdev> mestery: Thanks
21:25:01 <mestery> OK, my gift to all of you this week is 36 minutes of your time back!
21:25:03 <mestery> Thanks everyone!
21:25:09 <mestery> Lets see what we can do for Juno-2 and beyond!
21:25:14 <mestery> See you all in channel and on the ML!
21:25:16 <mestery> #endmeeting