21:00:21 <mestery> #startmeeting networking
21:00:22 <openstack> Meeting started Mon Sep  1 21:00:21 2014 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:24 <gus> hey
21:00:26 <openstack> The meeting name has been set to 'networking'
21:00:34 <mestery> #link https://wiki.openstack.org/wiki/Network/Meetings Agenda
21:00:38 <mestery> #topic Announcements
21:00:46 <mestery> The end of Juno is near.
21:00:56 <mestery> FF is this week on Thursday (8-4).
21:01:03 <mestery> #info FF is Thursday, 8-4-2014.
21:01:21 <mestery> Any BP which doesn't land has long odds to make Juno at that point because it will require a FFE
21:01:29 <mestery> #link https://launchpad.net/neutron/+milestone/juno-3
21:01:37 <salv-orlando> mestery: good so I won’t bother reviewing anything
21:01:44 <mestery> #link https://etherpad.openstack.org/p/neutron-juno-release Etherpad tracking L3 HA, ipset, and security group RPC refactoring reviews
21:01:48 <salv-orlando> if FF is expired by 4 weeks aready ;)
21:01:49 <mestery> salv-orlando: Heh :)
21:02:00 <yamamoto> 9-4?
21:02:01 <mestery> #info FF is Thursday, 9-4-2014
21:02:02 <mlavalle_> mestery: you meant 9-4-14, didn't you?
21:02:07 <mestery> salv-orlando: Good catch
21:02:19 * mestery just made everyone with an oustanding BP do a spit take
21:02:34 * mlavalle_ LOL
21:02:45 <mestery> Any questions on the FF and the end of Juno at this point?
21:02:58 <emagana> its a test to find out who is awake!
21:03:06 <mestery> emagana: :P
21:03:08 * markmcclain wonders whether to troll and ask if the feature freeze is Apr-9 or Sep-4
21:03:09 <nati_ueno> zzz
21:03:24 <mestery> Excellent!
21:03:35 <mestery> One other note here:
21:04:01 <mestery> #info The new meeting schedule will start soon (e.g. alternating meetings). We'll start that next week, email to the ML incoming.
21:04:03 <rkukura> hi - sorry I’m late
21:04:08 <mestery> #action mestery to send email about rotating meeting schedule
21:04:19 <mestery> rkukura: Hey sir, hope you're enjoying Labor Day weekend ;)
21:04:26 <mestery> Any other announcements for the team from anyone?
21:05:19 <mestery> #topic Bugs
21:05:21 <mestery> enikanorov__: Hi!
21:05:27 <enikanorov__> hi
21:05:53 <enikanorov__> there is a couple of bugs that trigger rechecks most:
21:06:03 <enikanorov__> bug 1349617
21:06:07 <uvirtbot> Launchpad bug 1349617 in neutron "test_volume_boot_pattern fails in grenade with "SSHException: Error reading SSH protocol banner[Errno 104] Connection reset by peer"" [High,New] https://launchpad.net/bugs/1349617
21:06:34 <enikanorov__> failures with this one are seen quite often
21:06:34 <mestery> enikanorov__: Yes, I was guessing that one was high on the list
21:06:39 <salv-orlando> still a half mistery for me.
21:06:47 <salv-orlando> all I can do is point at instance metadata
21:07:02 <mestery> salv-orlando: Does this one happen with nova-network as well as neutron?
21:07:07 <marun> mistery = misery + mystery?
21:07:17 <salv-orlando> mestery: hits nova network mostly on grenade job.
21:07:22 <mestery> salv-orlando: Ack
21:07:40 <salv-orlando> mestery: but it hits neutron tests which are not executed with nova network
21:07:54 <salv-orlando> so afaict it might as well be a problem affecting nova-network as well.
21:08:06 <salv-orlando> I will try and nail down the issue this week.
21:08:15 <mestery> salv-orlando: Thanks for driving this one!
21:08:17 <salv-orlando> if you have any ideas or intuitions let me know.
21:08:28 <enikanorov__> ok, another one is bug 1314313, i'm going to take care of it
21:08:29 <uvirtbot> Launchpad bug 1314313 in neutron "Firewall fails to become active within 300 seconds" [Medium,In progress] https://launchpad.net/bugs/1314313
21:08:32 <mestery> salv-orlando: Will do
21:08:33 <salv-orlando> mestery: anyway we’re positive is the instance booting without user data
21:08:58 <mestery> enikanorov__: That FW bug, is that the same one we were hitting early in Juno?
21:09:23 <enikanorov__> mestery: I has to look at it, yet, so I can't say for sure
21:09:36 <mestery> enikanorov__: Ack
21:09:39 <SumitNaiksatam> enikanorov_: that second one is only in the DVR experimental gate job right?
21:10:01 <SumitNaiksatam> enikanorov_: and that too should be fixed after a tempest patch merges
21:10:02 <enikanorov__> SumitNaiksatam: not only as I can see in reports
21:10:33 <SumitNaiksatam> enikanorov__: last week when i checked it was only in the dvr jobs, thats when i had pointed it out to you
21:11:17 <SumitNaiksatam> the issue earlier on that one was that the router was not ready when the firewall was created
21:11:24 <mestery> enikanorov__ SumitNaiksatam: It sounds like this one is under control then? Is a root cause known yet?
21:11:51 <enikanorov__> indeed, dvr jobs only
21:11:52 <SumitNaiksatam> mestery: most of the time it was because the l3_agent was not responding
21:11:57 <enikanorov__> so SUmit is right
21:12:18 <enikanorov__> anyway, going to take care of it this week
21:12:26 <SumitNaiksatam> enikanorov__: mestery: for the DVR jobs this will be fixed since armando had a fix for the tempest tests itself
21:12:42 <enikanorov__> SumitNaiksatam: goot to know!
21:12:48 <enikanorov__> *d
21:12:55 <SumitNaiksatam> the fix on the neutron side is already merged
21:13:05 <mestery> SumitNaiksatam: OK, thanks!
21:13:05 <enikanorov__> and another bug with attention is bug 1357476
21:13:06 <uvirtbot> Launchpad bug 1357476 in neutron "Timeout waiting for vif plugging callback for instance" [Medium,Confirmed] https://launchpad.net/bugs/1357476
21:13:21 <enikanorov__> it also triggers a few failures per week
21:13:53 <salv-orlando> I think arosen already has a patch for this>
21:14:08 <zhhuabj> if it's related with this patch https://review.openstack.org/#/c/115719/
21:14:09 <zhhuabj> not sure
21:15:01 <enikanorov__> could you add "Related-Bug: " in commit message?
21:15:12 <enikanorov__> so far it seems no patch is addressign the bug
21:15:21 <zhhuabj> sure
21:16:03 <enikanorov__> ok, on the bug side there was an issue iwth setup script, but the fix has been merged already
21:16:19 <mestery> enikanorov__: Great!
21:16:27 <mestery> enikanorov__: Thanks for the bugs update and for your work triaging bugs!
21:16:46 <enikanorov__> another one worth mentioning is lock wait timeouts in router scheduling happening in dvr jobs
21:17:04 <enikanorov__> but that might have been already addressed by armax's refactoring
21:17:13 <enikanorov__> unfortunately i don't have bug id for this
21:17:15 <mestery> enikanorov__: Is that one still seen post armax's refactoring?
21:17:18 <mestery> enikanorov__: OK
21:17:22 <enikanorov__> that's all from my side
21:17:31 <mestery> enikanorov__: Thank you sir!
21:17:49 <mestery> #topic Team Discussion Topics
21:18:00 <mestery> I'd like to mention that Kilo specs will open up after RC1 is finished.
21:18:09 <mestery> This will allow the team to focus on bugs and docs during the RC phase.
21:18:45 <mestery> One more item here: markmcclain, can you give us an update on the neutron incubator?
21:19:00 <mestery> #info Neutron specs for Kilo will open after RC1 is finished.
21:19:04 <markmcclain> mestery: yes
21:19:08 <mestery> markmcclain: thanks!
21:19:33 <markmcclain> jeblair raised some good concerns on the ML about the current plan
21:19:37 <markmcclain> so we'll revise it a bit
21:20:25 <markmcclain> but the current items we're incubating on slated for standalone projects
21:21:15 <mestery> markmcclain: Thanks for the update!
21:21:24 <markmcclain> depending on gate backlog we'll get hte repo running this week
21:21:32 <mestery> markmcclain: ack
21:22:14 <rkukura> markmcclain: I’m not seeing any emails on the thread from jeblair. Do you have a link to an archive?
21:22:42 <mestery> #link http://lists.openstack.org/pipermail/openstack-dev/2014-August/044125.html
21:22:53 <mestery> rkukura: ^^^^
21:23:01 <markmcclain> mestery: thanks for retrieving
21:23:09 <mestery> markmcclain: np
21:23:33 <mestery> Any other incubator questions?
21:24:26 <mestery> OK, lets move on then.
21:24:27 <mestery> #topic Parity
21:24:30 <mestery> markmcclain: Back again ;)
21:24:33 <mestery> Any updates this week?
21:25:16 <markmcclain> nothing too major… working on migration workflow
21:25:48 <markmcclain> since that will likely drive some extended work in Kilo
21:25:55 <mestery> markmcclain: nice!
21:26:00 <markmcclain> that's all I've got for parity
21:26:18 <mestery> I wanted to point out the review for defaulting devstack to neutron:
21:26:19 <mestery> #link https://review.openstack.org/#/c/105785/
21:26:29 <mestery> Do we want to push to enable this after FF this week?
21:27:07 <markmcclain> yeah.. while not likely to disrupt the gate prob best to wait until after rush
21:27:26 <mestery> #info mestery to work to merge patch to default devstack to neutron after FF
21:27:30 <mestery> Thanks for the update markmcclain!
21:27:37 <markmcclain> mestery: you're welcome
21:27:40 <mestery> #topic Docs
21:27:42 <mestery> emagana: Hi there!
21:27:49 <emagana> mestery: Hello!
21:28:20 <emagana> Last week I reported already the agreements for the Admin Guide changes
21:28:34 <emagana> Nothing to report!
21:29:09 <mestery> emagana: OK, thanks!
21:29:22 <mestery> emagana: I think once FF hits we should begin to buckle down on docs for the release.
21:29:41 <mestery> #topic Tempest
21:29:45 <mestery> mlavalle_: Any updates this week?
21:29:45 <emagana> mestery: Absolutely, we need to know what will be merged and what will not
21:29:52 <mestery> emagana: ++
21:30:23 <mlavalle_> mestery: yes. doing code reviews of api tests. In particular provider networks and multi-provider extension
21:30:32 <mestery> mlavalle_: Very good!
21:30:52 <mlavalle_> mestery: zzelle has a couple of patchsets that in my opinion are ready to merge
21:31:18 <mlavalle_> mlavalle_: I am also converting the current lbaas basic scenario to the tempest client.
21:31:42 <mlavalle_> mestery: and then I will use it as a base to create a scenario test for LBaaS 2
21:31:44 <mestery> mlavalle_: Nice!
21:32:20 <mlavalle_> mestery: enikanorov__ asked me help with a ipv6 test to review
21:32:31 <mlavalle_> mestery: which I will do
21:32:44 <mlavalle_> mestery: and that's all I have
21:32:49 <mestery> mlavalle_: Excellent and thank you!
21:32:55 <mestery> #topic Open Discussion
21:33:04 <mestery> In the interest of keeping this meeting short, lets move to Open Discussion
21:33:15 <emagana> mestery: +1
21:33:22 <mestery> I encourage people to continue reviewing the BPs linked here: https://etherpad.openstack.org/p/neutron-juno-release
21:33:30 * mestery notes the gate is fairly quiet right now ....
21:33:51 <mestery> I will send a note to the ML about the new meeting time starting next week.
21:33:52 * mlavalle_ glad he was brief... Don't want to stand between the meeting and the rest of the holiday
21:33:58 <mestery> mlavalle_: ;)
21:34:02 <kevinbenton> Neutron doesn’t work on 12.04 any more because of the dnsmasq version requirement
21:34:12 <ajo__> I have been tracking the ipset work with hanzhang , and we found something were it can be optimized,
21:34:15 <kevinbenton> is there a process guideline for those kind of deprecations?
21:34:22 <ajo__> we found excesive system calls to build ipsets,
21:34:30 <mestery> kevinbenton: Is there a newer version of dnsmasq in cloud archives?
21:34:56 <salv-orlando> ajo_: how long will it take in rough terms?
21:34:57 <kevinbenton> mestery: i’m not familiar with that, what is it?
21:34:58 <ajo__> but as long as we can have a FFE for the ipset we have a simple optimization we can do using the save/restore functionality of ipset
21:35:01 <mestery> kevinbenton: Not sure what you mean, I think the IPV6 changes required the newer dnsmasq right?
21:35:08 <ajo__> salv-orlando I think we can have it around tomorrow.
21:35:14 <salv-orlando> mestery: nope. I had to rebuild our devstack images for the CI
21:35:19 <salv-orlando> ajo__: that’s good then.
21:35:26 <mestery> kevinbenton: It's a place where anyone who uses 12.04 goes to get softrware written >= the last 2 years ;)
21:35:32 <mestery> salv-orlando: Interesting
21:36:01 <kevinbenton> mestery: i thought the version increase was get rid of workarounds
21:36:06 <kevinbenton> didn’t realize it was a hard requirements
21:36:09 <kevinbenton> requirement*
21:36:32 <HenryG> Somewhere there is a note saying that Juno will not support Ubuntu 12.04 (or is it the other way around?).
21:36:37 <salv-orlando> considering that the ubuntu LTS release is now trusty unless other main distros are shipping dnsmasq<2.63 I think the minimum requirement is acceptable.
21:37:03 <mestery> HenryG: That's entirally likely, 12.04 is quite literally ancient, and infra has moved to 14.04 for almost everything
21:37:09 <mestery> salv-orlando: ++
21:37:17 <ajo__> mestery, salv-orlando I'd also love to see the ProcessMonitor for external processes merged during juno-3, I know it's med-prio, but it's getting a good amount of review and I'm very happy about how it works: https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/agent-child-processes-status,n,z
21:37:28 <ajo__> it's something that we're leaving behind release after release
21:37:32 <mestery> ajo__: I'll take a look, I hope salv-orlando can as well.
21:37:37 <kevinbenton> but it is still supported…
21:37:49 <ajo__> sorry for the current state, as recent merge conflicted the work, but it's already worked out for the first patch in the chain,
21:37:51 <salv-orlando> ajo__: I’d love to see all blueprints merged ;)
21:37:52 <ajo__> next to be rebased tonight
21:38:07 <kevinbenton> oh well, an upgrade to Juno is as good a time as any to change the underlying OS
21:38:48 <mestery> Lets see what we can still merge before FF this week.
21:38:52 <amotoki> the quesiton is OpenStack does not support Ubuntu 12.04. IMO Ubuntu 12.04 supports openstack juno if they want.
21:38:52 <mestery> Thanks for joining everyone!
21:38:55 <ajo__> salv-orlando, yeah, me too, I understand we have priorities, but it's a "bug" we have been suffering for long :)
21:39:08 <mestery> amotoki: Right, it's the other way around, I agree.
21:39:09 <ajo__> anyway, if not merged It will be understood
21:39:14 <emagana> mestery: ma7be just adding a note on the installation guide
21:39:18 <emagana> maybe*
21:39:29 <mestery> emagana: I'll add it to the release notes for Juno for sure (the version requirement for dnsmasq)
21:39:34 <amotoki> emagana: +1 and release notes.
21:39:42 <mestery> And make a note that 12.04 stock doesn't have a version high enough
21:40:10 <kevinbenton> it does work if you compile the latest manually
21:40:25 <kevinbenton> so that could be listed as a workaround if 12.04 is required
21:40:32 <mestery> kevinbenton: ++
21:40:32 <ajo__> kevinbenton, what's our version requirement at the moment?
21:40:45 <ajo__> for dnsmasq, I mean
21:41:11 <amotoki> ajo__: dnamasq >= 2.63 now
21:41:17 <ajo__> thanks amotoki
21:42:10 <mestery> OK, thanks everyone!
21:42:12 <mestery> #endmeeting