14:01:27 <mestery> #startmeeting networking
14:01:28 <openstack> Meeting started Tue Oct  7 14:01:27 2014 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:31 <openstack> The meeting name has been set to 'networking'
14:01:37 <mestery> #link https://wiki.openstack.org/wiki/Network/Meetings Agenda
14:01:44 <mestery> #topic Announcements
14:01:55 <mestery> We released the RC1 for Neutron
14:01:58 <mestery> #link https://launchpad.net/neutron/+milestone/juno-rc1
14:02:02 <mestery> #link https://launchpad.net/neutron/juno/juno-rc1/+download/neutron-2014.2.rc1.tar.gz
14:02:12 <mestery> Please give this a go and report issues in launchpad as you find bugs.
14:02:28 * regXboi quotes "...and there was much rejoicing... (yay!)"
14:02:30 <mestery> If you find what you consider to be release blocking bugs, please tag them as "juno-rc-potential"
14:02:32 <ajo> hi :)
14:02:50 <mestery> We'll discuss the current list of RC potential bugs in the bugs section.
14:03:18 * ihrachyshka added one to the list
14:03:20 <mestery> #info Please tag release blocking bugs with "juno-rc-potential"
14:03:30 <emagana> Open Question: Is Multinode being tested by someone? If yes, please ping me!
14:03:32 <mestery> ihrachyshkaThanks!
14:03:41 <mestery> #link https://wiki.openstack.org/wiki/ReleaseNotes/Juno#OpenStack_Network_Service_.28Neutron.29 Release Notes
14:03:47 <mestery> We're also updating the release notes as a team now.
14:03:57 <mestery> So please feel free to edit that page, I've given it a good start already.
14:04:06 <mestery> Any other announcements for the team?
14:05:02 <mestery> #topic Bugs
14:05:04 <mestery> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=juno-rc-potential
14:05:13 <mestery> Those are the only bugs tagged as release critical right now.
14:05:19 <mestery> So lets take a walk through them now.
14:05:35 <mestery> First, this one: https://bugs.launchpad.net/neutron/+bug/1367892
14:05:38 <uvirtbot> Launchpad bug 1367892 in neutron "delete port fails with RouterNotHostedByL3Agent exception" [Medium,Fix committed]
14:05:46 <ihrachyshka> fix-committed?
14:06:01 <mestery> armax: Does this one need backporting to the release branch? Thoughts?
14:06:07 <mestery> ihrachyshka: I think this went into master.
14:06:28 <armax> mestery: I tagged it as juno-rc-potential on the LP bug report
14:06:29 <mestery> carl_baldwin: ^^^
14:06:37 * carl_baldwin looking
14:06:44 <mestery> armax carl_baldwin: Is this a DVR bug which we should backport into the stable branch?
14:06:49 <carl_baldwin> It is unclear if this was merged before the cut.
14:06:56 <carl_baldwin> If not, it should be ported.
14:07:05 <mestery> carl_baldwin: Ack, I'll figure this out.
14:07:16 <carl_baldwin> mestery: I’ll go figure it out.  Don’t worry.
14:07:17 <mestery> #action mestery to ensure https://bugs.launchpad.net/neutron/+bug/1367892 is a part of the Juno release
14:07:18 <uvirtbot> Launchpad bug 1367892 in neutron "delete port fails with RouterNotHostedByL3Agent exception" [Medium,Fix committed]
14:07:20 <armax> mestery: you mean proposed/juno?
14:07:21 <mestery> carl_baldwin: Thanks!
14:07:24 <mestery> armax: Yes.
14:07:39 <armax> mestery: bug 1367892 is not part of RC!
14:07:39 <mestery> Next one is this: https://bugs.launchpad.net/neutron/+bug/1372438
14:07:39 <uvirtbot> Launchpad bug 1367892 in neutron "delete port fails with RouterNotHostedByL3Agent exception" [Medium,Fix committed] https://launchpad.net/bugs/1367892
14:07:41 <uvirtbot> Launchpad bug 1372438 in neutron "Race condition in l2pop drops tunnels" [Medium,In progress]
14:07:42 <armax> *RC1
14:08:01 <mestery> armax carl_baldwin: OK, then we'll need to add it to the proposed branch. I'll work with carl_baldwin on that.
14:08:14 <mestery> ihrachyshka: Looks like this next one was added by you.
14:08:29 <ihrachyshka> for 1372438, I've marked it for Juno. it's a race in l2pop that may result in tunnels dropped and no connection for instances hosted on the node. the fix is in review, looks fine
14:08:43 <salv-orlando> there are still two gate offending bugs which might need a fix in neutron - I think we can try and make an effort by marking them as rc-potential. At least to root cause them - perhaps then they’re not even neutron bugs
14:09:00 <markmcclain> salv-orlando: ++
14:09:10 <ihrachyshka> similar fix was already merged before in master, but then reverted by dvr. the new one basically returns the previously reviewed code
14:09:13 <mestery> salv-orlando: ++
14:09:17 <salv-orlando> http://status.openstack.org/elastic-recheck/#1357055 and http://status.openstack.org/elastic-recheck/#1370496
14:09:41 <mestery> ihrachyshka: I think the L2pop bug looks doable for an RC2, seems simple enough.
14:09:43 <salv-orlando> there is also http://status.openstack.org/elastic-recheck/#1323658 which seems more of a nova bug - and the nova team decided to move it out to kilo
14:10:28 <mestery> salv-orlando: Ack.
14:10:37 <mestery> salv-orlando: Can you add "juno-rc-potential" to those two gate blocking bugs for now?
14:11:13 <salv-orlando> sure
14:11:35 <mestery> OK, the last one on the list is this one: https://bugs.launchpad.net/neutron/+bug/1349302
14:11:37 <uvirtbot> Launchpad bug 1349302 in neutron "Add verification of iproute2 capabilities used by SR-IOV agent" [Low,In progress]
14:11:47 <mestery> This one hasn't merged in master yet.
14:12:05 <amuller> That can't possibly be considered a release blocker
14:12:07 <mestery> It seems like a large change, I'm unsure if this will make an RC2.
14:12:15 <mestery> amuller: Agreed, and in fact I'll remove the tag.
14:12:25 <amotoki> afaik, it only affect SR-IOV. I think it fits backport-potential.
14:12:31 <ihrachyshka> isn't sanity check enough?
14:12:37 <marun> ihrachyshka++
14:12:40 <ajo> yes
14:12:42 <marun> we do
14:12:45 <ajo> I was about to say the same
14:12:46 <salv-orlando> what major ffeature is that bug blocking?
14:12:53 <mestery> No major feature.
14:13:04 <mestery> SR-IOV with mellanox cards?
14:13:10 <mestery> I don't see irenab here.
14:13:17 <mestery> I've removed the tag for now.
14:13:21 <amotoki> I am not sure at now.
14:13:21 <markmcclain> I'm not sure why the new features we're added to ip lib
14:13:43 <markmcclain> *we're not added to ipbli
14:13:50 * markmcclain can't type this early
14:13:55 <mestery> markmcclain: Agreed, and get more coffee
14:13:57 <mestery> :)
14:14:08 <ajo> :-)
14:14:15 <mestery> OK, I think we have a handful of bugs we're tracking for a likely RC2 now.
14:14:23 <mestery> I'll confirm this with ttx in my 1:1 with him this morning.
14:14:40 <mestery> If any other bugs pop up which anyone thinks are release blockers, please ping me on IRC and let me know.
14:14:52 <mestery> We're getting close to the end of Juno so I need to stay on top of this now. :)
14:15:21 <mestery> OK, moving on now.
14:15:34 <mestery> #topic neutron-drivers team
14:15:43 <mestery> #link https://wiki.openstack.org/wiki/Neutron-drivers
14:15:56 <mestery> I've decided to create a neutron-drivers team, mapped similar to nova-drivers.
14:16:05 <mestery> This team will be responsible for approving specs during Kilo.
14:16:21 <mestery> The idea is to focus on spec approval and provide a consistent direction for neutron during kilo by a focused group of cores.
14:16:30 <mestery> Please look at the wiki for more information.
14:17:05 <mestery> This process has worked for nova, so we'll give it a try during kilo and see how it works for neutron as well.
14:17:08 <mestery> Any questions?
14:17:28 <ajo> Looks good to me.
14:17:38 <mestery> ajo: Thanks!
14:17:42 <amuller> Should probably write down what are the goals for Kilo in that page
14:17:43 <ajo> :-)
14:17:54 <amuller> So there's some transparency or guidelines as to why a spec would get -2'd
14:18:04 <mestery> amuller: I sent an email to the ML about that: http://lists.openstack.org/pipermail/openstack-dev/2014-October/047954.html
14:18:12 <mestery> amuller: Good feedback though.
14:18:28 <emagana> mestery: only these members will +A specs and code?
14:18:36 <mestery> emagana: This is for specs only.
14:18:45 <mestery> emagana: neutron-specs repository. Code stays the same as it is now.
14:19:06 <mestery> For neutron-specs, cores can +2/-2, neutron-drivers additionally have +A.
14:19:12 <salv-orlando> I feel like the community is asking each project to write a constitution… I can’t picture myself as a “founding father"
14:20:00 <amuller> salv-orlando: I'll mail you a white wig
14:20:04 <mestery> OK, I'll be sending an email about this to the list after the meeting.
14:20:15 <mestery> We can continue discussion there or in-channel (or even during Open Discussion later in this meeting).
14:20:28 <markmcclain> amuller: please do…we should make salv-orlando wear it in paris
14:20:38 <salv-orlando> amuller: only if it’s made of cashmere wool.
14:20:40 <mestery> Pics or it didn't happen.
14:20:46 <ajo> lol
14:20:47 <mestery> lol
14:20:56 <amuller> #action amuller will provide one said white wig to be worn by Salv during the Paris summit
14:21:05 <mestery> amuller: rofl
14:21:07 <jschwarz> lol
14:21:09 <fawadkhaliq> LOL
14:21:10 <amotoki> :-)
14:21:13 <markmcclain> haha
14:21:20 <mestery> OK, lets move along.,
14:21:25 <mestery> #topic Kilo Design Summit
14:21:39 <mestery> Now that Juno is winding down, we need to start planning our Summit Sessions in earnest.
14:21:54 <mestery> For the backstory:
14:21:55 <mestery> #link http://lists.openstack.org/pipermail/openstack-dev/2014-September/045844.html
14:22:05 <mestery> Our shared etherpad of ideas:
14:22:07 <mestery> #link https://etherpad.openstack.org/p/kilo-neutron-summit-topics
14:22:34 <mestery> In parallel of tracking down the Juno RC2, I'm going to start organizing this list and I encourage folks to get their ideas on the etherpad this week.
14:23:12 <mestery> As I think salv-orlando said a few weeks ago, we have enough work on there for 10 years or so, if we work harder, we can get enough to last for hte rest of our careers :)
14:23:29 <mestery> We only get a limited number of slots, so I want the team to focus on shared community topics for those slots in Paris.
14:24:17 <mestery> Also, in regards to what I think the focus area should be for Kilo, see my email to the list this morning:
14:24:18 <mestery> #link http://lists.openstack.org/pipermail/openstack-dev/2014-October/047954.html
14:24:22 <mestery> Any questions or comments here?
14:24:30 <amotoki> Cross-project topics will be more prioritized.
14:25:08 <mestery> amotoki: Agreed! For instance, the refactoring of the nova/neutron interface needs to be there, along with migration from nova-network to neutron.
14:25:26 <obondarev> how many slots will we have?
14:25:31 <ajo> about cross project topics & paying technical debt, I believe the osprofiler integration would help on helping us learn more about neutron itself, and how does it integrate with other projects.
14:25:43 <mestery> obondarev:I believe we get 7, let me verify
14:25:59 <ihrachyshka> ajo: does it require summit slot though?
14:26:05 <ajo> nope, sorry
14:26:08 <ajo> probably not
14:26:58 <mestery> obondarev: We get 11 slots, and then on Friday we have pod time
14:27:00 <mestery> #link http://kilodesignsummit.sched.org/overview/type/neutron#.VDP4H-d8GoA
14:27:10 <obondarev> mestery: thanks
14:27:22 <obondarev> I think I saw migration from nova-network to neutron as a potential topic in Nova's etherpad as well, perhaps we should coordinate with them on this
14:27:24 <mestery> ajo ihrachyshka: Agreed, not sure it requires a summit slot, but maybe some time on Friday for F2F discussions.
14:27:34 <mestery> obondarev: We need that in the cross-project track.
14:27:44 <obondarev> mestery: agree
14:27:45 <mestery> #link http://kilodesignsummit.sched.org/overview/type/cross-project+workshops#.VDP4X-d8GoA
14:27:48 <mestery> obondarev: ^^^
14:27:57 <mestery> obondarev: Those are on Tuesday.
14:28:07 <ajo> mestery++
14:28:23 <mestery> So as you can see, we're constrained in relation to the amount of time we had in Atlanta.
14:28:32 <mestery> But this will help us focus on use the F2F time wisely I think.
14:28:46 <mestery> And focusing on cross-project time will also be very important.
14:29:04 <ihrachyshka> whatis f2f
14:29:16 <marios> face
14:29:18 <dougwig> face to face
14:29:19 <mestery> face to face
14:29:24 <ihrachyshka> thanks
14:29:26 <mestery> dougwig: jinx
14:29:27 <mestery> lol
14:29:34 <dougwig> :)
14:29:48 <kevinbenton> ihrachyshka: when everyone sits in a room and yells their opinions while plugging their ears
14:29:57 <regXboi> kevinbenton: nice
14:30:05 <ihrachyshka> that's why it's face-to-face, not ear-to-ear
14:30:16 <mestery> kevinbenton: Very eloquent description of a design summit
14:30:25 <ajo> lol ':)
14:30:40 <mestery> OK, moving on.
14:30:51 <mestery> I wanted to highlight the LBaaS feature branch and encourage cores to continue reviewing this.
14:30:57 * mestery waits for markmcclain to post a link
14:31:07 * mestery thinks dougwig has that link too
14:31:14 <dougwig> the first three reviews are ready for core attention:
14:31:15 <dougwig> https://etherpad.openstack.org/p/lbaas_reviews
14:31:19 <mestery> dougwigThanks!
14:31:23 <mestery> #link https://etherpad.openstack.org/p/lbaas_reviews
14:31:47 <mestery> dougwig: I plan to spend time on these today myself, I'll find you on #openstack-lbaas with questions.
14:31:52 <markmcclain> dougwig: thanks
14:31:53 <dougwig> ok
14:32:30 <mestery> #topic Parity
14:32:37 <mestery> markmcclain: Hi! Updates this week?
14:32:54 <markmcclain> we'll be writing up the final report of Juno work and posting to the mailing list
14:33:11 <markmcclain> the gate bugs that salv-orlando are really important to find the root cause
14:33:53 <markmcclain> since they're regularly the top gate offenders that will be a blocker to enabling neutron as devstack default
14:34:18 <ihrachyshka> markmcclain: not atm, some of them are disabled in tempest. though yes, it's not a long-term solution.
14:34:18 <mestery> #info Need to close on gate bugs for neutron so we can enable neutron as the default in devstack
14:34:38 <salv-orlando> I mean at the end of the day probably they’re not even neutron bugs - but al least we should know that for sure
14:34:49 <salv-orlando> and file patches where appropriate
14:34:50 <mestery> salv-orlando: ++
14:34:56 <markmcclain> salv-orlando: agreed
14:35:16 <anteaya> ihrachyshka: the fact they are disabled in tempest is frustrating for qa
14:35:27 <mestery> markmcclain: I need to sync with mikal yet on the wording around marking nova-network as deprecated in Juno.
14:35:42 <markmcclain> mestery: ack
14:35:44 <mestery> I hope we can get approval for that in the Juno release notes, given the progress on the parity plan we made.
14:35:48 <ihrachyshka> anteaya: it also makes me sleep bad
14:36:12 <anteaya> good, sounds like motivation for a fix, since you should be able to sleep well
14:36:26 <ihrachyshka> hah
14:36:51 <mestery> OK, thanks for the update markmcclain.
14:36:53 <mestery> #topic Docs
14:36:55 <mestery> emagana: Hi there!
14:37:18 <emagana> mestery: Hi
14:37:32 <emagana> Good progress on the Docs Side
14:37:41 <emagana> We completed the ToC for the Networking Guide
14:37:46 <emagana> #link https://wiki.openstack.org/wiki/NetworkingGuide/TOC
14:37:49 <mestery> emagana: Excellent!
14:38:04 <amotoki> emagana: what is TOC?
14:38:11 <emagana> Table of Content
14:38:22 <amotoki> got it
14:38:34 <emagana> This wiki will be use to track all the content in this guide
14:39:04 <emagana> As we decided before, we will only reference the default options for Neutron (ML2 & OVS)
14:39:48 <emagana> One or two members of the Docs team will help in moving the staff from the Networking Guide Wiki to Gerrit Commits
14:39:58 <emagana> I will post links once we have them
14:40:06 <mestery> emagana: Regarding DocImpact bugs, armax and I were discussing, how do we ensure those with that flag are covered inthe Juno documentation?.
14:40:11 <mestery> Does the Doc team need help with any of those?
14:40:14 <mestery> armax: ^^^
14:40:37 <armax> yes, we need owners for the bug reports that were filed automatically against openstack-manuals
14:40:43 <emagana> mestery: We need to review them, most of them where config changes that were included automatically
14:40:50 <mestery> emagana: Ack
14:41:16 <amotoki> we need more clear criteria what changes require DocImpact flag. I don't think simple config change need DocImpact because the config guide is generated automatically.
14:41:18 <emagana> mestery: Others will be included as the major refactor of the Networking section, such as L3 HA and DVR
14:41:46 <emagana> amotoki: Yes, but adding DocImpact ensures that we track those changes
14:42:09 <armax> emagana: I’ll review the bug reports to see whether we’re missing something
14:42:10 <amotoki> emagana: agree. we can discuss on it in docs list.
14:42:13 <mestery> emagana: Are you working with armax and carl_baldwin and amuller for that refactor? Those folks can really help there.
14:42:45 <carl_baldwin> emagana: glad to help when you need me
14:42:49 <emagana> I have been conecting carl_baldwin with some of the folks testing the DVR staff
14:42:56 <mestery> emagana: Thank you!
14:43:03 <emagana> will do the same for L3 HA
14:43:28 <mestery> emagana: Perfect! amuller is your friend there :)
14:43:30 <emagana> Those folks where able to get DVR and l3 HA working as far as I know
14:43:51 <emagana> I know.. amuller Thanks!
14:43:52 <amuller> emagana: Feel free to hit me up with any questions or anything you need
14:44:04 <mestery> Lets all make sure to help out the docs team when emagana comes calling, this is very important to ensure people can use the great software we write. :)
14:44:28 <emagana> mestery: I will mostly connecting people
14:44:28 <amotoki> ++
14:44:32 <mestery> Thanks for your work here emagana!
14:44:51 <emagana> mestery: I will provide a more extensive report next Monday
14:44:57 <mestery> emagana: Awesome!
14:44:59 <emagana> mestery: This week will be vey active  ;-)
14:45:05 <mestery> emagana: I expect so, yes.
14:45:06 <emagana> mestery: I am done!
14:45:10 <mestery> emagana: Thank you!
14:45:17 <mestery> #topic L3
14:45:18 <mestery> carl_baldwin: Hi!
14:45:21 <carl_baldwin> hi
14:45:29 <carl_baldwin> I don’t need any meeting time.
14:45:33 <carl_baldwin> #link https://wiki.openstack.org/wiki/Meetings/Neutron-L3-Subteam
14:45:51 <carl_baldwin> Anything for me?
14:45:56 <mestery> carl_baldwin: OK, thanks!
14:46:13 <mestery> ACtually, lets move to Open Discussion now.
14:46:16 <mestery> #topic Open Discussion
14:46:43 <matrohon> hi, I just added this bug to juno-rc-potential : https://bugs.launchpad.net/neutron/+bug/1361540
14:46:45 <uvirtbot> Launchpad bug 1361540 in neutron "no mechanism driver calls for gateway port removal" [Medium,In progress]
14:46:53 <mestery> I just had my 1:1 with ttx now, I'm going to be looking at other commits which were made since RC1 was cut for potential backporting for our RC2.
14:46:56 <mestery> I'll sync with ttx tomorrow on this.
14:47:15 <mestery> matrohon: I just saw that one
14:48:10 <mestery> OK, if there's nothing else, thanks for attending this week!
14:48:22 <mestery> I may ping people on potential RC2 bugs, so stay on top of those and docs this week.
14:48:28 <mestery> See you all in-channel and on the ML!
14:48:32 <mestery> #endmeeting