21:00:07 <mestery> #startmeeting networking
21:00:07 <kevinbenton> \o
21:00:07 <openstack> Meeting started Mon Mar 16 21:00:07 2015 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:11 <openstack> The meeting name has been set to 'networking'
21:00:25 <mestery> #link https://wiki.openstack.org/wiki/Network/Meetings Agenda
21:00:32 <mestery> #topic Announcements
21:00:45 <HenryG> o/
21:00:46 <mestery> Feature freeze is this week
21:00:55 <mestery> #info Feature Freeze is this week
21:01:11 <mestery> Given the gate issues we've had, if you want to be extra sure your stuff merges by Thursday, get it in the queue by tomorrow.
21:01:30 <kevinbenton> does deadline apply to merge time or approve time?
21:01:39 <mestery> kevinbenton: Merge time
21:01:55 <mestery> I expect some folks to ask for FFEs, I've already discussed with a few of you about that.
21:02:02 <mestery> For now, lets see what we can merge this week.
21:02:07 <mestery> And deal with FFEs post-Thursday.
21:02:17 <mestery> #link https://launchpad.net/neutron/+milestone/kilo-3
21:02:25 <mestery> ^^^^ is your review list
21:02:30 <mestery> Please try to focus there and not just randomly in gerrit :)
21:02:40 <mestery> Any other announcements for the team?
21:02:58 <Sukhdev> can I make an announcement>
21:03:07 <mestery> Sukhdev: Please!
21:03:49 <Sukhdev> Wanted to let the wider team know that L2 Gateway team has come with the initial implementation of L2 Gateway api
21:04:00 <Sukhdev> and it is ready for testing by wider community
21:04:04 <mestery> #info The L2 gateway team has finalized the L2 gateway API
21:04:08 <mestery> Sukhdev: Cool!
21:04:16 <Sukhdev> #link: https://wiki.openstack.org/wiki/Neutron/L2-GW
21:04:19 <salv-orlando> Sukhdev: cool, what's the backend for the ref impl?
21:04:37 <Sukhdev> salv-orlando: OVSDB
21:04:44 <mestery> Sukhdev: Nice nice nice!
21:04:47 <salv-orlando> Sukhdev: great thanks!
21:04:59 <Sukhdev> We would like folks to jump in and give it a test drive
21:05:14 <mestery> #info L2 Gateway team would love to get feedback
21:05:28 <mestery> Sukhdev and team: very cool! Any other announcements from anyone?
21:05:46 <mestery> OK, lets move along then.
21:05:48 <mestery> #topic Bugs
21:06:02 <mestery> enikanorov enikanorov__  can't join us today, but he wanted us to highlight a few bugs
21:06:11 <mestery> Like this one: https://bugs.launchpad.net/neutron/+bug/1432065
21:06:12 <openstack> Launchpad bug 1432065 in neutron "DBDeadlock: (OperationalError) (1213, 'Deadlock found when trying to get lock; try restarting transaction') 'DELETE FROM ipallocationpools WHERE ipallocationpools.id" [Critical,Confirmed]
21:06:29 <salv-orlando> not the first time I see this failure
21:06:55 <mestery> salv-orlando: Any ideas, or it's just a familiar face?
21:06:58 <salv-orlando> we know the root cause - but we love bikeshedding on whether it's better to take the hit for the deadlock or have a non locking approach
21:07:08 <mestery> salv-orlando: Ah, right.
21:07:16 * mestery proposes we bikeshed on the review rather than here in the meeting
21:07:22 <salv-orlando> I'm pretty sure I saw something from rossella_s that even if not elegant would have solved the issue
21:07:31 <mestery> It's a more intimate bike shedding that way
21:07:38 * markmcclain puts away his bucket of blue paint
21:07:44 <dougwig> pink
21:07:44 <mestery> lol
21:07:55 <mestery> Also, this one: https://bugs.launchpad.net/neutron/+bug/1419723
21:07:56 <openstack> Launchpad bug 1419723 in neutron "DBDuplicateEntry when creating secgroup" [High,In progress] - Assigned to Eugene Nikanorov (enikanorov)
21:08:28 <mestery> Handled byt this one: https://review.openstack.org/#/c/164463/
21:08:50 <rossella_s> salv-orlando are you referring some patch that I had to retry to operation or to the one that removes the lock?
21:09:09 <salv-orlando> rossella_s: the retry one
21:09:50 <rossella_s> salv-orlando I can start working on that again if there's consensus...there have been lots of discussions about that strategy
21:10:27 <salv-orlando> rossella_s: consensus there will be once the bike shed has a good coat of painting
21:10:47 <rossella_s> salv-orlando: :)
21:10:50 <mestery> lol
21:11:08 <salv-orlando> rossella_s: mestery asked us to move discussion to ML/gerrit/launchpad. Possibly bug report on launchpad as it seems the most rcent point of discussion
21:11:16 <mestery> salv-orlando: ++
21:11:25 <mestery> Any other bugs the team should discuss this week?
21:11:38 <mestery> Well, I''ll just mention this one here:
21:11:38 <mestery> https://bugs.launchpad.net/tempest/+bug/1432091
21:11:39 <openstack> Launchpad bug 1432091 in tempest "tempest javelin is busted" [Undecided,Fix released] - Assigned to Armando Migliaccio (armando-migliaccio)
21:11:53 <mestery> That's the grenade bug from the weekend which is now fixed but which stopped neutron development for the weekend and today
21:12:25 * mestery thinks most people are familiar with that one
21:12:25 <mestery> Any other bugs?
21:12:30 <salv-orlando> that is one great way of taking a weekend + monday off
21:12:35 <salv-orlando> break the gate on a friday
21:12:45 <mestery> It was a brilliant plan salv-orlando.
21:13:22 <dougwig> brilliant, and i hear that the tears of developers is good for the complexion.
21:13:30 <mestery> lol
21:13:33 <mestery> OK, lets move on
21:13:38 <anteaya> dougwig: sell that
21:13:48 <mestery> #topic Docs
21:13:55 <mestery> emagana: Around?
21:14:02 <emagana> mestery: Yes!
21:14:04 <mestery> And if not, pc_m, wanted to bringup the VPN API docs here in this slot
21:14:07 <armax> I take full responsability for not having reverted the culprit in the first place
21:14:11 <armax> :(
21:14:20 * mestery shakes his fist at armax
21:14:33 <emagana> mestery: just a short networking docs meeting last friday
21:14:35 <armax> and EmilienM
21:14:36 <armax> :)
21:14:43 <mestery> cool, thanks emagana!
21:15:14 <emagana> keep working on migrating work from github .rst to the new framework
21:15:18 <pc_m> mestery: Wondering if old stuff it cached/saved somewhere
21:15:26 <mestery> About those VPN API docs: I suggested to pc_m he ping you emagana so we can work to get them added to the official API docs somehow.
21:15:50 <emagana> mestery: I already talked to pc_m.. Actually, he conatcted me
21:15:58 <emagana> contacted*
21:16:04 <mestery> emagana: Sweet, great!
21:16:09 <pc_m> mestery: Have example REST requests and responses but rest of the content is gone.
21:16:25 <mestery> pc_m: I don't know how that happened, it's weird
21:16:45 <pc_m> mestery: hence hoping if anyone knows if we have a cached/backed up version somewhere of the wiki
21:16:51 <emagana> pc_m mestery: I am sure that the references are gone but the files shoudl be still around
21:17:09 <mestery> pc_m: Ok, lets see if we can find those.
21:17:11 <pc_m> Can only find the JSON files. Nothing more.
21:17:26 <mestery> pc_m: We can do that post meeting, or even more likely, post FF this week :)
21:17:32 <mestery> emagana: Any other doc updates for the team?
21:17:33 <pc_m> (in the old repo)
21:17:36 <pc_m> mestery: Sure
21:17:38 <salv-orlando> emagana, pc_m I think I was already asked this question?
21:17:49 <emagana> mestery: not really, slow process :-(
21:17:50 <salv-orlando> api reference repos have moved into openstack-attic
21:18:01 <salv-orlando> all content copied into openstack/neutron-specs
21:18:16 <salv-orlando> rendering might not work as expected, but all the content is there
21:18:18 <mestery> salv-orlando: Nice!
21:18:23 <salv-orlando> and if not, it's in openstack-attic
21:18:25 <mestery> pc_m: ^^^^
21:18:49 <pc_m> salv-orlando: Will talk to you off-line. I can only fine some of the info.
21:18:55 <pc_m> (in the attic)
21:19:08 <anteaya> pc_m: it should all be there in the history
21:19:16 <anteaya> we just made the repo read only
21:19:21 <anteaya> that is the only change
21:19:50 <pc_m> will ping you guys. I'll look again, but can't find info.
21:19:54 <anteaya> okay
21:20:00 <mestery> thanks for the help anteaya!
21:20:12 <anteaya> sure
21:20:32 <mestery> #topic Open Discussion
21:20:41 <mestery> Given the gate failure and FF, that's all I had this week
21:20:54 <amotoki> pc_m: i found some API contennts in the history of https://github.com/openstack-attic/netconn-api/
21:20:56 <mestery> I propose we continue focusing on landing the remaining K3 code
21:21:01 <salv-orlando> thanks mestery for giving us back 40 minutes
21:21:08 <mestery> salv-orlando: yw :)
21:21:12 <marun> time we can spend waiting on the gate :/
21:21:25 <mestery> marun: Well, there's that ...
21:21:25 <markmcclain> while we wait can we discuss paint colors :p
21:21:26 <salv-orlando> marun: it's called "contemplating the gate"
21:21:54 <marun> chartreuse!
21:21:58 <kevinbenton> can we make a feature branch for pecan work?
21:22:05 <anteaya> marun: that's a yellow right?
21:22:15 <salv-orlando> kevinbenton: sure, why not
21:22:18 <mestery> kevinbenton: Yes
21:22:23 <marun> anteaya: halfway between yellow and green
21:22:30 <markmcclain> kevinbenton: do we need one?
21:22:33 <pc_m> amotoki: Yeah, but search for ipsec, all you'll find is .json files.
21:22:50 <anteaya> marun: ew
21:22:58 <marun> anteaya: my feelings exactly
21:23:03 <mestery> lol
21:23:04 <salv-orlando> marun:  I think perhaps kevinbenton want to have something he can test in flight and allow other people to drop commits on it?
21:23:08 <kevinbenton> markmcclain: the nice thing about a feature branch is we can turn on pecan right away and get all of the jobs testing against it
21:23:12 <salv-orlando> osrry marun, that was for markmcclain
21:23:13 <marun> anteaya: but sometimes you have to set the stage for what you really want ;)
21:23:13 <mestery> salv-orlando: markmcclain you mean?
21:23:22 <anteaya> marun: the set up
21:23:34 <kevinbenton> markmcclain: rather than dropping it in and having special instructions to enable it
21:23:43 <marun> +1 for feature branch
21:23:48 <mestery> kevinbenton: Ack, ping me and we'll make it happen
21:23:50 <markmcclain> kevinbenton: yeah… there's that… more concerned about the syncing of the two
21:23:57 <marun> it would be good to see how faster iteration works out in practice
21:24:02 <mestery> markmcclain: That will be my cross to carry :|
21:24:06 <salv-orlando> markmcclain: like conflicts?
21:24:17 <marun> markmcclain: isn't perestroika supposed to save us?
21:24:28 <markmcclain> marun: yes
21:24:29 <kevinbenton> so far the code i have been touching hasn't had changes since the stone age
21:24:31 * marun looks pointedly at salv-orlando
21:24:33 <salv-orlando> marun: I would ask that to the russians ;)
21:24:36 <kevinbenton> so i don't suspect a lot of conflicts
21:24:50 <salv-orlando> marun: that perestroika thing is haunting me
21:25:02 <mestery> #action mestery Get a feature branch for pecan work
21:25:05 <marun> salv-orlando: you touched it!
21:25:06 <mestery> Look at that, an action item!
21:25:10 <anteaya> you folks really don't want 40 minutes do you
21:25:13 <mestery> OK, thanks for coming folks!
21:25:14 <salv-orlando> I did just file a spec in utah for relieving somebody else from the pressure of working on it!!!!
21:25:16 <mestery> #endmeeting