21:00:26 <armax> #startmeeting networking
21:00:26 <openstack> Meeting started Mon May 11 21:00:26 2015 UTC and is due to finish in 60 minutes. The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:29 <openstack> The meeting name has been set to 'networking'
21:00:36 <neiljerram> hi
21:00:55 <armax> mestery couldn’t host the meeting today, I have the ungrateful duty to act on his behalf :)
21:00:56 <banix> hi
21:01:10 <yamahata> hello
21:01:44 <armax> let’s wait one more minute for folks to join, it’s the week before the summit, so I’d imagine people are busy getting ready for it
21:02:17 <blogan> hi
21:02:25 <armax> hello!
21:02:33 <armax> #announcements
21:02:46 <armax> oops
21:02:46 <carl_baldwin> armax, pong
21:02:50 <armax> #topic Announcements
21:03:03 <armax> next week is Summit week
21:03:09 <armax> we have a packed agenda
21:03:27 <armax> the meeting won’t be held for the next 3 weeks
21:03:29 <armax> carl_baldwin: hi
21:04:06 <pcm_> armax: 2 weeks?
21:04:06 <sc68cal> o/
21:04:13 <marun> \o
21:04:18 <armax> pcm_: yes, that’s correct
21:04:27 * carl_baldwin took the meeting off his calendar when it was cancelled and forgot when it was uncancelled.
21:04:30 <armax> we’ll resume on June 2nd
21:04:41 <b3nt_pin> o/
21:04:42 <armax> carl_baldwin: yes, there was a bit of confusion
21:05:32 <armax> mestery initially cancelled this meeting because he couldn’t host it
21:05:44 <markmcclain> o/
21:05:48 <armax> then realized that perhaps this could be a good opportunity to sync up right before the summit
21:06:02 * kevinbenton thinks there might be too much meta-meeting discussion going on :)
21:06:08 <salv-orlando> aloha folks sorry for being late I was in another convo
21:06:33 <armax> we could keep this meeting short in case we don’t have much to discuss
21:06:44 <armax> the agenda for the summit has been published here:
21:06:47 <armax> #link https://wiki.openstack.org/wiki/Summit/Liberty/Etherpads#Neutron
21:07:13 <kevinbenton> i don't see anything on there about social gatherings
21:07:14 <armax> the summit schedule is available at #link https://libertydesignsummit.sched.org/type/design+summit/neutron#.VVEZ8mRVikq
21:07:32 <armax> #action kevinbenton volunteers to organize a social gathering
21:07:35 <neiljerram> Yes, I was wondering about gatherings too - would be keen on that
21:08:03 <neiljerram> As someone who doesn't know anyone personally yet, I'd prefer earlier in the week than later
21:08:32 <kevinbenton> maybe monday then? i'll send an email to the dev list
21:08:38 <armax> kevinbenton: :) I assumed you’d be fine organizing ar rendez-vous
21:08:59 <sc68cal> kevinbenton: congrats! don't mess up! ;)
21:09:04 <armax> kevinbenton: it’s best to cross-reference, I made the mistake not too last summit
21:09:16 <neiljerram> Monday evening would be great for me; unfortunately I might not make it in time for lunch.
21:09:20 <armax> only to realize later that I should have and that caused some confusion
21:09:30 <kevinbenton> armax: ack
21:09:38 <kevinbenton> neiljerram: it would be an evening thing
21:09:43 <neiljerram> cool, thx!
21:09:43 <pcm_> kevinbenton: thanks
21:10:02 <armax> we may want to aim to have two perhaps, an opening and and ending casual gathering
21:10:16 <armax> so that people who miss the former may join the later and vice versa
21:10:32 <neiljerram> Indeed, that would be great too.
21:10:36 <kevinbenton> yeah
21:11:11 <armax> besides these logistics should we be moving to discussing the summit agenda?
21:11:19 <armax> #topic Liberty Design Summit
21:12:44 <armax> does anyone have any question on the agenda as it has been outlined at #link https://wiki.openstack.org/wiki/Summit/Liberty/Etherpads#Neutron
21:12:58 <salv-orlando> kevinbenton: that's some many of us that I would see if these guys (http://www.urbanrec.ca/Vancouver/) rent soccer/basketball/whatever pitches for some sporty fun
21:12:59 <emagana> armax: sorry.. I was distracted... I am around if need me!
21:13:00 <armax> and #link http://libertydesignsummit.sched.org/event/213da02952470483dfd8b2765aa88485#.VVEbUGRViko for the lightining talks?
21:13:07 <armax> emagana: ok, thanks
21:13:15 <emagana> armax: Actually I want to share a link about the networking guide...
21:13:18 <kevinbenton> i have a session about RBAC. i don't think it's really controversial and doesn't require much discussion
21:13:34 <marun> so, swap with reference split?
21:13:43 <Swami> kevinbenton: what is RBAC
21:13:44 <kevinbenton> i was thinking of repurposing it to come up with some better approach to handling object state transitions
21:13:47 <armax> kevinbenton: ok do you think it’s worth bringing in some other topic or what marun suggested?
21:13:57 <kevinbenton> Swami: ability to share networks to subsets of tenants
21:14:03 <armax> kevinbenton: let’s make an #action to discuss this with mestery
21:14:15 <kevinbenton> armax: ack, what's was marun's suggestion?
21:14:25 <armax> kevinbenton: swap with the reference split
21:14:37 <armax> kevinbenton: we’ll let him aware and decide what’s best
21:14:47 <kevinbenton> armax: ah, well that would certainly generate more excitement
21:15:02 <marun> I don't think the discussion should be 'if', rather 'how'
21:15:07 <marun> so not as exciting
21:15:17 <kevinbenton> marun: "by not doing it!"
21:15:21 <kevinbenton> see, exciting now :)
21:15:48 <marun> :p
21:15:49 <armax> kevinbenton, marun I suppose this has been noted so that Kyle will act on it, anything else that might be worth raising awareness of?
21:15:54 <salv-orlando> marun: I think you are taken too many things for granted. There are people out there that will fight to death to resist the split ;)
21:16:30 <marun> salv-orlando: interesting... I wonder how we could harness that misplaced fealty?
21:16:38 * armax brings the cannons
21:16:51 * armax and tin helmet
21:17:04 <marun> tin -> tinfoil (ftfy)
21:17:16 <salv-orlando> marun: with WMDs
21:18:08 <armax> marun: thanks
21:18:18 <armax> ok, too many acronyms
21:18:29 <marun> so, maybe a bad idea to talk at summit if it's going to be too controversial.
21:19:04 <salv-orlando> marun: controversial discussions are the best thing at the summit
21:19:08 <armax> marun: perhaps that’s the rationale behind mestery’s decision
21:19:32 <armax> assumed we bring this to mestery’s attention, is there anything else you’d love to talk about the schedule?
21:19:44 * salv-orlando indeed it will soon be called "Jeremy Kyle's Openstack Design Summit"
21:20:32 <armax> bear in mind that there is a ‘free’ slot on friday morning
21:20:35 <armax> #link https://etherpad.openstack.org/p/YVR-neutron-contributor-meetup
21:20:50 <armax> salv-orlando: not everyone knows jeremy kyle
21:21:05 <armax> salv-orlando: but there is a Jeremy Kyle-like show in every country
21:21:06 <kevinbenton> who is jeremy kyle
21:21:23 <kevinbenton> is it similar to an RFE?
21:21:25 <armax> salv-orlando: you should provide a wiki page that shows the list
21:21:30 <kevinbenton> because i don't know what that is either
21:22:45 <armax> kevinbenton: there’s a Contributor Meetup on Friday 9am-12pm
21:22:55 <marun> kevinbenton: I'm confused as to how you can be confused about what an RFE is.
21:23:32 <armax> I would certainly like to use that one to talk about next steps for the vendor decomp, I know that I would like to take the opportunity to talk with HenryG and any other who is interested
21:23:33 <salv-orlando> isn't that a feee-form thing? in Paris the community tried to put up a schedule for it but it did not work well imo
21:23:33 <kevinbenton> marun: request for extension is what we lazy people did in academia every time we missed a deadline
21:23:49 <armax> #action armax to remind mestery of the vendor decomp
21:25:06 * HenryG joins late because he thought there was no meeting
21:25:19 <armax> HenryG: hi
21:25:32 <HenryG> armax: happy to talk about vendor decomp
21:25:38 <armax> salv-orlando: I guess it worked ok-ish
21:26:10 <armax> salv-orlando: granted some people had already left so, it’s sort of dangerous to postpone any major discussion right at the end of the week
21:26:12 <salv-orlando> armax: you can put a schedule for it if you feel it might be more productive
21:26:42 <armax> salv-orlando: at the moment I am just noting it down, as any good servant would do, then I’ll let mestery decide
21:27:14 <armax> emagana: sorry was there something you wanted to share?
21:27:22 <emagana> armax:
21:27:34 <kevinbenton> he's at a loss for words!
21:27:35 <emagana> armax: About the networking guide, the link went public :-)
21:27:51 <kevinbenton> emagana: do you have it handy?
21:27:51 <armax> ok, can you repost the link here for people’s sake?
21:27:53 <emagana> armax: I am a man of few words!
21:28:08 <emagana> #link http://docs.openstack.org/networking-guide/
21:28:41 <banix> emagana: great job! to be continued for sure
21:28:50 <emagana> still not officially realease but we are live.. no idea how!
21:28:51 <armax> emagana: nice one
21:28:52 <emagana> ha ha ha ah
21:29:23 <emagana> no more words from me .... but looking forward for getting drunk with you all!
21:30:08 <armax> emagana: that’s the righ _spirit_!
21:31:41 <armax> well if there’s nothing else on the summit agenda perhaps we can have a few minutes to have an #topic Open Discussion
21:31:53 <armax> #topic Open Discussion
21:33:09 * armax hears crickets in the background
21:33:24 <kevinbenton> armax: tell us about service chaining
21:33:30 <kevinbenton> is there going to be a summit session
21:33:31 <kevinbenton> ?
21:34:15 <armax> kevinbenton: there is going to be a session on NFV Enhancements on Thursday afternoon
21:34:31 <armax> kevinbenton: mestery and I would like to use that one to bring the topic forward
21:34:59 <kevinbenton> armax: ack
21:35:18 <shivharis> armax: who is leading that?
21:35:20 <shivharis> armax: i guess i got the answer
21:35:30 <armax> kevinbenton: we’ll have to iron out how to make progress this cycle wrt SFC
21:35:36 <armax> shivharis: mestery and armax
21:36:04 <banix> and an OPNFV day on manday by the way
21:36:06 <armax> shivharis: but being a design session it’s more of a collaborative effort
21:36:17 <kevinbenton> armax: it always seems to fall apart trying to address the huge myriad of insertion schemes and corner cases
21:36:25 <armax> banix: thanks for the reminder
21:36:26 <shivharis> armax: with you on that
21:36:47 <kevinbenton> armax: is there an existing model that we are just going to implement, or are we going to roll our own?
21:36:53 <armax> kevinbenton: agreed, we’d need to be very diligent this cycle if we want this effort to take off
21:37:01 <markmcclain> kevinbenton: wasn't the goal to create a starter set of use cases that most agree?
21:37:08 <armax> kevinbenton: there are a few folks very interested in promiting the ETSI model
21:37:30 <armax> and there’s been a weekly call being setup to talk on SFC
21:37:37 <armax> I think it’s on Tue 10am PST
21:37:41 <armax> details on the ML
21:38:01 <Swami> armax: yes you are right.
21:38:11 <kevinbenton> markmcclain: i think so. it's just nice to have a doc to point to when you can say why a certain use case was rejected
21:38:16 <armax> Swami: thanks for keeping me honest
21:38:33 <armax> kevinbenton: there are a few specs being churned as we speak
21:39:17 <armax> kevinbenton: besides the use cases, I am more concerned on how we’re gonna master the complexity that will inevitably arise when the tires need to hit the road
21:39:46 <kevinbenton> armax: by first re-doing all of the internals of neutron :)
21:40:25 <armax> kevinbenton: one thing is certain, as much as we’re tracking this effort in Neutron, it does not belong to neutron core and it certainly spans way beyond Neutron greater metropolitan area
21:40:50 <armax> core being Neutron’s downtown
21:40:50 <kevinbenton> armax: i think it will make sense to do some refactoring and possible internal API changes as necessary to make it easier to build these things on top of the neutron primitives
21:41:54 <kevinbenton> ok, well i'm done blowing smoke about vaporware for now :)
21:42:20 <armax> kevinbenton: there is going to be prelimary work to ensure that the right plugs/outlets/hooks etc are in place
21:42:23 <armax> kevinbenton: before we can really start talking about SFC
21:42:42 <armax> kevinbenton: until people realize that we’ll always be blowing smoke up the vaporware
21:42:44 <HenryG> sorry, what is 'SFC'?
21:42:54 <kevinbenton> HenryG: file an RFE to find out
21:43:03 <kevinbenton> request for explanation
21:43:03 <armax> HenryG: Service Function Chaining
21:43:45 <kevinbenton> HenryG: "admin dictates that all traffic from x to y must go through firewall z"
21:43:53 <armax> ok, let’s see if there’s anything else to talk about
21:44:16 <kevinbenton> gus: ping
21:44:18 <armax> otherwise we can try and keep this meeting under 45 mins\
21:44:38 <armax> anything else?
21:44:55 * armax starts the countdown
21:45:54 <armax> ok guys thanks for joining and sorry about the confusion
21:46:08 <armax> let’s have a great summit and safe travel!
21:46:25 <armax> #endmeeting