14:00:57 <mestery> #startmeeting networking
14:00:58 <openstack> Meeting started Tue Jul 14 14:00:57 2015 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:59 <yamamoto> hi
14:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:01 <mwang2> 0/
14:01:03 <openstack> The meeting name has been set to 'networking'
14:01:06 <mestery> #link https://wiki.openstack.org/wiki/Network/Meetings Agenda
14:01:12 <mestery> #topic Announcements
14:01:36 <mestery> #info Liberty-2 is approaching us at a fast clip, slated for approx. July 29
14:01:38 <mestery> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
14:02:04 <mestery> That's the main announcement I've got, does anyone have anything else?
14:02:24 <mestery> OK, lets move right into the juicy bugs
14:02:34 <mestery> We have a few of those
14:02:34 <mestery> #topic Bugs
14:02:50 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1465434
14:02:50 <openstack> Launchpad bug 1465434 in neutron "DVR issues with supporting multiple subnets per network on DVR routers - PortbindingContext does not have the status." [Critical,In progress] - Assigned to Carl Baldwin (carl-baldwin)
14:03:02 <carl_baldwin> Hi
14:03:02 <mestery> Swami has a patch posted for this one
14:03:08 <mestery> haleyb carl_baldwin: Have you guys had a chance to review this one yet?
14:03:20 <carl_baldwin> I think we’re close to merging this one.
14:03:34 <mestery> carl_baldwin: Will this one fix the DVR job by chance?
14:03:39 <mestery> It passes it I see
14:03:52 <carl_baldwin> Yes!
14:04:05 <mestery> I see yamamoto is also commenting on this one
14:04:19 <mestery> carl_baldwin yamamoto: Can you two work with Swami to get this in shape and merged this week?
14:04:25 <haleyb> yes, there were some comments last night and it will need an update, but it's close.  i'm commenting again now
14:04:27 <mestery> Would be good to get DVR stable so we can monitor it and MAKE IT VOTING!
14:04:34 <mestery> thanks haleyb!
14:04:58 <mestery> #action carl_baldwin haleyb yamamoto to work with Swami on 1465434 to merge it, enabling us to watch the DVR job for a week and MAKE IT VOTING.
14:05:04 <mestery> Awesome
14:05:04 <mestery> Next up
14:05:10 <mestery> https://bugs.launchpad.net/neutron/+bug/1468433
14:05:10 <openstack> Launchpad bug 1468433 in neutron "Pre reference plugin code movement" [Critical,In progress] - Assigned to Cedric Brandily (cbrandily)
14:05:11 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1468433
14:05:11 <carl_baldwin> +1
14:05:34 <mestery> I filed this one, and a lot of patches have gone in here
14:05:40 <mestery> I see it's assigned to ZZelle now, who isn't in this channel
14:05:44 <ihrachyshka> what's missing?
14:05:48 <mestery> ihrachyshka: Exactly
14:05:56 <mestery> I don't know why ZZelle assigned it to himself
14:06:02 <mestery> I'll comment in the bug since he's not here.
14:06:25 <yamamoto> the bug has a lot of feature branch commits. which is the real one to look?
14:06:30 <ihrachyshka> mestery, it was infra, some patch was sent for review that mentioned the bug I guess
14:06:39 <mestery> ihrachyshka: Ah, ok
14:06:47 <salv-orlando> mestery: probably he just pushed a patch trargeting it
14:06:55 <mestery> Yeah, I think so too
14:07:04 <mestery> ihrachyshka: I think we can close this one now, do you agree?
14:07:28 <ihrachyshka> nothing that I see now
14:07:40 <ihrachyshka> I mean, no work I see not done
14:08:04 <mestery> Right
14:08:04 <mestery> Next up
14:08:07 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1470186
14:08:07 <openstack> Launchpad bug 1470186 in neutron "Pylint 1.4.1 broken due to new logilab.common 1.0.0 release" [Critical,In progress] - Assigned to Assaf Muller (amuller)
14:08:44 <mestery> Looks like amuller's series of patches are in flight here
14:08:51 <mestery> #link https://review.openstack.org/#/c/197226/
14:09:11 <mestery> #link https://review.openstack.org/#/c/197227/
14:09:35 <mestery> markmcclain: If you're around, could use your g+r help on 197226. :)
14:09:44 <mestery> OK, next up
14:09:56 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1461172
14:09:56 <openstack> Launchpad bug 1461172 in neutron "neutron.tests.functional.agent.test_l3_agent.MetadataL3AgentTestCase.test_access_to_metadata_proxy times out intermittently" [High,Confirmed] - Assigned to Assaf Muller (amuller)
14:10:04 <mestery> Also amuller's :)
14:10:37 <ihrachyshka> he is the test blametenant
14:10:41 <mestery> lol
14:11:05 <mestery> And finally:
14:11:08 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1466663
14:11:08 <openstack> Launchpad bug 1466663 in neutron "radvd exits -1 intermittently in test_ha_router_process_ipv6_subnets_to_existing_port functional test" [Medium,In progress] - Assigned to Sridhar Gaddam (sridhargaddam)
14:11:16 <mestery> With review:
14:11:17 <mestery> #link https://review.openstack.org/#/c/193624/
14:11:30 <SridharG> mestery: I've updated my comments. I would appreciate if other reviewers take a look at it.
14:11:47 <mestery> SridharG: Yes, looks like you replied to Assaf. Given his comment, I'd like to see a reply from him before this merges as well.
14:12:34 <ihrachyshka> just asked him on #openstack-neutron
14:12:37 <mestery> We have 2 bugs tagged as "linuxbridge-gate-parity", lets cover thsoe now.
14:12:39 <mestery> thanks ihrachyshka
14:12:49 <SridharG> ihrachyshka: sure, thanks.
14:12:50 <mestery> First up
14:12:53 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1312016
14:12:53 <openstack> Launchpad bug 1312016 in neutron "nova libvirtError: Unable to add bridge brqxxx-xx port tapxxx-xx: Device or resource busy" [High,In progress] - Assigned to Sean M. Collins (scollins)
14:12:58 <mestery> sc68cal: ^^^^
14:13:34 <mestery> #link https://review.openstack.org/#/c/193485/
14:13:36 <mestery> ihrachyshka: That review is yours it appears :)
14:14:16 <mestery> This one looks like it's actively being worked on at least
14:14:31 <sc68cal> Yep - although my updated patches are probably bad
14:14:33 <ihrachyshka> mestery,  sc68cal was kind to take the faulty patch from me
14:14:37 <mestery> :)
14:14:44 <ihrachyshka> ok, we now have two faulty versions
14:14:48 <sc68cal> :)
14:14:51 <mestery> 2 wrongs make a right?
14:15:06 <sc68cal> so, I'll be poking at it a little longer
14:15:12 <mestery> Thanks sc68cal and ihrachyshka
14:15:34 <mestery> I don't see emagana around, so lets skip docs today and head right into the juicy part of the meeting
14:15:39 <mestery> I'll try not to wake anyone up as we finish the meeting.
14:15:43 <mestery> #topic Pecan WSGI Refactor
14:15:49 <mestery> blogan: Hi there! Around?
14:15:54 <blogan> mestery: yes
14:15:58 <mestery> blogan: Excellent!
14:16:04 <mestery> Can you update the team on what's going on here?
14:16:08 <mestery> Status updatE?
14:17:10 <blogan> basically just gettin the right master merges commits in so it passes the checks, but the reviews up now will still require some more additional work to get service plugins working
14:17:45 <mestery> So the plan is to get service plugins working, merge back to master and create a job which uses the pecan WSGI
14:17:54 <mestery> Stablize that, make it voting, then switch?
14:18:20 <blogan> mestery: i believe there are other things that probably need to get working as well, like notifications i believe
14:18:49 <mestery> blogan: OK, could you and kevinbenton put an etherpad or devref together with what's left?
14:18:56 <blogan> mestery: sure
14:19:20 <mestery> #action blogan and kevinbenton to put an etherpad or devref together to track remaining pecan work and plan of record
14:19:21 <mestery> thanks blogan!
14:19:26 <mestery> Any questions for blogan on the pecan work?
14:19:27 <blogan> but yeah once we get those gaps closed then the steps you outlined sound appropriate
14:19:34 <mestery> Awesome
14:20:01 <salv-orlando> blogan: I gave you my first review!
14:20:10 <salv-orlando> and obviopusly it's a -1 ;)
14:20:22 <blogan> salv-orlando: yes! it wouldn't be appropriate if it was a +1 :)
14:20:22 <mestery> salv-orlando: I hope it also included your charming pedantry :)
14:20:35 <salv-orlando> mestery: lots of that
14:20:39 <mestery> Heh :)
14:20:42 <blogan> lol
14:20:50 <ihrachyshka> I die for it. it's so scarse lately
14:21:02 <mestery> ihrachyshka: Be careful what you wish for
14:21:16 <ihrachyshka> RIGHT, NOT FOR QOS
14:21:25 <mestery> And thanks to blogan and kevinbenton for working on the pecan switch. :)
14:21:34 <mestery> #topic QoS
14:21:38 <mestery> ihrachyshka: Speaking of Qos ...
14:21:45 <mestery> ihrachyshka ajo: Can you give us an update on this now?
14:21:54 <mestery> Where are things at?
14:22:07 <ihrachyshka> ajo, go ahead, stage is yours
14:22:46 <ihrachyshka> hm. ok, I'll back up ajo. So we are working on the feature, slowly but steadily.
14:23:10 <ihrachyshka> we sent a plan for merge back setting how we see the approaching merge-back: http://lists.openstack.org/pipermail/openstack-dev/2015-July/069188.html
14:23:12 <ihrachyshka> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/069188.html
14:23:38 <ihrachyshka> we also have an email setting immediate priorities for those who track branch: http://lists.openstack.org/pipermail/openstack-dev/2015-July/069234.html
14:23:40 <ihrachyshka> #link http://lists.openstack.org/pipermail/openstack-dev/2015-July/069234.html
14:23:58 <ajo> ihrachyshka, thanks, sorry, I was totally off-stage writing devref ;)
14:24:05 * ajo reads
14:24:12 <ihrachyshka> we have almost all functional pieces on server side in, and some agent pieces
14:24:24 <ihrachyshka> we will work closely with amuller to get fullstack before merge-back
14:24:35 <mestery> ajo ihrachyshka: I know armax wanted to check out how you were using callbacks here, I spoke with him on this last week, I'll poke him to review those portions soon
14:24:43 <ihrachyshka> and ajo is working on devref ^^ that would provide more than enough details about the feature and its design
14:24:56 <ajo> yes, that's going to provide a lot of context on how we're doing that
14:24:57 <mestery> This is all really good stuff!
14:25:00 <ihrachyshka> mestery, yes, that's one of priorities set by ajo
14:25:05 <mestery> Cool
14:25:22 * regXboi pads in with a surprised look on his face
14:25:28 <ajo> the last message we sent to list mike kolesnik and me can be ignored for now, we're not going to need so many callbacks
14:25:35 <ihrachyshka> so, all in all, lots of cool bits to crunch, and we look forward to right after L2 when we want to consider the feature for merge
14:25:40 <ajo> just AFTER_READ which will be overruled by the new armax design on that
14:25:55 <mestery> Cool
14:26:24 <ajo> I want to say, ihrachyshka is doing an amazing job forward to automate any future versioned object usage in neutron
14:26:39 <regXboi> sorry for being late folks - quick question - where are the rate calculations done?  at the ingress port, I assume?
14:26:45 <mestery> ajo: That's because ihrachyshka is awesome, I've already told him that too :)
14:26:51 <ajo> he is :)
14:26:58 <ajo> regXboi, it's all port egress for now
14:27:13 <ajo> regXboi, we may want to support ingress in the future, and other type of limitings with guarantees
14:27:17 <ajo> but one bit at a time :)
14:27:24 <ihrachyshka> ok, that's how 'making project hard to understand' sounds like
14:27:27 <mestery> Slow and steady
14:27:31 <ihrachyshka> "automate any future versioned object usage"
14:27:33 <ajo> regXboi: egress from the VM perspective
14:27:55 <ajo> sorry :D
14:28:07 <ajo> I was meaning, "make it super easy and clean"
14:28:10 <regXboi> ajo: thanks - there is a spec running around talking about replicating packets across ports and I was worried about how it might interact with this
14:28:28 <ihrachyshka> I think we should leave the stage unless there are more questions/concerns for qos
14:28:34 <ajo> ack
14:28:35 <mestery> ihrachyshka: Agreed
14:28:38 <mestery> Thanks for the update folks!
14:28:47 <mestery> regXboi: Comment further on reviews or in #openstack-neutron with ihrachyshka and ajo
14:28:47 <mestery> :)
14:28:51 <mestery> Moving along in the agenda
14:28:55 <regXboi> mestery: no worries
14:28:55 <mestery> #topic Flavor Framework
14:29:04 <mestery> #link https://review.openstack.org/#/c/139758/
14:29:23 <mestery> I'm hopeful that this will merge this week when dougwig blogan and others look at it while at the mid-cycle for services in Seattle.
14:29:36 <mestery> I've been reviewing it and it's in good shape, thanks to madhu for his work on it!
14:29:53 <mestery> I encourage others to review as well
14:30:36 <markmcclain> mestery: I've taken a 1st look and will review it this week too
14:30:44 <mestery> markmcclain: Sweet, thanks!
14:31:13 <mestery> The rest of the agenda looks a little old, so lets move on to ...
14:31:15 <mestery> #topic Open Discussion
14:31:29 <markmcclain> I've added +2 to pylint update
14:31:51 <regXboi> mestery: who is the pep8 expert?
14:31:56 <ihrachyshka> one thing I had in mind for other folks... online-schema-migrations spec is just merged: https://review.openstack.org/#/c/192937/
14:32:07 <ajo> ++
14:32:18 * regXboi wants to examine the possibility of getting rid of magic constants
14:32:18 <ihrachyshka> and there is neutron patch hopefully going in in the future: https://review.openstack.org/#/c/194198/
14:32:20 <yushiro> mestery, I've already updated my RFE - bug.  I'd like to ask some review :-)
14:32:24 <mestery> regXboi: There are many, you could talk to gus among many :)
14:32:31 <anteaya> mestery: can we talk about the get-me-a-network spec implimentation a minute? it would be nice to have something to admire a nova mid-cycle
14:32:44 <yushiro> mestery, RFE - Packet logging API for Neutron - https://bugs.launchpad.net/neutron/+bug/1468366
14:32:44 <openstack> Launchpad bug 1468366 in neutron "RFE - Packet logging API for Neutron" [Undecided,Confirmed] - Assigned to Yushiro FURUKAWA (y-furukawa-2)
14:32:44 <ihrachyshka> and it will influence everyone who has migrations a bit, so please take a look to be prepared
14:32:52 <mestery> yushiro: The drivers team will be reviewing RFE bugs in the drivers meeting following this meeting (carl_baldwin to lead as I'm out of the office the rest of the day following this meeting)
14:33:01 <vikram> Feedback for flow-classifier
14:33:04 <mestery> anteaya: Yes! I think we'll want to make sure haleyb is here too
14:33:16 <anteaya> is here, at nova mid-cycle?
14:33:17 <yushiro> mestery, I see. thank you for your reply.
14:33:21 <mestery> vikram: We tried to talk flow-classifier last week but you weren't here :( If you're here now, lets do that post Get-Me-A-Network
14:33:34 <mestery> anteaya: No, in this meeting
14:33:36 <vikram> mestery: thanks
14:33:37 <mestery> anteaya: carl_baldwin and I and sc68cal will be at nova mid-cycle
14:33:40 <anteaya> ah
14:33:46 <anteaya> haleyb: are you here?
14:33:52 <anteaya> I thought I saw you
14:33:55 <haleyb> yes, i'm here
14:33:58 <anteaya> yay
14:34:08 <mestery> anteaya: Please go ahead
14:34:12 <anteaya> any thoughts on implementation for the group?
14:34:13 <salv-orlando> to tell that I'm interested in a RFE I do have to leave a comment, is that right?
14:34:26 <mestery> salv-orlando: That sounds right
14:34:27 <xgerman> we need reviews
14:34:36 <anteaya> we mostly I just wanted to know where we are so we have a chance at having something for next week
14:34:58 <anteaya> haleyb: do we have anything for anyone to look at?
14:35:05 <salv-orlando> thanks mestery. I was just wondering whether actually subscribing to the bug makes sense at all, since every neutron bug has hundreds of automatic subscrivers
14:35:08 <anteaya> or an idea of when they might have something to look at?
14:35:24 <mestery> salv-orlando: IT may, depending on how good your email filters work. :)
14:35:33 <yushiro> carl_baldwin, hi.  currently,  I've update my RFE-bug.  would you confirm later ? ;) https://bugs.launchpad.net/neutron/+bug/1468366
14:35:33 <openstack> Launchpad bug 1468366 in neutron "RFE - Packet logging API for Neutron" [Undecided,Confirmed] - Assigned to Yushiro FURUKAWA (y-furukawa-2)
14:35:59 <pc_m> mestery: I have a Dev Ref for RFE. Is it on the list for review by Driver's team? (#link https://review.openstack.org/#/c/191944/)
14:36:21 <carl_baldwin> yushiro: pc_m:  We’ll have a look.
14:36:26 <mestery> pc_m: Your bug is already approved
14:36:35 <regXboi> mestery: before we break up - i've got another potential elephant - use of shell
14:36:36 <haleyb> when i had talked to people at the mid-cycle (like mark) we were going to need some way for nova to indicate it is making a "special" request to neutron, so i need to talk this over with him again as to what that looks like
14:36:42 <mestery> It's "In Progress" see comment #8
14:36:42 <haleyb> anteaya: ^^
14:36:44 <pc_m> mestery: This is DevRef commit for it.
14:36:52 <mestery> pc_m: We'll review as normal
14:36:59 <yushiro> carl_baldwin, thank you! and, I've already implemented about my RFE-bug :-)
14:37:03 <anteaya> markmcclain: when do you have time to talk to haleyb to help him get what he needs?
14:37:05 <salv-orlando> mestery: sure, but I was talking about the subscriber list on the bug report. Still, it's ajust a curiosity, let's leave it aside. A comment is all we need.
14:37:10 <mestery> pc_m: In fact, I've already reviewed that one in fact
14:37:20 <pc_m> mestery: Posing several approaches and seeking review. Wondering if on the list to be reviewed - be up since 7/8
14:37:39 <haleyb> anteaya: i feel there are too many talking at once now
14:37:44 <mestery> I agree
14:37:53 <anteaya> haleyb: yes
14:37:59 <anteaya> markmcclain: are you still about?
14:38:02 * salv-orlando thinks the main topic now is "get me a bloody network"
14:38:04 <mestery> #topic Get Me a Network
14:38:04 <mestery> Folks, lets talk "Get Me a Network" now
14:38:07 <mestery> And move on to something else next
14:38:10 <anteaya> mestery: thanks
14:38:10 <yushiro> pc_m, thank you :-)
14:38:12 <mestery> anteaya haleyb: Continue
14:38:15 <yushiro> mestery,  thanks
14:38:21 <anteaya> waiting to hear from markmcclain
14:38:22 <pc_m> mestery: Yes, you've looked at https://review.openstack.org/#/c/191944/, but current version is awaiting review.
14:38:30 <markmcclain> anteaya: yes... I can try to catch up with haleyb tomorrow
14:38:36 <anteaya> wonderful
14:38:43 <anteaya> haleyb: does tomorrow work for you?
14:38:52 <haleyb> anteaya: yes, that works
14:39:03 <anteaya> and I will check in with you both on Thursday
14:39:09 <anteaya> and thank you
14:39:15 <anteaya> mestery: got what I needed
14:39:21 <haleyb> i will send an email to mark about my thoughts
14:39:25 <anteaya> let's move on
14:39:26 <mestery> haleyb anteaya markmcclain: Thanks!
14:39:27 <mestery> Yes
14:39:33 <anteaya> haleyb: can I get cc'd on that please
14:39:34 <mestery> moving along
14:39:34 <mestery> #topic Flow Classifier
14:39:36 <mestery> vikram: You're up
14:39:39 <anteaya> haleyb: just to follow along
14:39:48 <vikram> I have posted a link "https://etherpad.openstack.org/p/flow-classifier" for comments
14:39:52 <mestery> #link https://etherpad.openstack.org/p/flow-classifier
14:40:02 <vikram> need feedback :-)
14:40:18 <mestery> #info Looking for feedback on flow classifier etherpad
14:40:36 <vikram> that's all ..
14:40:53 <mestery> Thanks vikram!
14:41:04 <mestery> Who else had something to cover so I change the topic?
14:41:04 <mestery> Anyone?
14:41:10 <mestery> 18.5 minutes left or so
14:41:12 <regXboi> mestery: shell?
14:41:16 <mestery> #topic Shell Usage
14:41:19 <mestery> regXboi: Floor is yours :)
14:41:39 <regXboi> is anybody else concerned about how much we use shell underneath the code base?
14:41:54 <mestery> Yes
14:41:56 <mestery> Most of us are
14:42:02 <mestery> You're talking in things like the agent?
14:42:04 <regXboi> that's going to be a very big impediment to scale
14:42:11 <regXboi> I'm talking prettty much everywhere
14:42:11 <mestery> E.g. in ip_lib and ovs_lib?
14:42:14 <mestery> Right
14:42:24 <mestery> Do you want to replace it with an Apache 2 licensded python library?
14:42:34 <mestery> Which uses netlink or something like it?
14:42:43 <neiljerram> Sometimes the issue is licensing.
14:42:49 <haleyb> pyroute2 ?
14:42:54 <neiljerram> E.g. python-iptables is GPL, I believe
14:42:55 <regXboi> yes, I think we need to spin something to look at replacing it
14:42:56 <ihrachyshka> for ovs_lib, it's not the case IF you use native implementation
14:43:03 <regXboi> it may depend on the particular component
14:43:04 <mestery> Like this? https://pypi.python.org/pypi/pyroute2
14:43:06 <markmcclain> regXboi: I think there's a difference in just using shell and how we're using it
14:43:25 <regXboi> markmcclain: I sort of agree -
14:43:34 <mestery> ihrachyshka: That's only for the portions talking ovsdb, we still use shell for the openflow bits, right?
14:43:34 <mestery> e.g. ovs-ofctl?
14:44:04 <regXboi> markmcclain: I'm thinking this is yet another refactor staring us in the face,  but I'm not yet sure just how big it is
14:44:10 <ihrachyshka> well, I'm not the best candidate to answer to it :) otherwiseguy ^^
14:44:17 <markmcclain> regXboi: it's sizeable
14:44:23 <mestery> I think that's the case
14:44:36 <regXboi> markmcclain, mestery - I'm thinking that may be something to look at for M
14:44:37 <mestery> yamamoto's patch to move us to ryu would eliminate the ovs-ofctl usage as well
14:44:44 <yamamoto> mestery: yes
14:44:53 * otherwiseguy looks
14:45:02 <mestery> yamamoto: Do you have a link for that patch so regXboi can eyheball it?
14:45:04 <mestery> *eyeball
14:45:19 <yamamoto> #link https://review.openstack.org/#/c/153946/
14:45:24 * regXboi looks for his eyhes
14:45:39 <regXboi> yamamoto: thanks, I've got it queued for review later this morning
14:45:40 <mestery> thanks yamamoto
14:46:10 <yamamoto> #link https://review.openstack.org/#/c/154354/
14:46:10 <regXboi> mestery: the other thing is the magic constant issue
14:46:30 <otherwiseguy> There is also the privilege separation patch, which last I heard was going to be an oslo project? Haven't looked in a while.
14:46:31 <regXboi> but I think we can do that offline/another day
14:46:42 <mestery> Ack
14:47:35 <regXboi> markmcclain, mestery: would it make sense to catalog the shell usage in an etherpad to scope the size of what we are looking at?
14:47:47 <mestery> regXboi: Please do
14:47:53 <markmcclain> ++
14:47:54 <mestery> #action regXboi to categorize shell usage in etherpad
14:48:07 <mestery> OK, I think that's it for this week folks.
14:48:08 * regXboi plants foot in quicksand :)
14:48:17 <john-davidge> I’d like to raise #link https://bugs.launchpad.net/neutron/+bug/1471316 if there’s time
14:48:17 <openstack> Launchpad bug 1471316 in neutron "_get_subnetpool_id does not return None when a cidr is specified and a subnetpool_id isn't." [High,In progress] - Assigned to John Davidge (john-davidge)
14:48:23 * mestery looks
14:48:38 <john-davidge> Consensus since last week seems to be that this isn’t a bug, but an intened API change
14:48:49 <mestery> carl_baldwin: ^^^^
14:49:05 <john-davidge> Personally I think that’s going to be confusing forusers, but I’m willing to accept the consensus
14:49:34 <amotoki_> I dont' think it is a good idea to make some field visible/invisible conditionally.
14:49:51 <carl_baldwin> john-davidge: I looked at the tables on both the bug and the spec before the week-end and then had to leave it.  Need to come back to it.
14:49:59 <john-davidge> That said, I’ve proposed a fix to devstack to account for the change #link https://review.openstack.org/#/c/199038/
14:50:04 <mestery> Thanks carl_baldwin. john-davidge, you're in good hands
14:50:33 <carl_baldwin> amotoki: Could you elaborate with a comment in the bug report?
14:51:02 <mestery> OK, thanks folks!
14:51:05 <amotoki_> carl_baldwin: yes. am following the discussion
14:51:07 <regXboi> bye all
14:51:10 <mestery> Keep the reviews coming as we near Liberty-2!
14:51:14 <mestery> #endmeeting