14:00:15 <mestery> #startmeeting networking
14:00:15 <openstack> Meeting started Tue Sep  8 14:00:15 2015 UTC and is due to finish in 60 minutes.  The chair is mestery. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:18 <openstack> The meeting name has been set to 'networking'
14:00:22 <mestery> #link https://wiki.openstack.org/wiki/Network/Meetings Agenda
14:00:23 <haleyb> hi
14:00:24 <russellb> o/
14:00:33 <xgerman> o/
14:00:36 <rossella_s> hi
14:00:37 <annp> hi
14:00:38 <mestery> Basically, today is 1) Announcements 2) Bugs 3) RC1 (with some yelling about only merging stuff approved to go in)
14:00:44 <mestery> #topic Announcements
14:00:46 <amotoki> hi
14:00:49 <banix> hi
14:00:49 <mestery> Liberty-3 is out!
14:00:52 <mestery> #link https://launchpad.net/neutron/+milestone/liberty-3
14:01:03 <ZZelle> Hello
14:01:07 <mestery> #info Thanks to armax for going above and beyond last week
14:01:12 <emagana> Buenos Dias! (Good Morning)
14:01:16 <mestery> We as a project are lucky to have armax around, and I wanted to thank him!
14:01:22 <ajo> o/ :)
14:01:27 <amuller> armax++
14:01:33 <emagana> mestery: sorry I am late..
14:01:37 <ajo> armax^2
14:01:37 <mestery> emagana: No worries
14:01:38 <ajo> :-)
14:01:39 * armax blushes
14:01:50 * mestery thinks most people wish he was on vacation all the time after how awesome armax was last week
14:01:58 <mestery> Seriously, nice work armax
14:01:59 <gongysh> hi
14:02:04 <mestery> And nice work to the entire TEAM!
14:02:05 <armax> mestery: ok, now you’re pushing it
14:02:07 <mestery> :)
14:02:08 <armax> :)
14:02:09 <emagana> armax: absolutely!
14:02:16 <mestery> Liberty-3 was a great team effort by all.
14:02:19 <mestery> We should all be proud of that.
14:02:29 <mestery> #link https://wiki.openstack.org/wiki/ReleaseNotes/Liberty#OpenStack_Liberty_Release_Notes
14:02:36 <mestery> #info Please keep updating Liberty release notes
14:02:50 <mestery> That's all the announcements I had
14:02:57 <mestery> Anyone have anything else to share with the broader team this week?
14:03:22 <mestery> OK, lets slide along to bugs!
14:03:24 <mestery> #topic Bugs
14:03:38 <mestery> Starting at the top ...
14:03:49 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1484148
14:03:50 <openstack> Launchpad bug 1484148 in neutron "neutronclient gate broken following VPNaaS infra changes" [Critical,Confirmed] - Assigned to Paul Michali (pcm)
14:04:05 <mestery> This one belongs to pc_m, who doesn't appear to be here obviously :)
14:04:34 <mestery> I've posted some comments in the bug now, we'll move along unless someone else has an update here.
14:04:52 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1488282
14:04:53 <openstack> Launchpad bug 1488282 in neutron "Gate failures with 'the resource could not be found'" [High,Confirmed] - Assigned to Salvatore Orlando (salvatore-orlando)
14:05:02 <mestery> This one is assigned to salv-orlando :)
14:05:10 <mestery> I believe 2 weeks ago he volunteered to triage it a bit more
14:05:25 <mestery> Reported by armax
14:06:07 <HenryG> There was a tempest fix for that I believe?
14:06:10 * mestery looks at the logstash query
14:06:18 <salv-orlando> mestery but I declared it as "non neutron"
14:06:20 * pc_m sorry late
14:06:20 <ajo> mestery: comments by salvatore say it seems like a nova bug
14:06:22 <armax> HenryG: that was a different NotFound
14:06:34 <armax> HenryG: actually we had a few that hit at the same time
14:06:35 <ajo> hi salv-orlando  :)
14:06:35 <salv-orlando> I'm just waiting for a confirmation from the nova people to remove neutron from the affected list
14:06:43 <armax> one fix went into tempest
14:06:45 <mestery> salv-orlando: Awesome
14:06:47 <armax> the other in neutron
14:06:53 <mestery> Also, the logstash query shows no hits since 9-3
14:06:58 <mestery> So ....
14:07:02 <armax> this one, as salv-orlando points out
14:07:06 <armax> might be noa
14:07:07 <armax> nova
14:07:10 <ajo> salv-orlando: may be we should move neutron out from "confirmed" to something else?
14:07:21 <armax> ajo: not so hasty
14:07:28 <ajo> O:)
14:07:36 <mestery> lol
14:07:39 <salv-orlando> ajo: sure. will do. sir.
14:07:40 <armax> typically when you do so, the bug reassert itself as neutron’s fault ;)
14:07:41 <pc_m> mestery: I'm here
14:07:45 <armax> I proved with this one
14:07:49 <salv-orlando> once armax says it's ok to do
14:07:51 <ajo> lol
14:07:52 <mestery> pc_m: Once second
14:07:53 <ihrachys> yeah, we like to close unfixed bugs
14:07:55 <armax> https://bugs.launchpad.net/neutron/+bug/1490051
14:07:56 <openstack> Launchpad bug 1490051 in neutron "test_assert_pings_during_br_int_setup_not_lost fails with oslo_rootwrap.wrapper.NoFilterMatched" [High,In progress] - Assigned to Ihar Hrachyshka (ihar-hrachyshka)
14:08:03 <armax> I closed it and it showed up
14:08:08 <mestery> armax: Silly you ;)
14:08:20 <armax> mestery: well that was part of the strategy to lure the bug out
14:08:24 <armax> bugs have souls you know?
14:08:30 <ajo> armax, we need another phantom state (not closed) ... not to disturb the bugs...
14:08:31 <mestery> Oh for sure they do
14:08:32 <ihrachys> he assumed no logstash hits during weekend and labour day == no bug
14:08:37 <mestery> lol
14:08:47 <mestery> ihrachys: Doesn't the entire world get Labor Day off? ;)
14:08:51 <armax> ihrachys: no hits during the weekend no
14:08:56 <mestery> OK
14:08:58 <mestery> Lets leave it oipen
14:09:03 <mestery> salv-orlando looks to ahve this under hand
14:09:06 <ihrachys> mestery: well, if entire world == NA, then yes
14:09:10 <mestery> pc_m: This one was your's https://bugs.launchpad.net/neutron/+bug/1484148
14:09:11 <openstack> Launchpad bug 1484148 in neutron "neutronclient gate broken following VPNaaS infra changes" [Critical,Confirmed] - Assigned to Paul Michali (pcm)
14:09:14 <banix> mestery: yes but on may 1st
14:09:14 <mestery> ihrachys: lol
14:09:17 <mestery> pc_m: Any updates there?
14:09:22 <pc_m> I changed the project-config job and the neutron-client code. Infra indicated they want Neutron cores to review the project config change, before they will review.
14:09:22 <armax> ihrachys: we had an occurence today  by the looks of it
14:09:34 <pc_m> #link https://review.openstack.org/#/c/209887/
14:09:39 <ihrachys> armax: I debug it now, lots of weird stuff seen in logs
14:09:48 <pc_m> The other change, needs this upstreamed, so it can be tested.
14:09:57 <mestery> pc_m: Thanks!
14:10:07 <mestery> armax: Can you review 209887 today yet?
14:10:13 <pc_m> Currently, VPN tests are skipped, so it works.
14:10:28 <mestery> dougwig is out hunting this week with no access to cell or email (so we shoudl all fill up his inbox and voicemail) :)
14:10:32 <pc_m> Works as in, doesn't fail, but is not really tested.
14:11:09 <mestery> OK, lets move to the next one I'd like to discuss
14:11:14 <mestery> #link https://bugs.launchpad.net/neutron/+bug/1491131
14:11:17 <openstack> Launchpad bug 1491131 in neutron kilo "Ipset race condition" [High,New]
14:11:17 <ajo> mestery, lol
14:11:34 <mestery> This one appears to affect Kilo as well as master
14:11:53 <ajo> ah, yes, the racy thing, I totally forgot
14:12:29 <mestery> shihanzhang has a patch out which may be related (https://review.openstack.org/#/c/122368/)
14:12:34 <ajo> I will follow that up during this week , seems assigned to cedric
14:12:40 <mestery> It was abandoned
14:12:46 <mestery> ajo: Awesome, thanks!
14:12:47 <salv-orlando> related in the sense that it acvoid triggering the bug
14:12:58 <salv-orlando> *avoids triggering
14:13:00 <ajo> mestery, there's some previous patch which already got in that fixes some of the issues they see in kilo
14:13:14 <mestery> salv-orlando: Well, that's related isn't it? :)
14:13:15 <ajo> but, there's something that triggers ipset delete when it's already gone (or may be never created...)
14:13:18 <mestery> ajo: The patch got into master?
14:13:37 <salv-orlando> ajo,: do you know if someone beyond the reporter managed to reproduce it?
14:13:54 <ajo> mestery, I will review the whole thread and link the right patches.
14:13:56 <ajo> salv-orlando: not that I know
14:14:21 <mestery> ajo: Thanks!
14:14:26 <ajo> salv-orlando: I guess it could make sense to make ipset.delete("aaa") not fail, if the ipset didn't exist
14:14:49 <ajo> it could hide some source of races, but at least, we wouldn't block the agent. A warning may work..
14:15:16 <mestery> That's the last bug I wanted to discuss before we move along. Does anyone have any other bugs they want to highlight here?
14:15:16 <ZZelle> salv-orlando, i am trying to reproduce it but at the moment i fail to reproduce it
14:15:56 <salv-orlando> ajo: we could put in place measures to avoid triggering the bug, but we'd also be masking the underlying race condition. so we might not necessarily do something good
14:16:06 <salv-orlando> as at some point the race will explode in our face
14:16:20 <ajo> salv-orlando, yeah, but the failure mode is horrendous: broken agent until agent restart
14:16:22 <salv-orlando> (well in the face of the ref impl lieutenant)
14:16:35 <mestery> *cough cough* kevinbenton *cough cough*
14:16:36 <ajo> salv-orlando: at least, we could reduce the impact
14:16:57 <armax> mestery: kevinbenton is surely still sleeping
14:16:58 <ajo> and may be link the bug to a logstash query to look for ocurrences
14:17:07 <ajo> said that, salv-orlando , I couldn't find those ocurrences in logstash upstream
14:17:13 <mestery> armax: He's driving home from disneyland actually and told me he'd miss today's meeting
14:17:17 <ajo> (for ipset trying to delete something not existing..)
14:17:44 <armax> but he did so last night
14:17:51 <armax> mestery: last time I checked LA is not that far
14:17:55 <armax> from SF
14:17:57 <armax> :)
14:18:03 <mestery> armax: Nope, he's on the road right now in fact :)
14:18:08 <mestery> He must have not gotten enough Mickey Mouse
14:18:15 <ajo> :-)
14:18:20 <mestery> OK, lets move on before we lost the meeting completely :)
14:18:22 <mestery> NExt up ...
14:18:24 <armax> mestery: um…he’s probably eating corn somewhere on the road
14:18:27 <mestery> lol
14:18:29 <mestery> #topic Docs
14:18:31 * carl_baldwin sorry to be late
14:18:32 <mestery> emagana: What have you got for us today?
14:18:36 <emagana> Hello!
14:18:44 * mestery sends carl_baldwin to the back of the room
14:18:50 <emagana> mestery: not much really
14:18:54 <mestery> emagana: That's ok :)
14:18:58 <emagana> I have not seen new review for us..
14:19:13 * markmcclain gets in line behind carl_baldwin
14:19:25 <emagana> however, after release-3 is when we should invest even more in Documenting the new features
14:19:35 <mestery> lol
14:19:48 <mestery> emagana: That sounds good!
14:20:00 <mestery> emagana: Is there a plan, and does it involve Sam-I-Am as well? :)
14:20:01 <ajo> emagana, me owes QoS stuff
14:20:05 <emagana> mestery: I should have more details next week, after our networking docs meeting on Friday
14:20:10 <mestery> emagana: Thanks!
14:20:23 <mestery> #info Plan for documentation changes for new Liberty-3 items will be unveiled next week after networking docs meeting on Friday
14:20:24 <emagana> ajo: Yeah.. I will help there
14:20:50 <emagana> mestery: Always involves Sam-I-Am
14:20:51 <ajo> thanks emagana , may be a simple template or initial "empty" review on where to put things would help, then I can follow up adding the details
14:21:02 <mestery> :)
14:21:13 <emagana> ajo: sounds good.. You will have it
14:21:17 <ajo> emagana++
14:21:20 <emagana> I will add you as reviewer
14:21:43 <emagana> mestery: all from me!
14:21:52 <mestery> emagana: Thanks!
14:22:14 <mestery> #topic Liberty-RC1
14:22:20 <mestery> #link https://launchpad.net/neutron/+milestone/liberty-rc1
14:22:33 <mestery> Lets walk through what we have targeted and have a hard look at what realistically will make it
14:22:39 <mestery> Because I still think what's there isn't realistic at this point
14:22:47 <mestery> First up
14:22:49 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/get-me-a-network
14:22:59 <mestery> haleyb: This seems like it's Mitaka at this point, does that sound right?
14:23:00 <armax> mestery: yes, I simply let the stuff spill over RC1
14:23:08 <mestery> armax: I would have done the same :)
14:23:27 <haleyb> mestery: yes
14:23:33 <mestery> haleyb: That was easy :)
14:23:34 <ajo> mestery: what's the deadline for the RC1 cut?
14:23:41 <armax> haleyb: not even foundational work?
14:23:53 <mestery> ajo: https://wiki.openstack.org/wiki/Liberty_Release_Schedule
14:24:00 <armax> haleyb: that prepares it for an early land in M?
14:24:02 <mestery> We'll start cutting RC candidates the week of Sept. 21
14:24:30 <ajo> ah, ok, so it's not fixed for RC, just between 21sept to 9oct
14:24:30 <haleyb> armax: yes, possibly foundation work
14:24:53 <armax> haleyb: well...by now we’d need a little more than possibly
14:24:54 <mestery> haleyb: If you land a patch or two for this, we'll let them in pending review then.
14:25:04 <armax> :)
14:25:10 <mestery> OK
14:25:14 <mestery> Next up
14:25:16 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/lbaas-ref-octavia
14:25:21 <mestery> dougwig is gone, so perhaps blogan or xgerman can give us an update here
14:25:31 <mestery> I believe this one is still targeted as being landable, though no code shows up there
14:25:36 <xgerman> brogan worked all weekend so we should be good for the RC
14:25:39 <blogan_> mestery: yeah i believe it is still landable
14:25:47 <xgerman> +!
14:25:48 <armax> mestery: that must require landing code in more than one repo, though right?
14:25:49 <xgerman> +1
14:25:55 <mestery> Yay!
14:25:56 <armax> mestery: so stuff might be out of our control
14:25:59 <mestery> armax: Right!
14:26:02 <blogan_> armax: correct
14:26:06 <mestery> Where did hte code land xgerman blogan_ ?
14:26:17 <mestery> armax: Well, it's in our control as it's in the Stadium
14:26:19 <xgerman> octavia and lbaas repo
14:26:22 <mestery> Awesome
14:26:33 <mestery> #info Octavia as the default LBaaS implementation will make Liberty
14:26:44 <mestery> blogan_: Feel free to mark Implemented once you're done
14:26:48 <john-davidge> nice!
14:26:55 <armax> mestery: what about project-config changes, devstack changes etc
14:27:10 <xgerman> we got them covered
14:27:19 <mestery> armax: See, xgerman has it covered?
14:27:41 <armax> mestery: tight!
14:27:51 <xgerman> yep, very tight
14:28:00 <mestery> Lets move on, we've got plenty of yak shaving to complete while painting the bike shed yet
14:28:06 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/wsgi-pecan-switch
14:28:14 <mestery> I spoke to kevinbenton today
14:28:17 <mestery> And he says we still have a shat at this one
14:28:25 <mestery> Though blogan_ said service plugins don't load with the current branch, which is sad
14:28:37 <mestery> kevinbenton remains vigilant he can get this landed this week yet
14:28:45 * mestery waits for armax
14:28:55 <armax> mestery: that’s doable
14:28:57 <blogan_> mestery: well i would say most probably do work, but its not the same as the current wgi server
14:28:59 <armax> mestery: we have targeted code
14:29:07 <markmcclain> mestery: I've got some time to help kevinbenton with any reviews/work needed to land it
14:29:07 <armax> mestery: so we have an idea of what to expect
14:29:24 <mestery> markmcclain: Awesome! Please have a look here: https://review.openstack.org/#/q/project:openstack/neutron+branch:feature/pecan+status:open,n,z
14:29:26 <mestery> #link https://review.openstack.org/#/q/project:openstack/neutron+branch:feature/pecan+status:open,n,z
14:29:30 <mestery> armax: We do
14:29:33 <mestery> blogan_: OK
14:29:37 <mestery> So, this one looks like it's covered
14:29:39 <salv-orlando> mestery: blogan_ did a hack that forces the pecan app to load all plugins at startup
14:29:46 <mestery> salv-orlando: Nice
14:29:48 <salv-orlando> let's say that from an end user perspective it works
14:29:53 <mestery> rofl
14:29:53 <blogan_> mestery: this is just discussing whether it should roll back into master correct? it's not going to replace the current wgi is it?
14:30:05 <mestery> blogan_: God no, not at this stage! :)
14:30:09 <mestery> We're just rolling back to master
14:30:12 <salv-orlando> mestery: but tell armax not to look at the code. He'll faint.
14:30:14 <mestery> So we can release it as experimental
14:30:52 <armax> salv-orlando: thanks for the warning
14:31:00 <blogan_> sorry got dc'ed
14:31:02 <mestery> armax: Please, refrain from looking for a bit :)
14:31:08 <armax> I’ll make sure I have a cpr kit next to me when I do
14:31:15 <mestery> Awesome
14:31:17 <mestery> OK, lets move along
14:31:18 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/vm-without-l3-address
14:31:29 <mestery> armax reverted this one, luckily he had a CPR kit close by
14:31:37 <mestery> The author has reached out
14:31:46 <mestery> But the new direction this one goes in requires an API change (yuck)
14:31:49 <mestery> I'm inclined to boot this one out
14:31:51 <mestery> Thoughts?
14:31:55 <armax> mestery: unfortunately I hadn't
14:32:10 <kevinbenton> Port security is a work around IMO
14:32:12 * mestery takes a note to get armax portable CPR kits to keep near his computer
14:32:21 <mestery> kevinbenton: Sounds fair
14:32:30 <armax> kevinbenton: is alive!
14:32:32 <mestery> Shall we move this one out to Mitaka then?
14:32:37 <mestery> kevinbenton armax: ^^^^
14:32:54 <kevinbenton> I think so. We need a more fine grained port security API
14:33:03 <kevinbenton> Which will take some time to develop
14:33:07 <mestery> AGreed
14:33:15 <mestery> #info vm-without-l3-address is a Mitaka feature now!
14:33:19 <armax> kevinbenton: well, it depends on how fast we can get consensus on the approach
14:33:32 <armax> but yeah, probably it’s safer than shipping a hole in the ship
14:33:47 <armax> no-one wants neutron to sink
14:33:51 <armax> mestery: do you?
14:33:54 <kevinbenton> The only difference is that they won't have Mac spoofing protection
14:34:05 <mestery> armax: Of course not my friend
14:34:08 <kevinbenton> They can still do the non L3 addressed VM
14:34:11 <salv-orlando> armax: but almost everyone rocks the boat ;)
14:34:14 <mestery> It's out of Liberty
14:34:14 <mestery> Lets move along
14:34:16 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/external-dns-resolution
14:34:19 <amotoki> agree. we may need to combine unaddress port/port security with rbac
14:34:27 <mestery> This one looks close, mlavelle is working on it now
14:34:39 <mestery> I expect it to land this week once he re-spins to address current issues
14:34:57 <carl_baldwin> mestery: +1  This one is not intrusive.
14:35:06 <mestery> carl_baldwin: Cool
14:35:13 <mestery> Speaking of carl_baldwin ....
14:35:14 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/address-scopes
14:35:15 <emagana> and some operators need this one
14:35:21 * mestery calls carl_baldwin up to the front of the classroom
14:35:29 <emagana> I meant the dns resolution one
14:35:30 <mestery> carl_baldwin: Thoughts on this one making Liberty at this point?
14:35:35 <mestery> emagana: ++
14:35:35 * carl_baldwin walks up…
14:35:46 <mestery> carl_baldwin: I know you've been pushing hard on this one for the past few weeks yet
14:35:57 <carl_baldwin> The optimistic in me wants to say yes.  It is functional.  But...
14:36:28 <carl_baldwin> It needs tests to be completed.  I suspect some interaction with DVR and I need to look at what will happen with static routes.
14:36:53 <mestery> carl_baldwin: OK, I can leave it in there for now and we can re-evaluate next week?
14:36:55 <mestery> Sound fair?
14:37:02 * salv-orlando thinks carl_baldwin deserves a wildcard as he was already mothballed for liberty with pluggable-ipam
14:37:02 <gongysh> I can join the test team.
14:37:05 <carl_baldwin> Though I really want it in I think it would be better to merge early in Mitaka.
14:37:34 <mestery> carl_baldwin: Well, if that's your thinking, lets just move it out now. Sound ok?
14:37:41 <carl_baldwin> mestery: ok
14:37:50 * carl_baldwin stashes away the wildcard for later.
14:37:53 <mestery> lol
14:38:15 <ajo> :D
14:38:22 <mestery> Next up
14:38:23 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/better-quotas
14:38:31 <mestery> salv-orlando: I think we just need to review and merge 3 more patches right?
14:38:37 <mestery> Or maybe it's 4
14:38:55 <salv-orlando> I think it's 3
14:39:08 <mestery> Awesome
14:39:10 <salv-orlando> I can add some more testing coverage during RC phase, I reckon that would be ok, wouldn't it?
14:39:17 <mestery> salv-orlando: ++
14:39:21 <mestery> Thanks salv-orlando
14:39:33 <mestery> Next up
14:39:35 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/restructure-l2-agent
14:39:44 <mestery> rossella_s has been working on this one for quite a while now
14:39:45 <ajo> carl_baldwin: take out that wildcard for salv-orlando  :P :)
14:39:52 <mestery> 9 outstanding patches still rossella_s?
14:39:58 * carl_baldwin hands it to salv-orlando
14:40:01 <rossella_s> mestery, 5
14:40:06 <mestery> rossella_s: Not bad!
14:40:14 <mestery> rossella_s: Are you getting enough reviews for these?
14:40:20 <mestery> rossella_s: Or do you need more people to help focus on these?
14:40:36 <rossella_s> in the last days I got more review. Reviewers are always very welcome anyway
14:40:43 * carl_baldwin can jump in
14:40:51 <mestery> carl_baldwin: Please do!
14:40:57 <rossella_s> carl_baldwin thanks!
14:41:08 <mestery> #info 5 patches left for agent refactoring, please jump in and help rossella_s land these this week!
14:41:13 <mestery> Thanks rossella_s!
14:41:23 <rossella_s> mestery, thank you
14:41:27 <mestery> Next up
14:41:28 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/add-availability-zone
14:41:47 <mestery> If I'm not mistaken, I think russellb was reviewing these and testing htem recently
14:42:00 <mestery> armax also had a pass on these ones
14:42:07 <armax> mestery: yes, I meant to continue
14:42:08 <russellb> yeah i got the first patch to work
14:42:11 <russellb> wanted to do another pass
14:42:14 <hichihara> amotoki said API patch is OK
14:42:16 <ajo> rossella_s: I will re-review them all, sorry for being a bit slow on that.
14:42:16 <mestery> russellb: \o/
14:42:20 <hichihara> I'm waiting his review to Scheduler patch.
14:42:32 <mestery> So, looks like armax russellb and amotoki have this one covered
14:42:43 <amotoki> perhaps we need to review them combined with the scheduler patch.
14:42:48 <mestery> amotoki: ++
14:42:48 <russellb> ok if it's targeted, i'll be sure to do another pass ... i'm traveling this week again though
14:42:55 <russellb> hopefully can find some time in the evening
14:42:59 <rossella_s> ajo thanks a lot!
14:43:07 <ajo> amotoki++ russellb++ armax++
14:43:08 <ajo> :)
14:43:17 <mestery> russellb: Thanks!
14:43:20 <amotoki> lets check it next week again
14:43:25 <mestery> And thanks to amotoki and armax and ajo too :)
14:43:28 <mestery> amotoki: ++
14:43:30 <hichihara> Thanks!
14:43:38 <mestery> Next up
14:43:39 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/lbaas-l7-rules
14:43:44 <mestery> blogan xgerman: Any update here?
14:43:53 <mestery> dougwig made it sound like this one may be out of Liberty now
14:43:58 <xgerman> I think we deferred that to M
14:44:05 <mestery> xgerman: Cool, thanks!
14:44:05 <ajo> not to me, I did nothing related :D
14:44:44 <mestery> Next up
14:44:45 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/vlan-aware-vms
14:44:57 <mestery> I haven't reviewed this patches, has anyone been looking at these ones?
14:45:02 <mestery> I know they landed only a few weeks ago
14:45:14 <armax> mestery: looks like they have not had any beefy review
14:45:26 <mestery> armax: I figured
14:45:36 <armax> mestery: they were submitted too late in the cycle to get enough attention
14:45:38 <mestery> I'm inclined to give it one more week, but I don't remain optimistic these land in Liberty
14:45:44 <mestery> armax: ++
14:46:20 <amuller> I think they can be delayed to M
14:46:24 <amuller> at this point
14:46:33 <armax> too bad
14:46:44 <mestery> Yup
14:46:46 <mestery> Last one
14:46:47 <mestery> #link https://blueprints.launchpad.net/neutron/+spec/neutron-flavor-framework-templates
14:46:56 <mestery> Since dougwig isn't here, I'm inclined to just move this to Mitaka
14:47:11 <armax> mestery: he’s not doing the work though
14:47:19 <xgerman> well, we have the CLI and are working on a flavor -> service type thingy
14:47:23 <armax> mestery: someone from xgerman is doing it
14:47:32 <mestery> I just moved it out, should I move it back in?
14:47:35 <mestery> xgerman: Are you saying htis has a shot now?
14:47:48 <xgerman> there is still a chance
14:47:48 <mestery> xgerman: Please move the assignee to the actual person doing the work :)
14:47:53 <mestery> xgerman: Ok ,letaving it in
14:47:55 <armax> mestery: so long as the server side is fairly complete yes
14:47:56 <xgerman> ok, will do
14:48:11 <armax> but CLI is clearly blocked on the server side getting in shape
14:48:19 <mestery> armax: WEll
14:48:20 <mestery> Also
14:48:26 <mestery> We're releasing the Liberty client today
14:48:37 <mestery> Which means we won't release another one until after the Liberty release I guess
14:48:39 * ihrachys dances
14:48:46 * mestery dances with ihrachys
14:48:48 <xgerman> mmh, maybe then we are out
14:48:52 * ajo dances too
14:49:06 <mestery> xgerman: Please add the reviews to the BP as well: https://blueprints.launchpad.net/neutron/+spec/neutron-flavor-framework-templates
14:49:20 <armax> xgerman: the cli was ready to merge
14:49:21 <amotoki> it is a race condition between CLI dependency freeze and RC features :-(
14:49:27 <mestery> Yes
14:49:28 <xgerman> well, my powers don’t let me change much on the BP
14:49:32 <armax> xgerman: I only stopped it because I looked at hte server side code
14:49:36 <armax> …and fainted
14:49:36 <mestery> xgerman: In the work area
14:49:46 * mestery rushes the CPR kit to armax
14:49:56 <mestery> OK
14:50:00 <mestery> #topic Open Discussion
14:50:02 <armax> I am ok, I am ok
14:50:06 <mestery> Review review review ....
14:50:15 <armax> …and review what’s relevant
14:50:15 <mestery> We're nearing the end of Liberty
14:50:18 <mestery> Yes
14:50:24 <mestery> PLEASE PLEASE PLEASE don't merge random stuff at this stage
14:50:29 <armax> pushing random stuff in teh gate is not helping anyone
14:50:34 <ihrachys> what's about gate for functional? amuller ?
14:50:34 <mestery> If you have "workflow +1", you have to pay attentiong now
14:50:35 <armax> especially if the failure rate is high
14:50:40 <mestery> We can't afford to merge random things
14:50:46 <emagana> I want to collect questions back to the Operators?
14:51:30 <HenryG> Can vendor decomps continue to go in?
14:51:32 <emagana> we are preparing the agenda for the Tokyo operators meet-up and the topics are here: #link https://etherpad.openstack.org/p/TYO-ops-meetup
14:51:32 <mestery> emagana: Are you looking for input from folks?
14:51:38 <mestery> HenryG: Anything which removes code is a-ok
14:51:46 <mestery> #link https://etherpad.openstack.org/p/TYO-ops-meetup
14:51:49 <armax> mestery: +1
14:51:55 <emagana> mestery: Yes, I want to know what this team wants to know from Operators  :-)
14:51:56 <armax> mestery: remove all the things
14:51:56 <amuller> ihrachys: TBH I've been utterly disconnected since Friday, but I noticed that you and Armando and a few others continued to work on it quite a bit! Thanks for that! I'm pleased with the progress since the last weekly meeting. It's good to see action around that area.
14:52:04 <mestery> emagana: Sounds fair.
14:52:17 <mestery> #info Please add anything you want to understand or glean from operators to the etherpad here: https://etherpad.openstack.org/p/TYO-ops-meetup
14:52:32 <neiljerram> May I ask when we'll start brainstorming the Neutron agenda for Tokyo?
14:52:32 <mestery> amuller: ++, ihrachys and armax thanks!
14:52:49 <mestery> neiljerram: It's in progress as we speak, but I'll create an etherpad
14:52:55 <armax> gate stability is top priority IMO
14:52:56 <neiljerram> Cool, thanks.
14:52:57 <ajo> git rm ** ; git commit -m "remove all the things"; git review # O:)
14:52:57 <mestery> #action mestery create Mitaka summit etherpad idea page
14:53:09 <mestery> neiljerram: Thanks for mentinoing it! With the end of Liberty, I almost forgot to mention that :)
14:53:15 <armax> gate resets make people unhappy, apparently
14:53:16 <mestery> armax: ++
14:53:29 <gongysh> I found some patches on https://github.com/openstack/neutron-specs/blob/master/specs/liberty/bgp-dynamic-routing.rst
14:53:30 <neiljerram> Not wanting to detract from the Liberty endgame focus, of course!
14:53:46 <gongysh> do we have plan for it in liberty?
14:53:49 <armax> the more stable we are the more stuff we’re gonna merge
14:53:51 <mestery> gongysh: Taht is not targeted for Liberty
14:54:17 <gongysh> mestery: ok I will move my review to other spec related patches.
14:54:22 <mestery> gongysh: Thanks!
14:54:39 <mestery> Anything else from anyone before we close?
14:54:59 <ZZelle> mestery, should we remove dead code associated to ebtables management?
14:55:22 <mestery> ZZelle: Code removal sounds ok, assuming it passes reviews, etc.
14:55:23 <mestery> Sound ok?
14:55:32 <ZZelle> mestery, ok
14:56:02 <mestery> OK, lets keep the Liberty momentum going folks!
14:56:07 <mestery> Only a few weeks left!
14:56:14 <mestery> See you all on the ML, IRC, and in the ether!
14:56:16 <mestery> #endmeeting