21:00:11 <armax> #startmeeting networking
21:00:12 <openstack> Meeting started Mon Sep 28 21:00:11 2015 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:13 <dougwig> armax: no pressure. we're all silently judging you.
21:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:15 <mestery> I was doing something wrong all the time it appears
21:00:16 <openstack> The meeting name has been set to 'networking'
21:00:19 <armax> salv-orlando: too late
21:00:33 <salv-orlando> aloha anyway
21:00:39 <armax> #chair mestery
21:00:39 <regXboi> all welcome the new vict.... I mean ptl :)
21:00:40 <openstack> Current chairs: armax mestery
21:00:49 * mestery behaves
21:00:50 <armax> I am making mestery the honorary chair
21:00:58 * mestery feels honored
21:01:00 <pc_m> hi
21:01:08 <russellb> release isn't out, kind of an overlap period :)
21:01:14 <mestery> yup
21:01:16 <mestery> :)
21:01:19 <armax> carl_baldwin, kevinbenton ping
21:01:31 <armax> markmcclain:
21:01:32 <armax> ping
21:01:43 <dougwig> congrats to armax, a hearty thank you to regXboi and rossella_s for running!
21:01:51 <mestery> dougwig: ++
21:01:56 <carl_baldwin> present
21:01:58 <xgerman> dougwig +1000
21:02:01 <Sukhdev> dougwig++
21:02:04 <carl_baldwin> ++
21:02:09 <hichihara> ++
21:02:13 * mestery ^5s carl_baldwin :P
21:02:18 <armax> thanks all for the vote of confidence, I hope I won’t disappoint and make sure to continue the golden era that mestery started
21:02:48 <regXboi> there's kevinbenton
21:02:59 <armax> today’s agenda
21:03:00 <armax> #link https://wiki.openstack.org/wiki/Network/Meetings Agenda
21:03:02 <Sukhdev> mestery set the bar too high for you armax - so, you will have to work hard :-)
21:03:03 <kevinbenton___> o/
21:03:19 * mestery watches kevinbenton___ morph
21:03:36 <armax> Sukhdev: so high I am able to ride
21:03:44 <armax> *not
21:04:19 <armax> so we are in the latest weeks of Liberty
21:04:24 <armax> RC1 was cut last week
21:04:29 <armax> so Mitaka IS OPEN
21:04:33 <russellb> \o/
21:04:34 <mestery> #link https://launchpad.net/neutron/+milestone/liberty-rc1
21:04:55 <armax> #link https://wiki.openstack.org/wiki/ReleaseNotes/Liberty#OpenStack_Liberty_Release_Notes
21:05:09 <armax> please have a look at the realease notes, if we missed something
21:05:25 <armax> please either reach out to me or mestery or make edits yourselves
21:06:04 <regXboi> well - I'd kindly suggest if one does make edits to still reach out for confirmation
21:06:09 <armax> since liberty is still mestery’s mess…ahem realm…I am gonna have take the lead until it finishes off
21:06:20 * armax kids
21:06:20 <mestery> hey now!
21:06:21 * markmcclain sneaks in late
21:06:26 <dougwig> armax: edits were made for octavia as ref, btw.
21:06:35 <armax> dougwig: cool
21:06:39 <mestery> nice work dougwig
21:06:46 <xgerman> but I guess we need some link for people to download it
21:06:49 <dougwig> octavia folks, not me.  :)
21:06:53 <armax> mestery has kindly offered to help with the transition, true Leader mestery
21:07:02 <dougwig> xgerman: that'd be from pip.
21:07:14 <mestery> armax: I've got your back my friend
21:07:22 * mestery throws down cover fire for armax
21:07:39 <armax> so he and I will be working together to have Liberty be a great release
21:08:23 <armax> as for Mitaka, I will still work with him and the rest of the team to get the plan going, but it’ll take me a couple of days to ramp up
21:08:50 <armax> especially in relation to the design summit planning
21:10:34 <armax> I would be reaching out to the drivers, LT’s, cores to make sure we’ll be ready for another exciting cycle
21:10:44 <carl_baldwin> armax: You’ve got us to lean on…
21:11:09 <amuller> Indeed
21:11:17 <armax> carl_baldwin: yup, this can only be a collaborative effort to be successful
21:11:31 <armax> no-one can
21:11:33 <armax> do it all
21:11:39 <armax> anyhoo
21:12:38 <salv-orlando> unless it's Iron Man
21:12:49 <armax> I realized I should have set the Announcements topic, oh well…I told you my fingers are sweating
21:12:52 <salv-orlando> but then even Iron Man has Jarvis
21:13:00 <armax> let’s dive in in the rest of the agenda
21:13:03 <armax> #topic Bugs
21:13:32 <armax> we got a few on the agenda
21:13:42 <armax> we were talking about
21:13:45 <armax> #link https://bugs.launchpad.net/neutron/+bug/1499033
21:13:45 <openstack> Launchpad bug 1499033 in neutron "Add Liberty release milestone" [Medium,In progress] - Assigned to Henry Gessau (gessau)
21:13:55 <armax> in the channel a bit earlier
21:13:58 <mestery> We need that one in Liberty for sure
21:14:03 <mestery> Thus, meaning we many need an RC2
21:14:07 <mestery> *may
21:14:18 <HenryG> Nope, I suggest we abandon it
21:14:28 <mestery> HenryG: Ah, nice!
21:14:28 <mestery> New information :)
21:14:35 <armax> mestery: and yes, we gotta figure out a way not to have these fall off through the cracks next time
21:14:35 <mestery> I'm already out of date!
21:14:40 <salv-orlando> mestery: odds on that were like 100/99
21:14:53 <salv-orlando> sorry 1/100
21:14:56 <armax> HenryG: what’s the other course of action?
21:14:59 <mestery> salv-orlando: To be fair, I took the long one there, I've likely lost again
21:15:09 <HenryG> armax: do nothing
21:15:12 <regXboi> salv-orlando: three people in the world - those who like math and those who don't?
21:15:41 <salv-orlando> regXboi: unfortunately I was never good at that.
21:15:43 <HenryG> armax: I don't know what use it is
21:15:45 <armax> HenryG: meaning that users won’t have the shortcut to run neutron-db-manage upgrade to Liberty?
21:15:53 <salv-orlando> anyway, this bug is not trivial at all
21:15:57 <HenryG> armax: no one did that anyway
21:16:18 <HenryG> armax: everyone does "upgrade heads"
21:16:20 <armax> HenryG: meaning they always upgreaded to head?
21:16:23 <armax> HenryG: right
21:16:54 <armax> so the loss here would be lack of convenience?
21:16:58 <mestery> HenryG: The bug is invalid then?
21:17:00 <markmcclain> right, but the symbolic at least made it easy to determine where you were
21:17:03 <HenryG> If you're on master branch and you "upgeade kilo" your code won't work
21:17:09 <amuller> some installers used the symbolic names I'm sure
21:17:16 <salv-orlando> HenryG: how do we know what everybody does?
21:17:16 <markmcclain> can we add it for only one of the paths?
21:17:22 <amuller> so not having the liberty symbolic name might break fuel or RDO installers or whatever
21:17:27 <amuller> so this will need to be communicated
21:17:30 <armax> HenryG: did you sync up with ihar on this one?
21:17:49 <HenryG> I have not seen Ihar today
21:17:51 <salv-orlando> amuller: that should at least be release-noted
21:17:54 <armax> amuller: right, that’s why I was thinking of ihar
21:18:24 <HenryG> The patch I have out would provide this "feature"
21:18:25 <armax> HenryG: but abandoning this bug means we’ll be regressing on the way the tool worked
21:18:50 <armax> HenryG: and your patch does the job doesn’t it?
21:18:56 <HenryG> armax: yep
21:18:58 <mestery> I'm beginning to think we want this merged actually.
21:19:04 <armax> and works across multiple repos
21:19:04 <mestery> markmcclain seems to be agreeing with me. HenryG, why not proceed?
21:19:26 <armax> HenryG: correct?
21:19:26 <HenryG> armax: yes, all repos (once they tag themselves)
21:19:30 <armax> HenryG: right
21:19:35 <armax> so why would you want to abandon it?
21:20:05 <HenryG> armax: because I am not a package owner or an installer so I did not think that far
21:20:26 <armax> HenryG: that’s fine, let’s circle back with either and get this to conclusion
21:20:57 <armax> at least let’s get ihar’s input
21:21:01 <HenryG> thanks amuller for alerting to use cases
21:21:16 <amuller> No one remembers the poor installers :(
21:21:18 <salv-orlando> HenryG: as long as you preserve the user behaviour I think that's fine
21:21:32 <armax> amuller: I do (when I expressily ignore them ;)
21:21:34 <salv-orlando> as for the internals, we can iterate
21:21:43 <armax> salv-orlando: +1
21:21:59 <HenryG> OK, the patches are ready then
21:22:16 <armax> #info bug 1499033 will need to merge/backport once we get an agreement that it’s the way to go
21:22:16 <openstack> bug 1499033 in neutron "Add Liberty release milestone" [Medium,In progress] https://launchpad.net/bugs/1499033 - Assigned to Henry Gessau (gessau)
21:22:28 <armax> mestery: so this means we’ll have to cut RC2 then?
21:22:32 <mestery> Ack
21:22:35 <mestery> armax: Indeed
21:22:41 <armax> assumed that ihar gives us the thumb up
21:22:44 <mestery> #info We'll need an RC2 due to this
21:22:57 <HenryG> That's no different from last milestone, BTW
21:22:58 <mestery> #action mestery to alert the release team to be ready for Neutron Liberty RC2
21:23:22 <armax> mestery: this means we’ll probably get some breathing space to pick some other stuff
21:23:30 <armax> but let’s not get too excited
21:23:31 <mestery> armax: Yes
21:23:32 <mestery> In fact
21:23:41 <HenryG> In kilo we made RC2 for the milestone revisions
21:23:44 <mestery> I'd encourage folks to tag potential backports for RC2 with "liberty-rc-potential" in LP
21:23:56 <salv-orlando> you'd better do that otherwise we'll likely need a RC3 too
21:23:58 <mestery> HenryG: It's a pattern with us
21:24:07 <mestery> salv-orlando: Have we ever had an RC3?
21:24:12 <armax> #info tag "liberty-rc-potential” on a bug you care about
21:24:17 <markmcclain> yeah.. I think it's been in RC2 for a good while now
21:24:23 <salv-orlando> mestery: yes ask ptl emeritus markmcclain
21:24:38 <mestery> salv-orlando markmcclain: :P
21:24:38 <markmcclain> we've def hit rc3
21:24:50 <salv-orlando> usually because of some bug I introduced
21:25:03 <armax> yeah, it woudl be a shame have all those FF weeks go to waste
21:25:33 <armax> another bug seems tricky: bug 1484148
21:25:33 <openstack> bug 1484148 in python-neutronclient "neutronclient gate broken following VPNaaS infra changes" [High,In progress] https://launchpad.net/bugs/1484148 - Assigned to Paul Michali (pcm)
21:25:37 <armax> #link https://bugs.launchpad.net/python-neutronclient/+bug/1484148
21:25:49 <armax> pc_m: what do you reckon on this one?
21:26:19 <armax> a fix was partial
21:26:53 <armax> pc_m: udere?
21:26:54 <pc_m> it has workaround.
21:27:11 <pc_m> Also, final fix is in check queue.
21:27:18 <pc_m> job running as check queue.
21:27:18 <armax> pc_m: link?
21:27:29 <pc_m> Once it is tested, it can vote.
21:27:50 <pc_m> #link https://review.openstack.org/227232
21:28:17 <pc_m> So, non-problem as tests are skipped. These jobs, once voting will rstore VPN tests.
21:28:20 <pc_m> restore
21:28:35 <armax> pc_m: ok, so nothing needs to be merged in the neutron trees?
21:28:41 <pc_m> Just needs some run time to make sure everything is cool.
21:28:45 <pc_m> armax: correct.
21:28:51 <armax> pc_m: ok
21:29:03 <armax> HenryG: this one https://bugs.launchpad.net/neutron/+bug/1477192
21:29:03 <openstack> Launchpad bug 1477192 in neutron "neutron test_multi_prefix_slaac failing in the gate with ping failures starting around 7/22" [Medium,Confirmed] - Assigned to Henry Gessau (gessau)
21:29:06 <armax> #link https://bugs.launchpad.net/neutron/+bug/1477192
21:29:07 <pc_m> armax: Will be a job change from non-voting to voting.
21:29:15 <armax> has no code targeted
21:29:38 <HenryG> I have not pursued that recently
21:29:51 <armax> pc_m: thanks, I’ll update the bug report unless you beat me to it
21:30:10 <armax> HenryG: ok, but it’s not hurting th release, is it?
21:30:12 <pc_m> armax: I'd do it.
21:30:18 <armax> pc_m: thanks
21:30:33 <HenryG> I think it's a tempest issue
21:30:57 <HenryG> Assumptions or bugs in the test cases
21:31:03 <armax> HenryG: ok, being a gate failure let’s tag it as such
21:31:28 <armax> HenryG: I’ll look into it being the Infra Lt :)
21:31:58 <armax> #action armax to look into bug #1477192
21:31:58 <openstack> bug 1477192 in neutron "neutron test_multi_prefix_slaac failing in the gate with ping failures starting around 7/22" [Medium,Confirmed] https://launchpad.net/bugs/1477192 - Assigned to Henry Gessau (gessau)
21:32:15 <armax> dougwig: what about bug https://bugs.launchpad.net/neutron/+bug/1439696
21:32:15 <openstack> Launchpad bug 1439696 in neutron "Referencing a lb-healthmonitor ID for the first time from Heat would fail" [Medium,Confirmed] - Assigned to Doug Wiegley (dougwig)
21:32:16 <armax> #link https://bugs.launchpad.net/neutron/+bug/1439696
21:32:32 <armax> no code posted
21:32:42 <HenryG> armax: Yeah, sync up with me and I'll show you a suspect I have
21:32:50 <armax> HenryG: will do
21:32:57 <dougwig> armax: no progress.
21:33:11 <dougwig> armax: let me kick that over now.
21:33:19 <armax> dougwig: is it still something you’d want to look into or shall we pass it on?
21:33:35 <dougwig> it's lbaasv1, so i'm not in a hurry.
21:33:41 <armax> dougwig: ok seems fair
21:34:19 <armax> dougwig: this one is also assigned to you: https://bugs.launchpad.net/neutron/+bug/1163569
21:34:19 <openstack> Launchpad bug 1163569 in neutron "security groups don't work with vip and ovs plugin" [High,Confirmed] - Assigned to Doug Wiegley (dougwig)
21:34:23 <armax> #link https://bugs.launchpad.net/neutron/+bug/1163569
21:34:40 <armax> this bug is ancient
21:35:45 <mestery> Mark it as invalid?
21:35:56 <armax> I wonder if dougwig had managed to triage it
21:36:09 <dougwig> this bug is indeed ancient.
21:36:45 <dougwig> is it behavior that we want?
21:37:23 <armax> to be honest this isn’t clear to me from the description
21:37:26 <mestery> dougwig: Does it affect LBaaS V2 as well as V1?
21:37:41 <dougwig> mestery: both
21:37:58 <mestery> dougwig: So yeah, then maybe an email to the operators list asking the question of users and what they want?
21:38:00 <armax> I have been thinking that we need to come up with a better way for reporting bugs
21:38:04 * mestery waves hands around
21:38:11 <mestery> armax: +1000.5
21:38:18 <armax> so that they don’t sit in LP for so long
21:38:41 <armax> sometimes the back and forth for gathering information is painful to watch
21:38:51 <armax> mestery: thanks for the .5
21:39:05 <mestery> armax: It's the little extra that counts the most ;)
21:39:10 <armax> mestery: indeed
21:39:14 <mestery> armax: But I agree, having a clearer template makes a lot of sense
21:39:22 <armax> ok, let’s close in on the others
21:39:25 <armax> ajo: ping
21:39:35 <armax> #link https://bugs.launchpad.net/neutron/+bug/1491131
21:39:35 <openstack> Launchpad bug 1491131 in neutron "Ipset race condition" [High,In progress] - Assigned to shihanzhang (shihanzhang)
21:40:01 <armax> this doesn’t seem to affect Liberty
21:40:33 <armax> but from what I can see the fix is in both juno and kilo
21:41:04 <armax> ok ajo might not be around I’ll reach out to him
21:41:12 <armax> lastly
21:41:14 <armax> amuller: https://bugs.launchpad.net/neutron/+bugs?field.tag=functional-tests
21:41:17 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=functional-tests
21:41:18 <ZZelle_> armax, according to logstash, it affects juno and kilo only
21:41:27 <armax> and https://bugs.launchpad.net/neutron/+bug/1312016
21:41:27 <openstack> Launchpad bug 1312016 in neutron "nova libvirtError: Unable to add bridge brqxxx-xx port tapxxx-xx: Device or resource busy" [High,In progress] - Assigned to Sean M. Collins (scollins)
21:41:34 <armax> sc68cal: ^^
21:41:37 <armax> #link https://bugs.launchpad.net/neutron/+bug/1312016
21:41:59 <armax> amuller: functional job failure rate is a bit better
21:42:26 <armax> do you need eyes on some of the remaining fixes?
21:42:29 <amuller> armax: aye, last 3 days are back to the normal 12.5%
21:42:44 <amuller> I'm happy (For some definition of happy) with that failure rate
21:42:48 <armax> I wish the new normal would be something closer to being single digit
21:42:49 <armax> but ok
21:42:54 <anteaya> sc68cal: is offline right now
21:43:08 <armax> anteaya: ok
21:43:21 <armax> I’ll reach out to him later
21:43:30 <anteaya> k
21:43:33 <armax> thanks
21:43:39 <anteaya> welcome
21:43:58 <armax> ok, as for bugs I think we’re done with those listed on the agenda
21:44:17 <armax> if something starts screaming please reach out to me or mestery
21:44:28 <mestery> ++
21:44:41 <armax> and we’ll dispatch/figure out/reach out/pray/plead etc
21:44:49 <armax> accordingly
21:44:54 <regXboi> I like that last one
21:45:08 <armax> emagana is not here
21:45:22 <armax> so we’ll skip the doc section, unless someone has an update for the team
21:45:34 <armax> 1...
21:45:36 <armax> 2...
21:45:37 <armax> 3...
21:45:47 <armax> #topic Open Agenda
21:45:55 <armax> #undo
21:45:56 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x9b66cd0>
21:46:01 <armax> #topic Open Discussion
21:46:09 <dougwig> the open agenda would be more fun.
21:46:15 <markmcclain> +1000
21:46:17 <salv-orl_> the pedantry is strong with this PTL
21:46:17 <armax> dougwig: lol
21:46:22 <dougwig> #topic impeach armax!
21:46:30 <armax> salv-orl_: I have you to thank
21:46:31 <russellb> trololo
21:46:32 <regXboi> heck no
21:46:40 <mestery> lol
21:46:41 <armax> salv-orl_: you’re my mentor
21:46:50 <salv-orl_> I have an announcement to make
21:46:53 <regXboi> are we done?
21:46:57 <russellb> salv-orl_: uh oh
21:46:58 <regXboi> oops - guess not :)
21:46:59 <salv-orl_> today it's the PTL's birthday ;)
21:47:05 <russellb> !!!!!!!!
21:47:06 <mestery> lol
21:47:06 <openstack> russellb: Error: "!!!!!!!" is not a valid command.
21:47:07 <armax> salv-orl_: oh come on!
21:47:10 <mestery> HAPPY BIRTHDAY ARMAX!
21:47:11 <mestery> :)
21:47:12 <Swami> armax: happy birthday
21:47:13 * russellb glares at openstack
21:47:16 <armax> thanks folks
21:47:18 * xgerman sings happy birthday
21:47:19 <russellb> armax: HAPPY BIRTHDAY !!!!!
21:47:26 <armax> I am 10 years too old that I’d like to remember
21:47:26 <mlavalle> armax: 28?
21:47:28 * mestery bakes a cake for armax
21:47:29 <dougwig> everyone sing!
21:47:29 <armax> I wish
21:47:30 <hichihara> armax: Happy Birthday!
21:47:33 <ZZelle_> Happy birthday!
21:47:37 <mestery> salv-orl_: I think you owe armax a beer now :)
21:47:46 <mlavalle> armax: happy birthday
21:47:51 <russellb> have some pie:  [}
21:47:51 <regXboi> so does that mean salv-orl buys the first round in Tokyo?
21:47:59 <Sukhdev> armax: Happy B'day
21:48:04 <armax> thanks fellas
21:48:12 <HenryG> armax: Happy Birthday to you, you belong in this zoo!
21:48:12 <armax> I feel a little younger now
21:48:14 <xgerman> regXboi that’s what I heard
21:48:14 <mlavalle> regXboi: i was counting on that anyways
21:48:28 <mestery> New rule that salv-orl_ always buys the first round?
21:48:30 <armax> definitely younger compared to when Mitaka closes
21:48:32 <hoangcx> HenryG: lol
21:48:38 <mlavalle> mestery: ++
21:48:39 * markmcclain sends armax some birthday/ptl liquor
21:48:39 <russellb> armax: +1
21:48:49 <armax> markmcclain: look forward to it
21:49:12 <armax> ok, to bring us back to less glamorous topics
21:49:23 <armax> the design summit session brainstorm is taking shape here:
21:49:29 <armax> #link https://etherpad.openstack.org/p/neutron-mitaka-designsummit
21:49:48 <armax> keep adding ideas…I’ll be working with the team to come up with a coherent set of sessions
21:50:15 <Sukhdev> armax: When the cut-off date for selections of idea?
21:50:18 <armax> Liberty’s tail is long btw
21:50:41 <armax> so expect some of the Liberty’s topic to reappear again
21:50:59 <armax> Sukhdev: I am not aware of any specific date, but sooner the better
21:51:00 <armax> mestery: ?
21:51:02 <mestery> armax: ++, backlog stuff likely to surface
21:51:16 <mestery> Sukhdev: In previous cycles, I would try to get this nailed down 2 weeks out from the summit
21:51:24 <kevinbenton> nova-net NFV migration
21:51:30 <armax> mestery: for the stuff that needs face-face screaming and shouting mind you
21:51:37 <mestery> kevinbenton: Is it flavor based?
21:51:43 <russellb> oh dear
21:51:47 <mestery> lol
21:51:50 <salv-orl_> kevinbenton: it's statement like these that make me think you're the next PTL
21:51:51 <armax> kevinbenton: with this comment you’ve been banned
21:51:58 <armax> kevinbenton: out
21:51:58 <mestery> hahahhahahahahaha
21:52:20 * armax is going to erase kevinbenton’s digital footprint
21:52:33 <salv-orl_> mestery: see that's just because armax wants to keep its position with an iron fist and ban all opponents!
21:52:39 <regXboi> kevinbeton: you should have gone for the full quad!
21:53:03 <mestery> salv-orl_: He's a dictator! We've elected a dictator!
21:53:12 <russellb> good thing we're logging all this open discussion banter, heh
21:53:16 * Sukhdev 7 min. left
21:53:19 <mestery> russellb: lol :)
21:53:20 <regXboi> mestery: that is usually how it works
21:53:21 <armax> there’s quite a lot on the on-demand section that we could possibly cover in 7 mins
21:53:31 <mestery> armax: It may be stale
21:53:35 * Sukhdev waiting to open discussion to ask a question
21:53:36 <mestery> armax: I'd encourage you to skip it all this week
21:53:39 <armax> is there anything in particular guys would want to talk about?
21:53:41 <mestery> And we'll clean it up for next week
21:53:49 <russellb> Sukhdev: this is open discussion time
21:53:56 <armax> I have obviosuly dragged this meeting too long
21:53:58 <mestery> Sukhdev: Go ahead!
21:54:30 <Sukhdev> mestery: device_owner in the neturon port_create() is usually set to "compute:none"
21:54:51 <Sukhdev> with ironic, we are thinking about introducing "baremetal:xxx"
21:55:04 <Sukhdev> what do neutron cores think about it?
21:55:08 <mestery> Sukhdev: Just to be different? ;)
21:55:14 <Sukhdev> or "compute:baremetal"
21:55:16 <armax> Sukhdev: that’s set to compute:none for regular ports
21:55:19 <markmcclain> Sukhdev: does it have meaning to neutron or another system?
21:55:20 <Sukhdev> mestery: yes
21:55:30 <armax> Sukhdev: I thought we talked about this
21:55:34 <salv-orl_> it's supposed to be compute:<az>
21:55:40 <armax> salv-orl_: +1
21:55:40 <russellb> Sukhdev: non-cores don't get an opinion?  :-p
21:55:41 <salv-orl_> that's where the None comes form
21:55:53 <armax> Sukhdev: it’s compute:<cell> actually
21:55:58 <armax> salv-orl_: ^
21:56:03 <russellb> oh, nice
21:56:09 <markmcclain> device_owner with meaning is almost an anti-pattern
21:56:13 <salv-orl_> I missed the bit where Neutorn became cell-aware
21:56:19 <armax> markmcclain: +!
21:56:29 <armax> salv-orl_: well Neutron isn't
21:56:34 <Sukhdev> salv-orl_: correct - but, I was told this morning that nova and Ironic may use different owners - hence, wanted to ask if neutron specifically differentiates?
21:56:35 <armax> but that’s how nova pass it along
21:57:04 <markmcclain> Sukhdev: should be opaque to neutron
21:57:04 <kevinbenton> it would be nice to see at a glance based on the device_owner bare metal vs VMs
21:57:10 <armax> markmcclain: +!1
21:57:28 <armax> Sukhdev: bottom line, we care about the network:XXX ones
21:57:29 <salv-orl_> Sukhdev: as markmcclain is hinting devicE_owner is an attribute that has been abused by Neutron
21:57:47 <armax> Sukhdev: today we use it to discern neutron ports from vm’s ports
21:57:50 <salv-orl_> it was always meant to be a read-only info for clients
21:58:25 <armax> I suppose nothing can stop using baremetal:xx
21:58:34 <Sukhdev> Looks like Ironic folks are asking to use "baremetal:zone"
21:58:37 <armax> but compute:baremetal
21:58:39 <armax> seems wrong
21:58:50 <kevinbenton> barecompute:metal
21:58:51 <Sukhdev> I wanted to check in this form - before proceeding
21:59:17 <markmcclain> I
21:59:27 <russellb> bear metal
21:59:28 <mestery> kevinbenton: +0.5
21:59:33 <armax> I think that’s a discussion that needs to happen between nova and ironic first
21:59:34 <markmcclain> russellb: +1
21:59:36 <armax> imo
21:59:41 <mestery> 1 minute left armax :)
21:59:49 <armax> I am losing my shoe
21:59:53 <russellb> https://wiki.openstack.org/wiki/Ironic#Pixie_Boots.2C_the_Ironic_drummer_bear
22:00:07 <armax> ok folks
22:00:12 <armax> thanks for joining
22:00:13 <armax> #endmeeting