21:00:10 <armax> #startmeeting networking
21:00:11 <openstack> Meeting started Mon Mar 21 21:00:10 2016 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:16 <openstack> The meeting name has been set to 'networking'
21:00:19 <armax> let’s see how sleepy we are today
21:00:33 <armax> it’s the beginning of spring
21:00:35 <ihrachys> o/
21:00:40 <johnsom> On the dot
21:00:44 <xgerman> o/
21:00:47 <boden> o/
21:01:09 <njohnston> o/
21:01:09 <Sukhdev> hello
21:01:11 <pc_m> o/
21:01:18 <mlavalle> armax: a chilly beginning of spring in Texas. It was 38 this morning in San Antonio
21:01:52 <armax> mlavalle: it’s rainy and cold in this part of the world too
21:02:00 <xgerman> mlavalle glad you are still in San Antonio and not Houston
21:02:14 <xgerman> San Diego is nice as always :-)
21:02:15 <njohnston> everybody's glad they're not in Houston.
21:02:26 <xgerman> +1
21:02:27 <salv-orlando> aloha
21:02:45 <armax> let’s dive in so that we can all go back and hibernate
21:02:45 <anteaya> I'm glad I'm not in Houston
21:02:55 <amotoki> hi
21:03:00 <armax> #topic Announcements
21:03:27 <armax> We have an RC1 and we’re working towards an RC2
21:03:52 <mestery> o/
21:04:07 <armax> please test the release and for any issue that you find, file a bug report and tag it with mitaka-rc-potential
21:04:10 <armax> #link https://bugs.launchpad.net/neutron/+bugs/?field.tag=mitaka-rc-potential
21:04:28 <armax> right now we look RC bug free
21:04:47 * HenryG joins late
21:04:49 <armax> we’ll pull the trigger on RC2 in the next day or so
21:05:05 <anteaya> if you are rc bug free why do you need an rc2?
21:05:08 <armax> if no other bugs are found, this would be our Mitaka release
21:05:28 <armax> anteaya: we had bugs targeting RC2 that were fixed post-rc1
21:05:33 <anteaya> ah thanks
21:06:05 <armax> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/089701.html
21:06:20 <armax> this is the reminder email from the release team
21:06:55 <armax> the deadline for release candidates is Mar 28
21:07:29 <armax> having said that, Newton is open for business
21:08:10 <armax> before we dive into it though, please review https://review.openstack.org/#/c/286413/ to make sure we haven’t misrepresented anything
21:08:39 <armax> I’d like to get that merged before we can open up the specs repo for Netwon efforts
21:09:16 <armax> this actually brings me to the next point, which is: bump all targeted specs to the newton directory
21:09:18 <armax> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron-specs,n,z
21:10:05 <anteaya> nice idea on the post mortem
21:10:25 <armax> thanks
21:11:50 <armax> The summit is a little over a month from now
21:12:11 <armax> I have sent out an email to ask for design summit ideas
21:12:20 <armax> please collect your thoughts on https://etherpad.openstack.org/p/newton-neutron-summit-ideas
21:12:32 <armax> we’ll keep the design format similar to last year
21:12:48 <armax> and I’ll work with the drivers team to put together an agenda once we have enough feedback
21:13:05 <anteaya> is someone looking at other project etherpads for adding neutron sessions were appropriate?
21:13:21 <anteaya> I know nova's etherpad has a neutron section
21:13:40 <dougwig> anteaya: do you happen to have a link handy?
21:13:45 <armax> I looked at the nova etherpad
21:13:59 <armax> dougwig: https://etherpad.openstack.org/p/newton-nova-summit-ideas
21:14:01 <anteaya> awesome thanks
21:14:03 <anteaya> :)
21:14:24 <hichihara> When is dead line for the ideas?
21:14:27 <anteaya> I don't know if cinder and keystone and such have their planning etherpads up yet
21:14:34 <anteaya> hichihara: depends on the project
21:14:44 <armax> hichihara: no deadline per se, but we’d want to finalize the schedule in the next couple of weeks
21:14:45 <Sukhdev> armax : I added couple of ideas to the etherpad
21:14:57 <hichihara> Thanks
21:15:14 <anteaya> there is a deadline from ttx and thingee to have them up for everyone, but every project does it a bit differently
21:15:17 <armax> hichihara: as soon as I learn more from ttx and thingee will inform the team
21:16:03 <armax> typically the deadline is hinted by when the summit webside is online and we can start filling in the sessions
21:16:15 <Sukhdev> armax : We are looking to setup a joint session for Ironic/Nova/Neutron for Vlan Aware VMs for baremetal deployments
21:16:43 <armax> Sukhdev: ack
21:17:14 <armax> Sukhdev: knowing that we don’t even have an implementation for virtual trunking…I can’t help myself but giggle a little
21:17:43 <armax> Sukhdev: but yes, I think we’d want to start that conversation
21:17:51 <amuller> We probably want to continue the tradition of the bi yearly Friday vlan aware VMs meetup
21:17:57 <Sukhdev> armax : ha ha - but, sooner we sync up sooner we will make sure we do not drift apart in implementation
21:18:00 <amotoki> Sukhdev: only for vlan aware VMs? the joint session sounds helpful. it can cover various topics around ironic/neutron/nova
21:18:16 <Sukhdev> amotoki : +1
21:18:18 <armax> Sukhdev: yes, we’d want to confirm the model is sound across all the flavors of provisioning we can come up with
21:19:00 <armax> Sukhdev: we should probably drop the VMs from the title as Apple dropped Computer back in the days
21:19:09 <armax> but I digress
21:19:24 <Sukhdev> armax : +1 on both counts :-)
21:19:50 <armax> I hope this cycle is the cycle where we can get closure on vlan trunking
21:19:51 <Sukhdev> Vlan aware servers
21:20:09 <armax> but we’ll get to that
21:20:27 <Sukhdev> I thought some of the implementation is already underway from the neutron side
21:20:56 <armax> in fact, in the next few days I suggest anyone who’s got backlog items to make sure they get ready into shape by Newton-1
21:21:09 <armax> Sukhdev: we got some patches up for review but nothing has merged yet except the spec
21:21:26 <armax> which we’ll have to be reproposed for Newton
21:21:58 <Sukhdev> armax : there are few patches on Ironic side as well - and they are fairly apart from each other - hence, we should have joint session so that we can coverge
21:22:09 <armax> I’ll set up our next team meeting to go over the blueprints/rfe that didn’t make Mitaka
21:22:43 <armax> any other reminder/announcement from the team?
21:24:26 <armax> ok
21:24:55 <armax> #topic bugs
21:25:15 <armax> this past week we had hichihara as our deputy
21:25:22 <hichihara> Yeah
21:25:30 <hichihara> I have saw new 6 Critical bugs and some High bugs with mitaka-rc-potential.
21:25:32 <armax> hichihara: thanks for volunteering, is there anything you’d like raise?
21:25:40 <hichihara> The critical bugs were finished now.
21:25:50 <hichihara> and also all bugs with mitaka-rc-potential have been finished.
21:25:56 <hichihara> That's all :)
21:26:00 <armax> yup, there’s more with the backport-potential tag
21:26:06 <hichihara> yes
21:26:12 <hichihara> https://bugs.launchpad.net/neutron/+bugs?field.tag=mitaka-backport-potential
21:26:12 <armax> #link https://bugs.launchpad.net/neutron/+bugs/?field.tag=mitaka-backport-potential
21:26:28 <hichihara> oh...sorry duplicate ;)
21:26:28 <Sukhdev> ihrachys : can i bring up one bug which is in Mitaka RC-1, but is hitting kilo as well
21:26:51 <armax> there are probably not release critical but worth a quick land to stable if we manage to nail fixes in master
21:26:52 <ihrachys> Sukhdev: ?
21:26:52 <Sukhdev> ihrachys : and it is not back ported yet
21:27:01 <armax> Sukhdev: link?
21:27:11 <Sukhdev> #link: https://bugs.launchpad.net/neutron/+bug/1551542
21:27:13 <openstack> Launchpad bug 1551542 in neutron "need to check if a plugin's start rpc listeners is supported before trying to start it" [Medium,Fix released] - Assigned to Brandon Logan (brandon-logan)
21:27:25 <Sukhdev> https://review.openstack.org/#/c/286384/
21:27:55 <Sukhdev> This is in RC-1, but, Mirantis distros are hitting in Mirantis release 7.0 - which is Kilo
21:28:33 <amotoki> Sukhdev: i think it is backport-able, but kilo stable update has different schedule
21:28:49 <ihrachys> Sukhdev: ok, what stops us from backporting?
21:29:00 <ihrachys> Sukhdev: note that kilo will be soon closed after mitaka releases
21:29:14 <Sukhdev> ihrachys : nothing, really :-)
21:29:19 <armax> I thought kilo is security fixes only
21:29:29 <xgerman> +1
21:29:35 <amotoki> IIRC security fix or critical fix
21:29:41 <ihrachys> armax: and high impact stuff. so it depends on bug details.
21:29:47 <Sukhdev> ihrachys : I was hoping some Mirantis guys will jump in :-)
21:29:51 <armax> ihrachys: ack
21:30:14 <armax> ihrachys: this doesn’t look critical to me
21:30:22 <ihrachys> honestly, does not seem high impact. but let's just discuss in gerrit.
21:30:31 <armax> yup
21:30:42 <ihrachys> Mirantis can always backport into their MOS or however they call it
21:30:43 <armax> thanks Sukhdev for raising the issue
21:30:52 <Sukhdev> armax: The base class is changed - and fails many plugins to even initialize - so, figure the criticality
21:31:16 <armax> Sukhdev: but how is it possible that’s being broken for 3 releases?
21:31:45 <Sukhdev> armax : good question - even I was scraching my head when customers reported it :-)
21:31:52 <armax> Sukhdev: maybe the issue has been misrepresented, that said, at this point let’s get eyes on this
21:32:09 <Sukhdev> armax : agree
21:32:32 <amotoki> IIRC it is reported as an error, but most plugins succeed to start
21:32:39 <armax> apart for this, we need a new volunteer for next week
21:33:08 <armax> any takers?
21:33:48 <amotoki> i can volunteer
21:34:03 * Sukhdev three cheers for amotoki
21:34:03 <amotoki> is it for this week?
21:34:05 <armax> thanks amotoki
21:34:18 <armax> #action amotoki bug deputy for week of Mar 28
21:34:53 <hichihara> Who is bug deputy in this week?
21:34:59 <amotoki> we don't see any bug duputy for this week
21:35:20 <armax> hichihara: you’re right
21:35:27 <armax> hichihara: I overlooked
21:35:45 <armax> hichihara: any other taker? if not, I’ll fill in
21:36:07 <HenryG> I can do this week.
21:36:16 <armax> HenryG: attaboy
21:36:26 <armax> #action HenryG deputy for the week of Mar 21
21:36:29 <armax> thanks HenryG
21:36:42 <HenryG> Everyone take a week off. :D
21:36:42 <amotoki> I would like to raise https://bugs.launchpad.net/neutron/+bug/1430003
21:36:44 <openstack> Launchpad bug 1430003 in neutron "Corrupt POSTROUTING Chain when using Metering and VPN agents together" [High,Confirmed] - Assigned to Yi Jing Zhu (nick-zhuyj)
21:37:05 <amotoki> it seems metering-agent and vpn-agent cannot be used
21:37:28 <amotoki> we don't have a fix for this, but it is worth mentioned in our release note
21:38:14 * armax looks
21:38:59 <amotoki> the order of iptables chains is randomely swapped... and it leads to unexpected behavior.
21:39:37 <armax> if this issue is there since icehouse…oh boy
21:40:01 <amotoki> I found this last week :(
21:40:07 <armax> that’s even worse than the kilo issue that Sukhdev raised
21:40:13 <xgerman> iptables need some serious redesign we also run into issues from the FWaaS side
21:40:36 <Sukhdev> combination of two services - probably never were tested together :-)
21:40:45 <armax> Sukhdev: yup
21:41:05 <ihrachys> not the most popular services
21:41:15 <xgerman> yeah, and iptables/chains don’t have a good plugin model
21:41:34 <armax> do we even have expertise in the metering agent anymore?
21:41:57 <armax> I have got the impression that’s a limb we’re waiting to cut off
21:42:35 <amotoki> yeah... it might be better to apply iptables rules from one agent...
21:42:45 <amotoki> armax: i feel the same.
21:42:49 <armax> this is the usual dilemma, if we don’t have enough people who care about the quality of a piece of the puzzle…
21:43:12 <ihrachys> well, I see some interest in it expressed on ops@, so it's not like we can easily drop it with no complains
21:43:31 <armax> ihrachys: I was not going to drop it willy nilly
21:43:44 <jamespd> we really wanted to use the metering agent
21:43:48 <armax> ihrachys: but if we have no-one maintaining it, then we can’t ship something that’s broken eitehr
21:44:08 <jamespd> but it made us miserable, so we ended up dropping it for custom metering outside openstack.
21:44:17 <amotoki> at least we need to mention this in 'known issues' to avoid more people try this in the initial mitaka.
21:44:28 <xgerman> +1
21:44:33 <hichihara> amotoki: +1
21:44:34 <haleyb> they shouldn't step on each other since there is a lock, but there is no way for the agents to know the order each prefers it's rules in (i'm guessing that is the issue)
21:44:55 <xgerman> yep, hence my comment for a sane plugin model
21:45:02 <armax> amotoki: can you file a release note? I’ll make sure we include it in rc2
21:45:05 <xgerman> hinting at a bigger neutron problem
21:45:13 <amotoki> armax: sure
21:45:20 <armax> amotoki: thanks
21:45:53 <armax> I actually wondering why the metering agent needs to fiddle with iptables
21:46:06 <armax> but that tells the amount of knowledge that I have on the metering piece
21:46:10 <haleyb> armax: packet/byte counts
21:46:11 <jamespd> armax: it counts traffic via iptables counters.
21:46:16 <ihrachys> xgerman: neither we have any proper plugin point for ovs flows. it's quite a common issue throughout components.
21:46:23 <amotoki> metering agent needs to setup iptables rule to count traffic per iptables granurality
21:46:36 <armax> right, but that’s pretty invasive
21:47:15 <amotoki> yes
21:47:27 <xgerman> ihrachys yep hence my desire for a better way...
21:47:38 <amotoki> we mihgt need to explore a different approach for iptables
21:48:02 <amotoki> It is tricky two components touch iptables....
21:48:19 <haleyb> armax: enovance did most of the work, based on the nova-network path done by myself, so blame it on me :)  but i think Yi might have an easy fix
21:49:03 <armax> haleyb: ack
21:49:08 <armax> ok, moving on
21:49:09 <haleyb> i will watch the bug
21:49:24 <armax> Sam-I-Am couldn’t make the meeting
21:49:32 <armax> so we’ll skip the doc section
21:49:36 <armax> but let me remind folks
21:50:02 <armax> to make sure documentation is not neglected
21:50:24 <armax> we currently have 16 open bugs against docs
21:50:27 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=doc
21:51:16 <armax> let make sure we squash these in time for the release
21:51:27 <armax> we got another two weeks
21:51:42 <kevinbenton> Sukhdev: i think that bug you highlighted is because MOS back-ported an RPC listener fix that wasn't back-ported upstream
21:52:14 <kevinbenton> Sukhdev: i.e. it's mainly a MOS bug if i understand correctly
21:52:35 <Sukhdev> kevinbenton : Thanks for clarifying it for me
21:52:47 <armax> Sukhdev: so we good?
21:53:11 <Sukhdev> kevinbenton : our joint customer is facing this issue - what do you suggest is the best way to address it?
21:53:25 <Sukhdev> armax : yes, looks like now I am in good hands :-);-)
21:53:26 <kevinbenton> Sukhdev: file a bug against mirantis openstack
21:53:39 <armax> Sukhdev: kevinbenton has very good hands
21:53:40 <hichihara> armax: They are devref only. I guess that we have more doc bugs in openstack-manual and api-site
21:53:50 <kevinbenton> Sukhdev: https://launchpad.net/~mos-neutron
21:54:13 <Sukhdev> kevinbenton : Thanks
21:54:16 <armax> hichihara: true
21:54:48 <armax> ok folks, 5 more minutes, if there isn’t anything burning, I’d give you them back
21:54:53 <armax> oh and by the way…it looks like you guys are stuck with me for another cycle
21:55:02 <kevinbenton> :'(
21:55:07 <mlavalle> LOL
21:55:09 <armax> you lost your chance to oust me
21:55:32 <salv-orlando> armax: why would we?
21:55:48 <armax> salv-orlando: dunno, you tell me?
21:56:16 <armax> bye!
21:56:18 <armax> #endmeeting