21:00:32 <armax> #startmeeting networking
21:00:33 <openstack> Meeting started Mon Apr  4 21:00:32 2016 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:37 <openstack> The meeting name has been set to 'networking'
21:00:41 <johnsom> o/
21:00:49 <Sam-I-Am> hi
21:01:05 <sc68cal> o/
21:01:09 <ajmiller> hi
21:01:10 <armax> hi folks
21:01:11 <blogan> hi
21:01:19 <armax> #t
21:01:24 <armax> #topic announcements
21:01:35 <armax> #link https://wiki.openstack.org/wiki/Network/Meetings#Announcements_.2F_Reminders
21:01:45 <armax> We had a new RC last week
21:01:55 <hoangcx> hi
21:01:58 <armax> #link http://releases.openstack.org/mitaka/index.html#mitaka-neutron
21:02:18 <armax> we were hoping to include a few more translations, but we ended up having a handful of minor fixes
21:02:36 <armax> at this point this is 99.999% going to be our Mitaka release
21:02:59 <Sukhdev> Hi - sorry joining late
21:03:03 <mestery> Bad Sukhdev
21:03:06 <mestery> :)
21:03:07 <Swami> hi
21:03:20 <Sukhdev> mestery : thats me :-)
21:03:22 <mestery> lol
21:03:40 * armax waits for a few more people to join the party
21:03:43 <kevinbenton> hi
21:03:50 <haleyb> hi
21:04:00 <john-davidge> hi all
21:04:01 <ZZelle_> Av�!
21:04:08 <Sukhdev> mestery: Oh shit - so, I was not late after all -
21:04:16 <mestery> rofl
21:04:18 <Sukhdev> mestery : every body is waking up late today :-)
21:04:23 <mestery> indeed
21:04:24 <rtheis> o/
21:05:05 <ihrachys> well, some people are about to fall asleep if the meeting does not continue... :)
21:05:47 <armax> ah, ok so we’re all here then
21:05:55 <salv-orlando> ihrachys: are you questioning the authority of our dear PTL
21:05:55 * armax resumes
21:05:59 * salv-orlando readies room 101
21:06:13 <ihrachys> salv-orlando: lol. no I question timezones.
21:06:18 <armax> we had our RC3 last week
21:06:42 <armax> which is going to be our final Mitaka release
21:06:51 <salv-orlando> ihrachys: don't worry in a few billion years the earth will be pretty much still
21:06:55 <armax> so kudos to everyone that made that happen
21:07:12 <armax> despite the difficulties
21:07:18 <armax> and the flying -2s
21:07:23 <dasm> ;)
21:07:38 <armax> we’re in Newton mode for a while
21:07:44 <ihrachys> oh the irony
21:08:01 <armax> so this week I’d like to go quickly over the agenda and focus on the first milestone
21:08:09 <armax> to make sure we’re ready to roll
21:08:22 <armax> ihrachys: irony wasn’t directed at you :P
21:08:23 <Sukhdev> newton neutron repeate few time back to back :-)
21:08:37 <ihrachys> armax: I feel it with my burning skin
21:09:19 <armax> since we’re in Neutron mode, make sure you’re aware to bump your pending specs
21:09:26 <armax> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron-specs,n,z
21:09:28 <armax> if you have any
21:09:52 <armax> and if not please remind, reach out to folks who do and you work with
21:09:57 * HenryG sneaks in late
21:10:09 <armax> HenryG: sorry, you’re too late
21:10:10 <Sukhdev> mestery : HenryG is Bad
21:10:10 <armax> get out
21:10:16 <mestery> He's really bad Sukhdev
21:10:22 <mestery> armax: Now now, be nice.
21:10:26 <mestery> :)
21:10:28 <armax> 10 mins!
21:10:33 <armax> come on, outrageous
21:10:42 <HenryG> The roads are all snowed up!
21:10:52 <armax> yeah right
21:10:53 <salv-orlando> the community expects higher standards from you HenryG
21:11:02 <armax> ok
21:11:12 <armax> the summit is 3 weeks from now
21:11:19 <armax> a few etherpads to be aware
21:11:23 <armax> #link https://etherpad.openstack.org/p/newton-neutron-summit-ideas
21:11:37 <armax> your canvas to draw pretty pictures
21:12:04 <armax> a draft schedule will be announced in the next day or two collecting some of those ideas
21:12:05 <armax> for those that fail to meet the timebox for the summit
21:13:13 <armax> feel free to file RFE’s
21:13:13 <armax> for those of you who are interested in cross-project initiatives
21:13:13 <armax> check out
21:13:13 <armax> #link https://etherpad.openstack.org/p/newton-cross-project-sessions
21:13:13 <armax> for those of you who have Nova amongst the projects you care about
21:13:13 <armax> check out
21:13:13 <armax> #link v
21:13:13 <Sukhdev> armax : there is a broader Ironic/neutron session there -
21:13:13 <armax> #undo
21:13:13 <armax> #link https://etherpad.openstack.org/p/newton-nova-priorities-tracking
21:13:14 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xa7ed710>
21:13:26 <armax> as for Nova in particular
21:13:47 <armax> right now the Nova team is in backlog mode
21:13:49 <Sukhdev> armax : however, I have proposed a focused session for VLAN aware servers (VMS + BMS) in neutron side - not to confuse them
21:13:57 <armax> meaning they are only vetting stuff that fell the Mitaka wagon
21:14:06 <armax> Sukhdev: ack
21:16:05 <armax> so Mitaka approved specs are repurposed from now until the Summit
21:16:05 <armax> for new Nova specs, they will be reviewed after the summit
21:16:05 <armax> deadlines for the Nova release cycle will be announced after the summit
21:16:05 <armax> so if you do have cross-projects issues that affect both Nova and Neutron
21:16:05 <armax> be aware
21:16:05 <armax> of these points
21:16:05 * carl_baldwin is now aware
21:16:05 <armax> let’s move quickly to bugs and then we go back to milestone planning
21:16:05 <armax> #topic Bugs
21:16:13 <armax> bugs are already ramping up
21:16:37 <armax> we had about ~100 already filed and only a third got closed
21:16:43 <armax> so far
21:17:30 <armax> though the bug deputy rotation is helpful, we should all try and chip in to make sure a) we merge less buggy code b) we take ownership of issues being filed post-merge
21:18:09 <armax> this week’s deputy is amotoki
21:18:27 <armax> anyone willing to have a go for future weeks?
21:18:41 <blogan> i would
21:18:58 <armax> #action blogan deputy for the week of Apr 11
21:19:13 <carl_baldwin> I'm probably due for another week but would prefer after summit.
21:19:16 <blogan> thanks
21:19:22 <haleyb> i can do post-summit too
21:19:43 <armax> blogan, carl_baldwin, haleyb: thanks
21:19:45 <armax> noted
21:19:59 <armax> looking at the state of our CI
21:20:20 <armax> things are ok-ish in the gate, we had a temporary lapse of a reason last Friday
21:20:29 * john-davidge would also like to bug-deputy after the summit
21:20:33 <armax> but overall the success rate is >98%
21:20:43 <armax> john-davidge: ack
21:20:46 <ihrachys> armax: time to make some jobs voting? ;)
21:20:50 <armax> I’d invite to you check out grafana regularly
21:21:00 <armax> ihrachys: not so fast
21:21:01 <armax> http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=4&fullscreen
21:21:23 <ihrachys> #sadpanda
21:21:26 <kevinbenton> i find that graph upsetting because it includes patches that themselves cause failures
21:21:40 <sc68cal> ^ this
21:21:49 <armax> kevinbenton: thought that’s true for the check queue
21:21:54 <armax> not for the link I provided above
21:22:00 <armax> for instance this one
21:22:02 <armax> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=5&fullscreen
21:22:15 <kevinbenton> ah, cool
21:22:26 <armax> is failure rate on the check queue for jobs like api, functional and fullstack
21:22:29 <kevinbenton> yeah
21:22:40 <armax> though it’s true that check queue contains self-inflicted errors
21:22:51 <armax> this clearly shows taht functional and fullstack jobs are still unstable
21:22:58 <armax> their failure rates is hovering over the 40% mark
21:23:19 <armax> and knowing that the api job is in the gate queue at it’s <10% failure rate in teh check queue
21:23:22 <kevinbenton> but i don't understand how we can be sure when it includes self-inflicted errors
21:23:34 <HenryG> What about the PG job? Can we make it voting?
21:23:45 <armax> I can only infer there are still pending issues
21:24:03 <armax> HenryG: the PG job is at 30%
21:24:04 <kevinbenton> can we get a periodic of fullstack, functional, and api?
21:24:06 <armax> http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=6&fullscreen
21:24:09 <kevinbenton> against master
21:24:35 <armax> grenade multi is at <10% so sc68cal perhaps we should fire this one up and brace for impact
21:24:45 <sc68cal> :) :) :)
21:24:51 <armax> sc68cal: remind me the link offline please
21:24:53 <ihrachys> amen to that ^ :)
21:24:56 <njohnsto_> +1
21:25:09 <sc68cal> indeed, and on that topic, should we look into replacing single node grenade jobs with the multinode, in the future when it's reliable?
21:25:19 <sc68cal> to keep our total # of jobs reasonable
21:25:28 <ihrachys> sc68cal: singlenode is in integrated gate
21:25:39 <armax> kevinbenton: I don’t see the point, they should be made voting and applied to the gate queue once we’re happy with them
21:26:34 <kevinbenton> armax: how will we know when they're stable enough?
21:26:36 <armax> I know that amuller worked with the rest of the team to ensure functional and fullstack are in line with the other failure rates, but we’re not quite there yet by the looks of things
21:26:46 <armax> they would be comparable with the other gate jobs
21:26:54 <armax> until they are, they are not stable
21:26:56 <ihrachys> there are patches in review that should get fullstack in better shape
21:27:05 <sc68cal> ihrachys: right - but hasn't discussion happened in nova where they're trying to move off singlenode grenade? I'm a bit fuzzy and will have to chat with dansmith again at the summit
21:27:43 <kevinbenton> sort of assumes that they have a similar sensitivity to breaking on a given change
21:27:53 <ihrachys> sc68cal: I *think* that both stay for now. but yeah, if you set the goal, you should work on it in integrated gate jobs, not just dropping the job in neutron.
21:27:59 <armax> kevinbenton it’s a rule of thumb obviously
21:28:20 <armax> if they are all within the same range
21:28:35 <armax> we can assume that a change that breaks full, or api breaks others too
21:28:47 <armax> though some breakages can be specific to a job
21:29:03 <sc68cal> ihrachys: agreed
21:29:07 <armax> I would find hard to believe the massive gap we witness today is due to that
21:29:16 <kevinbenton> i think the API job is a lot less delicate than fullstack for example, since the API doesn't test actual dataplane connectivity or agent stuff
21:29:30 <kevinbenton> but it's better than nothing
21:29:34 <kevinbenton> so nevermind
21:30:22 <armax> let’s move the discussion offline if need be
21:30:32 <armax> if there’s nothing else on bugs I’d like to move to blueprints
21:31:17 <armax> ol
21:31:19 <armax> ok
21:31:25 <armax> #topic Blueprints
21:31:31 <armax> #link https://launchpad.net/neutron/+milestone/newton-1
21:31:59 <armax> this is the current workload for Newton Neutron
21:32:11 <armax> or Newtron for short
21:32:56 <armax> right now we have 13 blueprints targeted
21:33:13 <armax> blueprint fwaas-api-2.0
21:33:25 <armax> #link v
21:33:27 <armax> damn it
21:33:29 <armax> #undo
21:33:29 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xa3f8e90>
21:33:32 <armax> #link https://blueprints.launchpad.net/neutron/+spec/fwaas-api-2.0
21:33:32 <sc68cal> uh oh
21:33:42 * sc68cal hides
21:33:45 <armax> sc68cal, xgerman
21:33:55 <armax> so, care to give an update?
21:34:02 <armax> the spec merged
21:34:18 <armax> it needs to be reproposed
21:34:38 <armax> from here
21:34:41 <armax> #link v
21:34:44 <armax> oh come on
21:34:46 <armax> #undo
21:34:47 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xb3fee90>
21:34:49 <armax> #link https://github.com/openstack/neutron-specs/tree/master/specs/backlog/mitaka
21:34:50 <johnsom> hahaha
21:35:02 <armax> to
21:35:08 * armax is careful this time
21:35:08 <Sukhdev> armax needs a cup of coffee
21:35:10 <armax> #link https://github.com/openstack/neutron-specs/tree/master/specs/newton
21:35:21 <armax> Sukhdev: no, I need a new keyboard
21:35:30 <sc68cal> OK, we'll do the papework and reach out to coordinate.
21:35:45 <sc68cal> tl;dr is resource constraints hit hard and the work is ongoing
21:35:51 <armax> sc68cal: I’d argue it should be the other way around
21:36:09 <sc68cal> armax: ok sounds good, sorry
21:36:11 <armax> sc68cal: I mean, what’s the latest in terms of code development?
21:36:23 <armax> sc68cal: this is clearly more than a two man job
21:36:23 <sc68cal> little to report ;(
21:37:00 <sc68cal> armax: agreed - but that's the state of things as it is.
21:37:07 <armax> sc68cal: so if I go to https://review.openstack.org/#/q/status:open+project:openstack/neutron-fwaas
21:37:17 <armax> I see this
21:37:21 <armax> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron-fwaas+branch:master+topic:fwaas_v2_api
21:37:56 <armax> you guys plan to resume work or should this be handed over to someone else interested?
21:38:14 <sc68cal> good question. I do not have an answer at the present moment
21:38:27 <armax> sc68cal: ok, let’s aim to find the answer by end of the week?
21:38:44 <armax> as of today I see three options
21:39:00 <armax> a) you continue working on this; b) someone else take over; c) we scrap this for good
21:39:09 <armax> have I missed an option?
21:39:21 <sc68cal> no that's it in a nutshell
21:39:32 <sc68cal> does anyone actually *care* about fwaas. At all
21:39:33 <armax> sc68cal: ok, let’s touch base later in the week
21:39:51 <sc68cal> plenty of people love doing API design but boy does the crowd shrink when it comes time to do the hard part
21:39:52 <armax> and we’ll touch on this point too
21:40:14 <njohnsto_> sc68cal: I and willing to help, but I need you to tell me what part to work on.
21:40:16 <armax> sc68cal: we should become like IEEE
21:40:29 <sc68cal> armax: we aren't?! ;)
21:40:41 <armax> ok, moving on for now :)
21:40:45 <armax> #link https://blueprints.launchpad.net/neutron/+spec/routed-networks
21:41:10 <armax> carl_baldwin, kevinbenton: I think this is somewhat in good shape though we perhaps have to shuffle some positions?
21:41:28 <carl_baldwin> Hi
21:41:37 <carl_baldwin> shuffle some positions?
21:41:38 <armax> spec hasn’t merged yet btw
21:41:40 <armax> https://review.openstack.org/#/c/225384/
21:41:53 <armax> I see kevinbenton as the approver, and you as assignee
21:42:03 <armax> I don’t think that’s accurate any longer, or is it?
21:42:42 <armax> me hears crickets
21:42:47 <carl_baldwin> I think it is reasonably accurate unless Kevin is no longer going to be approver.
21:42:59 <kevinbenton> yeah, i'm still planning on reviewing the patches
21:43:01 <carl_baldwin> armax: That was me hitting the backspace key because I can't type.
21:43:17 <carl_baldwin> I'm still the primary assignee.
21:43:29 <armax> carl_baldwin: any reason why
21:43:31 <armax> #link https://review.openstack.org/#/q/status:open+topic:bp/routed-networks
21:43:37 <armax> hasn’t hit the launcpad dashboard
21:43:52 <armax> ah no never mind
21:43:59 <carl_baldwin> Not sure, is that supposed to be automatic?
21:44:08 <armax> carl_baldwin: no, it’s fine it’s me who’s blind
21:44:21 <armax> kevinbenton: do you have review bandwidth?
21:44:30 <carl_baldwin> armax: :)
21:44:30 <armax> I know blogan has also express an interest
21:44:42 <kevinbenton> if you want you can change it to blogan
21:44:49 <armax> I don’t want to
21:44:51 <armax> I am asking you
21:44:51 <kevinbenton> i will still review the patches
21:45:02 <kevinbenton> but it might make sense if blogan has more time to dedicate specifically to it
21:45:03 <armax> I am a puppet
21:45:05 <carl_baldwin> blogan was just talking to me about contributing to part of the development.
21:45:12 <armax> I do what I am told
21:45:16 <blogan> yes to all lol
21:45:22 <carl_baldwin> I think we should leave it as is for now.
21:45:25 <blogan> ill do whatever is asked, i too am a puppet
21:45:31 <ski2> carl_baldwin: armax we actually have decent resources to work on this effort
21:45:35 <carl_baldwin> kevinbenton can raise a flag if it is becoming too much.
21:45:44 <carl_baldwin> ... and I'll try to find other cores to pitch in.
21:45:45 <armax> ok, but then it’s kevinbenton’s head on a stake if this fails
21:45:54 <armax> kevinbenton: you sure?
21:45:55 <armax> :)
21:46:02 <armax> well, and carl_baldwin's
21:46:03 <blogan> i can coordinate with kevinbenton
21:46:12 <carl_baldwin> ski2: Come to our meeting on Tuesday mornings.
21:46:22 <ski2> carl_baldwin: will do
21:46:27 <armax> ski2: qualify yourself, please? Not sure I recognize the handle
21:46:33 <carl_baldwin> I can also review patches submitted by others and I intend to.
21:46:36 * kevinbenton hates that meeting time
21:47:00 <blogan> kevinbenton: ill buy you a 5 hour energy
21:47:00 <ski2> brian stajkowski, manager of osic neutron development team here at rackspace
21:47:08 <ski2> armax: basically working with blogan
21:47:21 <armax> ski2: nice, ok I recognize the name, welcome!
21:47:32 <ski2> ty ty
21:47:56 <armax> ok, so carl_baldwin, kevinbenton we have this under control then
21:47:57 <armax> moving on
21:48:00 <mlavalle> armax: I am also helping with routed networks
21:48:08 <armax> mlavalle: yup
21:48:09 <armax> mlavalle: good lad
21:48:14 <armax> #link https://blueprints.launchpad.net/neutron/+spec/multi-l3-backends
21:48:36 <armax> kevinbenton and armax are on the spotlight here
21:48:43 <kevinbenton> i've been working on reproposing the spec to newton
21:48:49 <armax> kevinbenton: sweet
21:49:02 <armax> kevinbenton: I am still happy to support you as much as you need to
21:49:17 <armax> kevinbenton: just hit me with some new patchsets and/or code reviews and I am happy to -2
21:49:23 <armax> err, -1
21:49:24 <kevinbenton> sgtm
21:49:26 <armax> err, +2
21:49:33 <armax> err, blocking -2
21:49:37 <armax> oh well never mind
21:50:02 <armax> moving on
21:50:07 <armax> but before we do
21:50:16 <armax> anyone interested to join the l3 flavor party?
21:50:26 <armax> no? ok
21:50:36 <armax> #link https://blueprints.launchpad.net/neutron/+spec/push-notifications
21:51:14 <kevinbenton> this being blocked by OVO is actually the biggest hurdle right now
21:51:18 <armax> kevinbenton, this has yet to find an approver, though this struggled to reach consensus last cycle
21:51:33 <ihrachys> I can be an approver
21:51:53 <ihrachys> I hope it won't take long to get pieces of it unblocked
21:52:00 <armax> kevinbenton: we should then coordinate on a plan of action
21:52:38 <armax> ihrachys: thanks for volunteering
21:52:47 <kevinbenton> the dhcp agent currently receives payloads
21:52:48 <armax> let
21:52:53 <kevinbenton> and doesn't depend on OVO
21:53:01 <kevinbenton> so i think i will use it as a proof of concept
21:53:09 <armax> let’s make sure we get the spec in a good shape too
21:53:17 <armax> kevinbenton: that sounds reasonable
21:53:37 <ihrachys> not sure why dhcp agent is different, but I will need to read the spec first.
21:53:53 <kevinbenton> ihrachys: dhcp agent already receives a push notification of sorts
21:53:59 <kevinbenton> ihrachys: so it's exposed to a race condition
21:54:09 <ihrachys> ok, you talk about race for now. ok.
21:54:10 <armax> kevinbenton: of anyone who reviewed the spec, do you think of anyone who could help code-wise?
21:54:48 <kevinbenton> so there won't be a significant amount of code from what i can tell
21:54:48 <armax> I suppose not
21:54:55 <armax> ok, cool
21:54:57 <armax> moving on
21:55:00 <armax> #link https://blueprints.launchpad.net/neutron/+spec/vlan-aware-vms
21:55:11 <armax> rossella_s: udere?
21:55:35 <carl_baldwin> I looked at this one a little bit late last week.  It appears to me luke warm.
21:55:41 <carl_baldwin> ... at best.
21:55:59 <carl_baldwin> I sent rossella_s a note about it.
21:56:12 <carl_baldwin> She replied that bence may not have time to work on it.
21:56:19 <armax> carl_baldwin: ok, keep in the loop too if you like
21:56:37 * armax is shocked
21:56:52 <carl_baldwin> I don't have much bandwidth to devote to it but I'll get involved as much as I can.
21:56:58 <carl_baldwin> It'd be nice to wrap it up finally.
21:57:03 <Sukhdev> can we find a new owner for this?
21:57:13 <armax> Sukhdev: I think we should
21:57:19 <carl_baldwin> ++
21:57:26 <Sukhdev> Ironic folks really need this -
21:57:30 <armax> though beagles is the owner of some patches
21:57:50 <Sukhdev> there is lots of work going on in Ironic on this - and I am holding them off pending this BP
21:58:10 <armax> Sukhdev: ack
21:58:21 <kevinbenton> we may have to detach the OVS implementation from teh API
21:58:39 <kevinbenton> i think we are all in agreement generally on the API at this point
21:58:42 <Sukhdev> kevinbenton : that is a good idea
21:58:46 <kevinbenton> OVN has an implementation ready
21:58:46 <armax> kevinbenton: that was always my goal
21:59:11 <armax> kevinbenton: though I either didn’t advertise it loud enough or fell on deaf ears
21:59:39 <kevinbenton> because i think it should be relatively easy for a contributor to implement the API
21:59:40 <armax> ok, we’ll continue from here next week
21:59:52 <armax> we have those patches already in the gerrit queue
21:59:56 <armax> btw
21:59:58 <kevinbenton> finding someone with the expertise to gut the OVS ref implementation to do this will be the hard part
21:59:59 <armax> https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/vlan-aware-vms
22:00:01 <armax> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/vlan-aware-vms
22:00:29 <carl_baldwin> kevinbenton: ++  Let's do that.
22:00:34 <ihrachys> 00:00
22:00:38 <ihrachys> (my time)
22:00:44 <carl_baldwin> ... split them and work on finding someone for the OVS.
22:00:46 <armax> #endmeeting