21:00:54 <armax> #startmeeting networking
21:00:54 <openstack> Meeting started Mon Apr 18 21:00:54 2016 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:54 <mestery> armax: Just tired. So very, very tired.
21:00:54 <dasm> armax: are you trying to invite everyone for a coffee in Austin?
21:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:56 <blogan> hello
21:00:57 <openstack> The meeting name has been set to 'networking'
21:01:00 <pmath> hey mlavalle!
21:01:11 <hichihara> hi
21:01:15 <yamahata> hello
21:01:15 <yamamoto> hi
21:01:15 <HenryG> o/
21:01:16 <armax> thanks everybody for joining this meeting
21:01:17 <annp> hello
21:01:21 <Sukhdev> o/
21:01:23 <mestery> armax: yw
21:01:25 <mestery> :)
21:01:28 <Sam-I-Am> y helo
21:01:28 <njohnston> o/
21:01:30 <armax> this is the week ahead of the summit and I know that many of view are superbusy
21:01:31 <johnsom> It's getting warm here, so inverse hibernation
21:01:34 <ihrachys> o/
21:01:46 <armax> johnsom: I am having this meeting with my speedo on
21:01:51 * armax tmi
21:01:58 <Sam-I-Am> eh
21:01:59 <johnsom> Things you can't unsee
21:02:01 * Sam-I-Am leaves channel
21:02:11 <Sam-I-Am> is this a dev brothel or a meeting?
21:02:14 <armax> that’s my strategy to keep the meeting short!
21:02:23 <salv-orlando> aloha
21:02:27 <armax> I guess it’s working
21:02:29 <armax> anyhoo
21:02:46 <armax> #link https://wiki.openstack.org/wiki/Network/Meetings
21:02:57 <armax> #topic Announcements
21:03:04 <mestery> armax: TMI!
21:03:12 <armax> some of you must be aware already
21:03:21 <armax> the schedule for the neutron sessions is available
21:03:24 <armax> #link v
21:03:27 <armax> #undo
21:03:29 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x8b22450>
21:03:42 <armax> for those you may wonder, yes, I haven’t got a new keyboard yet
21:03:45 <armax> #link https://www.openstack.org/summit/austin-2016/summit-schedule/global-search?t=Neutron%3A
21:04:25 <armax> so please do make sure you spot glaring errors about conflicts etc
21:04:53 <armax> if you are a session chair or not, come and talk to me if you want to get any update reflected
21:05:02 <dasm> Wed and Thu in the same spot. neat
21:05:17 <Sam-I-Am> who is providing the beverages?
21:05:24 <armax> There are more sessions that are related to Neutron
21:05:30 <armax> that link doesn’t show them all
21:05:49 <armax> for instance, on Tuesday, there are a bunch of cross project ones
21:05:57 <armax> like the one Sukhdev promoted
21:06:17 <armax> and for instance the one we’re having in the Nova’s time on Wed morning
21:06:30 <Sukhdev> yes - please look for Ironic-neutron session at 4:40pm on Tuesday
21:06:35 <armax> so be on the lookout
21:07:13 <anteaya> #info searching with the schedule app: http://lists.openstack.org/pipermail/openstack-dev/2016-April/091186.html
21:07:15 <mlavalle> armax: the nova-neutron joint meeting is Wednesday 11:00 - 11:40, Hilton hotel
21:07:32 <armax> anteaya, mlavalle thanks
21:07:37 <anteaya> the magicial colon is important when searching with the schedule app
21:07:48 <Sukhdev> armax : Can I take a moment to make the annocement about the Ironic-neutron session?
21:07:59 <armax> Sukhdev: didn’t you take it already?
21:08:11 <Sukhdev> ha ha -
21:08:16 <armax> Sukhdev: I can’t stop you, now can I?
21:08:25 <Sukhdev> wanted to share an etherpad
21:08:30 <Sukhdev> #link: https://etherpad.openstack.org/p/newton-baremetal-networking
21:08:36 <armax> Sukhdev: you got my permission
21:08:48 <Sukhdev> We need some critical mass from neturon side to attend this session
21:09:18 <Sukhdev> such as armax kevinbenton akihiro rossela
21:09:35 <armax> Sukhdev: are you saying that I am fat?
21:09:44 <jckasper> Sukhdev: link to that session ?
21:10:02 <Sukhdev> #link: https://www.openstack.org/summit/austin-2016/summit-schedule/#day=2016-04-26&summit_types=2&tags=3601
21:10:07 <Sukhdev> look for 4:40pm session
21:10:30 <armax> #link https://www.openstack.org/summit/austin-2016/summit-schedule/events/9491?goback=1
21:10:34 <armax> jckasper: ^
21:10:35 <Sukhdev> Ideally, we want an API to support Multiple VLAN netoworks on a single port
21:10:40 <jckasper> thanks
21:10:53 <armax> Sukhdev: you have it already
21:11:03 <Sukhdev> kind of like Vlan aware VMs - but, we would like a general purpose API from neutron
21:11:18 <Sukhdev> so that it can be used for BM as well
21:11:38 <Sukhdev> Anybody who has interest in this topic, please join that session
21:11:48 <armax> I would add, come prepared
21:12:06 <Sukhdev> yes thanks armax
21:12:18 <Sukhdev> I am done thanks armax
21:12:26 <armax> there’s substantial work done in this arew with http://specs.openstack.org/openstack/neutron-specs/specs/mitaka/vlan-aware-vms.html
21:12:37 <armax> if there are gaps, these should be documented somewhere
21:12:51 <armax> there’s a review out: https://review.openstack.org/#/c/277853/
21:13:36 <armax> and that somewhere should be neutron’s RFEs
21:13:38 <Sukhdev> Yes, that is why we want all the relevant players in one place so that we can identify any overlaps and conflicts and come up with a unified solution/API
21:14:20 <armax> Sukhdev: let me absolutely clear about this
21:15:13 <armax> I would rather give http://specs.openstack.org/openstack/neutron-specs/specs/mitaka/vlan-aware-vms.html time to mature in the context of virtual workloads
21:15:35 <armax> this means that this should be our objective for Newton
21:15:50 <armax> anyhow, we’ve taken more than a moment, let’s move on
21:16:11 <armax> last of the reminders
21:16:31 <armax> we have an entire day to have more focussed discussions on Friday
21:16:35 <armax> the etherpad is
21:16:38 <armax> #link https://etherpad.openstack.org/p/newton-neutron-unplugged-track
21:17:25 <armax> I appreciate that most people end up flying out sometime early in the last day of the summit, but if you are indeed around
21:17:37 <Sam-I-Am> can i bring my acoustic guitar?
21:19:22 <armax> Sam-I-Am: I suppose the silence means, yes you can
21:19:38 <armax> Ok moving on, unless someone else has an announcement to make
21:19:42 <Sam-I-Am> cool. we can sing together.
21:19:54 <anteaya> :)
21:20:26 <kevinbenton> What is the format of the sessions?
21:20:37 <kevinbenton> On Wed and Thursday
21:20:40 <kevinbenton> Big room?
21:20:53 <dougwig> last time the room was not nearly big enough.
21:20:56 <armax> kevinbenton: big rooms
21:21:23 <Sam-I-Am> neutron sessions make me feel like a sardine
21:21:29 <Sam-I-Am> and most of those people dont provide useful input
21:21:34 <johnsom> I hope it's one of those "everything is bigger in Texas" moments
21:21:38 <Sam-I-Am> they just exist to complain
21:21:40 <dougwig> i meant the contributor meetup.
21:21:43 <Sam-I-Am> so maybe we need our secret meeting :)
21:21:43 <armax> Sam-I-Am: things are getting better summit after summit
21:21:57 <xgerman> *aaS was always meeting somewhere else
21:21:58 <Sam-I-Am> i know of some back alleys in austin
21:21:58 <blogan> the weather is bigger in texas atm
21:22:15 <armax> #topic Blueprints
21:22:22 <Sukhdev> Sam-I-Am is that a good thing or bad :-)
21:22:30 <salv-orlando> Sam-I-Am: usually everyone gets into this community with a complaint ;)
21:22:38 <xgerman> as long as they server beer in those alleys
21:22:52 <salv-orlando> that's a way of saying "hello I am here to help, because everything is a mess"
21:22:54 <armax> last two meetings ihrachys and I went through the current workload to see if assignee/approver were still valid
21:23:18 <armax> we went through the entire list
21:23:26 <Sam-I-Am> xgerman: its austin, so yeah... except you'll have to wait 2 hours in line
21:24:09 <armax> a few others got kicked out relatively early from mitaka and appear as deferred in this list
21:24:10 <armax> #link https://blueprints.launchpad.net/neutron
21:24:42 <armax> we’re figuring out what to do with those, but if you do know something, please reach out
21:25:14 <armax> one last thing re: blueprints
21:25:41 <armax> I have seen people going on https://launchpad.net/neutron and registering blueprints ignoring the RFE process altogether
21:25:48 <armax> I mark those BP’s as obsolete
21:26:11 <armax> until a while ago I was giving an explaination, but I have lost the will to scold and I simply mark them obsolete
21:26:42 <mestery> armax: Let your iron fist rain down fire on those who ignore the process! :)
21:26:57 <ihrachys> how dare they
21:27:03 <njohnston> What should I do if I see a bug that says '[RFE]' in the title but is not tagged with the 'rfe' tag?  Refer them to the drivers team?
21:27:05 <mestery> Honestly, the fact that people can even do that with Launchpad means that Launchpad is not the right tool
21:27:06 <armax> the https://launchpad.net/neutron landing page has clearly stated  that for submitting blueprints/RFE and defect reports instructions are available at: http://docs.openstack.org/developer/neutron/policies/blueprints.html
21:27:33 <armax> njohnston: when in doubt add the tag, and we’ll clean it up
21:27:41 <njohnston> armax: Thanks, will do
21:27:55 <armax> mestery: we’re working within the constraints of the tool we have
21:28:10 <mestery> armax: Yup, I'm just pulling a salv-orlando and providing insight from the sidelines
21:28:11 <armax> mestery: give me a level and I will lift the world said a genius
21:28:21 <armax> mestery: but I am no genius so I don’t know what else to do
21:28:26 <salv-orlando> besides as the latin said "repetita iuvant"
21:28:59 <mestery> salv-orlando: lol
21:29:04 <njohnston> +1 for lingua latina
21:29:04 <mlavalle> armax: he said lever
21:29:06 <anteaya> armax: wasn't it a lever?
21:29:17 <Sukhdev> whats that ?
21:29:20 <anteaya> I'm all for working it over again with level
21:29:27 <salv-orlando> according to armax it was a level
21:29:35 <anteaya> much better
21:29:46 <armax> #link http://www.brainyquote.com/quotes/quotes/a/archimedes101761.html
21:29:50 <armax> no it’s lever
21:30:00 <mestery> No one is questioning the lever armax :)
21:30:01 <armax> #link http://dictionary.cambridge.org/dictionary/english/lever
21:30:02 <anteaya> I think yours is better
21:30:17 <armax> not sure I understand the source of confusion
21:30:23 <anteaya> ha ha ha
21:30:24 <armax> the quote or the object?
21:30:30 <salv-orlando> give me a level and I will beat the monster at the end, said the genius of arcade videogames
21:30:39 <ihrachys> :D
21:30:43 <njohnston> I've always heard it as 'give me a fulcrum', but I think that is just because fulcrum sounds cooler.
21:30:46 <Sukhdev> :-)
21:30:53 <armax> anyhoo we’re clearly digressing
21:31:00 * mestery can tell we're all ready for summit
21:31:00 <anteaya> njohnston: fulcrum inplies lever
21:31:11 <Sam-I-Am> this is how you bike shed even regular words
21:31:16 <anteaya> njohnston: it isn't a fulcrum without a lever
21:31:16 <Sam-I-Am> good jorb, neutron
21:31:35 <salv-orlando> njohnston: yeah like the MIG-29 fulctrum (ok I will stop it now)
21:31:35 <Sukhdev> Looks like this crowd is ready for a beer
21:31:36 <armax> I appreciate people’s effort to keep the conversation alive, btw
21:31:45 <dougwig> the shed is a rainbow
21:31:48 <armax> it means people are reading!
21:31:54 <armax> #topic Bugs
21:31:55 <Sam-I-Am> the shed is black from all the colors.
21:31:56 <salv-orlando> dougwig: with many levels
21:31:58 <mestery> armax: Your words are like poetry
21:31:58 <Sam-I-Am> paint it black
21:32:12 <armax> mestery: you’re welcome
21:32:16 <anteaya> Sam-I-Am: ha ha ha
21:32:27 * anteaya changes the playlist
21:32:46 <armax> ok, I think last week deputy was reedip
21:32:49 <armax> this week is blogan
21:32:56 <blogan> armax: nope last week was me
21:33:10 <armax> sorry
21:33:12 <armax> you’re right
21:33:29 <dougwig> sounds like blogan is doing it again!
21:33:32 <armax> I misread the last entry in the table
21:33:40 <blogan> sounds like dougwig just volunteered himself!
21:33:44 <armax> so we need a volunteer for this week
21:33:47 <armax> and possibly next week
21:33:59 <armax> any taker?
21:34:08 <mestery> Note for any potential takes: These are the light weeks
21:34:11 <dougwig> i'll do this week.
21:34:15 <mestery> dougwig: lol
21:34:15 <mestery> :)
21:34:17 <blogan> i could have sworn someone volunteered last week for this week
21:34:18 <armax> the job comes with a signed picture from me
21:34:21 <armax> as a gift
21:34:48 <johnsom> I remember someone taking this week as well
21:34:57 <armax> #action dougwig deputy for the week of Apr 18
21:35:00 * ihrachys already have the photo to pick up
21:35:13 <dougwig> no more amazon gift cards?
21:35:13 <armax> johnsom: both haleyb and john-davidge offered
21:35:37 <armax> ihrachys: since you were one of the earliest you also got a frame with it
21:35:51 <armax> dougwig: those if for code contributions
21:35:58 <armax> s/if/are
21:36:01 <dougwig> armax: sigh.
21:36:06 <blogan> armax: do you think i could get a strand of your hair?
21:36:09 <njohnston> "the job comes with a personally signed email containing my LinkedIn profile, with the heartfelt sentiments 'I'd like to add you to my professional network' engraved."
21:36:19 <armax> blogan: what hair? like I had anything left
21:36:36 <boden> who needs hair -- waste of time!
21:36:38 <blogan> armax: exactly, its even more valuable
21:36:40 <johnsom> Creepiest neutron meeting ever....
21:36:50 <armax> blogan: ok, let me grow some I just shaved last week
21:36:53 <armax> mestery: tmi?
21:37:01 <blogan> lol
21:37:26 <armax> ok, before moving on
21:37:31 <armax> let’s look at our dear grafana
21:37:47 <armax> which reminds me that last week we had a bump in our api job strategy
21:38:16 <armax> we put it back to non-voting temporarily to switch to using tempest-plugin
21:38:23 <armax> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate
21:39:02 <kevinbenton> I saw an interesting failure. Default security group creation hit a db deadlock. Then the retry mechanism kicked in as expected
21:39:13 <armax> kevinbenton: is there a bug report?
21:39:24 <kevinbenton> And every attempt after failed with a "no such save point error"
21:39:27 <armax> kevinbenton: did that show up in the gate or check queue?
21:39:27 <kevinbenton> Not yet
21:39:37 <kevinbenton> Showed up in a rally run
21:39:57 <armax> kevinbenton: ack
21:40:00 <armax> we should also monitor
21:40:02 <armax> #link http://status.openstack.org//elastic-recheck/
21:40:13 <armax> and
21:40:14 <armax> #link http://status.openstack.org//elastic-recheck/data/uncategorized.html
21:40:27 <armax> in particular to see if there are signatures for new failure modes
21:40:48 * njohnston bookmarks
21:41:07 <anteaya> armax: thank you
21:41:41 <anteaya> summit would be a great place for those folks looking to learn how to catagorize those uncatagorized failures
21:41:42 <armax> for some reason, something is unsettled with fullstack
21:41:58 <armax> http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=5&fullscreen
21:42:01 <armax> #link v
21:42:04 <armax> #undo
21:42:05 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x9a1ebd0>
21:42:07 <armax> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=5&fullscreen
21:42:31 <armax> then there’s this very worrying upward trend with grenade multi
21:42:34 <armax> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=6&fullscreen
21:42:41 <armax> has anyone looked into it?
21:43:09 <kevinbenton> Is that check or gate?
21:43:12 <armax> multi with dvr
21:43:15 <armax> that’s check
21:43:24 <njohnston> armax: Looks like fullstack jinked upwards yesterday, in a couple of increments over the day: http://grafana.openstack.org/dashboard/db/neutron-failure-rate?from=1460865600000&to=1460951999999
21:43:37 <ihrachys> I did not know about grenade one. I will take a look tomorrow.
21:45:02 <armax> ihrachys: to be fair
21:45:04 <armax> ihrachys: https://review.openstack.org/#/c/299844/
21:45:15 <armax> this got merged last nite
21:45:25 <armax> so it may be a simple reflection of more data points
21:45:58 <ihrachys> ack. if no one gets to it till my morning, I will take a look.
21:46:16 <ihrachys> ... and if you do, please drop something my way so that I am aware.
21:46:34 <armax> ihrachys: no sorry
21:46:38 <armax> I am getting confused
21:46:55 <armax> ihrachys: I take back what I said, the grenade multi that’s spiking up is not multi
21:48:35 <ihrachys> armax: how come
21:49:02 <armax> ihrachys: I mean is not dvr,
21:49:24 * armax is having a hard time tracking all the multiple ice cream flavors we have
21:49:53 <ihrachys> ok. what I see on the graph is: grenade multinode is below usual multinode jobs. so it probably just reflects some issues with the latter.
21:50:13 <ihrachys> since it runs less tests, it fails less frequently than -full
21:51:26 <armax> ihrachys: let’s take this offline
21:51:38 <armax> but we definitely want to understand what’s going on before we go ahead with
21:51:40 <armax> #link https://review.openstack.org/#/c/299843/
21:51:49 <armax> sc68cal: ^
21:52:18 <armax> ok, moving on
21:52:29 <armax> #topic Docs
21:52:39 <Sam-I-Am> moo.
21:52:39 <armax> Sam-I-Am: do you have anything for us?
21:53:03 <armax> I have a couple of docs patches I am waiting to review
21:53:18 <Sam-I-Am> nothing in particular. i've been busy working on a summit pres. trying to work through updating the scenarios for mitaka, but its been hard to find time.
21:53:25 <armax> nudge to carl_baldwin, tidwellr
21:53:39 <Sam-I-Am> i dropped working on the install guide for N, so hopefully i'll have more time to focus on the networking guide (including reviews)
21:53:55 <carl_baldwin> armax: ack.  :)
21:53:59 <Sam-I-Am> i've seen a few reviews. just cant focus on them right now.
21:54:07 <armax> Sam-I-Am: do you have an update on the api docs progress?
21:54:10 <Sam-I-Am> and apparently we dont have a lot of other people reviewing
21:54:17 <Sam-I-Am> no, i dont. that'd be an anne gentle thing.
21:55:09 <anteaya> this was the last I saw on that
21:55:12 <anteaya> #link http://lists.openstack.org/pipermail/openstack-dev/2016-April/091157.html
21:55:43 <Sam-I-Am> thats about where i'm at now
21:55:49 <armax> Sam-I-Am: ack
21:55:51 <njohnston> I had an interesting conversation with agentle earlier this week.  I noticed that while create network/update network API calls get extra QoS-related arguments when the QoS plugin is installed, those are not reflected in the API guide on the page that talks about those API calls.
21:55:51 <armax> Sam-I-Am: thanks
21:56:04 <Sam-I-Am> i dont follow api much, just too much to track
21:56:27 <Sam-I-Am> we probably should have someone here who tracks api docs, patches, etc.
21:56:34 <njohnston> I asked if the extra arguments should be grouped with the API calls or with QoS, and she said to add an additional bit plus example under the generic case for the API calls.  Just FYI for all.
21:56:34 <Sam-I-Am> one person can't do all the docs stuff
21:56:39 <anteaya> sorry meant to link http://lists.openstack.org/pipermail/openstack-dev/2016-March/090659.html
21:56:43 <anteaya> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/090659.html
21:57:46 <armax> Sam-I-Am: I can’t say I disagree
21:58:10 <armax> ok, 2 mins left
21:58:36 <armax> before we leave I wanted to share this link with you folks
21:58:40 <armax> #link https://www.youtube.com/watch?v=M4cDyM2s2bc&feature=youtu.be
21:58:50 <armax> OpenStack Design Summit - Tips for session moderatorsOpen
21:59:17 <armax> whether or not you’re a session moderator at this summit, it’s good to keep those notes in mind
21:59:27 <Sam-I-Am> arrive drunk
21:59:31 <Sam-I-Am> thats it
21:59:32 <rossella_s> thanks armax
21:59:34 <armax> and help for a smooth summit
21:59:42 <njohnston> thanks armax
21:59:44 <armax> bye folks
21:59:46 <armax> #endmeeting