14:02:38 <HenryG> #startmeeting networking
14:02:39 <openstack> Meeting started Tue May 10 14:02:38 2016 UTC and is due to finish in 60 minutes. The chair is HenryG. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:39 <hoangcx> Hi
14:02:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:43 <openstack> The meeting name has been set to 'networking'
14:02:47 <mestery> o/
14:02:50 <njohnston> o/
14:02:50 <rtheis> o/
14:03:02 <salv-orlando> aloha
14:03:13 <korzen__> hello
14:03:21 <carl_baldwin> Hi
14:03:24 <HenryG> Ihar is on vacation this week, and our intrepid PTL is still asleep as usual for this time. So I am chairing today.
14:03:34 <andreas_s> hi
14:03:49 <HenryG> #topic Announcements
14:04:11 <HenryG> Summit session reports have been posted to the mailing list.
14:04:29 <HenryG> A list of links is here: https://wiki.openstack.org/wiki/Network/Meetings#Announcements_.2F_Reminders
14:04:58 <HenryG> For the Neutron stadium evolution there is a spec under review ...
14:05:06 <HenryG> #link https://review.openstack.org/312199
14:05:20 <Sam-I-Am> its not controversial at all :)
14:05:43 <blogan> everyone is slowly coming around to it :)
14:05:59 <mestery> Kudos to armax for his work on that patch
14:06:03 <obondarev_> o/
14:06:12 <Sam-I-Am> yeah, its tough to write controversial stuff
14:06:17 <Sam-I-Am> ask me how i know :)
14:06:27 <amuller> we should deprecate the LB agent
14:06:37 <Sam-I-Am> amuller: yeah, and l3 ha.
14:06:46 <amotoki> what does LB mean?
14:06:47 <Sam-I-Am> dvr+ovs all the way
14:06:47 <amuller> good idea
14:06:53 <amotoki> linux bridge? load balancer?
14:06:55 * Sam-I-Am runs away
14:06:58 <amuller> amotoki: both
14:06:59 <HenryG> LB = load balancer
14:07:07 <njohnston> amuller: At first I read that as "deprecate the layer-eight agent". Now that would be a thing.
14:07:15 <haleyb> Sam-I-Am: i was going to say dvr too :)
14:07:20 <Sam-I-Am> sigh, we're all too fiesty this morning. i havent even had coffee yet.
14:07:30 * regXboi continues chuckling in the background
14:07:56 <HenryG> This is constructive. Let's move on.
14:08:04 <HenryG> #topic Blueprints
14:08:14 <HenryG> #link https://launchpad.net/neutron/+milestone/newton-1
14:08:31 <HenryG> Many on that list will not make N-1 methinks
14:08:43 <HenryG> Newton-1 milestone: http://releases.openstack.org/newton/schedule.html#n-1
14:09:16 <HenryG> Remaining BPs will bump to N-2 after that
14:09:58 <HenryG> I would like to point out one BP/spec that will affect everyone pretty drastically ...
14:10:22 <HenryG> #link https://review.openstack.org/257362
14:10:49 <korzen__> rossella_s, in OVO we are still using the tenant_id
14:11:10 <HenryG> This is the Keystone V3 adoption. It will (probably) rename all tenant_id columns to project_id.
14:11:11 <rossella_s> korzen, we should take care of that
14:11:24 <HenryG> Yes, OVO folks should pay close attention
14:11:50 <Sam-I-Am> HenryG: yeah, tenant needs to go
14:11:55 <Sam-I-Am> it causes confusion in the docs
14:11:57 <korzen> can we postpone the migration till OVO is adopted and do it in online migration?
14:12:19 <HenryG> korzen: Please comment on the spec review
14:12:41 <dasm> korzen: it was one of initial ideas. let's discuss (again) on spec.
14:12:41 <amotoki> API/DB/OVO can migrate to project_id in different timing. OVO allows us to do so :)
14:12:55 <korzen> HenryG, will do
14:12:57 <amotoki> what I am not sure is when we have online migration support. newton?
14:13:16 <HenryG> amotoki: My guess is later
14:13:20 <amotoki> but it should be discussed in the spec.
14:13:43 <korzen> HenryG, in Ocata or P-release
14:13:55 <HenryG> amotoki: We need to stop renaming things in the DB for online migration support
14:14:51 <amotoki> :)
14:15:00 <HenryG> moving on ...
14:15:08 <HenryG> #topic Bugs
14:15:16 * regXboi wakes up
14:15:26 <HenryG> regXboi: but first ...
14:15:38 <HenryG> Who wants to be Bug deputy for this week?
14:16:12 <regXboi> while we wait for volunteers
14:16:32 <regXboi> the good news is that we have 0 critical bugs this week
14:16:48 <dasm> \o/
14:16:52 <regXboi> the bad news is that we have 49 high importance bugs and 117 bugs in the "new" state
14:17:16 <regXboi> so... needs to see about getting some more triage done :(
14:17:48 <amotoki> how many new bugs without tags do we have?
14:18:18 <HenryG> Note: *Everyone* is welcome to pitch in and help with bugs any time.
14:18:20 <regXboi> that's a tough query
14:18:34 <amotoki> just from my curiosity. never mind.
14:18:47 <haleyb> sorry, was asleep, i can volunteer, week is almost half-over, right? :)
14:18:52 <regXboi> we can query for any tags, or all tags, but not *no* tags
14:19:03 <regXboi> HenryG: there we go...
14:19:10 * regXboi passes golden fly swatter to haleyb
14:19:15 <amotoki> one thing to note is that if a bug is tagged someone familiar with an area can triage the bug.
14:19:20 <HenryG> #action haleyb is Bug Deputy for May 09 week
14:19:38 <HenryG> thanks haleyb !
14:20:09 <regXboi> because we don't have any critical bugs, I'm done - let's move on
14:20:12 * regXboi drops mic
14:20:33 <HenryG> Any Bug Deputy volunteers for next week? May 16.
14:21:38 <hichihara> I will do next week
14:21:49 <HenryG> Thanks hichihara !
14:22:07 <HenryG> #action hichihara is bug deputy for week of May 16
14:22:16 <hichihara> :)
14:22:22 <Tung_> Hi all
14:22:37 <HenryG> #topic Gate Stability
14:23:13 <HenryG> A reminder to please keep an eye on ...
14:23:16 <HenryG> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate
14:23:51 <HenryG> The functional job still needs some love
14:24:11 <HenryG> I do know amuller and jlibosva have been trying
14:24:24 <haleyb> the failure rate in the gate queue did fall-off sometime over night, from 25 to <5%
14:24:29 <amuller> HenryG: jlibosva actually foot the root cause late last night
14:24:32 <jlibosva> yesterday we finally found the root cause now we need to come up with fix
14:24:34 <amuller> found*
14:24:40 <HenryG> Yay!
14:24:58 <rossella_s> great!!
14:25:09 <amotoki> :)
14:25:13 <jlibosva> even though we know what's happening I'm still not able to reproduce locally :(
14:25:46 <rossella_s> jlibosva, can you give us more details or it's a very long story?
14:26:29 <jlibosva> I updated launchpad - the short story is that ovsdb native interface stops responding to periodical echoes sent from ovsdb server
14:26:59 <amuller> jlibosva: can you link the comment you added to the bug? I'm not sure everyone know what bug is responsible for the functional job's failure rate
14:27:11 * jlibosva searches
14:27:17 <jlibosva> https://bugs.launchpad.net/neutron/+bug/1567668/comments/15
14:27:19 <openstack> Launchpad bug 1567668 in neutron "Functional job sometimes hits global 2 hour limit and fails" [High,In progress] - Assigned to Jakub Libosvar (libosvar)
14:27:39 <Sam-I-Am> regXboi: ^
14:27:45 <Sam-I-Am> captain ovs :)
14:27:55 * regXboi looks
14:28:10 <amuller> I'm confident that between otherwiseguy and jlibosva they can resolve the issue
14:28:10 <regXboi> oh lord
14:28:16 <regXboi> turn that probe stuff off
14:28:21 <regXboi> just turn it off
14:28:46 <HenryG> Alright, great work jlibosva. Let's discuss further in the bug and the neutron channel.
14:29:01 <rossella_s> thanks jlibosva
14:29:02 <jlibosva> regXboi: can you please comment on launchpad? I wonder the impacts and don't want to steal precious time of this mtg :)
14:29:45 <HenryG> Other job failure rates need to be addressed ...
14:29:52 <HenryG> http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=7&fullscreen
14:30:42 <HenryG> I have it on my plate to look into the PG job, but I haven't got far with it.
14:31:08 <haleyb> HenryG: I have also seen IP allocation failures recently, don't know if anyone else has
14:32:05 <HenryG> haleyb: might be a good idea to bring up in the L3 meeting?
14:32:09 <regXboi> jlibosva: comments posted
14:32:20 <jlibosva> regXboi: thank you :)
14:32:36 <regXboi> Sam-I-Am: captain ovs????
14:32:41 <HenryG> haleyb: a more focused group of people there perhaps
14:32:47 <Sam-I-Am> regXboi: yeah :)
14:32:57 <haleyb> HenryG: yeah, it doesn't seem agent-specific, i'll keep looking
14:33:15 <HenryG> OK
14:33:26 <HenryG> Any other comments on the gate jobs?
14:33:51 <amotoki> does anyone follow up the status of ovo 1.9.0 issue?
14:34:22 <HenryG> I saw dims and garyk discussing it in the channel earlier
14:35:13 <amotoki> and i saw ajo jumped in.
14:35:16 <HenryG> Something about reverting back to 1.8.0 I think.
14:36:46 <amotoki> at now upper-constraint.txt uses ovo 1.8.0 and the gate works. more investigation is ongoing. will catch up later.
14:36:58 <HenryG> thanks amotoki
14:37:13 <HenryG> moving on
14:37:20 <HenryG> #topic Docs
14:37:30 <Sam-I-Am> hello
14:37:34 <HenryG> Note that the OpenStack docs policies and tooling are evolving.
14:37:43 <HenryG> "Easing contributions to central documentation" by Sam-I-Am:
14:37:48 <HenryG> #link http://lists.openstack.org/pipermail/openstack-dev/2016-May/094390.html
14:38:01 <Sam-I-Am> trying to make your lives better
14:38:25 <HenryG> I think it's awesome. Please give feedback to Sam-I-Am there.
14:38:49 <Sam-I-Am> also discussing how to split help strings into long and short descriptions so the config files can be shorter, but the auto-generated docs longer
14:39:05 <HenryG> Cool
14:39:17 <Sam-I-Am> and api doc discussions are ongoing on the ML
14:39:26 <HenryG> Latest update to "getting API Docs off WADL and into RST":
14:39:32 <HenryG> #link http://lists.openstack.org/pipermail/openstack-dev/2016-May/094472.html
14:39:52 <HenryG> amotoki is going to kick this off for Neutron
14:40:22 <Sam-I-Am> woo. we need updated api docs badly.
14:40:28 <amotoki> once the initial import is merged, I think we need a api-ref sprint to clean up API ref.
14:40:32 <Sam-I-Am> but no one wanted to touch wadl, and i can see why
14:41:08 <HenryG> yup
14:41:27 <HenryG> Also,
14:41:28 <amotoki> IIRC api-site repo review is now frozen.
14:43:03 <HenryG> Also, thanks to Sam-I-Am's efforts, the networking guide is getting more love this cycle. Please contribute where you can.
14:43:23 <Sam-I-Am> yep
14:43:35 <Sam-I-Am> hopefully going to get a lot done in it
14:43:44 <Sam-I-Am> no longer working on the install guide, so that frees up a lot of time
14:45:19 <HenryG> Any other info or questions on docs?
14:45:49 <HenryG> #topic Client Transition
14:46:06 <HenryG> This is more of an awareness notice
14:46:31 <amotoki> there is no update this week. last week are holiday week in Japan and I just returned from the summit.
14:46:53 <amotoki> I will prepare the update from next week.
14:47:01 <amotoki> rtheis: anything?
14:47:39 <rtheis> amotoki: the devref should have the latest status based on summit
14:47:58 <rtheis> I have WIP patch sets started for OSC plugin enablement for python-neutronclient
14:47:59 <HenryG> Please read up and familiarize yourself with the plan. Use "openstack network ..." instead of "neutron ..." with devstack and help to fill in the gaps when you notice them.
14:48:26 <amotoki> rtheis: agree
14:48:29 <njohnston> +1
14:48:46 <rtheis> nothing else at this time
14:49:11 <HenryG> Ping rtheis and amotoki if you want to help or need details.
14:49:22 <amotoki> for all developers, let's use 'openstack network ...' in newton cycle and clarify the gap and let's fill it :)
14:49:49 <Sam-I-Am> isnt it actually 'openstack networking' ?
14:49:59 <dasm> Sam-I-Am: nope. just "network"
14:50:05 <Sam-I-Am> when referring to the service, at least
14:50:14 <rtheis> FYI: there are some existing OSC patches, bp and bugs opened to fill in gaps.
14:50:31 <Sam-I-Am> oh, you're talking about the actual cli commands :)
14:50:39 <HenryG> rtheis: link to launcpad for OSC bugs?
14:50:41 * Sam-I-Am gets more coffee
14:50:49 <rtheis> looking...
14:50:57 <dasm> Sam-I-Am: yep. OSC commands :)
14:52:17 <rtheis> https://bugs.launchpad.net/python-openstackclient/+bug/1545537
14:52:18 <openstack> Launchpad bug 1545537 in python-openstackclient "Enhancements to OS Network CRUD" [Medium,In progress] - Assigned to Reedip (reedip-banerjee)
14:52:31 <amotoki> pending OSC reviews are found at https://etherpad.openstack.org/p/osc-neutron-support
14:53:01 <rtheis> https://bugs.launchpad.net/python-openstackclient/+bug/1578819
14:53:02 <openstack> Launchpad bug 1578819 in python-openstackclient "Add network list filtering options" [Low,Confirmed] - Assigned to Deepti Ramakrishna (dramakri)
14:53:22 <vikram___> rtheis: when subprojects should start CLI transition
14:53:56 <rtheis> vikram____: are you referring to *aaS?
14:54:19 <vikram___> rtheis: networking-sfc and dynamic-routing .. both :)
14:54:25 <amotoki> vikram___: we first need to merge OSC plugin patch from rtheis. once it is merged, we can implement osc plugin for *aas and similar stuffs.
14:54:46 <vikram___> amotoki: so, when we can start ?
14:54:51 <vikram___> amotoki: after N-1
14:55:21 <amotoki> not decided, but i would like to start it around N-1.
14:55:22 <rtheis> amotoki: that is correct..., anything in python-neutronclient with need plugin support first. Things outside python-neutronclient can start now
14:55:46 <vikram___> amotoki, rtheis: got it .. thanks
14:56:05 <HenryG> All right. Four minutes for ...
14:56:07 <rtheis> here are WIP patches: https://review.openstack.org/#/c/309587/, https://review.openstack.org/#/c/309530/ and https://review.openstack.org/#/c/309515/
14:56:19 <HenryG> #topic Open Discussion
14:56:21 <vikram___> rtheis: I will have a look at those
14:56:31 <hichihara> amotoki: This may be what you want about OVO issue https://review.openstack.org/#/c/307938/
14:56:57 <ivc_> Hi all. I got some concerns about the current OVO concurrency model when interacting with the DB layer. I'd like to know if it should be discussed here or should I post it on the openstack-dev ML or somewhere else?
14:58:05 <HenryG> ivc_: ML and #openstack-neutron is good
14:58:10 <amotoki> hichihara: thanks :) I am just reading the logs.
14:58:14 <hichihara> ivc_: +1 to dev-ML
14:58:24 <ivc_> ok. thanks
14:58:26 <amotoki> ivc_: ML sounds better.
14:59:34 <HenryG> #endmeeting