21:00:48 <armax> #startmeeting networking
21:00:49 <openstack> Meeting started Mon May 16 21:00:48 2016 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:52 <openstack> The meeting name has been set to 'networking'
21:00:53 <sc68cal> o/
21:00:58 <njohnsto-> o/
21:01:09 <armax> welcome to this exciting episode of the networking saga
21:01:37 <regXboi> who's got the drumroll?
21:01:47 <armax> regXboi: I thought you did?
21:01:52 <Sukhdev> hello
21:02:00 <regXboi> heh - not me :)
21:02:11 <armax> #announcements
21:02:19 <armax> #topic Announcements
21:02:46 <armax> a reminder that we are well within the N-1 milestone
21:03:02 <armax> a reminder of the schedule
21:03:03 <armax> #link http://releases.openstack.org/newton/schedule.html
21:03:25 <armax> please familiarize yourselves with the deadlines
21:03:40 <armax> especially for those of you who have cross-projets items to deal with
21:04:11 <Swami> hi
21:04:16 <Sukhdev> It is July 4th for N1, right?
21:04:28 <armax> no
21:04:32 <regXboi> uh... no - try memorial day (or 5/30 if you prefer)
21:04:41 <armax> right
21:04:52 * carl_baldwin notices that's two weeks away!
21:05:02 * regXboi is in the same boat
21:05:09 <armax> another calendar worth keeping in mind is the one about mid-cycle sprints
21:05:11 <armax> #link https://wiki.openstack.org/wiki/Sprints
21:05:35 <Sukhdev> wow!! I did not know it was so close - thanks for pointing it our armax
21:05:47 <armax> Sukhdev: np that’s what I am here for!
21:06:28 <Sukhdev> armax : are we going to have any neutron sprint?
21:06:34 <armax> I think HenryG (who may not attend this meeting) is working on flushing out details for a Neutron mid-cycle
21:06:39 <mlavalle> armax: so no neutron mid-cycle scheduler yet?
21:06:50 <mestery> I can confirm HenryG is in fact fleshing those details out
21:07:06 <armax> which is most likely gonna be sometime mid-August
21:07:14 <regXboi> me whistles an air
21:07:47 <armax> stay tuned
21:08:00 <Sukhdev> looks like IBM may be hosting, right mestery ?
21:08:11 <mestery> Sukhdev: That's what we're aiming for :)
21:08:32 <Sukhdev> mestery : I must be mind reader :-)
21:09:43 <armax> since we’re two weeks away from N-1, it wouldn’t be fair if I did not remind the current status of the milestone
21:09:50 <armax> #link https://blueprints.launchpad.net/neutron/newton/+assignments
21:10:35 <armax> or
21:10:37 <armax> #link https://launchpad.net/neutron/+milestone/newton-1
21:11:13 <armax> as you can see virtually 0% of RFE and Blueprints have been implemented, but that’s typical
21:11:34 <armax> I had a question on blueprint https://blueprints.launchpad.net/neutron/+spec/ml2-ovs-qos-with-dscp
21:11:54 <njohnsto-> yes?
21:12:12 <armax> njohnsto-: is the fullstack patch the only one outstanding?
21:13:03 <njohnsto-> Yes, https://review.openstack.org/#/c/288392 is the only one outstanding.  I'll fix that up.
21:13:13 <armax> njohnsto-: ok, thanks
21:13:53 <armax> any other announcements/reminders?
21:14:59 <armax> looks like there aren't
21:15:32 <armax> #topic Bugs
21:16:00 <armax> looks like fullstack and functionals are still untamed beasts
21:16:23 <armax> anyone cares to comment? We also had a couple gate breakages last week
21:16:25 <haleyb> yes, some is due to this, https://bugs.launchpad.net/keystone/+bug/1578866
21:16:27 <openstack> Launchpad bug 1578866 in OpenStack Identity (keystone) "Race condition between token validation and revocation API causes intermittent gate failures." [High,In progress] - Assigned to Lance Bragstad (lbragstad)
21:16:57 <kevinbenton> time to disable and go back to unit tests :)
21:17:19 <amuller> jlibosva is investigating and making progress on the functional job issue
21:17:28 <armax> I just noticed that the integrated dashboard on grafana http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=5&fullscreen broke due to some recent change
21:17:30 <lbragstad> o/ we're (the keystone team) iterating on a fix for ^ now
21:17:34 <amuller> related to the ovsdb probe
21:17:40 * armax is probably to be blamed
21:18:22 <armax> amakarov: shoot
21:18:26 <armax> amuller: shoot
21:18:30 <armax> er sorry
21:18:32 <haleyb> lbragstad: thanks, i do get the bug updates :)
21:19:14 <lbragstad> haleyb cool - we hope to have it resolved soon
21:19:19 <amuller> armax: I was talking about https://bugs.launchpad.net/neutron/+bug/1567668
21:19:20 <openstack> Launchpad bug 1567668 in neutron "Functional job sometimes hits global 2 hour limit and fails" [High,In progress] - Assigned to Jakub Libosvar (libosvar)
21:19:37 <armax> amuller: ack
21:20:48 <armax> as far as Gate configuration goes
21:21:09 <armax> we recently made grenade multi voting and gating
21:21:44 <sc68cal> woo
21:21:49 <armax> we’ll continue on the journey towards improving our multinode coverage
21:21:53 <armax> in the gate
21:22:17 <sc68cal> #link https://etherpad.openstack.org/p/neutron-multinode-jobs-newton
21:22:39 <armax> thanks sc68cal
21:23:24 <amuller> Speaking of testing, I did want to point people's attention and energy towards http://lists.openstack.org/pipermail/openstack-dev/2016-May/094997.html ([openstack-dev] [Neutron][QA] Call to action - Neutron/Tempest API tests dedup). So far we have one volunteer, thank you Zhi Chang, we need a few more :)
21:23:39 <armax> thanks amuller
21:24:54 <armax> haleyb: anything else you’d like to add?
21:25:23 <haleyb> armax: the bugs were pretty light, mostly low priority
21:26:28 <armax> this week’s deputy is hichihara
21:26:36 <hichihara> Yeah :)
21:26:39 <armax> anyone interested in helping out next week?
21:26:51 <armax> to stay on top of the bugs that keep piling up?
21:27:12 <armax> alternatively we can stop merging code, and surely the bug reports will slow down
21:27:34 * armax leaves people to wonder if he’s serious
21:27:37 <sc68cal> +1 full gate freeze
21:27:58 * regXboi is happy to supply the dry ice
21:28:23 * carl_baldwin doesn't think that'll stop the bugs for a while.
21:28:57 <armax> carl_baldwin: there’s a long tail to deal with
21:29:25 <armax> so any volunteer for next week?
21:30:26 <kevinbenton> O/
21:30:26 <carl_baldwin> I could do it.
21:30:36 <armax> carl_baldwin: thanks
21:30:48 <armax> kevinbenton: would you like to have a go the week after?
21:30:56 <kevinbenton> Sure
21:31:00 <armax> thanks folks
21:31:13 <armax> #action carl_baldwin deputy for the week of 23rd
21:31:28 <armax> #action kevinbenton deputy for the week of 30th
21:32:05 <armax> after bugs we typically go to docs etc
21:32:49 <armax> one thought that floated around during the summit was to talk about two special efforts we’re trying to pull together
21:32:58 <armax> one is the client side transition to OSC
21:33:23 <armax> the other one is completing the keystone v3 transition
21:33:47 * sc68cal nodes that lib/neutron forces keystone v3
21:33:49 <sc68cal> *notes
21:33:57 <armax> I wonder if any of you find beneficial touching on these two on a regular basis
21:34:29 <sc68cal> https://github.com/openstack-dev/devstack/blob/master/lib/neutron#L155
21:34:47 <sc68cal> whoops that's for nova
21:35:49 <armax> it looks like we have neither rtheis nor amotoki in the channel
21:36:00 <armax> but I see dasm
21:37:27 <dougwig> the *aas/osc plan seemed a little weird.
21:37:38 <dougwig> i can find amotoki offline, though
21:37:46 <armax> dougwig: what do you mean?
21:38:54 <dougwig> the general discussion was, in python-neutronclient or in the server repos.  being in the server repos makes more sense, but then you pull in all the server deps on install. i was going to suggest that we start having -client repos for individual items, so we can break the monolith and not require pulling in server stuff.
21:40:48 <armax> dougwig: I suppose the argument against having individual client repos for each server side extension is that it’s probably not worth at this point?
21:41:24 <dougwig> for lb/fw/vpn it would seem to be, but maybe that's because i already inherently think they're "different enough", and should only be there optionally if they're installed.
21:43:15 <dougwig> rarely have i been able to cause such silence.
21:43:18 <armax> dougwig: from a user point of view it seems that the localtion of the client extension is not so much of an issue
21:43:36 <armax> dougwig: assumed that everything is accessed through openstacklient
21:44:09 <dougwig> it's more about aligning the responsibility of the code with the team that's making it. but then, i know i've always been on the side of "repos are cheap".
21:44:30 <amuller> dougwig: distro folks feel the pain =p
21:45:19 <armax> dougwig: I think this is a topic that’s gonna self-correct over time
21:46:15 <armax> well if there’s nothing else on docs we can move to
21:46:17 <ivc_> what if we make api discoverable by client? something hateoas'ish?
21:46:20 <armax> #topic Open Discussion
21:48:03 <dougwig> lively meeting this week.
21:48:11 <armax> ivc_: that’s a rather broad statement, but I think client capabilities and how these are implemented are two separate topics
21:48:11 <njohnsto-> yeah, seriously
21:48:50 <armax> probably I have gone past my expiration date as a chair of these
21:49:03 * regXboi wonders if it's just still post austin hangover
21:49:07 <armax> or it’s just one of those where people are heads down working on what they are working
21:49:34 <amuller> dougwig: let's talk about deprecating something really popular
21:49:36 <armax> if that’s the case, then we can all get 10 mins back and continue our errands
21:49:37 <dougwig> we need to bring up ML3 or v3 api or microversioning or something.
21:49:41 <haleyb> We're all multi-tasking waiting for someone to use our nick
21:49:57 <kevinbenton> haleyb: interrupt driven participation
21:50:05 <amuller> dougwig: so when are you deprecating Octavia and creating the new LBaaS thing?
21:50:11 <regXboi> kevinbenton: you mean there's another model?
21:50:25 <kevinbenton> I thought Octavia was being shut down completely?
21:50:29 <dougwig> amuller: i deleted it already. screw the packagers.
21:50:33 <kevinbenton> And it's features rolled into fwaas
21:50:40 <armax> let’s please not spread misinformation
21:51:02 <armax> come on, let’s call it a day
21:51:06 <armax> #endmeeting