14:00:45 <ihrachys> #startmeeting networking
14:00:47 <openstack> Meeting started Tue Jun  7 14:00:45 2016 UTC and is due to finish in 60 minutes.  The chair is ihrachys. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:51 <openstack> The meeting name has been set to 'networking'
14:00:54 <mestery> o/
14:00:55 <njohnston> o/
14:00:55 <dasm> o/
14:00:55 <hichihara> hi
14:00:58 <manjeets> hi
14:01:00 <boden> o/    howdy
14:01:01 <andreas_s> o/
14:01:02 <hoangcx> hi
14:01:02 <HenryG> o/
14:01:02 <blogan> hi
14:01:09 <bcafarel> o/ hi
14:01:09 <haleyb> hi
14:01:15 <john-davidge> o/
14:01:23 <johndperkins> hi
14:01:24 <ajo_> o/
14:01:29 <ihrachys> wow, seems like people long for meetings
14:01:33 <jschwarz> o/
14:01:34 <amotoki__> hi
14:01:36 <psargent> hi
14:01:37 <ihrachys> happy to see all of you :)
14:01:42 <ankur-gupta-f1> \o/
14:01:45 <jlibosva> hi
14:01:47 <amuller> hiho
14:01:55 <korzen> hello
14:01:58 <njohnston> You sraw the crowds, ihrachys.
14:02:03 <njohnston> s/sraw/draw/
14:02:10 <ajo_> :D
14:02:14 * ihrachys digs himself from under all those greetings
14:02:49 <ihrachys> #link https://wiki.openstack.org/wiki/Network/Meetings Agenda
14:02:55 <ihrachys> #topic Announcements
14:03:05 <ihrachys> first thing first. We released Newton-1 yay!
14:03:14 <dasm> \o/
14:03:15 <ihrachys> deliverables can be found at: http://releases.openstack.org/newton/
14:03:44 <ihrachys> afaik nothing really fancy included there, but I guess it's business as usual
14:04:25 <ihrachys> also, in case you haven't noticed, our PTL is on vacation
14:04:34 <ihrachys> it doesn't stop him to stay online though :)
14:04:57 <mestery> He's omniscient ihrachys :)
14:05:07 <ihrachys> finally, thanks to HenryG we have a midcycle meetup in August!
14:05:21 <ihrachys> WARNING: original dates of the event changed
14:05:23 <ihrachys> #link http://lists.openstack.org/pipermail/openstack-dev/2016-May/096255.html
14:05:30 <ihrachys> please make sure you don't book wrong dates!
14:05:44 <ihrachys> and I hope new dates are better for Europeans
14:06:26 <twm2016> o/
14:06:27 <ajo_> HenryG++
14:06:38 <ihrachys> #topic Ongoing discussions
14:07:08 <ihrachys> our glorious PTL had an attempt to change release model for *aas deliverables
14:07:21 <ihrachys> but the attempt failed due to being late in the cycle, and no agreement
14:07:55 <ihrachys> still, Armando strives to revisit the governance structure for neutron deliverables a bit
14:07:55 <ihrachys> #link https://review.openstack.org/#/c/323522/
14:08:10 <ihrachys> please comment, and bring your brushes
14:08:45 <ihrachys> also, I wonder whether amuller got the help he asked for at: http://lists.openstack.org/pipermail/openstack-dev/2016-May/094997.html
14:08:47 <ihrachys> amuller: ?
14:09:01 <amuller> ihrachys: We didn't progress as much as I wanted to
14:09:38 <ihrachys> ok folks, something to consider ^ we can't leave our test lieutenant without soldiers :)
14:09:56 <amuller> I don't like those terms =p
14:10:06 <ihrachys> :) moving on...
14:10:07 <ihrachys> #topic Bugs
14:10:25 <ihrachys> hichihara is the deputy of the previous week, and ajo_ is this wek
14:10:40 <ihrachys> hichihara: would you mind giving a brief update of the prev week?
14:11:03 <hichihara> No. Previous week is Carl or ajo?
14:11:29 <ihrachys> oh. it's actually kevinbenton I think
14:11:48 <ihrachys> as per wiki page at least
14:11:57 <carl_baldwin> Right, I was the week before.
14:12:02 <kevinbenton> ihrachys: so if i was supposed to be last week i messed up the week
14:12:09 <kevinbenton> ihrachys: and i have a backlog to go through :)
14:12:28 <ihrachys> the wiki page is confusing
14:12:31 <ajo_> I also messed up, and I thought mine was next week somehow.. so I have 1 day back log at least (monday), and taking up now
14:12:32 <ajo_> yes
14:12:33 <ihrachys> it states kevinbenton to be the deputy
14:12:43 <ihrachys> carl_baldwin: so you run the prev week? anything worthy?
14:12:48 <ajo_> that wiki page deserves a refactor (may be just two columns: date range, and who)  ?
14:12:54 <carl_baldwin> ihrachys: Mostly routine triaging.
14:12:57 <ihrachys> kevinbenton: nah, that's ok, it seems wiki is wrong.
14:13:12 <carl_baldwin> Saw one gate failure that was resolved by kevinbenton I think.
14:13:23 <ihrachys> ajo_: make sure we don't have bugs missed without attention from either of you
14:13:34 <carl_baldwin> ajo_: +1 to wiki refactor.
14:13:36 <ajo_> ihrachys, ack, we're syncing in private to catch up all of them
14:13:49 <ihrachys> #action ajo_ to refactor wiki bug deputy section
14:13:50 <ajo_> carl_baldwin, ack, handling it as we talk
14:14:01 <reedip> ajo_ +1
14:14:07 <rossella_s> ajo_, thanks! I was having troubles with that too
14:14:08 <hichihara> ajo_: +1
14:14:08 <amotoki__> for bug deputy etherpad might work
14:14:09 <carl_baldwin> Reduce it from O(nm) to O(n)
14:14:25 <ihrachys> ok thanks folks for doing the triaging
14:14:32 <ajo_> who wants to be next, please tell me, I'll add as part of the refactor
14:14:48 <ihrachys> right, we need next volunteers.
14:14:57 <ihrachys> preferrably two next weeks
14:15:14 <ihrachys> June 13-.. and June 20-..
14:15:34 <HenryG> I can do June 13
14:16:13 <ihrachys> thanks HenryG! you already did it twice, it would be great to see someone with just one week served to chime in for June 20..-
14:16:26 <rossella_s> I can take June 27...June 20 doesn't work for me, there's the opnfv summit
14:16:46 <ihrachys> rossella_s: sold! :)
14:17:26 <ajo_> ack, I'll ad you both, we need to cover June 20- if somebody could
14:18:02 <ajo_> btw, I will remove dates from old history, just the ocurrences of people in a nick list with no dates just for reference (to avoid history growing too tall)
14:18:14 <ihrachys> ajo_: ack
14:18:25 <ihrachys> no volunteers? mestery: dasm: ? :)
14:18:27 <rossella_s> ajo_, I like optimization
14:18:38 <ajo_> :D
14:18:40 <ihrachys> haleyb: blogan ?
14:18:48 * ihrachys calls out people with one week served :)
14:19:02 * ihrachys naively assumes the wiki is correct
14:19:12 <ihrachys> jlibosva: ?
14:19:16 <rossella_s> not only cores, everyone can volunteer! it's a good way to learn
14:19:20 * haleyb had tuned-out
14:19:23 <dasm> ihrachys: 13.07 can be for me
14:19:24 <john-davidge> I can do it, but it will be my first time :)
14:19:42 <dasm> ajo_: 13.07
14:19:44 <ihrachys> john-davidge: that's ok, it's expected
14:19:58 * blogan reads scrollback
14:19:59 <ihrachys> dasm: if HenryG gives it to you, I am ok
14:20:05 <haleyb> ihrachys: yes, i'm due for another
14:20:05 <john-davidge> ihrachys: Then I volunteer for the 20th
14:20:17 <HenryG> dasm: it's all yours
14:20:25 <HenryG> dasm: thanks
14:20:25 <ihrachys> ok, so, June 13 is HenryG/dasm, June 20 is john-davidge and June 27 is rossella_s
14:20:26 <dasm> HenryG: ++
14:20:46 <ihrachys> ok, so we mentioned gate failures before...
14:20:59 <blogan> put me down for the next one, but obviously thats too far away to put me down for
14:21:13 <ihrachys> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=gate-failure
14:21:37 <ihrachys> doesn't seem like anything critical is in the list right now, which is good
14:21:55 <ihrachys> grafana also seems calm now
14:21:55 <ihrachys> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate
14:22:07 <ihrachys> we had a gate failure for -api job yesterday due to fwaas tempest plugin being broken
14:22:19 <ihrachys> but the immediate fix landed into neutron-fwaas today
14:22:25 <ihrachys> so it's safe to recheck
14:22:34 <HenryG> Is the functional job timeout still happening sometimes? jlibosva?
14:22:41 <ajo_> ack
14:22:46 <amuller> also due to devstack installing fwaas it broke the main neutron api job
14:22:48 <dasm> HenryG: it seems so. i've seen timeouts couple of times
14:22:55 <ihrachys> that said, we should really decouple -api job from fwaas, which is the goal of sc68cal's set of kill patches:
14:22:55 <ihrachys> #link https://review.openstack.org/#/q/status:open+topic:kill-off-fwaas-seriously
14:23:02 <ihrachys> so folks please review ^
14:23:19 <jlibosva> I thought it doesn't, I'll sync with dasm
14:23:25 <amotoki__> api job failure lao broke ceilometer gate.
14:23:28 <dasm> jlibosva: ok.
14:23:36 <ihrachys> amotoki__: they install fwaas too right?
14:23:51 <amotoki__> looks so.
14:23:56 <ihrachys> they probably do, due to devstack-gate
14:24:08 <ihrachys> so, we should boost those patches of Sean.
14:24:19 <ihrachys> but for now, ceilometer can also recheck
14:25:41 <ihrachys> ok, I guess we will skip going thru newton-2 blueprints today. just a note to neutron drivers and cores and others: please make sure that neutron-specs patches get enough attention so that feature progress is not blocked due to specs.
14:25:55 <ihrachys> #topic Docs
14:26:04 * ihrachys haven't seen Sam-I-Am for a while
14:26:12 <ihrachys> anyone to give an update on neutron docs?
14:27:13 <amotoki__> recently some contents about dhcp has been moved from user guide.
14:27:37 <ihrachys> amotoki__: is it good? bad?
14:27:43 <amotoki__> also nwguide meeting faces low number of attendees
14:27:58 <amotoki__> that,s what i heard.
14:28:08 <ihrachys> #link http://eavesdrop.openstack.org/#Networking_Guide_Team_Meeting
14:28:13 <ihrachys> that's the meeting event ^
14:28:27 <ihrachys> amotoki__: thanks for the info
14:28:46 <amotoki__> difficult to type on smartphone :(
14:29:02 <ihrachys> #topic Transition to OSC
14:29:09 <ihrachys> dasm: wanna update the team?
14:29:18 <ajo_> off band link: let me know if I broke something: https://wiki.openstack.org/wiki/Network/Meetings#Bug_deputy   :-)
14:29:30 <dasm> ihrachys: probably amotoki__ knows better.
14:29:40 <rtheis> I've updated https://etherpad.openstack.org/p/osc-neutron-support with current status for OSC 2.5.0 release
14:30:09 <rtheis> OSC plugin patch set progress is slow
14:30:16 <amotoki__> osc plugin patch got stalled. i talked with rtheis and I decided to take it.
14:30:27 <rtheis> thanks amotoki__ !
14:30:32 <hichihara> ajo_: Good!
14:30:52 <ajo_> thanks amotoki__
14:31:00 <ihrachys> rtheis: what's the strategy for new features?
14:31:37 <rtheis> ihrachys: we are following strategy in devref: http://docs.openstack.org/developer/python-neutronclient/devref/transition_to_osc.html
14:31:57 <rtheis> core resources go into OSC
14:32:02 <amotoki__> one difficult point is where we should implement a patch. in general osc is the first priority.
14:32:19 <rtheis> *aaS and related go as OSC plugins within neutronclient
14:32:29 <ihrachys> right. do we prioritize osc or neutronclient, and whether we should require new features to support OSC?
14:32:39 <manjeets> rtheis: i guess etherpad can be update ip availability is done
14:32:53 <manjeets> or is it updated after release ?
14:33:05 <ajo_> njohnston, do you remember if we have qos support in OSC ? we may want to add it otherwise
14:33:15 <rtheis> manjeets: I've been updated after release, 2.6.0 is coming soon
14:33:21 <hichihara> I thought new feature must go to OSC.
14:33:31 <njohnston> ajo_: I believe it is in the list of things that still need to be done.
14:33:38 <dasm> hichihara: http://docs.openstack.org/developer/python-neutronclient/devref/transition_to_osc.html#developer-guide
14:33:48 <amotoki__> neutronclient is optional
14:33:52 <ajo_> njohnston, let's track it as a qos bug to make sure we don't forget or that we get help
14:34:04 <hichihara> dasm: Thanks
14:34:08 <rtheis> no qos commands in OSC yet
14:34:23 <rtheis> for network that is, there is volume qos support
14:34:30 <ihrachys> interesting. I think we have specs in progress that talk about neutron CLI but not opentack. Maybe worth going thru them and -1? And maybe new spec template should state it more explicitly it's now a requirements...
14:34:33 <njohnston> ajo_: agreed
14:34:55 <ajo_> ihrachys: +1
14:35:07 <dasm> ihrachys: makes sense.
14:35:26 <ihrachys> #action ihrachys to -1 all specs that don't cover OSC
14:35:32 <hichihara> ihrachys: +1
14:35:39 <amotoki__> ihrachys, +1
14:35:40 <ihrachys> #action ihrachys to update neutron-specs template to be explicit about OSC requirement
14:36:12 <manjeets> ihrachys: +1
14:36:26 <ihrachys> ok, I guess apart from that, it's a matter of coding and reviews that are always in shortage
14:36:32 <ihrachys> thanks amotoki__ for driving it!
14:36:35 <ihrachys> #topic Moving to Keystone v3 API in Neutron
14:36:45 <ihrachys> dasm: I guess that one is yours
14:36:51 <dasm> ihrachys: indeed.
14:36:59 <dasm> cli part is merged and i believe got to n1
14:37:14 <dasm> currently there are leftovers with keystoneclient: https://review.openstack.org/#/c/322268/
14:37:15 <ihrachys> dasm: neutronclient is not part of milestones
14:37:22 <dasm> ihrachys: ack
14:37:39 <ihrachys> dasm: but we may want to release client anyway. maybe let's sync on it after the meeting.
14:37:50 <dasm> ihrachys: ++
14:38:00 <dasm> next step is to update docs: especially developers
14:38:15 <dasm> and two more "huge" parts left: db and codebase.
14:38:44 <dasm> i'll try to finish changes for docs till end of week
14:38:48 <dasm> and next one will focus on db.
14:38:55 <dasm> that's all
14:39:06 <amotoki__> do we need more volunteers?
14:39:23 <ihrachys> dasm: re patch for keystoneauth1 switch: how can we validate it does not break anything? we don't have coverage for designate, right?
14:39:35 <dasm> would be nice to have couple more eyes on it. esp in db.
14:39:42 <dasm> ihrachys: we do not have.
14:40:14 <dasm> ihrachys: i did the change based on keystone description, but there still could be a problem
14:40:39 <ihrachys> dasm: is it covered in designate gate at least?
14:40:54 <dasm> i'll check it again
14:41:08 <dasm> and will talk to designate folks.
14:42:13 <ihrachys> let's make sure we don't break anything for a cleanup. I hope they have some scenarios for neutron.
14:42:24 <twm2016> dasm: Are you talking about the keystone-v3 bp, that needs more help? For updating docs, and work in db and codebase.
14:42:37 <dasm> twm2016: yes.
14:43:10 <twm2016> - just clarifying, I'm going to look into it and see if i can help :)
14:43:27 <dasm> twm2016: ++
14:44:10 <ihrachys> ok cool
14:44:25 <ihrachys> let's make it happen
14:44:25 <ihrachys> and finally...
14:44:27 <ihrachys> #topic On Demand Agenda
14:44:35 <ihrachys> the agenda is empty
14:44:40 <ihrachys> but I wanted to raise one thing
14:45:13 <ihrachys> upgrades team works on converting db code to using objects.
14:45:33 <ihrachys> and sometimes we lack core reviewers.
14:45:48 <ihrachys> we think that maybe it's due to low exposure of the work to the whole team
14:46:01 <ihrachys> so we started to produce bi-weekly status updates with links to interesting patches
14:46:05 <ihrachys> first one is:
14:46:06 <ihrachys> #link http://lists.openstack.org/pipermail/openstack-dev/2016-June/096512.html
14:46:12 <ihrachys> thanks to korzen for preparing it
14:46:29 <korzen> ihrachys, np
14:46:35 <amotoki__> nice idea
14:46:45 <ihrachys> would love to see people read and click thru some links there to make yourself more aware about that process.
14:46:48 <ajo_> thanks, that's very helpful
14:47:10 <blogan> +1
14:47:12 <ihrachys> ok, that's all I have. anything else?
14:47:18 <carl_baldwin> ihrachys: That will be helpful.  I'll try to review more there.
14:47:46 <amotoki__> for more background of the work, the summit video will help you much
14:48:02 <ihrachys> carl_baldwin: thanks! some of that stuff is WIP, but I think we finally got to the point where we can land more invasive patches.
14:48:33 <ihrachys> I guess amotoki__ refers to https://www.youtube.com/watch?v=UQLBw1_VGcU
14:48:48 <amotoki__> yeah
14:49:02 <ihrachys> ok, I guess no more topics and we can enjoy 10 mins till a next meeting :)
14:49:21 <ihrachys> thanks everyone, really glad to see all of you at that early time of day (for some) :)
14:49:23 <ihrachys> #endmeeting