21:00:12 <armax> #startmeeting networking
21:00:12 <yamahata> hi
21:00:12 <openstack> Meeting started Mon Jul 25 21:00:12 2016 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:14 <dougwig> o/
21:00:15 <openstack> The meeting name has been set to 'networking'
21:00:18 <mlavalle> o/
21:00:19 <sbelous> o/
21:00:19 <amotoki> hi
21:00:24 <Sam-I-Am> helllooooooo
21:00:26 <hichihara> hi
21:00:31 <pc_m> o/
21:00:31 <namnh> hi
21:01:43 <dasm> is it me, or it's quiet?
21:01:48 <armax> #link https://wiki.openstack.org/wiki/Network/Meetings
21:01:53 <Sam-I-Am> its party time
21:01:57 <armax> #topic Announcements
21:02:01 <ihrachys> o/
21:02:02 <armax> if you haven’t done so
21:02:07 <armax> please cast your vote on;
21:02:16 <armax> https://docs.google.com/forms/d/e/1FAIpQLSevnzF9z4a9jiXy8w8MRvvmXVmexK5QCxphOoFaOhBuaj9INw/viewform?c=0&w=1
21:02:59 <dougwig> i guess it's better choices than hilary or trump.
21:03:06 <kevinbenton> dougwig: TOO SOON!
21:03:11 <Sam-I-Am> you forgot the cow
21:03:15 <armax> any other announcement/reminder from the team?
21:03:16 <Sam-I-Am> cows are trendy
21:03:29 <mlavalle> armax: the mid-cycle in Cork, Ireland
21:03:30 <armax> Sam-I-Am: it was not prposed I don’t think
21:03:37 <armax> mlavalle: good point
21:03:45 <Sukhdev> o/
21:03:57 <armax> mlavalle: HenryG and I would be working on a schedule and share it with the team in the next couple of days
21:04:21 <armax> #link https://etherpad.openstack.org/p/newton-neutron-midcycle
21:04:22 <armax> for updates
21:04:41 * Sam-I-Am couldnt go due to family things
21:04:59 <Sam-I-Am> but i should be around if i'm needed for docs-y things.
21:05:02 <kevinbenton> Sam-I-Am: i shall complain about dvr in your place
21:05:24 <Sam-I-Am> kevinbenton: isnt that what records my tv shows?
21:05:36 <Sukhdev> I like the etherpad - all the fun stuff is on the top
21:05:49 <armax> #topic Blueprints
21:05:57 <armax> #link https://launchpad.net/neutron/+milestone/newton-3
21:06:27 <armax> there are a bunch of blueprints that are sitting idle in the queue
21:07:02 <ihrachys> armax: it's interesting that no downtime is High while objects are Low, while the latter are a prereq for the former.
21:07:06 <armax> if you are an approver/assignee of the blueprint please consider writing a few notes on the whiteboard providing a status update
21:07:58 <dasm> ihrachys: come on. no one cares about objects. everyone cares about no downtime :)
21:08:18 <armax> ihrachys: we can revisit the priorities if need be
21:09:21 <armax> if you are an approver/assignee of a blueprint, or you’re simply interested in the effort and see no progress, please reach out to me
21:09:47 <armax> and we can figure out where the blocker is, if there’s one
21:10:53 <armax> blueprints without an updated dashboard will most likely not make to Newton at this point
21:11:06 <armax> we’re slowly running out of time
21:11:32 <armax> unless they are meant to track an ongoing multi-cycle effort that is
21:13:21 <kevinbenton> ack
21:13:53 <armax> ok, moving on
21:13:58 <armax> #topic Bugs
21:14:14 <mlavalle> hi
21:14:28 <armax> mlavalle: hi
21:14:28 <mlavalle> I was the bugs deputy this past week
21:14:55 <armax> mlavalle: anything worth raising attention?
21:14:58 <mlavalle> We have to review the critical bug we have: https://bugs.launchpad.net/neutron/+bug/1540983
21:14:58 <openstack> Launchpad bug 1540983 in OpenStack-Gate "Gate failures for neutron in test_dualnet_multi_prefix_slaac" [Undecided,Expired]
21:15:21 <armax> mlavalle: that has been lurking around fo a while
21:15:34 <mlavalle> there's been 24 ocurrences over the past 7 days
21:15:47 <mlavalle> but it has slowed down since the 22nd
21:15:47 <armax> I attempted to skip the test in the past
21:15:52 <armax> https://review.openstack.org/#/c/275457/
21:16:10 <armax> but it looks like the qa folks are happy to keep the neutron gate broken
21:16:19 <armax> in liue of someone fixing the issue
21:16:29 <armax> I recall that haleyb volunteered once to look into it :)
21:17:18 <mlavalle> ok, I didn't want that one to fall through the cracks
21:17:29 <armax> it looks like there’s bug #1604370 filed by jlibosva
21:17:29 <openstack> bug 1604370 in neutron "functional: test_legacy_router_ns_rebuild is unstable" [High,Confirmed] https://launchpad.net/bugs/1604370
21:17:29 <electrocucaracha> shouldn't cirros has a user cirros and password cubswin:)?
21:17:37 <armax> mlavalle: well me neither
21:17:44 <kevinbenton> that should be fixed by otherwiseguy's patch
21:17:50 <armax> kevinbenton: link?
21:17:55 <kevinbenton> one sec
21:18:03 <armax> https://review.openstack.org/#/c/344859/
21:18:07 <kevinbenton> https://review.openstack.org/#/c/344859/
21:18:11 <armax> ack
21:18:19 <kevinbenton> well now you made me look stupid
21:18:21 <kevinbenton> :)
21:18:34 <armax> no
21:18:37 <armax> you were simply slower
21:18:45 <armax> slower != stupid
21:18:48 <otherwiseguy> not "slow"
21:18:56 <otherwiseguy> just slow
21:18:57 <armax> I look stupid for asking :)
21:19:17 <kevinbenton> otherwiseguy: can you update your patch to also say it closes bug 1604370
21:19:17 <openstack> bug 1604370 in neutron "functional: test_legacy_router_ns_rebuild is unstable" [High,In progress] https://launchpad.net/bugs/1604370 - Assigned to Terry Wilson (otherwiseguy)
21:19:31 <otherwiseguy> kevinbenton: sure.
21:19:40 <armax> can we get the L2 cores to look on it please?
21:20:29 <otherwiseguy> kevinbenton: done
21:21:03 <armax> our integrated gate looks relatively quiet this week
21:21:18 <armax> well done to ihrachys and kevinbenton for nailing the mtu issue on the grenade jobs
21:21:35 <armax> though I take it right back because they broke the linuxbridge job in the process
21:21:35 <armax> :)
21:21:52 <ihrachys> I was away smoking when it happened!!!
21:22:14 <armax> ihrachys: your absence makes you just as guilty!
21:22:25 <kevinbenton> yeah, need to work with sc68cal to figure out how to get that change into devstack again
21:22:41 <armax> mlavalle: anything else you want to add?
21:22:53 <ihrachys> kevinbenton: at least we should always get neutron CI including experimental check before landing anything in devstack
21:23:01 <mlavalle> armax: nope, that's it
21:23:07 <kevinbenton> ihrachys: definitely
21:23:52 <armax> we have 789 bugs filed since the Newton timeframe, right now we have 39 new and 104 unassigned
21:24:22 <armax> we should try and squash these numbers during the mid-cycle
21:24:29 <kevinbenton> +1
21:24:41 <armax> any volunteer for next week’s deputy role?
21:24:54 <mlavalle> I thinl we already have one
21:25:09 <armax> ihrachys: you wanted to suggest an improvement to the process, you want to bring it up now?
21:25:12 <mlavalle> ihrachys: somebody volunteered last week, right?
21:25:14 <armax> mlavalle: we have kuba for this week
21:25:29 <armax> we need one for the week of Aug 1st
21:25:36 <armax> I don’t see one here:
21:25:42 <armax> #link https://wiki.openstack.org/wiki/Network/Meetings#Bug_deputy
21:25:44 <ihrachys> armax: we "discussed" it before, and I think I just need to push a devref patch for everyone to have a place to comment
21:25:50 <electrocucaracha> I would like to volunteer myself for next week
21:26:00 <ihrachys> armax: we == on the prev meeting
21:26:03 <ihrachys> that you skip :P
21:26:21 <armax> ihrachys: I am guilty I did not review the logs last week
21:26:25 <kevinbenton> you mean the other neutron team? :)
21:26:31 <ihrachys> haha
21:26:37 <armax> electrocucaracha: what’s your lp handle?
21:27:00 <ihrachys> mlavalle: I don't think we had anyone.
21:27:01 <ihrachys> people are shy!
21:27:01 <electrocucaracha> I need to check but I guess that it's electrocucaracha
21:27:03 <armax> we should give ourselves different names otherwise it gets confusing
21:27:13 <mlavalle> electrocucaracha: read this in preparation: http://docs.openstack.org/developer/neutron/policies/bugs.html
21:27:29 <electrocucaracha> thanks mlavalle, I'll do it
21:27:36 <Sam-I-Am> electrocucaracha: you get a bottle of scotch too
21:27:37 <armax> https://launchpad.net/~electrocucaracha
21:27:45 <armax> ok, I found you
21:27:47 <electrocucaracha> yes, that one
21:28:04 <armax> #action electrocucaracha deputy for the week of Aug 1st
21:28:12 <electrocucaracha> Sam-I-Am: :)
21:28:15 <armax> ok, anything else bug related?
21:28:43 <kevinbenton> https://bugs.launchpad.net/cirros/+bug/1605832
21:28:43 <openstack> Launchpad bug 1605832 in CirrOS "no 8021q support" [Undecided,New]
21:28:59 <kevinbenton> i'm not sure if anyone is directly involved with CirrOs
21:29:03 <kevinbenton> or knows someone who is
21:29:05 <armax> kevinbenton: nice one
21:29:10 <kevinbenton> but it would be nice if we can get some feedback on that
21:29:22 <kevinbenton> so we can have a path to tempest scenario vlan-aware-vms tests
21:29:59 <armax> kevinbenton: yes indeed
21:30:29 <Sam-I-Am> kicking the can down the road - https://bugs.launchpad.net/neutron/+bug/1523031
21:30:30 <openstack> Launchpad bug 1523031 in openstack-ansible trunk "Neighbor table entry for router missing with Linux bridge + L3HA + L2 population" [High,Confirmed] - Assigned to Jesse Pretorius (jesse-pretorius)
21:30:40 <armax> #topic Docs
21:30:46 <armax> Sam-I-Am: anything worth sharing?
21:30:51 <Sam-I-Am> well, the neutron version of that bug
21:30:59 <Sam-I-Am> armax: yeah, i'm reorganizing the networking guide
21:31:08 <armax> Sam-I-Am: you ready to handle the volume of docs patches coming your way?
21:31:13 <Sam-I-Am> #link https://review.openstack.org/#/c/345110/
21:31:31 <armax> Sam-I-Am:  ack
21:31:36 <Sam-I-Am> i'd like to get that merged before this wave of patches you speak of
21:31:43 <Sam-I-Am> also curious about this wave
21:31:50 <Sam-I-Am> its been a pretty steady stream
21:31:56 <armax> Sam-I-Am: anyone specifically you’d like to involve in the review?
21:32:18 <Sam-I-Am> review of the reorg?
21:32:21 <armax> Sam-I-Am: ya
21:32:25 <armax> besides me, as I see
21:32:32 <Sam-I-Am> you and edgar are on it, and sean
21:32:33 <armax> and mestery
21:33:01 <armax> ok
21:33:05 <Sam-I-Am> anyone else is welcome to chime in
21:33:05 <johnsom> Sam-I-Am Did you see my IRC about the LBaaS docs being messed up?
21:33:16 <Sam-I-Am> johnsom: no, where?
21:33:35 <Sam-I-Am> or is this a continuation of the octavia mess
21:33:38 <amotoki> Sam-I-Am: one question. most contents currently added are still about mitaka. doen't it make it difficult to backport?
21:33:41 <johnsom> I will send you a link direct.  Somehow the LBaaSv1 and v2 docs got merged
21:34:32 <Sam-I-Am> amotoki: yeah, it gets more interesting. thats why i'm trying to do this after mitaka and before most of the newton content, if possible
21:34:56 <johnsom> Sam-I-Am http://developer.openstack.org/api-ref/networking/v2-ext/#lbaas-1-0-deprecated-lb-vips-health-monitors-pools-members
21:34:57 <Sam-I-Am> i can always patch mitaka stuff directly
21:34:58 <amotoki> Sam-I-Am: thanks. N-3 is approaching. it sounds a good timing to me.
21:35:16 <Sam-I-Am> amotoki: yeah, just need a few +1s from the neutron crowd, then push it through docs
21:35:31 <Sam-I-Am> johnsom: oh, api docs.
21:36:00 <amotoki> johnsom: api-ref needs to be clean up.
21:36:14 <Sam-I-Am> armax: once the reorg merges, i want to update some of the scenarios
21:36:20 <amotoki> i shared api-ref clean up virtual sprint last week. I have to coordinate the date.
21:36:28 <johnsom> Yeah, they were two sections, but somehow it got merged into one, in a bad way
21:36:30 <Sam-I-Am> there's progress, its just slow (as usual)
21:36:50 <Sam-I-Am> johnsom: i'm not much of an api docs guy (yet)
21:37:22 <amotoki> johnsom: let me check the bug you pointed out,
21:37:30 <armax> amotoki: regarding the api-ref
21:37:33 <armax> the rendering here:
21:37:34 <armax> http://developer.openstack.org/api-ref/networking/
21:37:36 <Sam-I-Am> there might also be some more reorg later, but less drastic
21:37:55 <Sam-I-Am> primary objective was getting all the stuff out of advanced config
21:37:56 <armax> looks mixed up with the versions of the repo in which they are defined
21:38:43 <armax> the links look broken but so are for other projects AFAIK
21:38:49 <amotoki> armax: I think the common theme for api-ref has been updated.
21:39:07 <armax> amotoki: ok
21:39:15 <armax> thanks
21:39:28 <armax> if there’s nothing else, let’s move to the next topic of the meeting
21:39:33 <armax> #topic OSC
21:39:42 <amotoki> let me discuss the virtual sprint for api-ref?
21:39:50 <armax> amotoki: sure
21:39:51 <armax> #undo
21:39:52 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x7f5bc01d5ed0>
21:39:59 <armax> amotoki: go ahead
21:40:09 <amotoki> one idea is to do it next week
21:40:40 <amotoki> and if there are more to be discussed, we can discuss it in the midcycle or somewhere.
21:41:06 <amotoki> how about the next week?
21:41:21 <ihrachys> sadly I am off to a conference next week
21:42:41 <amotoki> I am not sticking a specific week, but we can start it gradually.
21:42:45 <armax> amotoki: next week sounds good, we should is there a list of changes that are already up for review?
21:43:12 <armax> scrap the ‘we should’ part
21:43:19 <amotoki> armax: https://review.openstack.org/#/c/330890/ is a prepation
21:43:32 <armax> amotoki: ack
21:43:43 <hichihara> I'm OK about next week
21:43:52 <amotoki> and this is the announce mail last week http://lists.openstack.org/pipermail/openstack-dev/2016-July/099558.html
21:44:00 <amotoki> i will send a follow up mail.
21:44:37 <amotoki> let's move on the next
21:44:59 <armax> ok
21:45:02 <armax> #topic OSC
21:45:08 <armax> amotoki: anything worth sharing?
21:45:27 <amotoki> no special update from me.
21:45:40 <rtheis> osc network rbac create and delete commands are ready for review: https://review.openstack.org/#/c/346705/
21:45:54 <armax> amotoki: I did look into OSC and neutronclient in the context of vlan-aware-vms
21:45:55 <amotoki> i will review through related patches this week from the point of view of OSC guideline.
21:46:07 <armax> it looks like all the building blocks are there
21:46:26 <rtheis> amotoki: I will plan to do the same
21:46:26 <armax> I was talking to rtheis this morning that we might want to consider capping osc and osc-lib in global requirements
21:46:45 <armax> because right now some external plugins end up depending on both
21:46:58 <armax> and I assume python-openstackclient to be less stable than osc-lib
21:47:24 <rtheis> armax: I plan to discuss that with dtroyer and stevemar
21:47:32 <armax> rtheis: thanks
21:47:42 <rtheis> yw
21:48:03 <rtheis> nothing else from me
21:48:11 <armax> rtheis: keep me posted, pls :)
21:48:19 <rtheis> will do
21:48:23 <armax> rtheis: btw
21:48:38 <armax> rtheis: is there any way to hide certain commands if the functionality is not available?
21:48:45 <armax> rtheis: is there any way you’d like us to handle this?
21:49:14 <rtheis> armax: is this in the context of an extension not being available?
21:49:17 <armax> rtheis: I always hated to see a generic 404 error from Neutron when a client command cannot be executed correctly because of a lack of an extension
21:49:20 <armax> yes
21:49:42 <armax> I suppose 404 is still pertinent, but a nicer message would be more friendly
21:50:07 <rtheis> armax: I'm not aware of a generic way to handle this
21:50:09 <armax> rtheis: I guess the same applies to entire services
21:50:21 <armax> rtheis: no?
21:50:31 <rtheis> that is, we haven't implemented that
21:50:32 <amotoki> i have the similar feeling.
21:50:46 <rtheis> does neutronclient do anything today?
21:50:50 <armax> rtheis: nope
21:50:55 <kevinbenton> maybe server side we can give a different error message in the body if the 404 is because an extension is gone?
21:50:55 <amotoki> is it better to check a required  extension?
21:51:08 <armax> kevinbenton: I think the 404 is thrown by the policy engine
21:51:30 <amotoki> i think it is returned by 'route' framework.
21:51:40 <kevinbenton> or the client can detect a 404 and do a required extension check in the exception handler
21:51:44 <armax> amotoki, rtheis: all I wanted to raise now is whether this is something worth looking into
21:51:54 <amotoki> armax: agree
21:51:56 <rtheis> I think it is worth looking into
21:52:09 <armax> rtheis: and make it avaiable in osc-lib somehow
21:52:31 <armax> as it can be potentially reused across a wider set of use cases
21:52:41 <amotoki> regaring osc, somthing like "openstack help networking" would be nice to show netwokring related commands only.
21:52:41 <rtheis> sure, I'll make a note to ask
21:52:57 <armax> rtheis: thanks a lot!
21:52:58 <amotoki> we see too many commands from 'openstack help' :-(
21:53:41 <armax> amotoki: I am not suggesting to hide commands if the server side is misisng
21:53:50 <dasm> amotoki: ++. grep helps, but not always
21:53:58 <armax> but perhaps we can figure out a better way to gracefully fail
21:54:20 <amotoki> armax: perhaps I understand your point. better error message.
21:54:35 <amotoki> my last comment is another one. sorry for confusion.
21:54:46 <armax> amotoki: something like that, no worries, we’ll get this nailed
21:54:47 <armax> :)
21:54:48 <armax> shall we move on to keystone v3?
21:55:02 <amotoki> sure
21:55:04 <armax> we have a few minutes left and I know dasm and HenryG have some update for us
21:55:12 <dasm> quick reminder: https://etherpad.openstack.org/p/neutron-stadium-tenant2project
21:55:15 <armax> #topic Keystone v3
21:55:18 <manjeets__> amotoki: openstack pattern ?
21:55:22 <dasm> this is list of all db changes
21:55:38 <dasm> changes need more reviews, some of them are already merged.
21:56:06 <armax> dasm: I was going to sit down with HenryG tomorrow to go over the list
21:56:07 <dasm> neutron change is blocked by queue of subprojects.
21:56:18 <dasm> armax: ok
21:56:18 <amotoki> do we need to merge patches for all stadium projects first?
21:56:19 <armax> dasm: ack, anything we can look into right now for you?
21:56:26 <dougwig> which subprojects?
21:56:55 <dasm> amotoki: armax decided, that subprojects should be merged before neutron change.
21:57:19 <dasm> armax: just in general. i'm trying to update/resolve merge conflicts when something appears.
21:57:21 <armax> it doesn’t help that the gate is at ~500 jobs
21:57:52 <armax> dasm: ok, but we’re pretty much ready to roll?
21:58:23 <dasm> neutron stadium projects are in queue. "other projects" noted by HenryG are not ready yet.
21:58:38 <amotoki> i think 'related projects' are best-effort.
21:58:49 <armax> yes
21:58:51 <dougwig> i don't think we should wait for non-stadium projects.
21:59:02 <armax> let’s share this etherpad again on the ML
21:59:13 <dasm> ok
21:59:26 <armax> dasm: thanks for pulling this off, kudos!
21:59:33 <armax> ok folks we’re at time
21:59:40 <armax> next week ihrachys_ is out
21:59:46 <armax> so someone else will have to run the meeting
21:59:59 <armax> don’t be surprised
22:00:03 <armax> :)
22:00:12 <armax> it’s not a third neutron team coming alive
22:00:16 <armax> #endmeeting