14:00:01 <HenryG> #startmeeting networking
14:00:02 <openstack> Meeting started Tue Aug  2 14:00:01 2016 UTC and is due to finish in 60 minutes.  The chair is HenryG. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:06 <openstack> The meeting name has been set to 'networking'
14:00:06 <manjeets_> hi
14:00:09 <haleyb> hi
14:00:09 <john-davidge> hi
14:00:12 <hichihara> hi
14:00:18 <hoangcx> Hi
14:00:19 <korzen> hello
14:00:31 <dasm> o/
14:00:33 <ajo> o/ :)
14:00:40 <amotoki> o/
14:00:53 <njohnston> o/
14:01:02 <Sam-I-Am> hello
14:01:26 <HenryG> #link https://wiki.openstack.org/wiki/Network/Meetings
14:01:47 <HenryG> #topic Announcements
14:02:03 <yottatsa> o/
14:02:21 <HenryG> The midcycle is approaching
14:02:25 <HenryG> #link https://etherpad.openstack.org/p/newton-neutron-midcycle
14:02:32 <Sam-I-Am> i'll be missing it :/
14:02:43 <annp> Hi
14:02:57 <HenryG> We have a comprehensive list of workitems
14:03:01 <HenryG> #link https://etherpad.openstack.org/p/newton-neutron-midcycle-workitems
14:03:25 <HenryG> Any other announcements?
14:03:46 <amotoki> I will announce the API reference cleanup sprint soon.
14:04:01 <amotoki> please check my email on the dev list.  in the meeting last week we decided to start it this week,
14:04:13 <HenryG> Looking forward to it amotoki, thanks.
14:04:19 <amotoki> but the preparation took time more than what I expected :-(
14:05:24 <HenryG> No problem. We appreciate the effort.
14:06:02 <HenryG> #topic Blueprints
14:06:13 <HenryG> #link https://launchpad.net/neutron/+milestone/newton-3
14:06:57 <HenryG> A reminder to keep your progress up to date in the BP whiteboards
14:09:02 <HenryG> I think the Keystone V3 (tenant_id rename to project_id) patch will merge this week and it could be quite disruptive.
14:09:18 <HenryG> Please pay close attention. Especially if you maintain a sub-project.
14:09:41 <HenryG> #topic Bugs
14:10:24 <HenryG> electrocucaracha was deputy?
14:10:28 <jlibosva> I was
14:10:46 <HenryG> Sorry electrocucaracha is this week
14:10:51 <mlavalle> I think electrocucaracha is this week
14:10:56 <HenryG> Anything to report jlibosva
14:11:00 <jlibosva> yep
14:11:00 <HenryG> ?
14:11:27 <jlibosva> so we had two bugs as gate-failures: one broke tempest fwaas - https://bugs.launchpad.net/bugs/1607625 - is fixed by now
14:11:27 <openstack> Launchpad bug 1607625 in neutron "gate-neutron-fwaas-dsvm-tempest is not working properly" [Critical,Fix released] - Assigned to YAMAMOTO Takashi (yamamoto)
14:11:51 <jlibosva> second didn't occur that often - https://bugs.launchpad.net/bugs/1607412 - also fixed by now
14:11:51 <openstack> Launchpad bug 1607412 in neutron "gate-grenade-dsvm-neutron-multinode fails server build on newton side with "Unrecognized attribute(s) 'dns_name'"" [High,In progress] - Assigned to Miguel Lavalle (minsel)
14:12:09 <mlavalle> For this one, the fix is close to merge
14:12:29 <jlibosva> we have a critical bug that appeared after switching to native of_interface - https://bugs.launchpad.net/bugs/1607787
14:12:29 <openstack> Launchpad bug 1607787 in neutron "Missing secure fail mode on physical bridges" [Critical,In progress] - Assigned to Hynek Mlnarik (hmlnarik-s)
14:12:59 <hynekm> It seems that native ofctl interface does not work properly under high load, ovs loses connection with the ryu controller and that leads to interruption of network traffic. It seems that there is setting secure fail mode missing on phys bridges, but something more than it might be an issue. Under investigation currently.
14:13:00 <jlibosva> it breaks l2 connectivity via phys bridges in case of ovs agent restarts or when node is under heavy load
14:13:58 <jlibosva> the work in progress for that last one can be found here: https://review.openstack.org/348889
14:14:25 <jlibosva> HenryG: that's all from my side
14:14:39 <HenryG> Thanks jlibosva
14:15:00 <HenryG> Any other bugs to highlight from anyone else?
14:15:13 <mlavalle> jlibosva, HenryG: for 1607412, we need a final nudge for the fix: https://review.openstack.org/#/c/349214/
14:15:36 <jlibosva> good point, sorry I marked it as fixed :) backport is crucial
14:16:49 <HenryG> Who wants to volunteer for bug deputy next week?
14:17:30 <john-davidge> I can do it if there are no other volunteers
14:17:40 <HenryG> Thanks john-davidge !!
14:17:58 <john-davidge> HenryG: No worries :)
14:18:09 <HenryG> #action john-davidge bug deputy for the week of August 8th
14:18:12 <dasm> should we also find someone for mid-cycle week?
14:18:19 <dasm> or leave it to armax? :)
14:18:35 <amotoki> john-davidge: thanks for volunteer twice these two months!
14:19:08 <HenryG> Anyone can volunteer at any time. Just add your name to the table in https://wiki.openstack.org/wiki/Network/Meetings
14:19:15 <john-davidge> HenryG: Actually, I think I have to un-volunteer myself :( I have a wedding to go to next week
14:19:25 <HenryG> #undo
14:19:26 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7f5bc0020550>
14:19:30 <john-davidge> HenryG: Sorry to get your hopes up!! :(
14:20:00 <HenryG> john-davidge: no problem, weddings are important too :)
14:20:25 <john-davidge> If there's anything reading this wondering if they should volunteer for the first time, do it! It's a great learning experience :)
14:20:30 <john-davidge> *anyone
14:20:44 <njohnston> I'll do it next week
14:20:53 <mlavalle> and there's plenty of help around
14:21:07 <HenryG> njohnston: No weddings next week? ;)
14:21:12 <HenryG> njohnston: Thanks!
14:21:30 <HenryG> #action njohnston bug deputy for the week of August 8th
14:21:36 * regXboi likes the idea of anything being the bug deputy for a week
14:22:10 <john-davidge> regXboi: BugDeputyBot? I think that would be very popular...
14:22:30 <regXboi> it very well could be ...
14:22:47 <HenryG> Somehow I don't think a bot would be good at this.
14:22:59 <HenryG> Moving on...
14:23:07 <HenryG> #topic Docs
14:23:32 <HenryG> We already touched on the upcoming api-ref sprint
14:24:02 <Sam-I-Am> moo.
14:24:23 <Sam-I-Am> couple patches to the networking guide in review
14:24:35 <Sam-I-Am> other than that, i'm trying to work on updates to the config scenarios
14:25:03 <Sam-I-Am> for those of you who missed it, the reorg patch merged
14:25:13 <HenryG> Sam-I-Am: Thanks. Do you have the review links handy?
14:25:14 <Sam-I-Am> now it might be backported, so the mitaka guide has better organizaion
14:25:17 <Sam-I-Am> no, i dont
14:25:37 <amotoki> handy review links https://review.openstack.org/#/q/status:open+project:openstack/openstack-manuals+path:%255Edoc/networking-guide/.*
14:25:56 <HenryG> amotoki: nice!
14:26:04 <HenryG> #link https://review.openstack.org/#/q/status:open+project:openstack/openstack-manuals+path:%255Edoc/networking-guide/.*
14:26:12 <Sam-I-Am> thats one way to do it
14:27:36 <HenryG> #topic OSC
14:27:50 <HenryG> rtheis: Anything to report this week?
14:28:11 <rtheis> progress continues both on OSC network commands and OSC plugin in neutronclient
14:28:20 <rtheis> just one reminder
14:28:41 <rtheis> when writing commands, please review https://github.com/openstack/python-openstackclient/blob/master/doc/source/commands.rst
14:29:11 <amotoki> rtheis: according to https://etherpad.openstack.org/p/osc-neutron-support, it seems all planned network commands in OSC side has been implemented.
14:29:44 <rtheis> amotoki: no, the first pass of core command are done
14:30:07 <rtheis> amotoki: there are several more to go and likely some missing options which we can handle separately too
14:30:24 <amotoki> rtheis: ah.. we need to see L.165 or after in the etherpad page
14:30:40 <rtheis> yes
14:30:49 <HenryG> #link https://github.com/openstack/python-openstackclient/blob/master/doc/source/commands.rst
14:30:56 <HenryG> #link https://etherpad.openstack.org/p/osc-neutron-support
14:31:04 <rtheis> addition OSC guidance for plugins is under https://github.com/openstack/python-openstackclient/tree/master/doc/source
14:31:18 <rtheis> that's it for now
14:31:20 <HenryG> #link https://github.com/openstack/python-openstackclient/tree/master/doc/source
14:31:31 <HenryG> Thanks rtheis, and amotoki
14:31:39 <rtheis> yw
14:31:51 <HenryG> #topic Open Discussion
14:32:48 <yottatsa> Hi, I'd like to discuss rfe about CIDR updating
14:32:55 <yottatsa> #link https://bugs.launchpad.net/neutron/+bug/1605343
14:32:55 <openstack> Launchpad bug 1605343 in neutron "[rfe] update CIDR for subnet" [Wishlist,Triaged] - Assigned to Vladimir Eremin (yottatsa)
14:34:16 <HenryG> yottatsa: unless there is someone present who wants to chime in, I would suggest a discussion with carl_baldwin present
14:34:34 <yottatsa> Ok, skip
14:35:04 <HenryG> yottatsa: Let's try on Thursday at the drivers meeting
14:35:13 <john-davidge> Perhaps an ML thread? I'd be interested to hear more about the use case
14:35:28 <HenryG> An ML post would help, yes.
14:35:41 <yottatsa> john-davidge HenryG I'll drop email in openstack-dev then and will be on Thursday
14:35:54 <HenryG> yottatsa: great, sounds good
14:37:29 <HenryG> If there is nothing else, let's get back to real work.
14:37:45 <hichihara> nice
14:37:56 <dasm> thanks o/
14:37:59 <HenryG> #endmeeting