21:00:51 <armax> #startmeeting networking
21:00:52 * haleyb wonders if this is a 3-hour tour on the good ship neutron
21:00:52 <openstack> Meeting started Mon Oct 17 21:00:51 2016 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:55 <openstack> The meeting name has been set to 'networking'
21:00:56 <njohnston> o/
21:01:00 <dasanind_> o/
21:01:07 <amotoki> hi
21:01:14 <HenryG> o/
21:01:41 <armax> welcome everyone
21:02:10 <johnsom> o/
21:02:21 <armax> thanks for joining this neutron meeting!
21:02:25 <armax> the agenda for today
21:02:29 <armax> #link https://wiki.openstack.org/wiki/Network/Meetings
21:02:35 <armax> #topic Announcements
21:03:28 <armax> the design summit is one week away if you have not noticed
21:03:31 <dougwig> o/
21:03:33 <armax> the summit schedule is up
21:03:41 <armax> https://www.openstack.org/summit/barcelona-2016/summit-schedule/global-search?t=Neutron%3A
21:04:25 <armax> this is the last summit in the well known format and as such it’s gonna be the last one where we’re gonna have a contributors meetup
21:04:27 <armax> #link https://www.openstack.org/summit/barcelona-2016/summit-schedule/events/17227
21:04:52 <armax> if any of you is staying the Friday, I’d strongly invite you to sign up on the related etherpad
21:07:02 <armax> because of the summit it’s safer to cancel the next couple of meetings
21:07:18 <manjeets> o/
21:07:50 <armax> so the next Neutron team meeting is going to be on
21:08:06 <armax> Tue 8th
21:08:11 <armax> November
21:09:02 <njohnston> I'll be serving as an official in the US election, so I will miss it.
21:09:24 <kevinbenton> njohnston: you running for president?
21:10:00 <njohnston> Yes, haven't you seen the TV ads for the FWaaS party?
21:10:10 <manjeets> :)
21:10:42 <armax> any other announcement?
21:10:51 <armax> it’ll be difficult to top njohnston’ one
21:11:07 <hichihara> Social event in Summit?
21:11:16 <armax> mlavalle organizing one
21:11:19 <mlavalle> yeah
21:11:31 <dasm> http://lists.openstack.org/pipermail/openstack-dev/2016-October/105757.html
21:11:32 <armax> I’ll defer to him for any further details
21:11:34 <mlavalle> here's the message I sent to the ML
21:11:55 <mlavalle> #link  http://lists.openstack.org/pipermail/openstack-dev/2016-October/105757.html
21:11:57 <armax> mlavalle: if you struggle with finding a good venue, we can always meet on the beach
21:12:09 <mlavalle> we have a good venue
21:12:14 <hichihara> mlavalle: +1 :)
21:12:21 <mlavalle> so far 30 people have confirmed
21:12:32 <dougwig> usually about 50-100 show up, iirc.
21:12:47 <armax> mlavalle: let’s hope they don’t cancel on us as it happened in Austin?
21:13:19 <mlavalle> armax: I'll keep reminding people
21:13:41 <armax> mlavalle: ack
21:13:49 <armax> ok next topic
21:14:21 <armax> #topic blueprints
21:14:52 <armax> I still see people registering neutron blueprints in launchpad being completing oblivious to the RFE process
21:16:02 <armax> I’d like to remind here that blueprints are created at the very end of the RFE process and if and only if the drivers team gives a green light
21:16:18 <blogan> is there any way to add a warning when creatin ga blueprint in LP?
21:16:27 <armax> unfortunately I can’t see a good one
21:17:32 <armax> but the landing page, if someone cared to read it, does provide instructions
21:17:40 <armax> anyhoo
21:19:45 <armax> we have not scrubbed the dashboard for the first Ocata milestone
21:19:47 <armax> #link https://launchpad.net/neutron/+milestone/ocata-1
21:19:59 <armax> but we’ll do it soon
21:20:24 <armax> if you are involved with any of the activities being tracked on that dashboard
21:20:43 <armax> please consider providing an update on the blueprint whiteboard
21:21:34 <armax> #topic Bugs and Gate failures
21:22:06 <armax> Last week’s deputy was john-davige, nothing scary to report
21:22:18 <armax> even our Grafana dashboards
21:22:20 <armax> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate
21:22:29 <armax> don’t seem to reflect anything alarming
21:22:37 <kevinbenton> yay
21:22:49 <armax> kevinbenton: you must have been on vacation?
21:22:56 <HenryG> ouch
21:23:01 <kevinbenton> yeah, i didn't get anything merged :)
21:23:07 <armax> kevinbenton: that explains it
21:23:08 <armax> :)
21:23:44 <armax> I am still licking the wounds post dhcp-turmoil
21:24:41 <armax> as far as bugs being reported since the start of Ocata I can already count 150 in the span of a month
21:25:10 <armax> we only fixed a third, if any of you has any idea on how to improve that ratio, I’d love to hear it
21:25:27 <armax> because even though we managed to keep the size of our backlog relative steady
21:25:39 <armax> we can’t seem the squash it
21:26:06 <armax> and we hover over the 800 bug count mark
21:26:10 <armax> which is pretty annoying
21:27:07 <armax> other than revoking kevinbenton
21:27:10 <armax> gerrit rights
21:27:16 <armax> I can’t think of anything else
21:27:33 <armax> and I must add
21:27:40 <dougwig> i think kevin is a net win, so that might hurt.
21:27:43 <armax> revoking my +2/+A rights too
21:28:06 <trevormc> One way to keep down the bug count would encourage developers to submit only fixes instead of a bug a nd a fix. Right? or do we prefer how it is now?
21:28:08 <armax> dougwig: ok, I would agree with that statement, actually
21:28:25 <armax> trevormc: you mean cheating? :)
21:28:33 <armax> trevormc: or lying?
21:28:38 <dasm> the other thing would be to delete a code.
21:28:45 <dasm> then we wouldn't have a bugs. am i rite?
21:28:51 <armax> because that doesn’t change the fact that hte codebse is buggy :)
21:29:03 <manjeets> dasm then there will be failures
21:29:07 <armax> I think dasm is onto something!
21:30:31 <armax> this probably deserves more discussion, but I think one of the issues I see is that developers hog the bug report for too long
21:30:44 <kevinbenton> +1
21:30:46 <armax> and the bug stays in progress for ever
21:30:59 <kevinbenton> I've encountered several times where it's already assigned so i won't dig into it
21:31:11 <armax> because from the number I can see that the number of new/unassigned bugs is relatively low
21:31:14 <kevinbenton> is there a way we can auto unassign after a week of no activity?
21:31:31 <dougwig> an auto-unassign after N days of idle is intriguing.
21:31:32 <armax> kevinbenton: I do that, even though not that frequently
21:31:59 <armax> and the reason I do that less frequently is that you can’t just rely on a script to auto unassign
21:32:35 <armax> you need some time in figuring out whether the bug report next status
21:32:37 <dasm> armax: in that case, maybe would be good to add one more thing for bug deputy? to verify that?
21:32:43 <amotoki> it might be useful to listi such bugs though.
21:32:49 <trevormc> What about those patch sets where it has jenkins +1 just no one has reviewed it? Is it the owner's responsibility to bring it up in meetings or the IRC chat?
21:32:59 <dasm> trevormc: ++
21:33:11 <armax> dasm: right, but ihar and I were contemplating making the deputy duties doing some proactive backporting
21:33:12 <manjeets> trevormc, +++
21:33:13 <alraddarla> trevormc: agere
21:33:21 <alraddarla> agree* i'm glad i can type
21:33:27 <armax> we don’t want to swamp the deputy too much
21:33:36 <dasm> armax: true
21:33:48 <armax> ok, let me mull over on this a bit more
21:34:10 <armax> we can certainly monitor this area during the team meeting
21:34:11 <dougwig> armax: bug deputy and stable team are two different roles.  instead of merging them, perhaps we have a stable nominee for each week as well?
21:34:17 <armax> that’s what this topic is for after all
21:34:36 <armax> dougwig: you mean estabilish a stable backport deputy?
21:34:44 <dougwig> armax: yes.
21:34:46 <dasm> dougwig: intriguing idea
21:35:02 <armax> dougwig: we can talk about this next week and see where we go with it
21:35:19 <dasm> armax: "Nov 8th" week
21:35:28 <armax> I think it was always ihar’s intention of making this a rotating effort
21:35:42 <armax> dasm: we are going to meet secretly at the summit
21:35:46 <armax> dasm: hence next week
21:35:54 <dasm> NOOO!!!1111onoenoe :'(
21:36:01 <armax> dasm: and tell no-one about the outcome
21:36:10 <armax> and ignore any suggestion
21:36:18 <electrocucaracha> armax: how other projects keeps their numbers low?
21:36:21 <armax> comment or feedback
21:36:28 <dougwig> that's where we adopt a complete NFV focus, right?
21:37:11 <armax> electrocucaracha: numbers are pretty high overall
21:37:34 <trevormc> electrocucaracha: In another project I work in, I observe developers uploading patch sets without a bug. They reserve bug reporting for users and operators.
21:37:48 <armax> electrocucaracha: but I must admit I have not talked to the respective PTL’s
21:37:54 <armax> so it’s something I can work on
21:38:39 <electrocucaracha> yeah, maybe it's a common know issue, but it's better to keep a short active list instead of a longer wishlist
21:39:07 <armax> again, I am less concerned to have a 1000 bugs in the backlog at any given time
21:39:50 <armax> assumed we can close bugs as fast as they are openee
21:39:53 <armax> opened
21:39:59 <armax> or faster
21:40:19 <armax> but first and foremost
21:40:23 <manjeets> for some bugs discussion goes too long on just choosing a solution
21:40:34 <armax> not give reporters the chance to file them in the first place would be the way to go
21:40:50 <armax> but one can only hope for so muh
21:40:51 <armax> much
21:41:13 <armax> ok let’s move on for now
21:41:17 <armax> but before we do
21:41:26 <armax> dasm: was wondering about a deputy post-summit
21:41:34 <armax> if anyone is interested, please raise your virtual hand
21:41:41 <armax> if not, it’ll fall back to me
21:42:03 <armax> but please, don’t be shy/lazy and raise your virtual hand
21:42:11 <trevormc> I would be interested in shadowing, just so I know what to do when I volunteer for it sometime.
21:42:28 <armax> trevormc: there’s a very detailed how to guide
21:42:31 * manjeets wanted to do that but it would be his first time
21:42:57 <armax> #link http://docs.openstack.org/developer/neutron/policies/bugs.html#neutron-bug-deputy
21:42:58 <electrocucaracha> armax, post-summit means... the first week of november right?
21:43:19 <dougwig> the week after the summit?  i can do it.
21:43:35 <armax> electrocucaracha: correct
21:43:37 <dasm> electrocucaracha: yes, until next meeting when someone will be picked
21:44:22 <armax> ok between manjeets, trevormc and dougwig who wins?
21:44:31 <dasm> dougwig: ++ thanks
21:45:00 <armax> ok
21:45:03 <manjeets> I vote for dougwig and trevormc before me would be right choice
21:45:13 <armax> #action dougwig deputy for the week of Oct 31st
21:45:24 <dougwig> i win.  i win all the things. i will be the best bug deputy you have ever seen,  you don't even know what you're missing yet . make launchpad great again!
21:45:43 <armax> dougwig: you’ll get some tricks and treats in the post
21:45:44 <kevinbenton> we will have the smallest bug counts
21:45:45 * electrocucaracha lol
21:46:29 <armax> ok next one up
21:46:32 <armax> #topic Docs
21:46:47 <armax> I am not sure we have an official Doc dude or gal
21:46:59 <armax> all I know is that our docs still shows emagana
21:47:03 <armax> and we should change that
21:47:19 <armax> sam-I-Am doesn’t seem to be online either
21:47:44 <HenryG> He is flying today
21:48:22 <armax> we have 33 docs bug open
21:48:24 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=doc
21:48:26 <armax> we suck
21:48:32 <armax> we should have 0
21:48:59 <armax> or close to zero
21:49:13 <armax> HenryG: where to?
21:49:14 <dasm> isn't this that, person who implemented the change, should also update the docs?
21:49:32 <armax> dasm: ideally yes, and that’s the operating assumption I am under
21:49:47 <trevormc> I like to tag the person as a reviewer at least.
21:49:50 <HenryG> armax: around in circles, probably
21:50:14 <alraddarla> Just my two cents: but being able to fix doc bugs is helpful as a newbie because it requires me to read up on Neutron while still being able to look into some of the code
21:50:24 <armax> I’ll attempt to clean up the list between now and the time after the summit
21:50:59 <armax> we need a new official doc liasion regardless
21:51:33 <armax> this table
21:51:35 <armax> #link http://docs.openstack.org/developer/neutron/policies/neutron-teams.html#core-review-hierarchy
21:51:39 <armax> is a little outdated
21:52:35 <armax> #action armax to refresh page http://docs.openstack.org/developer/neutron/policies/neutron-teams.html
21:53:17 <armax> next topic
21:53:21 <armax> #topic OSC
21:53:31 <armax> amotoki anything newsworthy you’d like to share?
21:53:45 <amotoki> I'd like to have a review for https://review.openstack.org/#/c/348097/
21:53:59 <amotoki> neutron OSC plugins can use this as a utility.
21:54:13 <armax> amotoki: consider it done
21:54:34 <armax> amotoki: anything else?
21:54:52 <amotoki> For the summit, I am preparing a list of a gap and/or missing points. i'll share next week or some. that's all
21:55:00 <armax> amotoki: cool, thanks
21:55:07 <armax> #topic Neutron-lib
21:55:13 <armax> HenryG/dougwig
21:55:32 <HenryG> Nothing of great interest is happening
21:55:39 <armax> HenryG: nothing?
21:55:49 <HenryG> Just mundane things
21:55:52 <armax> didn’t you see my amazing patches?
21:56:08 <HenryG> That's api-ref
21:56:11 <armax> no
21:56:15 <armax> that one
21:56:36 <armax> the one that introduced the plugin registry, I’ll be working on bringing the context and policy engine to neutron lib later today
21:57:14 <armax> or directory as I have actually called it
21:57:20 <HenryG> OK I didn't see you took it out of WIP
21:57:24 <armax> but I am open to suggestion
21:57:26 <armax> s
21:57:42 <kevinbenton> what is the reason for brining the policy engine into neutron-lib
21:57:54 <armax> kevinbenton: because the context depends on it
21:58:05 <armax> but maybe I can get away with it
21:58:19 <armax> I haven’t actually finished everything up
21:58:23 <kevinbenton> ack
21:58:32 <armax> ok
21:58:47 <dougwig> kevinbenton: neutron-policy-oslo-thing-wrapper-lib, of course.
21:58:51 <armax> 2 minutes left, I am no longer running these meeting as effeciently as I used to
21:58:55 <armax> I am getting sloppy
21:59:04 <boden> there are a few other interesting patches for review in lib.. such as the callback api updates and hacking checks rollout using incubation
21:59:08 <boden> if you get time
21:59:27 <armax> boden: aye, I’ll try to be more involved in neutron-lib this cycle
21:59:32 <boden> or at least I want you to think they’re interesting
21:59:40 <HenryG> And this one is lib-related: https://review.openstack.org/337731
21:59:55 <armax> HenryG: ack
21:59:57 <armax> ok
22:00:01 <armax> we’re almost at time
22:00:08 <mlavalle> boden: are you the author?
22:00:13 <armax> thanks everyone for joining
22:00:18 <hichihara> bye
22:00:20 <hoangcx> bye
22:00:21 <armax> and safe travels if you’re going to the summity
22:00:24 <armax> #endmeeting