21:00:28 <armax> #startmeeting networking
21:00:29 <openstack> Meeting started Mon Nov 14 21:00:28 2016 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:34 <openstack> The meeting name has been set to 'networking'
21:00:36 <njohnston> o/
21:00:39 <mlavalle> o/
21:00:41 <lindycoder> o/
21:00:44 <HenryG> o/
21:00:44 <amuller> o/
21:00:44 <kevinbenton> hi
21:00:47 <electrocucaracha> o/
21:00:47 <armax> hello everyone
21:00:48 <hichihara> hi
21:01:29 <armax> let’s dive in
21:01:36 <armax> #topic Announcements
21:01:54 <dougwig> o/
21:01:56 <armax> Liberty is about to be EOL
21:02:05 <Swami> hi
21:02:21 <armax> this means a few things
21:03:14 <armax> a) infra changes will take place in order to drop support to the branch
21:03:46 <armax> b) mitaka becomes the next one to be targeted for EOL
21:04:07 <armax> the EOL date for mitaka is set to be 2017-04-10
21:04:14 <HenryG> c) https://review.openstack.org/393973 can merge
21:04:42 <armax> HenryG: aye
21:05:22 <armax> when reviewing stable patches or triaging bug reports
21:05:34 <armax> please take into account of the fact that mitaka is security fixes only
21:05:53 <armax> next announcement
21:06:04 <armax> Ocata-1 is nearly upon us
21:06:16 <armax> dasm will cut the release sometime this week
21:06:23 <dasm> aye
21:07:12 <armax> we’ve been always pretty lax about what hash we pick for the first milestone
21:08:01 <armax> of the neutron projects that follow the release:cycle-with-milestones
21:09:37 <armax> however, if there’s stadium related work that you’d like to see included in the milestone of the project of your choice, bear in mind that you have just a few days left
21:10:29 <armax> by the end of the week, I’ll go back to https://review.openstack.org/#/c/389397/ and reassess where we are once again
21:12:16 <armax> one thing to take into account when dealing with testing and CI of neutron stadium projects, is the adoption of xenial
21:12:48 <armax> since newton, xenial is used as default ubuntu node
21:13:10 <armax> the neutron team has been looking at this and you can find more details in http://lists.openstack.org/pipermail/openstack-dev/2016-November/107151.html
21:13:29 <armax> we already switched over pretty much everywhere except fullstack, functional and rally
21:13:39 <njohnston> The infra folks have been very good enforcing xenial while riding herd on the gush of neutron stadium project-config patches.
21:14:08 <armax> njohnston: nice
21:14:27 <armax> that said, if you end up spotting a gap where you’re still using trusty when you should not
21:14:41 <armax> make sure you plug the hole to avoid surprises down the road
21:16:19 * armax makes a note to switch gate-tempest-dsvm-neutron-src-neutron-lib to xenial
21:17:19 <armax> anyone else has anything to announce?
21:17:22 <armax> remind us?
21:18:18 <armax> ok, looks like you’re all shy
21:18:23 <armax> or have nothing to share
21:18:25 <armax> moving on
21:18:31 <armax> #topic blueprints
21:19:09 <armax> anyone has anything to share on OVO/no API downtime?
21:19:42 <armax> anything that’s blocked/needs review help/bike shedding/ you name it?
21:19:59 <kevinbenton> i'm going to need some eyes on a few changes
21:20:19 <kevinbenton> impacting both engine facade and push notifications
21:20:25 <armax> you got the stage
21:20:36 <kevinbenton> getting rid of the last of those GUARD_TRANSACTION flags
21:20:41 <armax> kevinbenton: patch #s?
21:20:53 <kevinbenton> armax: one sec
21:21:19 <kevinbenton> the patches in this dependency chain
21:21:20 <kevinbenton> https://review.openstack.org/#/c/396015/
21:21:28 <armax> kevinbenton: ack
21:21:28 <kevinbenton> i will clean them up today
21:21:58 <kevinbenton> but basically each place where we use GUARD_TRANSACTION means we emit AFTER events still inside of a transaction
21:22:00 <armax> kevinbenton: is this link better?
21:22:03 <armax> #link https://review.openstack.org/#/q/topic:bug/1540844
21:22:21 <armax> or rather
21:22:23 <armax> #link https://review.openstack.org/#/q/topic:bug/1540844+status:open
21:22:39 <kevinbenton> yeah, that's good. i think it's missing one but i'll update the topic for it
21:22:44 <armax> aye
21:22:48 <armax> btw, needless to say
21:23:22 <electrocucaracha> from the ovo implementation perspective, the patch for router, router route and floating ip (https://review.openstack.org/#/c/307964/) it's blocking another patches, more eyes on that are welcoming
21:23:30 <armax> it’s the responsibility or core reviewers to help review all the effort with high priority for Ocata
21:23:48 <armax> *of
21:24:52 <armax> if you are a core reviewer and you are struggling to keep up with your review duties this cycle
21:25:01 <armax> please come and talk to me
21:25:38 <armax> I have noticed that many reviewers have been dropped dramatically
21:26:09 <dougwig> guilty. i'll start putting some time blocks into my calendar, so they don't get eaten up.
21:26:26 <armax> dougwig: thanks
21:26:55 <armax> ok, if no-one has anything to add to this section of the meeting, let’s move on
21:27:00 <armax> #topic Bugs and gate failures
21:27:52 <armax> andreas shared this ealier today:
21:27:54 <armax> #link http://lists.openstack.org/pipermail/openstack-dev/2016-November/107232.html
21:28:45 <armax> if you have a few minutes to spare, please check if you can help squash some of the bugs highlighted
21:29:23 <armax> fwiw I’d like to raise awareness on bug 1629133
21:29:23 <openstack> bug 1629133 in Magnum "New neutron subnet pool support breaks multinode testing." [Undecided,In progress] https://launchpad.net/bugs/1629133 - Assigned to Spyros Trigazis (strigazi)
21:29:38 <armax> this bug has quite a long story
21:30:05 <armax> and the recent change to neutron as default in devstack-gate has caused some havoc as mordred pointed out
21:30:28 <armax> IMO, this is all due to a botched up patch to support subnetpools for the trove project
21:30:57 <kevinbenton> is that something we can revert or skip temporarily while it's worked out?
21:31:13 * mordred wants to be helpful in whatever way possible
21:31:24 <armax> kevinbenton: I provided some suggestions here:
21:31:26 <armax> https://review.openstack.org/#/c/381965/
21:32:02 <armax> if anyone is willing to clean this up in devstack, it’s much appreciated it
21:33:11 <armax> mordred: I’d love to get this past us, but I am yet to be convinced there’s anything that we can do in neutron proper
21:33:23 <mordred> I am willing to do some devstack hacking, but usually fear I lack enough context on the neutron side ot be able to make good decision
21:33:45 <kevinbenton> is the devstack change invasive?
21:33:59 <armax> kevinbenton: the devstack change fiddles with the routing table of the host
21:34:04 <armax> and the host loses connectivity
21:35:12 <armax> anyhow
21:35:19 <kevinbenton> well i can look into it this afternoon if nobody else is on it and can ping mordred for devstack help :)
21:35:28 <armax> kevinbenton: thanks
21:35:33 <mordred> kevinbenton: woot! I'm super happy to help and/or hit things iwth sticks
21:35:38 <armax> we have electrocucaracha as deputy for the week
21:35:43 <mordred> kevinbenton, armax: thankyou
21:35:51 <armax> mordred: sure thing
21:36:17 <armax> is there anyone willing to volunteer for the week of 21st?
21:36:43 <armax> being the week of thanksgiving, perhaps it’s not gonna be superbusy?
21:36:59 <armax> who wants to lose the opportunity for a lightweight deputy week?
21:37:04 <kevinbenton> i can do it :)
21:37:22 <armax> kevinbenton: you sure?
21:37:30 <armax> you’re not stretched thin are you?
21:37:41 <kevinbenton> that's why i picked the easy week :)
21:37:47 <armax> kevinbenton: fair enough
21:37:56 <armax> #action kevinbenton deputy for the week of Nov 21st
21:38:22 <armax> ok
21:38:24 <armax> moving on
21:38:28 <armax> #topic Docs
21:38:38 <armax> anything anyone is willing to share here?
21:39:14 <armax> we still have a few docs patches in flight that are needed to document features for newton, both in openstack-manual and neutron-lib/api-ref
21:39:45 <armax> It’d strongly encourage people to review
21:39:47 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=doc
21:40:30 <armax> next topic
21:40:36 <armax> # transition to OSC
21:41:03 <armax> any devstack reviewer with superpowers listening here?
21:41:21 <armax> there’s a patch in devstack that helps switch to openstack CLI for all networking related bugs
21:41:26 <armax> s/bugs/commands
21:41:30 <armax> #link https://review.openstack.org/#/c/391188/
21:41:47 <armax> sc68cal: ^
21:42:22 <armax> I’ll look at grenade next
21:43:01 <armax> reedip: if you can unblock https://review.openstack.org/#/c/393011/, that would be great
21:43:44 <armax> bear in mind that OSC extensions for high level services will need to be well undergoing by now
21:44:31 <armax> dynamic-routing, fwaas, sfc, bgpvpn etc they all have to be close to getting these completed and functional
21:45:12 <armax> anything anyone wants to add?
21:45:29 <armax> #topic neutron-lib
21:45:48 <HenryG> hi
21:45:54 <armax> HenryG: anything worth sharing?
21:46:07 <HenryG> There are many patches in flight
21:46:16 <HenryG> Please review :)
21:46:17 <armax> HenryG: narrow down, please?
21:46:26 <mlavalle> HenryG: any priorities?
21:46:56 <HenryG> I have not prepared a list, I can send an email
21:47:08 <mlavalle> HenryG: ++
21:47:33 <HenryG> Some decision needs to be made on the workflow
21:47:42 <armax> I have a patch in the works to adopt some of the latest additions to neutron-lib
21:47:43 <armax> #link https://review.openstack.org/#/c/386845/
21:48:07 <armax> I am still battling with test insanity, but I am seeing the light at the end of the tunnel
21:48:20 <armax> HenryG: fire away
21:48:34 <HenryG> Workflow: https://review.openstack.org/331338
21:49:11 <armax> so shall I assume that your call for decision translated into ‘please review https://review.openstack.org/#/c/331338/'?
21:50:00 <HenryG> yes, it will help avoid procedural questions in code reviews
21:50:10 <njohnston> +1
21:50:21 <armax> ok
21:50:33 <armax> #topic open discussion
21:50:41 <armax> we have a bullet point from dasm
21:50:50 <HenryG> I have one too
21:51:08 <dasm> armax: we do?
21:51:18 <armax> Deprecation policy
21:51:26 <armax> on
21:51:29 <armax> #link https://wiki.openstack.org/wiki/Network/Meetings#On_Demand_Agenda
21:51:30 <dasm> True. completely forgot about that :)
21:52:00 <armax> personally I don’t see a difference between the code being deprecated
21:52:10 <armax> so long as the code it’s exercised in neutron
21:52:12 <armax> it must be covered
21:52:28 <armax> until it’s remove
21:52:29 <armax> d
21:52:41 <armax> does that answer your question?
21:53:02 <HenryG> +1
21:53:16 <armax> HenryG: your turn?
21:53:23 <HenryG> OK
21:53:27 <dasm> armax: yep, thx
21:53:34 <HenryG> Due to changes at work I will be ramping down my involvement in upstream Neutron.
21:53:47 <kevinbenton> :'(
21:53:53 <mlavalle> :(
21:54:05 <armax> HenryG: I would want to make a joke to cheer the mood up, but I can’t
21:54:21 <armax> HenryG: you’ll be sorely missed
21:54:22 <dasm> :/
21:54:33 <amuller> HenryG: shit =/
21:54:38 <hichihara> :(
21:54:39 <njohnston> :(
21:54:52 <armax> HenryG: please hand over your badge on your way out?
21:54:53 <armax> :S
21:54:58 <SridarK_> HenryG: sigh
21:55:01 <mlavalle> I think amuller elonquently expressed the team's feeling
21:55:13 <armax> mlavalle: amuller is the potty mouth of the group
21:55:33 <dougwig> o rly?
21:55:38 <HenryG> Well, I'll still be around a little on most days
21:55:41 * mlavalle surprised about that
21:55:54 <armax> HenryG: ack
21:56:13 <HenryG> And I have a thing or two to wrap up
21:56:15 <armax> thanks, I hope we can still reach out from time to time to get clarification of how to clean up the mess you leave behind?
21:56:30 <HenryG> But I would suggest looking for another oslo liason
21:56:31 <armax> there, I found energy to make at least a few jokes
21:56:37 <armax> HenryG: aye
21:57:31 <armax> #action neutron oslo liasion for hire
21:57:41 <HenryG> I will always be reachable in IRC
21:58:12 <armax> HenryG: thanks, should circumstances change in the future, you’ll always be welcome
21:58:40 <armax> thanks for all the late hour reviews and more
21:58:50 <HenryG> Thanks, circumstances always change
21:59:13 <HenryG> Neutron is the best project to work with
21:59:29 <armax> and on this note…
21:59:29 <HenryG> Because of all you folks
21:59:51 <armax> I think it’s best way to close the recorded notes!
22:00:08 <armax> thanks everyone!
22:00:11 <armax> #endmeeting