14:00:19 <rossella_s> #startmeeting networking
14:00:21 <openstack> Meeting started Tue Dec  6 14:00:19 2016 UTC and is due to finish in 60 minutes.  The chair is rossella_s. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:25 <openstack> The meeting name has been set to 'networking'
14:01:00 <ataraday> hi
14:01:02 <rossella_s> I hope somebody is there for the team meeting or are you all on holidays?
14:01:25 <rossella_s> ataraday, hi
14:01:27 <johnsom> o/
14:01:34 <rossella_s> #topic Announcements
14:01:47 <dasm> o/
14:02:05 <rossella_s> just wanted to reminder reviewers to have a look at the dashboard to identify priorities
14:02:11 <rossella_s> #link http://status.openstack.org/reviews/
14:02:41 <rossella_s> the PTG is also approaching
14:02:42 <alraddarla_> o/
14:02:53 <dasm> talking about priorities.
14:02:53 <rossella_s> #link https://www.openstack.org/ptg/
14:02:58 <dasm> next week is O-2
14:03:01 <dasm> #link https://releases.openstack.org/ocata/schedule.html#o-2
14:03:33 <rossella_s> dasm indeed
14:04:01 <rossella_s> I don't have any other announcement, let's move on
14:04:17 <rossella_s> #link https://launchpad.net/neutron/+milestone/ocata-2
14:04:31 <rossella_s> #topic blueprints
14:04:57 <rossella_s> I wanted to give an update regarding the sec group logging blueprint
14:05:08 <rossella_s> #link https://review.openstack.org/#/c/203509/
14:05:26 <rossella_s> the spec is in a good shape and I'd like to ask other people to review it
14:06:14 <rossella_s> does anybody want to add anything else about blueprints?
14:06:44 <ataraday> enginefacade is in progress :)
14:07:07 <rossella_s> ataraday, great!
14:07:51 <rossella_s> #topic OVO/no API downtime?
14:07:57 <ataraday> it will require several refactors which are in progress. I want to ask to take a look at this https://review.openstack.org/#/c/398873/ breaking one :)
14:08:35 <korzen> Hi, so we are progressing with OVO adoption
14:08:36 <rossella_s> It seems I have changed topic too early
14:08:42 <korzen> #link https://review.openstack.org/#/q/topic:bp/adopt-oslo-versioned-objects-for-db
14:09:03 <korzen> I have updated the devref
14:09:08 <korzen> #link https://review.openstack.org/#/c/336518/ Docs for NeutronDbObject:
14:09:09 <rossella_s> korzen, cool
14:09:22 <korzen> Ihar has updated the spec:
14:09:28 <korzen> #link https://review.openstack.org/386685 Plan to support no-downtime upgrade for neutron-server
14:09:43 <korzen> please take a look and review
14:10:17 <korzen> one thing that is still not addressed is that we have db object as property in NeutronDbObject
14:10:28 <korzen> and it is detached from sesssion
14:10:48 <korzen> which is blocking the integration of OVO with extensions
14:11:04 <korzen> because extensions that are defining the relationship in DB
14:11:31 <korzen> are not able to call its extension when extend_<port/subnet/network>_dict is called
14:11:56 <ataraday> korzen, I faced the same with new enginefacade
14:12:21 <korzen> ataraday, oh, I wanted to get in touch with you to see if you have the solution...
14:13:43 <korzen> the first online data migration will be tried for distributed port binding for LM
14:13:51 <korzen> we will see how it will go
14:14:11 <lindycoder> o/
14:14:19 <korzen> and I guess that is all
14:14:46 <ataraday> korzen, I and Kevin decided to move call extend_<port/subnet/network>_dict under the same session or do context.session.add(obj) before, you can ping me for details
14:15:01 <korzen> ataraday, ok thanks
14:16:21 <rossella_s> korzen, anything else to add?
14:16:33 <korzen> it is all
14:16:40 <rossella_s> korzen, thanks
14:16:50 <rossella_s> #topic Bugs and Gate issues
14:17:21 <rossella_s> keep an eye on the CI and let's try to keep the failure rate of the tests under control
14:17:31 <rossella_s> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate
14:17:50 <johnsom> I wanted to mention that I have finished moving the neutron-lbaas bugs out of the neutron launchpad.
14:18:06 <johnsom> Please move any future lbaas bugs you see to the octavia project.
14:18:25 <rossella_s> thanks johnsom
14:19:08 <rossella_s> it seems the failure rate of the integrated tempest job has a spike
14:19:50 <rossella_s> this week's bug depute is mlavalle, it's probably too early for him
14:19:56 <haleyb_> rossella_s: the grenade job has a spike, fix for that in progress, https://review.openstack.org/#/c/406428/
14:20:18 <haleyb_> rossella_s: i'm actually this week, but the week just started :)
14:20:18 <rossella_s> haleyb_ I was going to ping you next...thanks for the link
14:20:34 <haleyb_> miguel is moving this week
14:20:39 <rossella_s> then the wiki is wrong :D
14:20:47 <haleyb_> yes, i'll fix it
14:21:27 <rossella_s> no, sorry, it was me, the wiki is right
14:21:38 <rossella_s> haleyb_, anything else to report this week?
14:22:17 <haleyb_> there have not been any critical bugs filed this week (yet)
14:22:58 <rossella_s> cool!
14:22:59 <njohnston> o/
14:23:09 <rossella_s> any volunteer for being deputy next week?
14:23:11 <haleyb_> i don't know about last week, but don't remember much, people have been picking things up
14:23:36 <haleyb_> i think miguel is next week
14:24:27 <rossella_s> miguel is week 12/12, right? for me next week should be 19/12
14:25:37 <haleyb_> i'm starting the 5th, he's the 12th
14:25:46 <rossella_s> any volunteer for week starting the 19th?
14:26:08 <rossella_s> maybe korzen ?
14:26:34 <korzen> rossella_s, I'm planning to have time off next week
14:26:43 <john-davidge> I can do it again if there are no other volunteers
14:27:00 <rossella_s> john-davidge, thanks a lot!
14:27:07 <rossella_s> it's going to be a quiet week I think
14:27:07 <john-davidge> rossella_s: No problem :)
14:27:28 <john-davidge> Unless Santa's workshop runs on neutron...
14:27:47 <rossella_s> #action john-davidge bug deputy for week the 19th
14:28:07 <rossella_s> #topic Docs
14:28:20 <rossella_s> any update on this?
14:29:43 <john-davidge> Trunking guide patch is v close to merging https://review.openstack.org/#/c/361776/
14:30:03 <rossella_s> sweet
14:30:08 <john-davidge> Currently just needs naother docs core, but neutron reviewers always welcome
14:30:14 <john-davidge> *another
14:30:38 <rossella_s> :)
14:31:11 <rossella_s> #topic OSC transition
14:31:41 <rossella_s> amotoki is not around
14:32:25 <njohnston> I hope amotoki is feeling better, I had heard he was sick
14:32:37 <rossella_s> I hope that too
14:33:33 <rossella_s> during last team meeting armax was asking for volunteers to work on this front
14:33:40 <rossella_s> please stand up if you'd like to help
14:34:59 <rossella_s> #topic Neutron-lib and planned neutron refactoring
14:35:43 <HenryG> hi
14:35:52 <rossella_s> HenryG, hi!
14:36:12 <rossella_s> HenryG, can you update us on the neutron lib work?
14:36:35 <HenryG> Most of the impacting patches I proposed and alerted about have merged
14:36:50 <rossella_s> nice
14:36:56 <HenryG> It seems the world did not come to an end
14:37:07 <HenryG> Next up is https://review.openstack.org/399891
14:37:16 <sindhu> rossella_s: a lot of OSC work is being taken by ppl here at OSIC and all the major transitions have patches already https://etherpad.openstack.org/p/osc-neutron-support
14:37:43 <HenryG> I will rebase it shortly
14:37:45 <rossella_s> HenryG, :)
14:37:57 <rossella_s> sindhu, thanks !
14:38:09 <lindycoder> Regarding the migration to neutron-lib, i know there's the blueprints but it seems to only be listing done items, is there a list somewhere to nice to have stuff i could give a hand with?
14:39:20 <HenryG> lindycoder: search for "from neutron\." in codesearch.o.o
14:39:25 <HenryG> http://codesearch.openstack.org/?q=from%20neutron%5C.&i=nope&files=&repos=
14:40:02 <HenryG> Every import from neutron (outside neutron itself) must be addressed
14:40:28 <lindycoder> Oh that's a good resource, thanks
14:41:55 <HenryG> There's also an etherpad, trying to find it
14:42:33 <HenryG> https://etherpad.openstack.org/p/nl-planning
14:42:53 <HenryG> ^^ needs more TLC
14:44:13 <lindycoder> (sorry... TLC?)
14:44:21 <HenryG> tender loving care
14:44:29 <lindycoder> Ah of course :)
14:45:46 <HenryG> Also this link:
14:45:47 <HenryG> https://review.openstack.org/#/q/status:open+message:%22NeutronLibImpact%22
14:45:56 <HenryG> (from the agenda)
14:47:22 <rossella_s> anything else or we can close the meeting?
14:47:34 <HenryG> that's all from me
14:48:12 <electrocucaracha> just a FYI, the oslo guys are planning to release an oslo.db soon
14:49:19 <rossella_s> thanks electrocucaracha
14:49:26 <rossella_s> I think that's all then
14:49:28 <rossella_s> thanks everybody!
14:49:37 <rossella_s> #endmeeting