21:00:31 <armax> #startmeeting networking
21:00:31 <openstack> Meeting started Mon Dec 12 21:00:31 2016 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:33 <abhiraut> hi
21:00:34 <openstack> The meeting name has been set to 'networking'
21:00:56 <armax> Hello everyone
21:01:08 <annp> Hi
21:01:13 <armax> let’s jump in
21:01:23 <bzhao> gn
21:01:36 <manjeets> 0/
21:01:48 <armax> #topic Announcements
21:01:57 <armax> not much since last week
21:02:09 <armax> needless to say, this week is Ocata-2
21:02:31 <armax> https://releases.openstack.org/ocata/schedule.html
21:03:00 <armax> so dasm and I will work to find a good cut for O-2 by mid-week
21:03:17 <dasm> yep
21:03:56 <armax> anyone else has anything else as far as announcements/reminders go?
21:04:56 <johnsom> Just to move any lbaas related bugs over to the "octavia" project in launchpad.
21:05:12 <armax> johnsom: thanks
21:05:15 <johnsom> If new ones come in.
21:05:22 <armax> we should at least tag both projects
21:05:42 * mlavalle takes note since i will be the bug deputy this week
21:05:58 <armax> cool
21:06:00 <armax> moving on
21:06:03 <armax> #topic Blueprints
21:06:20 <armax> #link https://launchpad.net/neutron/+milestone/ocata-2
21:06:29 <armax> I went through this dasbhboard last week
21:06:46 <armax> and added some status updates here and there
21:07:19 <armax> if you are an approver/assignee, please consider providing more coments on the whiteboards
21:07:33 <armax> and work with your peer to make sure the blueprints make steady progress
21:07:38 <armax> with holidays looming over
21:07:49 <armax> and feature freeze happening sooner than usual this cycle
21:07:59 <njohnston> o/
21:08:01 <armax> there’s not much time left for squashing this existing backlog
21:08:57 <armax> ihrachys: anything worth sharing on OVO/no API downtime effort?
21:09:09 <ihrachys> actually yes :) several things
21:09:18 <armax> ihrachys: go for it, you own the floor
21:09:37 <ihrachys> we have a pool of patches that I believe are ready for a second reviewer attention
21:09:39 <ihrachys> #link https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db+label:Code-Review%252B2
21:10:00 <ihrachys> also, https://review.openstack.org/#/c/403832/ should be ready but I can't +2 myself ;)
21:10:31 <armax> ack
21:10:40 <ihrachys> there is also a spec up for review describing the high level approach for no-downtime upgrades that is probably ready too: https://review.openstack.org/#/c/386685/
21:11:04 <armax> #action core team to squash OVO list asap
21:11:07 <ihrachys> of course there is a lot more in the queue than that as can be seen in https://review.openstack.org/#/q/status:open+project:openstack/neutron+branch:master+topic:bp/adopt-oslo-versioned-objects-for-db
21:11:32 <ihrachys> but most of this work is in progress, though quite some patches need just a tiny nudge from authors to get ready
21:11:45 <armax> ack
21:11:49 <ihrachys> that's it from the upgrades subteam, we'll keep you all updated ;)
21:11:57 <mlavalle> ihrachys: this one is good to go https://review.openstack.org/#/c/393150/
21:12:00 <mlavalle> also
21:12:06 <armax> ihrachys: are you getting enough help from rossella_s?
21:12:18 <ihrachys> mlavalle: oh right, that one too, it has a different topic, thanks!
21:12:33 <ihrachys> armax: I could use a lot more ;)
21:12:48 <mlavalle> ihrachys: i'll change the topic so it shows in that query
21:13:03 <ihrachys> mlavalle: makes sense, thanks
21:13:16 <armax> ihrachys: you should nudge rossella :)
21:13:25 <ihrachys> while at it, I'd like to publicly praise what mlavalle did in comments for https://review.openstack.org/#/c/393150/
21:13:37 <armax> but we’ll get these patches on their way to gerrit heaven
21:13:55 <ihrachys> that's what you may call taking an extra mile... anyhoo
21:14:01 <armax> ihrachys: what did he do?
21:14:13 <mlavalle> ihrachys: thanks :-)
21:14:14 <armax> let’s praise him while we’re at it
21:14:17 <armax> :)
21:14:20 <ihrachys> armax: I do nudge, sometimes it doesn't magically result in action, but we do our best.
21:14:31 <ihrachys> armax: let's praise him irrespective of what he did!
21:14:44 <ihrachys> mlavalle is awesome, hail mlavalle!
21:14:59 <ihrachys> anyway, I think we can move on
21:15:01 <mlavalle> Thanks again!
21:15:03 * electrocucaracha is praising
21:15:08 <manjeets> mlavalle, :)
21:15:15 <armax> I am bowing, but irc doesn’t show
21:16:05 <mlavalle> :-)
21:16:20 <armax> ok moving on
21:16:30 <armax> #topic bugs and gate failures
21:17:12 <n91634> I am remote so can't paste failure rate link
21:17:22 <armax> http://grafana.openstack.org/dashboard/db/neutron-failure-rate
21:17:23 <n91634> this is HALEYB
21:18:07 <n91634> anyways uptick in hate failure this morning
21:18:07 <armax> looks like fullstack is sick
21:18:43 <armax> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=7&fullscreen
21:19:09 <armax> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=6&fullscreen
21:19:15 <haleyb__> logs were showing dbdeadlock failures
21:19:19 <armax> #link http://grafana.openstack.org/dashboard/db/neutron-failure-rate?panelId=5&fullscreen
21:19:43 <armax> the last two are the key indicators for something bad happening in the gate
21:20:07 <armax> we have also a stadium-wide bell weather here:
21:20:09 <armax> #link http://grafana.openstack.org/dashboard/db/neutron-lib-failure-rate?panelId=4&fullscreen
21:20:42 <ihrachys> armax: but it's only fullstack trusty?
21:20:49 <ihrachys> armax: which is Mitaka-- at this point
21:21:08 <armax> ihrachys: yeah
21:21:11 <armax> I was going to say
21:21:13 <armax> xenial looks fine
21:22:07 <ihrachys> we don't have much patches in mitaka
21:22:12 <armax> ihrachys: action item for you and/or kuba to see what’s going on?
21:22:22 <ihrachys> so it may as well be a single hit total that resulted in 100%
21:22:26 <armax> ihrachys: true
21:22:30 <ihrachys> armax: ack on action item
21:22:37 <armax> but it usually doesn’t spike that abrubtly
21:22:43 <haleyb__> is this due to neutron lib bug filed today or yesterday ?
21:22:58 * armax goes and look
21:23:19 <armax> haleyb: any hint on what that might be?
21:23:31 <mlavalle> haleyb__: ^^^
21:23:33 <armax> there are hundreds of bugs filed per day :)
21:23:42 <haleyb__> although neutron would not be gating with that right ?
21:24:01 <armax> nothing stands out here:
21:24:04 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=lib
21:24:18 <armax> ihrachys: thanks
21:24:25 <haleyb__> I am on phone don't have number handy but patch for the one I'm thinking of already out
21:24:34 <armax> haleyb: what is that about?
21:24:48 <armax> haleyb: perhaps we can find it if you could give us a clue
21:24:56 <armax> or just let’s take this offline
21:25:15 <haleyb__> I'll look for link
21:25:28 <ihrachys> functional is definitely not ok though :-| 40% steady failure rate
21:25:32 <armax> nothing stands out here too
21:25:34 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=gate-failure
21:26:47 <haleyb__> https://bugs.launchpad.net/bugs/1649079
21:26:48 <openstack> Launchpad bug 1649079 in neutron "TypeError seen on gate-neutron-lib-api-ref" [Undecided,In progress] - Assigned to YAMAMOTO Takashi (yamamoto)
21:27:07 <mlavalle> haleyb__: thanks for the link
21:27:07 <armax> haleyb: yo rock
21:28:17 <armax> this is somewhat different though
21:28:21 <armax> api-ref is a doc job
21:28:21 <haleyb__> I have no idea if that's it 😀
21:28:47 <haleyb__> I was just remembering job failures
21:28:52 * armax makes a note to review taht one
21:28:57 <armax> haleyb: fair enough, kudos
21:29:25 <armax> does anyone know on the top of their head is neutron-lib is part of the integrated gate?
21:29:32 <armax> I would be tempted to say yes
21:29:49 <haleyb__> mlavalle I do see the flusherror in some of the logs too
21:30:19 <mlavalle> haleyb__: yeah, it must be common
21:30:33 <mlavalle> thnaks for the notes
21:30:39 <ihrachys> armax: not sure what you mean, but since it's a lib released on pypi and consumed thru reqs.txt, I would say no, it should have an intependent queue in zuul
21:30:52 <armax> ihrachys: I’ll double check
21:31:35 <armax> thanks
21:32:09 <armax> this week we have mlavalle as deputy, anymoe interested to be deputy for the week prior to Christmas?
21:32:15 <armax> that should be easy picking, not
21:32:45 <mlavalle> yes, I will be on bugs duty this week :-)
21:33:46 <ihrachys> I see huge turnout
21:33:47 <armax> mlavalle: thanks
21:34:00 <armax> yes, ihrachys, please folks not all at once
21:34:06 <mlavalle> lol
21:34:23 * armax watches the stampede
21:34:52 * electrocucaracha still waiting for that
21:35:05 <armax> I’ll give it a shot
21:35:19 <dasm> praise our PTL!
21:35:22 <ihrachys> thanks armax for volunteering!
21:35:25 <ihrachys> that's the spirit!
21:35:28 <ankur-gupta-f1> way to go
21:35:29 <dasm> ihrachys: ++
21:35:31 <armax> #action armax deputy for week of Dec 19th
21:35:37 <electrocucaracha> merry christmas armax
21:35:48 <armax> I said I’d do it
21:35:54 <armax> that doesn’t mean I’ll do a good job
21:35:57 <armax> :)
21:36:00 <manjeets> lol
21:36:11 <dasm> oh come on. no one expects good job!
21:36:20 <ihrachys> and now, he already threatens us!
21:36:32 <armax> you’re all going to pay for this
21:36:33 <electrocucaracha> I haven't done a good job even during non-xmas time
21:36:33 <ihrachys> I am sure armax can't do a bad job
21:36:38 <armax> I was going to take some time off before the holiday
21:37:00 <ankur-gupta-f1> armax: I can sub in if needed just ping me
21:37:28 <armax> ankur-gupta-f1: anyone should be welcome to step in and help review any bug report that comes our way
21:37:42 <armax> after all launchpad is open to anybody
21:37:56 <armax> ankur-gupta-f1: but thanks, I’ll keep that in mind!
21:38:08 <armax> ok
21:38:11 <armax> moving on
21:38:15 <armax> #topic OSC
21:38:39 <abhiraut> for the refactor stuff things picked up
21:38:46 <armax> abhiraut has kindly volunteered to help keep an eye on patches that currently are keeping our client queue busy
21:38:53 <abhiraut> ack
21:39:00 <armax> mainly related to OSC transition bits
21:39:18 <abhiraut> a new action item has been added to https://etherpad.openstack.org/p/osc-network-command-sdk-support
21:39:27 <armax> I also heard from amotoki that he’ll be back in full force to help the team squash bits and pieces all over the client repo
21:39:39 <abhiraut> to complete the SDK refactor
21:39:45 <armax> abhiraut: any patch that requires immediate attention from any of us?
21:39:45 <abhiraut> thats good news :)
21:39:51 <abhiraut> i shall ping
21:39:57 <sindhu> armax: all the major commands the needs transition have patches out https://etherpad.openstack.org/p/osc-neutron-support
21:40:07 <armax> sindhu: ack
21:40:20 <abhiraut> but the etherpad is updated and we have a decent amount help from volunteers
21:40:33 <armax> I need to double check a patch from reedip for gateway-set/clear commands
21:40:45 * armax makes a mental note
21:41:09 <sindhu> armax: there is another blueprint to track the work on missing options https://etherpad.openstack.org/p/network-commands-options-sprint
21:41:09 <armax> abhiraut: cool, most of these patches are on the openstackclient/sdk end right?
21:41:13 <abhiraut> yes
21:41:24 <electrocucaracha> my understanding is that ankur-gupta-f1 has made a great job coordinating OSIC efforts for OSC
21:41:27 <abhiraut> and sindhu has provided the link to CLi. so thanks
21:41:44 <armax> hail to ankur-gupta-f1
21:41:48 <ankur-gupta-f1> armax: there are 2 efforts under way as neutron-client plugins. For Tag and Dynamic Routing. But aside from that most are in OSC and SDK
21:41:48 <abhiraut> electrocucaracha: ack
21:42:13 <armax> ankur-gupta-f1: there are a few more coming up
21:42:20 <armax> ankur-gupta-f1: like fwaas, sfc, et al
21:42:32 <armax> ankur-gupta-f1: these will be all in the neutronclient repo
21:42:32 <abhiraut> fwaas is mostly ready to go
21:42:47 <armax> abhiraut: ack, we need to make sure that the server-side patch is ready to roll then
21:42:55 <abhiraut> ill do another round of review on it
21:42:58 <abhiraut> got it
21:43:08 <armax> ool
21:43:09 <armax> cool
21:43:11 <ankur-gupta-f1> armax: good to know will go through thanks
21:43:37 <armax> ankur-gupta-f1: I asked folks to use topic:stadium-implosion to keep them into one place but to no avail
21:43:50 <armax> ankur-gupta-f1: either way they should be easy to find these days
21:43:56 <ankur-gupta-f1> thinking about putting together a cleaner etherpad for all remaining items
21:44:01 <ankur-gupta-f1> the above etherpad is a mess
21:44:07 <armax> ankur-gupta-f1: maybe the time is ripe
21:44:12 <abhiraut> agreed
21:44:26 <armax> ankur-gupta-f1: like something-something-final-steps
21:44:48 <ankur-gupta-f1> Will pull all together and have link up on meeting agenda soon
21:44:53 <armax> ankur-gupta-f1: you can link it here:
21:44:54 <armax> https://bugs.launchpad.net/neutron/+bug/1521291
21:44:55 <openstack> Launchpad bug 1521291 in neutron "[RFE] Transition neutron CLI from python-neutronclient to python-openstackclient" [Wishlist,Triaged] - Assigned to Akihiro Motoki (amotoki)
21:45:02 <ankur-gupta-f1> done deal
21:45:20 <armax> ok
21:45:28 <armax> abhiraut, ankur-gupta-f1: anything else?
21:45:32 <armax> if not, moving on
21:45:36 <abhiraut> nothing else comes to my mind
21:45:53 <ankur-gupta-f1> nope
21:46:05 <armax> #topic neutron-lib, planned refactoring and other impacts
21:46:28 <armax> there are a few changes in the pipeline
21:46:56 <armax> last periodic check on the lib-dashboard looks good, so we should be able to nudge one more in the gate
21:47:10 <armax> the most scary one I can think of is those from Ann
21:47:27 <ihrachys> session to context?
21:47:39 <armax> ihrachys: aye
21:48:16 <armax> I am thinking of nudging this one first https://review.openstack.org/#/c/403329/
21:48:22 <armax> as the base patch merged
21:48:24 <armax> without havoc
21:48:52 <ihrachys> armax: seems like it's not rebased on latest?
21:49:17 <armax> ihrachys: do you think gerrit will barf at the end?
21:49:29 <armax> when it attempts to merge?
21:49:32 <ihrachys> I don't think it will even put it into zuul
21:49:43 <ihrachys> we need to rebase, then push
21:49:49 <armax> it’s churning now
21:49:51 <ihrachys> ok rebased
21:50:07 <armax> damn
21:50:09 <armax> I saw it in the gate
21:50:14 <dasm> ihrachys: afaik, gerrit wouldn't complain if it's not rebased.
21:50:16 <armax> it was fine I think
21:50:21 <armax> oh well
21:50:21 <ihrachys> armax: ok assume I don't know shit
21:50:27 <dasm> ihrachys: you broke everything :'(
21:50:44 * armax makes a note that ihrachys doesn’t know manure as per his own words
21:50:51 <dasm> :)
21:51:08 <ihrachys> armax: anyhoo it should be easy to push it once more :)
21:51:23 <armax> ihrachys: you increased global warming right there
21:51:34 <armax> ihrachys: lots of CO2 emission for nothing
21:51:37 <armax> anyhoo
21:51:41 <ihrachys> it's pretty cold down here, I don't see how it's an isuse
21:51:53 <electrocucaracha> lol
21:51:54 <armax> ihrachys: it’s all relative, my friend, it’s all relative
21:51:59 <armax> butterfly effect
21:52:19 <armax> anyhoo, my suggestion is to eye Ann’s patches next
21:52:35 <armax> I need to get on with my context patches
21:52:46 <dasm> ihrachys: we'll talk about CO2 when you'll move to CA
21:52:49 <armax> but I found a pretty big flaw in the way the context was exported in the first place
21:53:10 <armax> dasm: if he doesn’t hurry there won’t be anything he can move to
21:53:40 * ihrachys should get to it with reviews, but I agree with electrocucaracha's sentiment there that TypeDriverNew is not an ideal name
21:53:41 <dasm> xD
21:53:57 <armax> ok
21:54:05 <armax> one more thing related to this section
21:54:46 <armax> when ihrachys does have his brain wired, he has been working on a couple patches that aim at documenting our approach on how to deal with runtime changes
21:55:14 <armax> ihrachys: wanna share with the team?
21:55:39 <ihrachys> yeah, I proposed some policy change that should help us track changes that may affect supported platforms
21:55:40 <ihrachys> #link https://review.openstack.org/#/c/402004/
21:56:07 <ihrachys> tl;dr be more cautious about new runtime deps; and use UpgradeImpact tag in commit message in some more cases
21:56:10 <armax> ihrachys: the gist of it, if you are a core reviewer, before you put something in the gate, think twice
21:56:28 <armax> general rule :)
21:56:38 <armax> in particular, if the change affects the runtime, think three times :)
21:57:19 <armax> #link https://review.openstack.org/#/q/status:open+message:%22UpgradeImpact%22+project:openstack/neutron
21:57:50 <armax> there are a few in the pipeline, we should keep an eye on those
21:58:12 * ihrachys will incorporate the link into upgrades subteam meeting protocol
21:58:53 <ihrachys> btw 2 mins
21:59:14 <armax> ihrachys: ack
21:59:17 <armax> ok
21:59:18 <armax> 1 minute
21:59:28 <armax> #topic open discussion
21:59:29 <bzhao> :)
21:59:37 <armax> anyone has anything to share in <60 sec?
21:59:47 <armax> if not
21:59:49 <dasm> just one thing. liberty is EOL
21:59:51 <ihrachys> I share love
22:00:00 <ihrachys> and appreciation
22:00:01 <mlavalle> Happy Holidays!
22:00:01 <armax> good riddance
22:00:03 <kevinbenton> o/
22:00:28 <armax> bye everone
22:00:30 <armax> everyone
22:00:32 <dasanind> bye
22:00:33 <manjeets> bye
22:00:34 <ihrachys> o/
22:00:36 <sindhu> thabks bye
22:00:37 <bzhao> by
22:00:38 <mmalik4> bye
22:00:44 <armax> thanks for participating
22:00:46 <dasm> thxbye
22:00:46 <armax> #endmeeting