14:01:08 <jlibosva> #startmeeting networking
14:01:09 <openstack> Meeting started Tue Dec 20 14:01:08 2016 UTC and is due to finish in 60 minutes.  The chair is jlibosva. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:12 <bzhao> hello
14:01:14 <openstack> The meeting name has been set to 'networking'
14:01:16 <amotoki> hi
14:01:18 <hichihara> hi
14:01:20 <hoangcx> Hi
14:01:20 <ihrachys> o/
14:01:21 <bcafarel> hello
14:01:27 <jlibosva> #topic Announcements
14:01:27 <korzen> hello
14:01:35 <dasanind> Hi
14:01:36 <annp> hi
14:01:39 <jlibosva> We have a new mechanism for branch management
14:01:45 <jlibosva> #link http://lists.openstack.org/pipermail/openstack-dev/2016-December/108923.html
14:01:59 <jlibosva> Please have a look
14:02:17 <jlibosva> It basically means we'll be able to create new feature or stable branches by sending patches to gerrit
14:02:24 <jlibosva> Pretty cool
14:02:35 <ihrachys> yay, we asked for it for cycles
14:02:39 <amotoki> +100
14:02:46 <jlibosva> There is a proposal to introduce nova-compute-api
14:02:52 <jlibosva> #link https://review.openstack.org/#/c/411527/1
14:03:04 <jlibosva> It can be relevant to us in the meaning of how we interact with nova when plugging a new port
14:03:42 <jlibosva> Next announcement
14:03:46 <jlibosva> New dates for PTL nominations and elections for Pike are now on review
14:03:55 <jlibosva> #link https://review.openstack.org/#/c/404275/
14:04:24 <trevormc> o/
14:04:43 <jlibosva> There is also a discussion about new goal for Pike about supporting Python 3.5
14:04:47 <dasm> jlibosva: are you suggesting to dethrone armax? :)
14:05:08 <jlibosva> dasm: no! Just setting dates in which we're gonna support armax to run for PTL for another cycle :-P
14:05:16 <dasm> \o/
14:05:19 <ihrachys> hehe
14:05:23 <bzhao> :)
14:05:27 <ihrachys> jlibosva: re python3, are you going to take care of it? ;)
14:05:30 <jlibosva> #link https://review.openstack.org/#/c/349069/7
14:05:36 <jlibosva> Python3 link ^^
14:06:03 <ihrachys> I think we may need to set up another job for py3 neutron mode
14:06:29 <dasm> ah right.. i thought we have it already, but it's just for unittests.
14:06:32 <jlibosva> maybe, that's planned for Pike though :)
14:06:49 <jlibosva> right, we do run unittests but they don't guarantee you can run your cloud on Py3 :)
14:07:03 <ajo> late o/
14:07:12 <ihrachys> yeah, but since it may take some time, I would suggest our testing lieutenant to start poking it already
14:07:23 <jlibosva> ihrachys: ok, I'll poke him :)
14:07:29 <dasm> heh
14:07:30 <dasm> *hehe
14:07:39 <ihrachys> jlibosva: him?? :)
14:07:48 <jlibosva> Next good news announcement
14:08:03 <jlibosva> Our Neutron team is growing, we have new members in go-to contacts for certain areas
14:08:10 <jlibosva> Specifically abhiraut is a new contact for clients
14:08:21 <jlibosva> mlavalle is now L3 lieuteant
14:08:33 <jlibosva> And for services we have tidwellr and njohnston
14:08:43 <jlibosva> Congratulations to all and keep up with the good work :)
14:09:24 <ihrachys> nice to see the team regaining for late drop-offs
14:09:27 <jlibosva> You can see updated list of contacts here:
14:09:31 <rossella_s> congratulations!
14:09:32 <jlibosva> https://github.com/openstack/neutron/blob/master/doc/source/policies/neutron-teams.rst#core-review-hierarchy
14:09:41 <bzhao> awesome
14:09:47 <trevormc> haleyb was also added tl L3
14:09:54 <trevormc> to L3* right?
14:10:16 <ajo> congratulations :)
14:10:18 <jlibosva> trevormc: oh, right! Thanks
14:10:30 <trevormc> didnt want to leave anyone out, congrats to all
14:10:32 <jlibosva> so also congratulations haleyb-away
14:10:42 <annp> congratulations :)
14:11:03 <jlibosva> The last announcement is that we're out of Ocata-2 milestone
14:11:25 <jlibosva> Which means we should now focus on o-3 bugs and features
14:11:51 <jlibosva> The list of o-3 seems empty so far but I'd expect it's gonna be filled soon
14:12:16 <jlibosva> anybody wants to announce anything?
14:12:38 <jlibosva> #topic Blueprints
14:13:22 <jlibosva> There are some blueprints tagged for o-2
14:13:37 <jlibosva> which weren't finished, I assume they are gonna be flipped to o-3
14:13:39 <jlibosva> https://launchpad.net/neutron/+milestone/ocata-2
14:14:14 <jlibosva> Is there anybody who gets his BP work blocked by anything or any important patches that lack reviews?
14:14:58 <hoangcx> Security Group Logging is ready to go and really need to get more attention from cores.
14:15:06 <hoangcx> #link https://review.openstack.org/#/c/203509/
14:15:28 <jlibosva> hoangcx: thanks for raising this
14:15:35 <hoangcx> Thanks rossella_s for helping the work as approver
14:15:59 <boden> Also the diagnostics spec is ready for some core reviews; it’s currently a bit rough, but once we can get some direction from cores I’ll solidify it..  https://review.openstack.org/#/c/308973/
14:16:25 <jlibosva> https://review.openstack.org/#/c/308973/
14:16:31 <jlibosva> ^ fixed link for diagnostics :)
14:16:32 <ihrachys> rossella_s: how close are we for logging spec to merge?
14:16:36 <jlibosva> thanks boden
14:16:36 <rossella_s> hoangcx, my pleasure
14:16:48 <amotoki> hoangcx: I was requested to review it from yushiro and will check the spec in a couple of days.
14:17:02 <ihrachys> amotoki: hey! nice to see you back!
14:17:05 <hoangcx> amotoki, Thanks a lot :-)
14:17:05 <amotoki> I will check it from the API perspective.
14:17:07 <rossella_s> ihrachys, from my point of view it's ok but I would like to get more eyes on it
14:17:21 <rossella_s> amotoki, welcome back
14:17:26 <ihrachys> rossella_s: I believe your +2 would help to get that attention :)
14:17:28 <amotoki> thanks. sorry for my absense.
14:18:15 <korzen> how about port binding for Live Migration? https://review.openstack.org/404293
14:18:15 <rossella_s> ihrachys, technically I am not a driver...don't think I am allowed to +2
14:18:28 <ihrachys> rossella_s: any core is allowed to +2, you just can't merge
14:18:43 <korzen> is port binding for LM going to happen in Ocata?
14:18:45 <rossella_s> ihrachys, cool
14:18:54 <ihrachys> rossella_s: and since you are an approver for the feature, it only makes sense for you to assess it for merge
14:19:00 <hoangcx> ihrachys, Oh, Thanks for clarifying the point
14:19:11 <amotoki> korzen: what does LM mean?
14:19:12 <rossella_s> ihrachys, great, will do then
14:19:16 <hichihara> I'm watching the spec as well. I also wait rossella_s's +2 :)
14:19:18 <ihrachys> amotoki: live migration
14:19:41 <jlibosva> korzen: is this the spec https://review.openstack.org/#/c/309416/ ?
14:19:43 <rossella_s> sorry for my misunderstanding
14:19:44 <amotoki> I see. a lot of abbreviation
14:20:05 <korzen> jlibosva, ye
14:20:14 <dasanind> korzen: we have made some good progress for live migration
14:20:34 <jlibosva> so that needs to go in first before code patches get in
14:21:10 <korzen> and we have only 4 weeks
14:21:37 <korzen> we should think of online data migration for that one
14:21:51 <ihrachys> I think it's a classic case of no owner/approver
14:22:04 <ihrachys> for blueprints, we have a person to help with landing
14:22:10 <ihrachys> for bare RFEs we don't
14:22:22 <jlibosva> Would creating a blueprint help with prioritizing the work?
14:22:38 <jlibosva> oh, there is an rfe, sorry
14:22:41 <dasanind> korzen: here is the WIP patch for live migration https://review.openstack.org/#/c/404293/
14:22:44 <ihrachys> jlibosva: I think that's worth exploring, at least raising the flag to armax about it
14:23:09 <jlibosva> #action jlibosva to talk with armax about prioritizing live migration
14:23:48 <jlibosva> any other blueprints that lack attention?
14:24:12 <ihrachys> I will use a separate slot for OVO stuff
14:24:26 <jlibosva> ihrachys: I was just about to ask about it as there are no patches linked on wiki
14:24:31 <jlibosva> #topic OVO/no API downtime
14:24:40 <jlibosva> ihrachys: lead the show
14:24:55 <ihrachys> ok, sec
14:25:12 <ihrachys> there was some progress done on OVO from the prev Monday
14:25:20 <ihrachys> thanks for all reviewers who stepped in!
14:25:35 <ihrachys> there are some more patches in the queue that would benefit from some core reviewer attention
14:25:45 <ihrachys> 1. switching flavour service plugin to OVOs: https://review.openstack.org/#/c/306685/
14:26:13 <ihrachys> 2. there are also several patches in the queue for ml2 type drivers that depend on https://review.openstack.org/#/c/398873/ going in
14:26:25 <jlibosva> #link https://review.openstack.org/#/c/306685/
14:26:27 <jlibosva> #link https://review.openstack.org/#/c/398873/
14:26:28 <ihrachys> I see ataraday just respinned it so it's probably good to go
14:26:39 <ihrachys> I will review the patch after the meeting, and I hope someone else does it too
14:27:01 <ihrachys> I think the patch was advertised as breaking on ML and during prev team meetings, so it should be fine
14:27:13 <ihrachys> we of course will check stadium grafana boards before pulling the lever
14:27:44 <ihrachys> I think that's mostly it for broader team, we will spin a bit more internally before asking for more attention
14:27:53 <jlibosva> thanks ihrachys
14:27:55 <ihrachys> passing the show back
14:28:01 <jlibosva> #topic Bugs and gate failures
14:28:25 <jlibosva> Bug deputy for the last week was mlavalle
14:28:36 <jlibosva> But I see he's not connected
14:28:54 <ihrachys> yeah. I think we had that ask to send email reports if not present during irc meeting
14:28:58 <ihrachys> was it ever documented?
14:29:34 <jlibosva> I don't think that's documented
14:29:53 <ihrachys> ok I can check it and propose a patch if not
14:30:23 <jlibosva> #action ihrachys to check bug deputy policy and whether it's advised to send email if not attending weekly irc meeting
14:30:41 <jlibosva> thanks ihrachys for checking
14:30:50 <jlibosva> we have john-davidge bug deputy this week
14:31:04 <john-davidge> jlibosva: Hi
14:31:06 <jlibosva> and we already have set a bug deputy for the next week - our mighty PTL armax will serve over Christmas
14:31:12 <jlibosva> john-davidge: hi :)
14:31:24 <john-davidge> jlibosva: Pretty quiet so far this week :)
14:31:28 <jlibosva> just updating about bug deputy role
14:32:19 <jlibosva> john-davidge: good :) maybe people are already taking time off for Christmas
14:32:25 <ihrachys> john-davidge: if you think it's quiet, swap chairs with armax!
14:32:31 <ihrachys> that will surely be quiet ;)
14:32:32 <jlibosva> I checked open launchpad bugs for gate-failures and most of them are fixed by now
14:32:43 <jlibosva> We have gate failure open to dvr https://bugs.launchpad.net/neutron/+bug/1649867 though that doesn't have any assignee
14:32:44 <openstack> Launchpad bug 1649867 in tempest "Gate tempest dsvm neutron dvr test fails" [Undecided,Incomplete]
14:33:08 <jlibosva> as per comments it might be issue related to some other existing bug
14:33:18 <jlibosva> any volunteers to look at this one?
14:33:25 <ihrachys> it's a dup
14:33:33 <ihrachys> bug in libvirtd
14:33:45 <ihrachys> since xenial switch, the hypervisor is in xenial
14:33:50 <ihrachys> sorry, in denial
14:33:50 <ihrachys> :)
14:34:10 <jlibosva> ihrachys: do we have a bug # for it?
14:34:28 <ihrachys> bug 1646779
14:34:29 <openstack> bug 1646779 in tempest "libvirt killed by kernel on general protection or stack segment traps" [Undecided,Incomplete] https://launchpad.net/bugs/1646779
14:34:44 <ihrachys> we landed an elastic-recheck query for that lately: https://review.openstack.org/406278
14:34:51 <ihrachys> that should capture all new failures
14:34:57 <ihrachys> if not, consider tweaking the query
14:35:04 <jlibosva> ihrachys: good stuff, thanks
14:35:55 <jlibosva> anybody noticed any other failures or bugs worth highlighting?
14:36:22 <ihrachys> I have small thing
14:36:30 <ihrachys> not a breakage, yet, but gate related
14:36:46 <ihrachys> we have those scenario jobs in experimental queue
14:36:53 <ihrachys> both dvr as well as non dvr
14:37:12 <ihrachys> it turned out that our gate hook always enables dvr tests even for non-dvr setups
14:37:22 <ihrachys> which breaks those jobs if we land DVR scenarios
14:37:41 <ihrachys> so I was working lately on tweaking our gate hook to enable the tests only when DVR is configured for the job
14:37:48 <ihrachys> the result is https://review.openstack.org/#/q/status:open++branch:master+topic:dvr-scenario and I am happy to see reviews
14:38:01 <ihrachys> EOM
14:38:09 <jlibosva> ihrachys: thanks for update
14:38:16 <jlibosva> #link https://review.openstack.org/#/q/status:open++branch:master+topic:dvr-scenario
14:38:29 <jlibosva> I'll also have a look after meeting
14:38:37 <ihrachys> thanks
14:39:02 <jlibosva> #topic Docs
14:39:15 <jlibosva> I don't see Sam-I-Am around
14:39:32 <dasm> jlibosva: afair, john-davidge is docs liaison
14:39:34 <ihrachys> I think someone was to take it over from him?
14:39:37 <ihrachys> right, john-davidge!
14:39:41 <jlibosva> aaah
14:39:45 <jlibosva> john-davidge: hi again :)
14:39:52 <john-davidge> jlibosva: Hello again :)
14:40:02 <jlibosva> john-davidge: do you want to give any updates about docs?
14:40:40 <john-davidge> jlibosva: A couple of patches to highlight for reviews:
14:40:59 <john-davidge> #link https://review.openstack.org/#/c/411463/
14:41:31 <amotoki> shortcut for networking guide reviews:
14:41:35 <amotoki> #link https://review.openstack.org/#/q/status:open+project:openstack/openstack-manuals+path:%255Edoc/networking-guide/.*
14:41:44 <john-davidge> And if anyone has a working auto-allocation-enabled environment I'd appreciate a thumbs up/down on this one: https://review.openstack.org/#/c/410493/
14:42:06 <john-davidge> Haven't had much luck getting a dev env working for that myself
14:43:23 <john-davidge> That's it from me. The transition to OSC commands continues at a good pace.
14:43:48 <john-davidge> Thanks ankur-gupta-f!
14:43:54 <jlibosva> john-davidge: thanks for update :)
14:44:13 <jlibosva> since you mentioned it
14:44:15 <jlibosva> #topic Transition to OSC
14:44:47 <jlibosva> john-davidge: is there anything to update beside it continues at a good pace? :)
14:45:47 <john-davidge> jlibosva: Aha, I'll defer to amotoki on that
14:45:55 <amotoki> hehe
14:45:57 <jlibosva> amotoki: hello :)
14:46:03 <amotoki> I haven't grabbed the status on OSC transition while I was absent...
14:46:09 <amotoki> but I am checking the status this week and will report before the next meeting.
14:46:24 <ihrachys> I think john-davidge mentioned docs transition to providing examples with OSC instead of neutronclient CLI
14:46:35 <ihrachys> not transition itself
14:46:40 <jlibosva> amotoki: ok, thanks. And welcome back, it's good to have you :)
14:47:05 <amotoki> ihrachys: that's true, but checking documents is one of the works of OSC transition.
14:47:14 <amotoki> it helps us identify the gap.
14:48:11 <jlibosva> #topic Neutron-lib and planned neutron refactoring
14:48:21 <jlibosva> HenryG: are you around?
14:48:35 <HenryG> I am
14:48:47 <ihrachys> lol
14:48:58 <ihrachys> neutron is not going to let you off, never
14:49:11 <HenryG> I know o_O
14:49:28 <boden> I can add a few neutron-lib details if HenryG doesn’t have any
14:49:36 <jlibosva> boden: that would be good :)
14:49:37 <HenryG> I will defer to boden
14:49:41 <jlibosva> HenryG: sorry for pinging :D
14:50:23 <boden> we recently had some neutron-lib hacking check patches land. There’s still some related work in progress but I’d encourage folks to have a look at:
14:50:25 <boden> #link https://github.com/openstack/neutron-lib/blob/master/doc/source/usage.rst
14:50:51 <boden> a number of the patches for review now are related to api-def for subprojects and for neutron extensions
14:51:15 <boden> I’ve noticed a few core reviewers on neutron-lib patches, but would encourage other cores to try and find a little time to review the lib patches
14:51:18 <ihrachys> boden: dasm: what's the release plan for those bits we landed already?
14:51:26 <amotoki> boden: that's my fault. I am taking some of them over and rebasing for reviews.
14:51:45 <dasm> ihrachys: neutron-lib is planned to be released after xmas
14:51:56 <dasm> ihrachys: prob 1st, 2nd week of Jan
14:52:08 <ihrachys> ok I hope it will not take till o-3 and we will have some more time till final Ocata release
14:52:33 <ihrachys> so that we have time to fix any issues we unveil with adoption of new bits
14:52:59 <dasm> in that case, we should double confirm with armax, who decided about deferring it till next year.
14:53:13 <dasm> but i believe we will have enough time to verify it before o3
14:53:18 <boden> dasm: we actually did discuss with armax the other day..> I can tryh to find the IRC log
14:53:35 <ihrachys> no, I think it's correct to defer to after xmas
14:53:43 <ihrachys> just hopefully not to after o3 :)
14:53:49 <dasm> boden: afair, reedip was also involved in this. and armax decided it should be after xmas
14:54:03 * dasm looking through logs for details
14:54:14 <boden> dasm: that’s what I remember too
14:54:24 <amotoki> Jan 16-20 is the week of lib freeze and it sounds a good idea to release neutron-lib in 1st or 2nd week of Jan.
14:55:16 <boden> search for ‘release of neutron-lib’ in #link http://eavesdrop.openstack.org/irclogs/%23openstack-neutron/%23openstack-neutron.2016-12-15.log.html
14:55:24 <boden> for a discussion of release dates for neutron-lib
14:55:32 <dasm> boden: http://eavesdrop.openstack.org/irclogs/%23openstack-neutron/%23openstack-neutron.2016-12-15.log.html#t2016-12-15T21:48:00
14:55:59 <ihrachys> ack. 5 mins!
14:56:08 <dasm> amotoki: ack
14:56:22 <ataraday_> Hi, everyone! sorry, for being very late... Can I ask for some attention for this refactoring change https://review.openstack.org/#/c/398873/? This refactor is need for refactor of segments db. Which is needed for new engine facade
14:56:26 <jlibosva> good to have this cleared :) Any other updates about lib?
14:56:39 <boden> I don’t have any other lib updates myself
14:56:53 <jlibosva> boden: thanks
14:56:59 <jlibosva> #topic Open discussion
14:57:00 <ihrachys> ataraday_: yeah, I mentioned that before. I will review
14:57:07 <boden> ataraday_ I’ll try to make a pass through the libimpact patches today
14:57:20 <ataraday_> ihrachys, boden Thanks!
14:57:36 <jlibosva> The on demand agenda is empty
14:57:46 <jlibosva> anybody has any topic he'd like to discuss?
14:57:54 <jlibosva> we have 2 minutes :)
14:57:55 <ihrachys> then we can use 3 mins for coffee woot
14:58:09 <jlibosva> or we can sing chorals
14:58:11 <dasm> enjoy xmas time folks!
14:58:26 <dasm> btw. any updates on next meetings?
14:58:38 <dasm> ive seen, ihrachys sent message that upgrades one is cancelled
14:58:45 <amotoki> I think everyone is having coffee or some during the meeting :)
14:58:47 <ihrachys> that's prolly armax to ask
14:58:56 <ihrachys> but I don't expect one in next week ;)
14:58:58 <jlibosva> I would expect next meeting to be cancelled. I guess armax will send an email :)
14:59:00 <mlavalle> danm, did I miss the meeting?
14:59:10 <jlibosva> mlavalle: nope, you still have a minute
14:59:18 <ihrachys> haha
14:59:21 <john-davidge> mlavalle: now 30 seconds :)
14:59:25 <ihrachys> and counting
14:59:31 <mlavalle> sorry, I thought it was now
14:59:31 <dasm> mlavalle: yes. we tried to praise you, but because you've missed it... you don't get anything
14:59:48 <john-davidge> Happy holidays everyone!
14:59:49 <mlavalle> as far as bugs, it was relatevile quiet
14:59:51 <jlibosva> ok, thanks folks for showing up :) Enjoy Christmas
14:59:58 <hichihara> bye
14:59:59 <bzhao> bye, happy christmas
15:00:00 <trevormc> thanks
15:00:02 <dasm> thanks all
15:00:06 <electrocucaracha> thanks
15:00:08 <jlibosva> mlavalle: thanks for update! :)
15:00:10 <jlibosva> #stopmeeting
15:00:11 <dasanind> Happy holidays thank you
15:00:12 <hoangcx> thanks
15:00:16 <annp> Happy Xmas, bye
15:00:17 <dasm> jlibosva: wrong command :)
15:00:22 <amotoki> jlibosva: endmeeting instead
15:00:24 <jlibosva> #endmeeting