21:01:12 <armax> #startmeeting networking
21:01:12 <openstack> Meeting started Mon Feb  6 21:01:12 2017 UTC and is due to finish in 60 minutes.  The chair is armax. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:13 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:15 <openstack> The meeting name has been set to 'networking'
21:01:18 <hichihara> hi
21:01:40 <armax> let’s dive in with the announcements
21:01:51 <armax> #topic Announcements and Reminders
21:02:01 <armax> Today it is my last meeting as chair and PTL
21:02:14 <armax> which reminds me that if you have not voted for your next PTL, please do
21:03:09 <armax> also the PTG is only a few weeks away
21:03:23 <armax> #link https://etherpad.openstack.org/p/neutron-ptg-pike
21:03:34 <armax> please, make sure you check it out if you haven’t already
21:03:34 <mlavalle> in 2 weeks, really
21:04:04 <sindhu> hi
21:04:31 <armax> the drivers team and the new PTL is going to announce a more formal agenda and organization based on the input gathered on taht etherpad
21:05:05 <armax> #link https://review.openstack.org/#/c/429855/
21:05:14 <armax> Pike is officially open as of last friday
21:05:40 <armax> so don’t forget to rebase your patches, specs or otherwise, to make sure you’re targeting the current master release
21:06:11 <armax> we have still a number of outstanding issues we’d like to pull into ocata
21:06:17 <armax> but gate instability is getting in the way
21:06:32 <armax> hopefully we’ll be in a much better shape by the end of this week
21:07:03 <armax> as Ocata is nearly officially closed, please make sure you look at the postmortem
21:07:04 <armax> #link https://review.openstack.org/#/c/425990/
21:07:13 <armax> in case there’s any last minute exception that can be allowed
21:07:40 <armax> tag ocata-rc-potential any bug you think it’s worth looking at
21:07:44 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=ocata-rc-potential
21:08:00 <armax> and ping the release team in IRC for any urgent matter
21:08:44 <armax> we have time until Feb 17th-ish to nail down release candidates
21:09:26 <armax> expect an RC2 between the end of this week and the next, so if you can make sure we have a solid RC1
21:12:17 <armax> finally
21:12:22 <armax> #link https://review.openstack.org/#/c/389397/
21:12:55 <armax> even though this is dragged a little longer than I anticipated, I think it’s fair to say that this is capturing the steady state and it’s ready for merging
21:13:07 <armax> we’ll close on the last items, since Pike has opened up
21:13:24 <armax> questions/comments/anything that comes to mind?
21:13:55 <mlavalle> armax: to thank you for your leadership over the past few cycles
21:14:16 <mlavalle> you did a great job as our PTL. Thanks
21:14:47 <ihrachys> CI meeting announcement, a new meeting has started on Tues, and the next will be tomorrow. anyone interested in gate stability and evolution, please join.
21:14:49 <armax> mlavalle: I couldn’t have done it with the great team I had around me
21:14:57 <armax> I was enabled to do well, thanks you you all
21:15:08 <ihrachys> mlavalle++
21:15:14 <hichihara> +1000
21:16:03 * haleyb thinks we all owe armax a beer
21:16:39 <hichihara> ihrachys: What time?
21:16:59 <ihrachys> hichihara: it's 16pm UTC: http://eavesdrop.openstack.org/#Neutron_CI_team
21:17:08 <hichihara> ihrachys: Thanks
21:17:24 <ihrachys> haleyb: we do, but if everyone who owes gives one, we can loose armax
21:17:38 <armax> hichihara: http://lists.openstack.org/pipermail/openstack-dev/2017-January/111292.html
21:17:52 <armax> ihrachys: I can pace myself slowly :)
21:18:06 <hichihara> armax: Thank you!
21:18:13 <ihrachys> your steadiness is well known, yes
21:18:18 <armax> :)
21:18:21 <armax> ok, moving on
21:18:43 <armax> #topic https://wiki.openstack.org/wiki/Network/Meetings#Blueprints
21:18:52 <armax> we are in https://launchpad.net/neutron/+milestone/ocata-rc1
21:18:54 <armax> #link https://launchpad.net/neutron/+milestone/ocata-rc1
21:19:24 <armax> if your name shows up on any of those items, please take 2 minutes of your time to make sure information captured is current
21:19:38 <armax> I’ll try to have a pass by the end of the week, when/if we roll over to RC2
21:19:59 <armax> also the list of bugs captured in obviously unrelealistic for an RC window
21:20:07 <armax> so I’ll be moving some to Pike-1
21:20:14 <armax> if you beat me to it, I’ll be grateful
21:21:59 <hichihara> armax: I believe tag enhance can be in ocata https://review.openstack.org/#/c/429621/
21:22:15 <armax> hichihara: yes, I have it on my radar
21:22:28 <hichihara> armax: Thanks
21:24:01 <armax> #topic Gate issues and bugs
21:24:05 <armax> as ihrachys beat me to it
21:24:29 <armax> there’s a weekly meeting solely dedicated to CI matters
21:24:57 <armax> nonetheless it’s good to take a couple of minutes here to catch people up
21:25:35 <armax> we’ve been fighting with oom-kill failures in the gata
21:25:36 <armax> gate
21:25:47 <armax> I am attempting a temporary stop-gap here
21:25:53 <armax> https://review.openstack.org/#/c/429069/
21:26:06 <armax> as it sounds like we reached a resource ceiling
21:26:25 <armax> if any of you has time to go assessm why memory bloated as much as it has over the span of two releases
21:26:58 <armax> then you deserve a beer much more than I do :)
21:27:12 <armax> ultimately this is an openstack wide issue
21:27:24 <armax> as not just neutron grew as much as it did
21:27:46 <armax> the long discussion, if you’re intereted
21:27:48 <armax> #topic http://lists.openstack.org/pipermail/openstack-dev/2017-February/111413.html
21:27:51 <armax> #undo
21:27:51 <openstack> Removing item from minutes: #topic http://lists.openstack.org/pipermail/openstack-dev/2017-February/111413.html
21:27:53 <armax> #link http://lists.openstack.org/pipermail/openstack-dev/2017-February/111413.html
21:29:12 <armax> did the topic change back?
21:29:14 <armax> not sure
21:29:25 <armax> #topic Gate issues and bugs
21:29:29 <mlavalle> armax: it did
21:29:41 <armax> anyhow
21:29:48 <armax> anything to add here?
21:30:53 <armax> I see a long list of confirmed gate failure bugs
21:30:55 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.tag=gate-failure
21:31:34 <hichihara> I'd like to know some bugs
21:31:37 <hichihara> We had some issues of FWaaS gate.
21:31:44 <hichihara> #link https://bugs.launchpad.net/neutron/+bug/1661418
21:31:44 <openstack> Launchpad bug 1661418 in neutron "neutron-fwaas functional tests do not execute" [Critical,Confirmed]
21:31:45 <armax> hichihara: on stable/newton
21:31:54 <hichihara> yes
21:31:55 <armax> we’re good now
21:32:05 <armax> the one you mentioned, it’s still open
21:32:06 <ihrachys> no tests executed is master thing
21:32:10 <armax> njohnston: ^
21:32:26 <hichihara> armax: Could you update the status? bug/1661419 bug/1661420
21:32:31 <njohnston> yes, I am working on that now, experimenting with a few things
21:32:56 <armax> I just did a second ago
21:33:03 <hichihara> armax: Sorry. You done. I missed.
21:33:14 <armax> hichihara: I did while watching the bugs now :)
21:34:04 <hichihara> That's all from me
21:34:14 <armax> ack
21:34:23 <armax> we need a deputy for next week
21:34:35 <armax> it might as well be me
21:34:46 <armax> as I will be on the lookout for RC issues
21:34:58 <armax> helping the new PTL having a smooth transition is the least I can do :)
21:35:12 <armax> #action armax deputy for the week of Feb 13
21:35:37 <ihrachys> thanks armax
21:35:41 <hichihara> +1
21:36:11 <armax> ok
21:36:12 <armax> moving on
21:36:16 <armax> #topic Docs
21:36:30 <armax> boden did a great job looking at the list
21:36:39 <armax> #link https://bugs.launchpad.net/neutron/+bugs?field.tag=doc
21:36:45 <armax> please keep an eye on it as well
21:36:59 <armax> we’re trying to organize a cross-project session with the docs team at the PTG
21:37:09 <armax> stay tuned for more info, if you’re interested
21:37:52 <armax> anything to add?
21:38:00 <armax> if not we’ll move to the next topic
21:38:27 <armax> #topic OSC/client
21:38:46 <armax> abhiraut, amotoki: ping
21:38:54 <armax> ankur-gupta-f1: ping
21:39:31 <abhiraut> i added some reviews in the etherpad which lists a few feature gaps for resources
21:39:39 <abhiraut> like ports fips etc
21:39:47 <abhiraut> which are in review in osc
21:40:06 <armax> abhiraut: ack
21:40:18 <abhiraut> for Pike i think we have 3 big ticket items
21:40:28 <abhiraut> a couple of them in decent shape
21:40:41 <abhiraut> i dont see a bug for release candidate in the review queue
21:40:53 <armax> what do you mean?
21:41:08 <abhiraut> i mean… for RC .. client seems good :)
21:41:19 <armax> right, but client is released and we’re in freeze
21:41:23 <abhiraut> yeah
21:41:23 <armax> :)
21:41:30 <armax> unless we have the world falling on us
21:41:32 <armax> we should be good
21:41:36 <abhiraut> ack
21:41:41 <armax> if that’s what you mean :)
21:41:53 <abhiraut> yeah.. nothing that we released is falling on us
21:41:56 <armax> good
21:41:58 <sindhu> abhiraut: is there a etherpad ur using to track OSC work?
21:42:01 <armax> you scared me a little
21:42:02 <abhiraut> yes
21:42:14 <abhiraut> ^^https://etherpad.openstack.org/p/osc-transition-priorities
21:42:25 <sindhu> abhiraut: thanks :)
21:42:46 <abhiraut> thank you sindhu
21:42:58 <armax> abhiraut: so now that master is open, we’ll keep on chewing on those reviews
21:43:04 <abhiraut> ack
21:43:14 <armax> moving on?
21:43:31 <armax> moving on!
21:43:34 <armax> actually
21:43:42 <armax> there was a patch on osprofiler for neutronclient
21:43:47 <armax> I was not sure if OSC supported it
21:43:57 <armax> https://review.openstack.org/#/c/281508/
21:44:10 <armax> being the client in lockdown mod
21:44:11 <armax> e
21:44:18 <armax> we want to consider what to do with that one
21:44:46 <abhiraut> ok.. ill take a look and see if we need to do get this in neutronclient if osc is not supporting
21:44:48 <armax> ihrachys, kevinbenton either one of you will need to make an executive decision as soon as Wednesday
21:45:00 <armax> abhiraut: thanks
21:45:10 <ihrachys> why Wed exactly
21:45:34 <armax> isn’t that when the election results are announced?
21:45:38 <armax> or is it Thursday?
21:45:51 <ihrachys> oh you mean AFTER Wed, not TILL Wed
21:46:26 <armax> not sure when the poll closes
21:46:37 <kevinbenton> as soon as == as early as
21:46:37 <ihrachys> I am sure we will be able to come up with resolution irrespective of who is the next ptl
21:46:46 <ihrachys> it closes in a day
21:46:51 <armax> ok, if there’s nothing else on OSC/client
21:47:12 <armax> moving on to
21:47:33 <armax> #topic neutron-lib
21:47:56 <armax> there’s quite a queue of impactful changes
21:48:06 <armax> but we were in freeze mode due to the release
21:48:20 <armax> now that Pike is open we can relax things a little but not yet
21:48:31 <armax> for two reasons
21:48:54 <armax> 1) we’re still in release mode and some subprojects have not cut stable/ocata yet
21:49:24 <armax> 2) we cannot release a neutron-lib version until the requirement freeze is lifted
21:50:12 <boden> so realistically we won’t see much movement until after the PTG.. sound like a fair assumption?
21:50:26 <armax> so if you’re doubtful, err on the side of caution and avoid approving anything you fear might break something
21:50:51 <armax> boden: maybe up until
21:50:56 <armax> kevinbenton: did I say that correctly?
21:51:25 <kevinbenton> If we're in requirements freeze
21:51:25 <armax> boden: we’ll have to assess how we are before the PTG
21:51:36 <kevinbenton> Why does it matter what we do in neutron lib?
21:52:27 <armax> we may need a new neutron-lib release
21:53:03 <boden> armax: true, but in reality new rehomed function is dead code until someone starts consuming it :)
21:53:49 <armax> right, but when you do, you may realize you need a new release
21:54:13 <armax> my point being, please don’t let the release freeze stop you from reviewing
21:54:15 <boden> armax: and that’s fine, no one broke as a result
21:54:50 <armax> and be careful if you think something is trivial enough that can be merged
21:55:13 <kevinbenton> Is it like opposite day?
21:55:32 <kevinbenton> Trivial patches cant merge but untested scary patches can?
21:55:32 <armax> not sure I know what that means
21:55:38 <armax> oh
21:55:40 <kevinbenton> :)
21:55:42 <armax> yes
21:55:44 <armax> :)
21:55:45 <armax> no
21:55:48 <armax> maybe
21:56:13 <armax> ok
21:56:17 <armax> 4 minutes for the
21:56:24 <armax> #topic Open Discussion
21:56:35 <armax> can someone eyeball https://review.openstack.org/#/c/416380/?
21:57:14 <armax> anything else worth raising now?
21:57:29 <armax> anything we may want to take to the neutron channel?
21:57:48 <kevinbenton> I would like to land some massive last minute refactors to see if anything breaks
21:58:05 <armax> let’s talk offline :)
21:58:12 <armax> I don’t like the sound of that
21:58:22 <armax> ok, if there’s nothing else
21:58:24 <armax> it’s been a pleasure serving this community
21:58:36 <armax> thanks and bye bye
21:58:52 <kevinbenton> armax: speech, speech, speech!
21:59:07 <armax> I just did
21:59:09 <njohnston> armax: Go with our gratitude.
21:59:16 <armax> kevinbenton: ^
21:59:19 <armax> didn’t you like it?
21:59:24 <armax> #endmeeting