14:00:01 <jlibosva> #startmeeting networking
14:00:02 <openstack> Meeting started Tue Apr 11 14:00:01 2017 UTC and is due to finish in 60 minutes.  The chair is jlibosva. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:05 <openstack> The meeting name has been set to 'networking'
14:00:08 <jlibosva> Hi everyone!
14:00:11 <mlavalle> o/
14:00:12 <dasm> o/
14:00:14 <haleyb> hi
14:00:16 <jlibosva> #topic Announcements
14:00:20 <hichihara> hi
14:00:35 <ralonsoh> hi
14:00:43 <john-davidge> hi
14:00:52 <annp> hi
14:00:55 <jlibosva> Regarding Boston summit, there are already topics for The Forum
14:01:01 <jlibosva> http://forumtopics.openstack.org/
14:01:23 <jlibosva> Next announcement is that TC elections are gonna start soon
14:01:25 <jlibosva> https://governance.openstack.org/election/#pike-tc-candidates
14:01:37 <bcafarel> hello
14:01:40 <jlibosva> and that's all I had :)
14:01:52 <jlibosva> anybody else wants to announce something?
14:01:56 <dasm> one more thing. this is Pike-1 release week
14:02:18 <jlibosva> https://releases.openstack.org/pike/schedule.html#p-1
14:02:30 <dasm> so, around Thu, we will cut it. AFAIR it won't change anything, with development.
14:02:52 <jlibosva> beside flipping bugs set to milestone 1 to milestone 2 maybe
14:03:03 <jlibosva> dasm: thanks for that announcement
14:03:18 <jlibosva> anything else?
14:03:55 <jlibosva> #topic Blueprints
14:04:10 <jlibosva> so as it was said, we are still before p1 cut
14:04:12 <jlibosva> https://launchpad.net/neutron/+milestone/pike-1
14:04:39 <jlibosva> I think those blueprints that didn't make it to p1 will be rescheduled
14:04:52 <jlibosva> anybody has anything that blocks the work on blueprint that is worth highlighting here?
14:05:23 <annp> yes, i have one.
14:05:33 <jlibosva> good
14:05:38 <annp> For the logging api spec link https://review.openstack.org/#/c/203509 this spec has been updated more than 4 week ago. However we didn’t get any review or comments. So I’d like to get more attention on that.
14:06:22 <jlibosva> annp: do you know if it was discussed on the drivers mtg?
14:06:53 <annp> jlibosva: I don't know.
14:07:10 <jlibosva> annp: ok, I'll try to sync with somebody from drivers and remind that one
14:07:10 <annp> Do you have any news from drivers mtg?
14:07:28 <annp> jlibosva: thank you. :)
14:07:32 <jlibosva> #action jlibosva to sync with drivers about https://bugs.launchpad.net/neutron/+bug/1468366
14:07:33 <openstack> Launchpad bug 1468366 in neutron "[RFE] (Operator-only) Logging API for security group rules" [Wishlist,In progress] - Assigned to Nguyen Phuong An (annp)
14:07:33 <hichihara> It looks like the spec should be reviewed and given +1 by ovs and ovn folks.
14:08:17 <jlibosva> I should also read as it's realted to ovs fw :)
14:08:22 <jlibosva> annp: thanks for bringing this up
14:08:29 <jlibosva> anybody else has anything?
14:09:03 <jlibosva> #topic Bugs and gate failures
14:09:17 <amotoki> hi, sorry for late
14:09:41 <annp> jlibosva, hichihara: thanks for your support. :)
14:09:51 <jlibosva> amotoki: hi :)
14:09:52 * ihrachys says late hi
14:10:00 <jlibosva> you were the bug deputy last week?
14:10:33 <amotoki> yeah, I was a bug deputy last week, but it was a quiet week.
14:10:51 <jlibosva> we like quiet weeks :)
14:10:56 <mlavalle> ++
14:11:33 <jlibosva> amotoki: so nothing to report, right?
14:11:53 <amotoki> yeah, I have nothing to raise.
14:11:58 <jlibosva> good
14:12:15 <jlibosva> so we can pick volunteer for this week if hasn't been picked on the last meeting
14:12:17 * jlibosva checks
14:12:40 <jlibosva> anybody wants to take the role this week?
14:13:07 <jlibosva> otherwise I guess I can take it with hope it's gonna be yet another quite week :)
14:13:24 <trevormc> I can do it
14:13:35 <jlibosva> trevormc: ah, cool! thanks for stepping up
14:13:50 <jlibosva> #info trevormc is bug deputy for week of Apr 10
14:13:51 <dasm> trevormc: you've saved jlibosva :)
14:14:03 <amotoki> anybody for the next week?
14:14:06 <jlibosva> seems like quite weeks are attractive :)
14:14:47 <ihrachys> now you know how to lurk people into a trap
14:14:58 <jlibosva> nobody for next week? I can take it if nobody wants
14:15:29 <jlibosva> ok, sold to me
14:15:50 <jlibosva> #info jlibosva is bug deputy for week of Apr 17
14:16:13 <jlibosva> I guess we can move on then
14:16:21 <jlibosva> #topic Docs
14:16:23 <jlibosva> john-davidge: yo
14:16:34 <john-davidge> jlibosva: yo
14:16:45 <jlibosva> john-davidge: any updates from the docs team
14:17:16 <john-davidge> As well as the regular mentions of continuing progress on the OSC and RFC 5737 fronts, I'd like to draw the team's attention to - https://review.openstack.org/#/c/445536/
14:17:44 <john-davidge> It's a new governance tag concerning cooperation with the openstack-manuals team to publish and maintain docs
14:18:33 <john-davidge> The neutron team is already actively involved in most or all of the required activities, but it's something to keep an eye on as there will now be requirements to get the tag
14:20:28 <jlibosva> john-davidge: is that all for docs?
14:20:36 <john-davidge> jlibosva: That's it
14:20:40 <amotoki> I also filed a bug https://bugs.launchpad.net/openstack-manuals/+bug/1675840 on OSC migration.
14:20:42 <openstack> Launchpad bug 1675840 in openstack-manuals "CLI reference of networking commands should be generated from OSC" [Medium,Confirmed] - Assigned to fupingxie (fpxie)
14:20:42 <jlibosva> john-davidge: ok, thanks for updates
14:21:21 <amotoki> I asked the docs team to generate networking commands referneces based on OSC plugins.
14:21:54 <jlibosva> amotoki: thanks
14:21:59 <amotoki> we don't need to hurry, but it is nice to generate CLI reference for advanced networking services.
14:22:25 <john-davidge> amotoki: Thank's, it helpful to track that separately from the Networking Guide chnages
14:23:00 <ni291187> which meeting is currently going on?
14:23:07 <jlibosva> ni291187: networking
14:23:16 <jlibosva> it's in the topic for this channel
14:23:17 <ni291187> thanks
14:23:25 <amotoki> ni291187: aka the neutron team meeting
14:24:20 <jlibosva> I think we can move on to the next topic unless somebody wants to share something regarding docs
14:24:20 <mlavalle> aka the Neutrinos
14:24:28 <jlibosva> let's move on
14:24:30 <jlibosva> #topic Transition to OSC
14:24:33 <jlibosva> amotoki: hi again :)
14:24:39 <reedip_> o/
14:24:52 <amotoki> OSC migration is a good progress
14:24:53 <reedip_> looks like I came at the right time :)
14:25:08 <amotoki> i would like to share this https://docs.google.com/spreadsheets/d/1ueCvIKUfpUaLFm_3YTT4MkuTV-PYIdeErnt7Wleshl0/edit#gid=0
14:25:38 <amotoki> 8 remaining commands.  4 are related to L3 agent management and it is in good progress
14:25:58 <amotoki> remaining 3 commands are related to 'tag'.
14:26:37 <amotoki> I think the work is stuck a bit and will check the progress this week
14:26:52 <amotoki> if necessary I will work on it including SDK support
14:27:00 <reedip_> amotoki : I can help out with tag if required
14:27:08 <jlibosva> amotoki: does stuck mean it's blocked by anything?
14:27:19 <jlibosva> or just lacks traction?
14:27:27 <amotoki> jlibosva: I don't see a progress for a while
14:28:29 <amotoki> artur is assigned to this, but after discussion at PTG we needed to refresh the work completely.
14:28:54 <ihrachys> artur?
14:28:56 <amotoki> I discussed with OSC core team and we changed the approach
14:29:07 <amotoki> i might be wrong. let me check
14:29:10 <jlibosva> https://review.openstack.org/#/c/396727/ ?
14:29:15 <jlibosva> Ankur :)
14:29:25 <ihrachys> makes sense
14:29:46 <amotoki> sorry typo
14:29:48 <reedip_> amotoki : I can discuss with ankur and help him out with this ...
14:30:10 <amotoki> okay, I will follow it up
14:30:58 <jlibosva> #action reedip_ to sync with ankur about neutronclient OSC tags support
14:31:03 <hichihara> I should review it too ;)
14:31:32 <amotoki> reedip_: let's check the current status after the meeting
14:31:40 <jlibosva> it sounds like the approach is gonna be different, right? so we currently don't have any patch to review
14:31:49 <reedip_> amotoki : sure
14:32:00 <jlibosva> amotoki: reedip_ thanks!
14:32:18 <jlibosva> I guess we can jump to the next topic, right?
14:32:26 <amotoki> jlibosva: sure
14:32:32 <jlibosva> I saw boden connected, are you already here?
14:32:39 <boden> hi yes
14:32:42 <jlibosva> cool :)
14:32:43 <jlibosva> #topic Neutron-lib and planned neutron refactoring
14:32:59 <boden> neutron-lib 1.4.0 was recently released. thanks to all who helped including dasm and ihrachys
14:33:26 <boden> among other things 1.4.0 contains a change (https://review.openstack.org/#/c/453063/) that may help subprojects adopt the db facade
14:34:01 <boden> also lib 1.4.0 also syncs up the callbacks from neutron; expect to see lib impact changes that start moving us onto lib's callbacks soon
14:34:35 <boden> finally there's a handful of patches that could use some review lovin on the queue (https://review.openstack.org/#/q/project:openstack/neutron-lib+status:open)
14:35:10 <boden> if no questions/comments I don’t have anything else worth noting at the moment
14:35:19 <jlibosva> boden: thanks for updates
14:35:27 <ihrachys> thanks for working on it boden
14:35:31 <mlavalle> boden: did you mean to draw attention to a couple of reviews? whick ones?
14:35:46 <ihrachys> we can now unblock https://review.openstack.org/#/c/446730/ right?
14:35:47 <hichihara> boden: Good work!
14:35:56 <ihrachys> now that we have a release
14:36:12 <ihrachys> with disabled log translation enforcement
14:36:21 <amotoki> ihrachys: i think so
14:36:25 <ihrachys> ok will do
14:36:25 <boden> ihrachys: sounds reasonable
14:36:57 <hichihara> Master branch is still 1.3.0 https://github.com/openstack/neutron/blob/master/requirements.txt#L18
14:37:17 <jlibosva> does it mean we'll need to remove all translations from Neutron before next neutron-lib release?
14:37:28 <amotoki> hichihara: https://review.openstack.org/#/c/455286/
14:37:32 <ihrachys> jlibosva, kinda
14:37:44 <ihrachys> jlibosva, alternative being disabling the new check for the time being
14:37:47 <jlibosva> oh, I see there is already a patch for it :)
14:37:50 <ihrachys> if we see we can't make it
14:37:58 <hichihara> amotoki: cool!
14:38:12 <amotoki> we need to wait a bit
14:38:24 <hichihara> Right
14:39:14 <jlibosva> anything else to be added for neutron-lib topic?
14:39:36 <boden> nothing from me
14:39:40 <jlibosva> there was no topic added to "On demand agenda"
14:39:50 <jlibosva> #topic Open discussion
14:40:10 <jlibosva> anybody wants to discuss any topic here?
14:40:14 <jlibosva> we have 20 minutes :)
14:40:20 <amotoki> I have small announcements for the team
14:40:30 <jlibosva> amotoki: stage is yours
14:40:48 <amotoki> the one is about neutron stadium project dashbaord http://lists.openstack.org/pipermail/openstack-dev/2017-April/115200.html
14:41:20 <amotoki> perhaps we will go to a route that each project has a corresponding dashboard project
14:41:38 <amotoki> the other thing is also related to the dashboard.
14:41:51 <amotoki> Dropping nova-network support in horizon: http://lists.openstack.org/pipermail/openstack-dev/2017-April/115194.html
14:42:17 <amotoki> it seems no objection on dropping nova-net support in pike from horizon.
14:42:34 <robcresswell> +1, you have my full support :)
14:42:46 <john-davidge> Hooray! \o/
14:42:47 <amotoki> this topic also raises us an interesting topic: how client python binding should be.
14:43:24 <amotoki> if you are interested in the topic, check the thread!
14:43:28 <amotoki> that's all from me.
14:43:55 <jlibosva> thanks amotoki
14:44:28 <jlibosva> and yay for deprecating nova-network horizon support
14:44:30 <jlibosva> :)
14:44:47 <jlibosva> s/depracating/dropping
14:44:57 <amotoki> neutron will be the world of networking? :)
14:45:04 <ihrachys> it is already
14:45:10 <ihrachys> some just haven't noticed
14:45:26 <mlavalle> ihrachys: you got it ++
14:45:28 <ihrachys> that rock they live under must be heavy
14:46:39 <reedip_> amotoki : that also means changes in OSC for nova-network ( maybe in Q cycle ) , isnt it?
14:46:54 <amotoki> reedip_: no
14:47:29 <amotoki> reedip_: dtroyer is working on its own support of nova-net in OSC as shade does
14:48:00 <reedip_> oh , maybe I missed that part, thanks :)
14:48:22 <amotoki> reedip_: you should check the side discussion on python binding on the horizon thread above
14:48:58 <jlibosva> so unless there is another topic to discuss I think we can end earlier and spend those 15 minutes more effectively :)
14:49:03 <jlibosva> well, 10 minuts
14:49:04 <reedip_> ok amotoki .. thanks for the headsup :)
14:49:36 <jlibosva> ok, thanks all for showing up :)
14:49:41 <jlibosva> keep up the good work
14:49:44 <amotoki> we can focus on P-1 :)
14:49:44 <jlibosva> #endmeeting