14:00:03 <jlibosva> #startmeeting networking
14:00:05 <openstack> Meeting started Tue Sep 26 14:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is jlibosva. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:08 <openstack> The meeting name has been set to 'networking'
14:00:10 <jlibosva> Hello everyone
14:00:36 <jlibosva> #topic Announcements
14:00:45 <annp_> hi
14:00:46 <bcafarel> hello
14:00:47 <haleyb> hi
14:00:47 <mlavalle> o/
14:00:57 <ralonsoh_> hi
14:01:16 <jlibosva> the PTL role has been transitioned to mlavalle : http://lists.openstack.org/pipermail/openstack-dev/2017-September/122004.html
14:01:34 <jlibosva> thanks mlavalle for being our leader for Queens :)
14:01:44 <mlavalle> Thank you all for the trust
14:02:13 <jlibosva> there was a PTG two weeks ago, mlavalle sent out the summary that you can find here: http://lists.openstack.org/pipermail/openstack-dev/2017-September/122583.html
14:02:59 <jlibosva> next announcement: ihrachys sent out an email about Ocata stable phase: http://lists.openstack.org/pipermail/openstack-dev/2017-September/122626.html
14:03:23 <jlibosva> which means "Only critical bugfixes and security patches are acceptable." for the Ocata branch
14:03:37 <jlibosva> that's all announcements I prepared anybody has any announcement to make?
14:04:04 <mlavalle> I have on
14:04:30 <haleyb> mlavalle: we need to update bugs.rst with new owners, there's more than just kevin that needs updating in there, i'll get started on that today
14:04:31 <mlavalle> There is a call to propose Forum sessions for Sydne
14:04:53 <mlavalle> haleyb: thanks!
14:05:08 <haleyb> when in doubt i'll default to you :)
14:05:47 <mlavalle> http://lists.openstack.org/pipermail/openstack-dev/2017-September/122599.html
14:05:49 <jlibosva> the site where you can propose a session for Sydney Forum: http://forumtopics.openstack.org/
14:06:43 <jlibosva> any other announcements?
14:07:07 <mlavalle> not from me
14:07:27 <jlibosva> ok, let's move one then
14:07:32 <jlibosva> #topic Blueprints
14:07:45 <jlibosva> #link https://blueprints.launchpad.net/neutron/queens
14:08:07 <jlibosva> I'm looking there assuming those are current BPs scheduled for Q cycle
14:08:33 <ihrachys> I am looking at white page because comcast sucks
14:08:57 <jlibosva> I can send you a screenshot :)
14:09:02 <ihrachys> huh
14:09:17 <ihrachys> thanks, but I think I can survive
14:09:52 <jlibosva> The next Q-1 milestone is scheduled to 19 October 2017, currently planned blueprints to this milestone are https://launchpad.net/neutron/+milestone/queens-1
14:10:24 <jlibosva> regarding run-in-wsgi-server , should we find a new assignee ?
14:10:42 <jlibosva> it's marked as high priority b
14:10:44 <jlibosva> bp*
14:11:06 <mlavalle> sorry, my irc client froze
14:11:26 <ihrachys> I think kevinbenton was saying during ptg he will take care of that?
14:11:45 <ihrachys> but of course it would be nice to have someone who is available fulltime to at least back kevinbenton up
14:11:51 <mlavalle> which one?
14:12:03 <ihrachys> mlavalle, run-in-wsgi-server
14:12:53 <jlibosva> https://blueprints.launchpad.net/neutron/+spec/run-in-wsgi-server
14:13:38 <mlavalle> I tried to update https://blueprints.launchpad.net/neutron/+spec/live-migration-portbinding earlier today, with my name
14:14:00 <mlavalle> but I don't have privileges to do it. Who can grant me those privileges?
14:14:57 <jlibosva> mlavalle: maybe armax can?
14:15:10 <mlavalle> ok, I'll ping him later today
14:15:55 <jlibosva> mlavalle: what do you think about the run-in-wsgi-server assignee, should we keep it up to kevinbenton ?
14:16:41 <mlavalle> probably not. But I'll talk to him Thursday or Friday
14:16:53 <mlavalle> when he comes back from orientation
14:17:00 <jlibosva> okies
14:17:11 <mlavalle> there are several things in the PTG summary that he put his name on
14:17:14 <ihrachys> we also need approvers are reviews for each piece
14:17:37 <mlavalle> so I will find out a realistic picture
14:17:47 <ihrachys> *approvers aka reviewers
14:17:59 <mlavalle> ihrachys: yes, that is why I want to be able to update them
14:18:19 <mlavalle> I will work over the next few days lining this up
14:19:10 <mlavalle> jlibosva: would you please add an action item for me on this?
14:19:25 <jlibosva> #action mlavalle to go over bp and update assignees and approvers
14:19:31 <mlavalle> :-)
14:19:41 <jlibosva> am I doing something wrong or the bot is dead?
14:19:58 <ihrachys> no why
14:20:05 <ihrachys> I don't think it should report the action added
14:20:10 <ihrachys> it will still be in resulting report
14:20:17 <ihrachys> it switches topics just fine
14:20:19 <jlibosva> oh, I thought it always reacts
14:20:30 <jlibosva> alright then
14:20:51 <jlibosva> anybody else has anything regarding blueprints? is anybody blocked on any issue?
14:21:03 <annp_> hi
14:21:12 <jlibosva> annp_: hi
14:21:12 <annp_> In PTG, We have discussed about security group logging. There are some patch is targeted for queen-1
14:21:13 <annp_> https://review.openstack.org/396104
14:21:13 <annp_> https://review.openstack.org/468265
14:21:13 <patchbot> patch 396104 - neutron - [log]: implement logging agent extension
14:21:15 <annp_> https://review.openstack.org/468281
14:21:15 <patchbot> patch 468265 - neutron - [log]: Add driver api and rpc stuff for logging
14:21:16 <patchbot> patch 468281 - neutron - [log] ovs fw logging implementation
14:21:17 <annp_> So I’d to get more attention from folks on that. Thanks in advance.
14:21:22 <annp_> sorry,
14:21:38 <annp_> In PTG, We have discussed about security group logging. There are some patch is targeted for queen-1
14:21:54 <annp_> https://review.openstack.org/396104
14:21:54 <annp_> https://review.openstack.org/468265
14:21:54 <annp_> https://review.openstack.org/468281
14:21:54 <patchbot> patch 396104 - neutron - [log]: implement logging agent extension
14:21:55 <patchbot> patch 468281 - neutron - [log] ovs fw logging implementation
14:21:57 <patchbot> patch 468265 - neutron - [log]: Add driver api and rpc stuff for logging
14:22:01 <mlavalle> annp_: they are in my sight to review them over the next few days
14:22:18 <annp_> So I 'd like get more attention from folks.
14:22:25 <mlavalle> and I encourage other revieres to do the same :-)
14:22:27 <annp_> Thanks mlavalle.
14:22:42 <jlibosva> mlavalle: are you gonna put yourself as approver to the BP for this one? :)
14:23:19 <mlavalle> maybe, don't know yet
14:23:23 <jlibosva> ok :)
14:23:37 <annp_> that's all from me
14:23:38 <yushiro> :)
14:23:42 <jlibosva> annp_: thanks for bringing this up :)
14:23:49 <yushiro> thanks annp_
14:23:51 <jlibosva> any other BPs patches lack reviews?
14:24:00 <annp_> jlibosva: thanks please go ahead.
14:24:06 <jlibosva> #topic bugs
14:24:13 <yushiro> jlibosva, Thanks for ur help!!
14:24:19 <jlibosva> :)
14:24:32 <jlibosva> a small announcement from the PTG
14:24:57 <jlibosva> as we've been struggling lately to get bug deputies, it was agreed at the PTG to have a rotating roles
14:25:20 <ihrachys> do we have an ordered list of 'volunteers'?
14:25:30 <mlavalle> we don't yet.
14:25:44 <mlavalle> I was travelling last week, so I need to work on that this week
14:25:58 <mlavalle> I will propose a roster
14:26:19 <jlibosva> maybe we should make an etherpad or something where volunteers can sign up for rotating role?
14:26:40 <mlavalle> jlibosva: that is an excellent idea
14:26:48 <ihrachys> yeah I guess it makes sense to create the list on volunteer base still
14:26:55 <ihrachys> then rotate by force :)
14:27:10 <mlavalle> I will create it and send an email in a little bit
14:27:20 <jlibosva> makes sense :)
14:28:24 <jlibosva> I don't see any current critical bug on the LP - does anybody have any bug he'd like to mention here?
14:28:29 <mlavalle> #link https://etherpad.openstack.org/p/neutron-rotating-bug-deputy-volunteers
14:29:00 <ihrachys> we just spotted a linuxbridge bug in logs
14:29:13 <jlibosva> mlavalle: nice :)
14:29:13 <ihrachys> and I don't know whom to ask to triage those now that kevinbenton is out
14:29:29 <ihrachys> (there is no bug report yet, but I have log link if interested)
14:29:46 <ihrachys> my question is general: who's the linuxbridge fella now
14:30:00 <jlibosva> I noticed slaweq does some work around linuxbridge
14:30:04 <jlibosva> at least for fullstack
14:30:23 <jlibosva> maybe he could help you?
14:30:34 <ihrachys> it's about iptables rules. I can try.
14:30:54 <jlibosva> iptables rules for firewall driver?
14:30:58 <ihrachys> yes
14:31:00 <haleyb> i can help with SG code as well
14:31:05 <ihrachys> http://logs.openstack.org/21/504021/2/check/gate-tempest-dsvm-neutron-scenario-linuxbridge-ubuntu-xenial-nv/e47a3f3/logs/screen-q-agt.txt.gz#_Sep_26_09_17_36_512389
14:31:14 <jlibosva> yeah, I also digged into some iptables stuff too
14:31:17 <ihrachys> haleyb, ok let's run through it off band
14:31:48 <mlavalle> still, we need to identify someone to help with Linuxbridge in general
14:32:13 <mlavalle> not necessarily now
14:32:18 <mlavalle> in this meeting
14:32:22 <jlibosva> #action we must find a new linuxbridge agent guru
14:32:34 <mlavalle> jlibosva: lol, you beat me to it
14:32:36 <haleyb> maybe it's time to put linuxbridge into life-support mode?  mark it for deprecation in Rocky and see who screams?
14:33:06 <mlavalle> mhhhh
14:33:06 <ihrachys> well that's harsh. let's give the team time to find new people.
14:33:06 <jlibosva> we could have a look at the latest openstack survey to see how many users would be impacted
14:33:18 <ihrachys> alternatively, it will bitrot itself and then it will be a safe call
14:33:18 <mlavalle> yeah, let's try to find some one
14:33:55 <haleyb> i will charge the paddles to keep it alive :)
14:34:45 <jlibosva> ok :) if nobody has other bugs to talk about I think we can move on
14:34:53 <jlibosva> #topic Docs
14:35:11 <jlibosva> boden: hi, are you already around? :)
14:35:21 <mlavalle> I think we held the line fine for boden
14:35:21 <boden> hi, I’m here
14:35:30 <mlavalle> :-)
14:35:41 <jlibosva> good timing :)
14:36:11 <boden> continuing to work through doc/api-ref tagged bugs, a number of patches out for review
14:36:26 <boden> including patches to validate URL links via a tox target
14:36:48 <mlavalle> I think I reviewed that want last night
14:36:55 <boden> https://review.openstack.org/#/c/505327/
14:36:56 <patchbot> patch 505327 - neutron - add doc link validation to release checklist and tox
14:36:58 <boden> yes you did
14:36:58 <mlavalle> that one^^^
14:37:00 <boden> thanks
14:37:36 <mlavalle> I wanted others to take a look
14:37:46 <mlavalle> if nobody does, I'll merge it later today
14:37:50 <boden> yup, good idea
14:37:53 <boden> there’s one for lib too
14:38:05 <boden> https://review.openstack.org/#/c/506342/
14:38:06 <patchbot> patch 506342 - neutron-lib - add api ref and doc link validation to release
14:38:31 <mlavalle> ok, will take a look as well
14:38:38 <boden> also I saw note on the ML about generating PDFs for docs… I will have to follow up on that in the next doc meeting
14:38:59 <boden> http://lists.openstack.org/pipermail/openstack-dev/2017-September/122461.html
14:39:24 <boden> not clear if we should look into that for neutron/lib, but I’ll try to find out
14:39:55 <boden> I don’t have any other doc topics, unless there are questions/comments
14:40:47 <jlibosva> boden: thanks for updates
14:40:57 <jlibosva> I think we can jump to the lib topic
14:41:03 <jlibosva> #topic Neutron-lib
14:41:10 <jlibosva> boden: hi :)
14:41:16 <boden> :)
14:41:33 <boden> neutron-lib 1.10.0 is released… requirement bumps to pick it up should be in the queue now
14:41:54 <boden> someone was asking for that release at the PTG, but sorry I can recall who now
14:42:35 <boden> as we discussed at PTG, I re-queued the callback payload changes.. more details: http://lists.openstack.org/pipermail/openstack-dev/2017-September/122293.html
14:43:33 <boden> and finally I’m re-queuing a number of lib impact (consumption) changes… I will send a consolodated note/list when they are all ready
14:43:57 <boden> that’s what I have for lib
14:44:13 <mlavalle> thanks.... enjoy your vacation days :-)
14:44:33 <boden> thanks :)
14:44:37 <jlibosva> +1 to the above :)
14:44:50 <jlibosva> anybody has any comments/questions to neutron-lib topic?
14:45:53 <jlibosva> let's move on then
14:45:58 <jlibosva> #topic OSC
14:46:13 <jlibosva> amotoki: hi, are you around?
14:46:27 <mlavalle> amotoki is on vacation in Italy this week
14:46:39 <mlavalle> he will be back on Monday
14:46:51 <mlavalle> I bet he is thinking about us :-)
14:47:04 <jlibosva> aha, good choice for vacation :)
14:47:41 <jlibosva> just one note from the PTG - python-neutronclient will stay with us until the parity is reached
14:48:13 <boden> and I have an item on my plate to help reach that parity, but I don’t have any new details yet… I’ll follow up next week after my vaca
14:48:13 <mlavalle> good thing you remembered that, jlibosva :-)
14:48:37 * jlibosva is looking at mlavalle's PTG summary email
14:49:09 <jlibosva> if nobody has anything to add for OSC, we can go to open discussion
14:49:12 <jlibosva> #topic Open discussion
14:49:19 <jlibosva> does anybody have a topic he'd like to discuss?
14:50:16 <mlavalle> Not from me
14:50:23 <jlibosva> then we can end earlier
14:50:35 <ihrachys> 10 minutes of free time, exciting
14:50:51 <mlavalle> jlibosva: is the CI meeting in this channel?
14:50:58 <jlibosva> one more thing - kevinbenton shared with us a team photo from the PTG - https://photos.app.goo.gl/Aqa51E2aVkv5b4ah1 - so you can print it out and put it on your nightstand or dashboard at your working place or wherever you want ;)
14:51:05 <jlibosva> mlavalle: yes, it's here in an hour
14:51:21 <mlavalle> see you then :-)
14:51:29 <jlibosva> thanks everybody for joining :)
14:51:33 <jlibosva> #endmeeting