21:00:19 <mlavalle> #startmeeting networking
21:00:20 <openstack> Meeting started Mon Oct  2 21:00:19 2017 UTC and is due to finish in 60 minutes.  The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:23 <openstack> The meeting name has been set to 'networking'
21:00:27 <mlavalle> hey
21:00:37 <Swami> hi
21:00:40 <haleyb> hi
21:01:01 <mlavalle> have I seen you somewhere before, Swami, haleyb?
21:01:22 <Swami> mlavalle: not at all
21:01:26 <haleyb> we're everywhere these days :)
21:01:46 <mlavalle> the three amigos are ubiquitous
21:02:04 <mlavalle> ok, let's get going
21:02:17 <mlavalle> #topic Announcements
21:02:51 <mlavalle> We are getting close to Q-1: Oct 16 -20
21:03:07 <mlavalle> #link https://releases.openstack.org/queens/schedule.html
21:03:36 <mlavalle> I proposed a Neutron session for the forum:
21:03:57 <mlavalle> #link http://forumtopics.openstack.org/cfp/details/61
21:04:36 <mlavalle> A similar session got good feedback in Boston, so I thought of re-running it in Sydney
21:05:04 <mlavalle> It is always good to get feedback from operators
21:05:21 <Swami> mlavalle: sounds good.
21:05:50 <mlavalle> Another Neutron related session was proposed by Reedip: http://forumtopics.openstack.org/cfp/details/11
21:06:33 <mlavalle> Any other announcements from the team
21:06:35 <mlavalle> ?
21:07:22 <Swami> mlavalle: nothing else.
21:07:25 <mlavalle> BTW, forgot to mention that the agenda is here: https://wiki.openstack.org/wiki/Network/Meetings
21:07:51 <mlavalle> #topic Blueprints
21:08:25 <mlavalle> The blueprints that we have targeted currently for Queens is here:
21:08:32 <mlavalle> #link https://blueprints.launchpad.net/neutron/queens
21:08:54 <mlavalle> There are blueprints that I need to add to the series
21:09:15 <mlavalle> But I don't have the privileges needed in Launchpad to do that yet
21:09:27 <mlavalle> I was hoping armax would be here today
21:09:41 <mlavalle> I'll ping him in channel after the meeting
21:10:47 <mlavalle> I want to draw reviewers attention to the blueprints we have scheduled for Q-1
21:11:03 <mlavalle> We have 4 patchsets in the logging API:
21:11:32 <mlavalle> #link https://review.openstack.org/#/c/396104/
21:11:32 <patchbot> patch 396104 - neutron - [log]: implement logging agent extension
21:11:52 <mlavalle> #link https://review.openstack.org/#/c/468265/
21:11:52 <patchbot> patch 468265 - neutron - [log]: Add driver api and rpc stuff for logging
21:12:12 <mlavalle> #link https://review.openstack.org/#/c/468281/
21:12:12 <patchbot> patch 468281 - neutron - [log] ovs fw logging implementation
21:12:34 <mlavalle> #link https://review.openstack.org/#/c/409819/
21:12:35 <patchbot> patch 409819 - python-neutronclient - Add Logging commands for OSC plugin
21:12:50 <mlavalle> well, looking at them, none is passing Jenkins
21:13:10 <mlavalle> I don't see yushiro or annp around
21:13:20 <mlavalle> I'll follow up with them in channel
21:13:38 <hichihara> It seems there are more patches https://review.openstack.org/#/q/topic:bug/1468366+(status:open)
21:13:50 <mlavalle> They attend the FWaaS meeting on Tuedays. I'll catch them there
21:14:20 <hichihara> 10 patches? We should review more and more :)
21:14:21 <mlavalle> Any other bluprints that require attention?
21:14:49 <mlavalle> hichihara: the other are targeted at Q-2
21:15:01 <hichihara> I see
21:15:46 <mlavalle> ok, let's move on
21:15:59 <mlavalle> #topic Bugs and Gate issues
21:16:20 <mlavalle> Good news is that we don't have critical bugs at the time being
21:16:38 <mlavalle> haleyb, Swami: do we want to mention something about DVR?
21:17:10 <Swami> mlavalle: It would be a complete list.
21:17:22 <Swami> mlavalle: probably just an update on the bugs and were we stand.
21:17:53 <haleyb> from a high level, we did stabilize the gate issues it was causing, just in time for zuulv3 :)
21:17:58 <Swami> mlavalle: We have fixes for most of the high bugs. We need some reviews and get it merged.
21:18:27 <mlavalle> Swami: do you have links handy?
21:18:38 <Swami> mlavalle: haleyb: Still we have that multinode tempest job failing, that needs attention.
21:18:49 <Swami> mlavalle: sure.
21:19:13 <Swami> #link https://review.openstack.org/#/c/500143/
21:19:13 <patchbot> patch 500143 - neutron - DVR: Always initialize floating IP host
21:19:30 <Swami> #link https://review.openstack.org/#/c/504252/
21:19:30 <patchbot> patch 504252 - neutron - DVR: Fix bad arping call in centralized floating I...
21:19:44 <Swami> #link https://review.openstack.org/#/c/505324/
21:19:44 <patchbot> patch 505324 - neutron - DVR: Fix unbound fip port migration to bound port
21:20:02 <Swami> #link https://review.openstack.org/#/c/503530/
21:20:03 <patchbot> patch 503530 - neutron - DVR: Fix centralized floatingip with DVR and HA
21:20:45 <Swami> These are the patches that need some attention. Couple of patches require a +2 and workflow. One patch is failing the gate on workflow.
21:21:09 <Swami> haleyb: did I miss anything here.
21:21:29 <haleyb> Swami: no, that's a good short list
21:21:34 <mlavalle> hichihara: some of these patchsets have already a +2. We need someone to nudge them in. If you have some bandwidth, please give us a hand
21:22:12 <hichihara> mlavalle: Sure. I'll check after meeting.
21:22:21 <mlavalle> Thanks
21:23:14 <mlavalle> I also wnat to mention that we got an excellent response of people volunteering for the bugs deputy rotation
21:23:47 <mlavalle> Based on the volunteers, earlier today I created this rotation:
21:24:14 <mlavalle> #link https://wiki.openstack.org/wiki/Network/Meetings#Bug_deputy
21:24:25 <mlavalle> and also sent a message to the ML
21:24:48 <hichihara> mlavalle: I didn't notice it because of vacation. I added my name into etherpad now.
21:25:16 <mlavalle> hichihara: perfect, thanks. your first duty will be on January 15th :-)
21:25:36 <mlavalle> I will be the bugs deputy this week
21:25:57 <hichihara> mlavalle: I got it
21:26:50 <mlavalle> I also want to mention that I was looking at the "undecided bugs" and we have a ton
21:27:32 <mlavalle> so I want to see what folks think of a triaging bugs sprint one day next week?
21:27:50 <mlavalle> otherwise it might take too long to catch up
21:28:12 <hichihara> mlavalle: +1
21:28:35 <Swami> mlavalle: +1
21:29:00 <mlavalle> cool, I'll send a message to the ML
21:29:17 <mlavalle> #action mlavalle to send message to ML about bugs sprint
21:29:34 <mlavalle> any other bugs we should talk about today?
21:30:30 <mlavalle> ok, let's move on
21:30:52 <mlavalle> #topic Docs
21:31:00 <mlavalle> boden: you around?
21:31:06 <boden> mlavalle here
21:31:15 <boden> but I don’t have much as I was out the later part of last week
21:31:53 <mlavalle> sounds good. of the "undecided bugs" that I mentioned above, it seems that there are a few related to docs
21:32:11 <mlavalle> since I am the bugs deputy this week, I will be sending them your way :-)
21:32:28 <boden> mlavalle: just ensure they have the doc tag and I’ll get to them
21:32:34 <boden> or someone will
21:32:37 <mlavalle> cool :-)
21:32:49 <mlavalle> #topic neutron-lib
21:32:59 <boden> suppose thats me
21:33:05 <mlavalle> same status here, boden ?
21:33:21 <boden> well I’ll mention there are a few issues with the zuul v3 gate jobs
21:33:31 <boden> I’ve been trying to work through them
21:34:13 <boden> I’ve added the issues here: https://etherpad.openstack.org/p/zuulv3-migration-faq
21:35:05 <mlavalle> Hoepfully you will get help there
21:35:12 <boden> lets hope so :)
21:35:23 <mlavalle> anything else?
21:35:57 <boden> nothing other than what was mentioned last week.. which will have to wait until the gate is stable
21:36:08 <mlavalle> ok
21:36:32 <mlavalle> thanks for the update and I hope you enjoyed your vacation last week
21:36:51 <mlavalle> #topic Transition to OSC
21:37:02 <mlavalle> amotoki: ping
21:38:11 <mlavalle> maybe he is not around. I was talking to him about 5 hours ago, so he must be a night owl, not an early riser ;-)
21:38:39 <mlavalle> #topic Open Agenda
21:38:55 <mlavalle> any other topics we should discuss today?
21:39:34 <Swami> mlavalle: I don't have any topics to discuss.
21:39:53 <Swami> mlavalle: just a general question. Can someone tell me how to run the fullstack tests.
21:40:22 <mlavalle> well, there are instructions in the docs
21:40:29 <mlavalle> have you gone thorugh that?
21:40:43 <davidsha> Swami: Run the Functional test script in neutron/tools/
21:41:01 <Swami> davidsha: ok will take a look at it.
21:41:24 <mlavalle> davidsha: it's good to know you are around, even if you stay quiet :-)
21:41:26 <Swami> mlavalle: yes I remember going through a doc. But let me try again.
21:41:49 <davidsha> Swami: This one here: https://github.com/openstack/neutron/blob/master/tools/configure_for_func_testing.sh, run it on a VM though, it can mess up your env
21:42:07 <mlavalle> yeah, it will mess your environment badly
21:42:22 <davidsha> mlavalle: I like to pop on every now and then :)
21:42:44 <Swami> davidsha: thanks
21:43:11 <mlavalle> hichihara: amotoki was also on vacation last week. he went to Italy. Was last a special vacation week in Japan?
21:43:35 <davidsha> I was trying the funct tests last week actually and they had a very high failure rate... So there may be more configuration to do
21:43:36 <mlavalle> like the US Thanksgiving?
21:44:21 <hichihara> mlavalle: No. Japanese works everytime. It is just me and amotoki :)
21:44:23 <mlavalle> Swami, davidsha: yes, high rate failures. In fact, Jakub is trying to simplify them
21:44:39 <mlavalle> hichihara: LOL, did you go somewhere?
21:45:30 <mlavalle> ok team, Thanks for attending
21:45:31 <hichihara> mlavalle: Yes. My travel is in Japan :)
21:45:42 <mlavalle> hichihara: Nice :-)
21:45:45 <Swami> bye
21:45:49 <mlavalle> See you all next week
21:45:50 <hichihara> thanks, bye
21:45:52 <davidsha> Thanks
21:45:56 <mlavalle> #endmeeting