21:00:25 <mlavalle> #startmeeting networking
21:00:26 <openstack> Meeting started Mon Jun 25 21:00:25 2018 UTC and is due to finish in 60 minutes.  The chair is mlavalle. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:29 <openstack> The meeting name has been set to 'networking'
21:01:05 <mlavalle> Hi there!
21:01:11 <hongbin> o/
21:01:12 <haleyb> hi
21:02:00 <mlavalle> Agenda for today is here:
21:02:15 <mlavalle> #link https://wiki.openstack.org/wiki/Network/Meetings#Bugs_and_Gate_issues
21:02:26 <mlavalle> #undo
21:02:27 <openstack> Removing item from minutes: #link https://wiki.openstack.org/wiki/Network/Meetings#Bugs_and_Gate_issues
21:02:46 <mlavalle> #link https://wiki.openstack.org/wiki/Network/Meetings
21:02:59 <mlavalle> #topic Announcements
21:03:26 <mlavalle> Rocky-3 milestone will take place on July 23 - 27
21:03:39 <mlavalle> That's a little more than 4 weeks away
21:03:45 <manjeets> hello
21:04:38 <mlavalle> The call for presentations for the Berlin Summit will close on July 16th
21:05:02 <mlavalle> hopefully we will have many Neutron submissions ;-)
21:05:30 <mlavalle> Any other announcements from the team?
21:06:41 <mlavalle> ok, let's move on
21:07:00 <mlavalle> #topic Blueprints
21:08:09 <mlavalle> These are the blueprints we are targeting for Rocky-3:
21:08:15 <mlavalle> #link https://launchpad.net/neutron/+milestone/rocky-3
21:09:22 <mlavalle> Does anyone want to give an update on a blueprint?
21:10:07 <mlavalle> Ok, I have some updates
21:10:35 <mlavalle> First, https://blueprints.launchpad.net/neutron/+spec/live-migration-portbinding
21:11:26 <mlavalle> We have a series of patches awaiting review:
21:11:33 <mlavalle> #link https://review.openstack.org/#/q/topic:bp/live-migration-portbinding+(status:open+OR+status:merged)
21:11:56 <mlavalle> The series starts here:
21:12:02 <mlavalle> #link https://review.openstack.org/#/c/414251/
21:12:03 <patchbot> patch 414251 - neutron - Multiple port binding for ML2
21:12:24 <mlavalle> I consider this serires complete
21:12:35 <mlavalle> Tested in my development environment
21:12:52 <mlavalle> Next step I will be adding a fullstack test and tempest API tests
21:13:07 <mlavalle> Please review at your earliest convinience
21:13:10 <manjeets> thanks for release note mlavalle :)
21:14:12 <mlavalle> manjeets: thanks for the comments. I also addressed your concern about pluralizing port_binding and binding in the Port's OVO. All the in the same note
21:14:53 <manjeets> yea looks good however I have one question on multiple port binding ?
21:15:15 <mlavalle> As for https://blueprints.launchpad.net/neutron/+spec/port-forwarding
21:15:48 <mlavalle> We have a serires of patches starting here: https://review.openstack.org/#/c/535647/
21:15:49 <patchbot> patch 535647 - neutron - [1] Neutron server side Floating IP port forwarding
21:16:01 <mlavalle> Please take a look if you can
21:16:45 <mlavalle> Since I have made good progress with multiple port binding, I will try to find the time to review this series of patches for port forwarding
21:17:27 <mlavalle> In regards to https://blueprints.launchpad.net/neutron/+spec/strict-minimum-bandwidth-support
21:17:53 <mlavalle> We have a patch for review here: https://review.openstack.org/#/c/574783/
21:17:53 <patchbot> patch 574783 - neutron - WIP Drive binding by placement allocation
21:18:35 <mlavalle> I have a chat last week with Bence and agreed on an approach to address a hrudle he found with hirarchical port binding
21:18:42 <mlavalle> awaiting for next revision
21:19:22 <mlavalle> Any other blueprints updates / comments?
21:19:30 <boden> hi, mlavalle as we discussed the neutron-lib decouple db work (https://blueprints.launchpad.net/neutron/+spec/neutron-lib-decouple-db) is currently blocked… as I mentioned before; I doubt we can finish in R
21:20:35 <mlavalle> boden: I know I have to send a message to the ML covering the steps you and I agreed on last week
21:20:41 <mlavalle> I will do it tomorrow
21:20:56 <boden> mlavalle thx
21:22:10 <mlavalle> #action mlavalle to send message to the ML explaining approach to sustain neutron-lib progress when sub-projects stop reviewing patches to adopt neutron-lib
21:22:48 <mlavalle> #topic Community Goals
21:23:18 <mlavalle> annp has been making progress with wsgi support
21:24:02 <mlavalle> Patch is here: https://review.openstack.org/#/c/555608/
21:24:03 <patchbot> patch 555608 - neutron - Allow neutron-api load config from WSGI process
21:24:38 <mlavalle> I just added it to my queue
21:25:11 <mlavalle> and I think njonhston is helping with an issue around fwaas
21:26:07 <mlavalle> any other updates on community goals?
21:26:43 <njohnsto_> actually it looks like that issue is not fears-specific; the issue seems to occur in the RPC messaging stack. See the ML thread for more.
21:27:11 <mlavalle> njohnsto_: thanks for the update ;-)
21:27:13 <njohnsto_> s/fears/fwaas/ (typing on my phone)
21:27:25 <mlavalle> we figured, LOL
21:28:03 <mlavalle> ok, moving on
21:28:08 <mlavalle> #topic Bugs
21:28:33 <mlavalle> Our deputy last week was haleyb
21:28:44 <mlavalle> Here's his report:
21:28:51 <mlavalle> #link http://lists.openstack.org/pipermail/openstack-dev/2018-June/131800.html
21:29:50 <haleyb> this one seemed interesting from a performance standpoint, https://bugs.launchpad.net/neutron/+bug/1777968
21:29:50 <openstack> Launchpad bug 1777968 in neutron "Too many DBDeadlockError and IP address collision during port creating" [High,In progress] - Assigned to LIU Yulong (dragon889)
21:30:16 <haleyb> liu has proposed a change that will need some review
21:31:04 <haleyb> two need further triage
21:31:08 <haleyb> https://bugs.launchpad.net/neutron/+bug/1777965
21:31:08 <openstack> Launchpad bug 1777965 in neutron "Create port get quota related DBDeadLock" [Undecided,New]
21:31:37 <haleyb> wanted to at least try and reproduce that one
21:31:47 <haleyb> https://bugs.launchpad.net/neutron/+bug/1778207
21:31:47 <openstack> Launchpad bug 1778207 in neutron "fwaas v2 add port into firewall group failed" [Undecided,New]
21:32:15 <haleyb> need to ping someone on fwaas team to take a look
21:32:56 <mlavalle> haleyb: if you are not lucky finding someone by Thursday, I will bring it up in their meeting
21:33:08 <haleyb> ack
21:34:56 <mlavalle> those RFEs / bugs for QoS and vlan_transparency.... it seems submitters sent several. I commented on two late last week
21:35:09 <mlavalle> same submitters
21:36:03 <mlavalle> ok, our bugs deputy this week is armax
21:36:13 <armax> ack, I am on it, mlavalle
21:36:21 <boden> i have 1 more to mention
21:36:22 <mlavalle> I can see he is already commenting on some bugs
21:36:26 <mlavalle> Thanks!
21:36:33 <mlavalle> boden: please go ahead
21:36:37 <boden> https://bugs.launchpad.net/neutron/+bug/1777908
21:36:37 <openstack> Launchpad bug 1777908 in neutron " Ensure _get_changed_synthetic_fields() return updatable fields - breaks consumers" [High,Confirmed]
21:36:37 <armax> things are pretty quite so far but I have just started looking
21:36:50 <boden> have submitted 2 reverts for that one, if you get time to peek
21:37:19 <mlavalle> boden: oh yeah, do you have the gerrit urls handy?
21:37:30 <boden> https://review.openstack.org/#/c/577513
21:37:31 <patchbot> patch 577513 - neutron (stable/queens) - Revert "Ensure _get_changed_synthetic_fields() ret...
21:37:43 <boden> https://review.openstack.org/#/c/577512/
21:37:44 <patchbot> patch 577512 - neutron (stable/ocata) - Revert "Ensure _get_changed_synthetic_fields() ret...
21:38:00 <mlavalle> boden: I'll review at the end of the meeting
21:38:13 <boden> tho zuul is failing in the queens one for reasons I’m unsure of
21:39:06 <mlavalle> Next week's deputy is Zhaobo. I'll send him an email to make sure he is aware
21:39:40 <mlavalle> I also want to mention that we had one loss and one addition to our deputies rotation
21:39:52 <mlavalle> njohnsto_ was added to it
21:40:01 <mlavalle> Thanks for jumping in!
21:40:12 <njohnston> Many hands make light work.  Happy to help.
21:40:27 <mlavalle> ok, moving on
21:40:34 <mlavalle> #topic neutron-lib
21:40:47 <mlavalle> boden: any other updates here?
21:41:14 <boden> hi, I will just mention the note I sent our earlier in regards to tox setup for networking projects http://lists.openstack.org/pipermail/openstack-dev/2018-June/131801.html
21:41:31 <mlavalle> Thank you for that
21:41:52 <boden> this topic can become a problem if we are trying to test with depends-on which can affect neturon-lib patches
21:42:01 <mlavalle> yeap
21:42:04 <boden> we can rehash once folks get a chance to read
21:42:10 <boden> and that’s all I have
21:42:20 <mlavalle> cool, thanks!
21:42:24 <hongbin> i have another one
21:42:32 <mlavalle> shoot hongbin
21:42:45 <hongbin> i am looking for review for this one: https://review.openstack.org/#/c/575560/ , then make a newer release of neutron-lib
21:42:46 <patchbot> patch 575560 - neutron-lib - Add the two missing 'is_filter' keyword
21:42:57 <hongbin> have patches on neutron server that are waiting for this release
21:43:10 <hongbin> would appreciate reviews on that
21:43:28 <mlavalle> hongbin: I will review most likely tomorrow morning
21:43:32 <boden> hongbin I will try to make a pass on reviews in the AM tomorrow…
21:43:44 <hongbin> mlavalle: boden cool, thanks
21:44:15 <mlavalle> manjeets: did we decide on the minimum requirements discussion of last week?
21:44:31 <manjeets> mlavalle, yes I had a discussion with boden and amotoki
21:44:50 <manjeets> they said its okay to bump the requirements if needed
21:45:07 <mlavalle> are you pushing a patch?
21:45:12 <manjeets> so I submitted a patch
21:45:18 <manjeets> https://review.openstack.org/#/c/577245/
21:45:19 <patchbot> patch 577245 - neutron - Bump neutron-lib version to 1.16.0
21:45:20 <mlavalle> ther you go ;-)
21:46:06 <mlavalle> let's do something. let's wait for hongbin to propose a new release and then we bump it
21:46:12 <mlavalle> does that work?
21:46:21 <manjeets> sounds good
21:46:38 <mlavalle> Thank you!
21:47:05 <mlavalle> #topic Docs
21:47:17 <mlavalle> any updates on this topic?
21:48:19 <boden> mlavalle sorry I don’t have any.. I have a weekly conflict with the docs meeting now so I haven’t been there for awhile
21:48:34 <mlavalle> ok, thanks!
21:49:03 <mlavalle> #topic CLI / SDK
21:49:16 <mlavalle> is amotoki around to give an update on this?
21:49:56 <mlavalle> apparently not, so let's move on
21:50:12 <mlavalle> #topic Open Agenda
21:50:21 <mlavalle> I have one additional topic
21:50:42 <mlavalle> Next meeting is scheduled on Tuesday July 3rd at 1400 UTC
21:51:34 <mlavalle> I expect low attendance from US based contributors, due to celebartion of Independence Day on July 4th. It is a big Holiday week in this country
21:52:06 <mlavalle> I will still run the meeting for our team members outside the US
21:52:26 <mlavalle> any toher topics we shlud discuss today?
21:52:53 <mlavalle> ok team, thanks for attending!
21:52:59 <mlavalle> #endmeeting