21:00:04 <slaweq> #startmeeting networking
21:00:04 <openstack> Meeting started Mon Nov 25 21:00:04 2019 UTC and is due to finish in 60 minutes.  The chair is slaweq. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:07 <openstack> The meeting name has been set to 'networking'
21:00:15 <njohnston> o/
21:00:24 <haleyb> hi
21:00:38 <slaweq> hi
21:01:15 <slaweq> lets wait 2-3 minutes for others before we will start
21:01:42 <bcafarel> o/
21:04:51 <slaweq> ok, lets start than
21:05:01 <slaweq> #topic Announcements
21:05:23 <slaweq> We are still looking for a "new daddies" for projects:
21:05:29 <slaweq> neutron-fwaas: http://lists.openstack.org/pipermail/openstack-discuss/2019-November/010929.html
21:05:31 <slaweq> and
21:05:35 <slaweq> neutron-vpnaas: http://lists.openstack.org/pipermail/openstack-discuss/2019-November/010931.html
21:05:58 <slaweq> last week lajoskatona offered his (and his company) help with networking-bagpipe/bgpvpn
21:06:20 <slaweq> and together with tmorin they will maintain this project so we should be good in this one
21:07:05 <slaweq> As a reminder, we are still in the middle of removing of neutron-interconnection from stadium projects: https://review.opendev.org/#/q/branch:master+topic:neutron-interconnection-retire
21:07:22 <slaweq> all should be ready on our side, now I'm waiting for approval from the tc
21:07:55 <slaweq> njohnston: maybe You know what I'm missing in https://review.opendev.org/#/c/694480/ to get it merged?
21:09:37 <njohnston> according tot he rules it has to be out there for comment for a period of time
21:09:52 <slaweq> ahh, ok
21:10:01 <slaweq> so we are now waiting only :)
21:10:05 <slaweq> thx for explanation
21:10:11 <njohnston> see: https://governance.openstack.org/tc/reference/house-rules.html
21:10:31 <njohnston> "If there is no objection posted one week after the change is proposed (or a significant new revision of the change is posted), then the change can be approved by the chair."
21:10:48 <njohnston> tmorin has a -1, that may cause delays
21:11:25 <slaweq> sure, now I understand
21:11:27 <slaweq> thx
21:11:49 <slaweq> ok, lets move on
21:11:58 <slaweq> last announcement (reminder) from me for today
21:12:01 <slaweq> Shanghai PTG summary: http://lists.openstack.org/pipermail/openstack-discuss/2019-November/010702.html and also on http://kaplonski.pl/blog/shanghai_ptg_summary/ (with photos from team dinner)
21:12:31 <slaweq> I will keep link to this summary in the meeting agenda page for whole Ussuri cycle, if anyone would look for it :)
21:12:38 <slaweq> and that's all from my side
21:12:51 <slaweq> do You maybe have any other announcements for the team today?
21:14:18 <slaweq> ok, lets go to the next topic than
21:14:19 <bcafarel> looks like that's a no :)
21:14:20 <slaweq> #topic Blueprints
21:14:40 <slaweq> we have pretty many BPs scheduled for U-1: https://launchpad.net/neutron/+milestone/ussuri-1
21:14:55 <slaweq> I added BPs for RFEs approved recently
21:15:41 <slaweq> some of them don't have assignement yet but I will ping people who proposed them if they will work on implementation of those
21:16:04 <njohnston> Should we add one for stateless security groups?
21:16:19 <slaweq> we also need approvers for some of those BPs, so if You want to be approver of some of them, please add Yourself there
21:16:30 <slaweq> njohnston: do You have link to RFE maybe?
21:16:49 <njohnston> slaweq: Other project team updates¶
21:16:58 <njohnston> oops that was the wrong copy/paste
21:17:07 <njohnston> slaweq: https://bugs.launchpad.net/neutron/+bug/1753466
21:17:07 <openstack> Launchpad bug 1753466 in neutron "[RFE] Support stateless firewall" [Wishlist,Confirmed] - Assigned to Giel Dops (nuage.gieldops)
21:17:24 <slaweq> I will add this one to the list too
21:17:29 <slaweq> thx for reminding me it
21:17:41 <njohnston> thanks!
21:17:51 <njohnston> I can be the approver for that one
21:17:53 <slaweq> #action slaweq to create BP for stateless SG and add it to U-1 dashboard for tracking
21:17:58 <slaweq> ok, thx
21:18:50 <slaweq> one more question: should we maybe also add here BP for merging ovn into neutron tree?
21:18:55 <slaweq> what do You think about it?
21:19:19 <njohnston> I see little downside, it is a major piece of work
21:19:31 <njohnston> little downside to tracking it
21:20:36 <slaweq> ok, I will add it there too
21:20:52 <slaweq> #action slaweq to add BP for networking-ovn merge
21:21:17 <slaweq> anything else regarding Blueprints?
21:22:22 <slaweq> ok, I guess that this means "no"
21:22:26 <slaweq> so let's move on
21:22:28 <slaweq> #topic Community goals
21:22:55 <slaweq> we still have 2 community goals on the list: one is ipv6 only deployments, and I don't have any update on this still
21:23:01 <slaweq> and second is dropping py2 support
21:23:06 <slaweq> njohnston: any updates on this one?
21:23:27 <njohnston> I am working on the etherpad to have it ready for the CI meeting tomorrow
21:24:35 <slaweq> great, thx njohnston
21:24:51 <slaweq> that will be good starting point for this :)
21:25:06 <slaweq> ok, lets move on than
21:25:07 <slaweq> #topic Bugs
21:25:22 <slaweq> last week mlavalle was on bug deputy
21:25:27 <slaweq> and he send summary http://lists.openstack.org/pipermail/openstack-discuss/2019-November/011109.html
21:26:16 <slaweq> in overall I think we are good with most of the bugs
21:26:37 <slaweq> there is one medium which needs some volunteer: https://bugs.launchpad.net/neutron/+bug/1853637
21:26:37 <openstack> Launchpad bug 1853637 in neutron "Assign floating IP to port owned by another tenant is not override-able with RBAC policy" [Medium,New]
21:27:43 <slaweq> if there will be no anyone, I will try to take a look into that one in next few days
21:28:43 <bcafarel> rbac in the title, I think you will "win" it
21:28:50 <slaweq> there is also one another bug which I want to bring to Your attention here
21:28:54 <slaweq> https://bugs.launchpad.net/neutron/+bug/1853840
21:28:54 <openstack> Launchpad bug 1853840 in neutron "Neutron fails to create bandwidth providers if CONF.host is set" [High,New] - Assigned to Bence Romsics (bence-romsics)
21:29:01 <slaweq> discussion about that is on ML also: http://lists.openstack.org/pipermail/openstack-discuss/2019-November/011044.html
21:32:55 <njohnston> so what is on us about this right now - implementing the backportable solution while we wait for the nova api change?
21:33:44 <slaweq> njohnston: IIUC we should change the way how the "host" variable is determined on our side
21:33:48 <slaweq> in placement client
21:34:04 <slaweq> but I'm not 100% sure as I didn't read whole thread on ML yet
21:35:31 <njohnston> "Neutron(/Cyborg?): backportable patch to s/CONF.host/socket.gethostname()/"
21:35:31 <slaweq> I will read this thread tomorrow morning to check exactly what it is about
21:36:01 <njohnston> the other part waits on nova to make a new microversioned api
21:36:17 <slaweq> yes
21:37:31 <slaweq> please check this thread and be aware of those changes, I think rubasov will send patch with backportable solution for neutron for that
21:37:40 <slaweq> he is assigned to this LP now
21:38:24 <slaweq> and that's all related to bugs from me for today
21:38:34 <slaweq> do You have any other bugs You want to discuss now?
21:39:21 <bcafarel> just a heads-up on deputy rotation, in the next one I will probably not be around
21:39:37 <bcafarel> end of december/early january I am far away from a laptop usually :)
21:40:16 <bcafarel> (and I guess that will apply to a few of us-
21:40:46 <slaweq> bcafarel: thx for heads-up
21:41:18 <slaweq> I will propose next round of bug deputy for next week's meeting so we can check who can maybe replace with You
21:41:35 <bcafarel> sounds good!
21:41:47 <slaweq> #action slaweq to prepare next bug deputy round
21:42:02 <slaweq> and speaking about bug deputy, this week njohnston is on it
21:42:12 <slaweq> and I know that You are already aware of it, right?
21:43:13 <njohnston> yep!
21:43:25 <slaweq> great :)
21:43:41 <slaweq> ok, so I think we are good with bugs topic for today
21:43:44 <slaweq> next topic than
21:43:48 <slaweq> #topic Neutron performance subteam
21:44:11 <slaweq> as we decided during the PTG, we are now mergin perfomance meeting into this team meeting
21:44:22 <slaweq> but I don't think mlavalle is with us today
21:44:32 <slaweq> so I think we will skip this topic
21:45:47 <slaweq> and the last topic for today is
21:45:49 <slaweq> #topic On Demand agenda
21:46:05 <slaweq> there are no topics on the list for this section for today
21:46:18 <slaweq> but maybe You have anything You want to discuss with the team now?
21:46:57 <bcafarel> none on my side
21:47:24 <slaweq> if not, than I think we can finish a bit earlier today's meeting
21:47:35 <njohnston> nothing here
21:47:37 <slaweq> thx for attending the meeting
21:47:44 <slaweq> and have a great week
21:47:47 <slaweq> o/
21:47:48 <bcafarel> o/
21:47:49 <slaweq> #endmeeting