21:00:21 <slaweq> #startmeeting networking
21:00:22 <openstack> Meeting started Mon Dec 9 21:00:21 2019 UTC and is due to finish in 60 minutes. The chair is slaweq. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:24 <slaweq> hi
21:00:26 <openstack> The meeting name has been set to 'networking'
21:00:36 <mlavalle> o/
21:00:44 <bcafarel> o/
21:01:09 <haleyb> hi
21:01:51 <slaweq> ok, lets start
21:01:52 <slaweq> #topic Announcements
21:02:29 <slaweq> First is just a reminder that we are still looking for "new daddies" for two projects neutron-fwaas and neutron-vpnaas
21:03:18 <bcafarel> did we have a deadline for "adoption candidates"?
21:03:18 <slaweq> second one on the list for today is that neutron-interconnection project is finally removed from the stadium and is now in x/ namespace
21:03:38 <mlavalle> yes, U-2
21:03:43 <slaweq> bcafarel: we said in Shanghai that milestone-2 is deadline
21:04:01 <slaweq> I will send reminder email about those 2 this week
21:04:22 <slaweq> #action slaweq to send reminding email about new daddies for neutron-{fwaas,vpnaas}
21:05:39 <njohnston> o/
21:06:22 <slaweq> next one
21:06:25 <slaweq> It's Ussuri-1 milestone week: https://releases.openstack.org/ussuri/schedule.html
21:06:36 <slaweq> so I think it's time to release stable branches
21:06:39 <slaweq> right?
21:07:14 <bcafarel> yup and as checked we are in good state backlog-wise
21:07:58 <slaweq> ok, I will talk tomorrow morning with amotoki about new releases for stable branches
21:09:04 <slaweq> ok, next one
21:09:07 <slaweq> We now have review priority also in stadium projects' patches
21:09:29 <slaweq> dashboard
21:09:31 <slaweq> https://review.opendev.org/#/dashboard/?title=Neutron+Priorities+Dashboard&foreach=%2528project%253Aopenstack%252Fneutron+OR%250Aproject%253Aopenstack%252Fneutron%252Dlib+OR%250Aproject%253Aopenstack%252Fneutron%252Dtempest%252Dplugin+OR%250Aproject%253Aopenstack%252Fpython%252Dneutronclient+OR%250Aproject%253Aopenstack%252Fneutron%252Dspecs+OR%250Aproject%253Aopenstack%252Fnetworking%252Dbagpipe+O
21:09:33 <slaweq> R%250Aproject%253Aopenstack%252Fnetworking%252Dbgpvpn+OR%250Aproject%253Aopenstack%252Fnetworking%252Dmidonet+OR%250Aproject%253Aopenstack%252Fnetworking%252Dodl+OR%250Aproject%253Aopenstack%252Fnetworking%252Dovn+OR%250Aproject%253Aopenstack%252Fnetworking%252Dsfc+OR%250Aproject%253Aopenstack%252Fneutron%252Ddynamic%252Drouting+OR%250Aproject%253Aopenstack%252Fneutron%252Dfwaas+OR%250Aproject%253A
21:09:35 <slaweq> openstack%252Fneutron%252Dfwaas%252Ddashboard+OR%250Aproject%253Aopenstack%252Fneutron%252Dvpnaas+OR%250Aproject%253Aopenstack%252Fneutron%252Dvpnaas%252Ddashboard+OR%250Aproject%253Aopenstack%252Fos%252Dken+OR%250Aproject%253Aopenstack%252Fovsdbapp%2529+status%253Aopen&High+Priority+Changes=label%253AReview%252DPriority%253D2&Priority+Changes=label%253AReview%252DPriority%253D1&Blocked+Reviews=lab
21:09:37 <slaweq> el%253AReview%252DPriority%253D%252D1 should be already prepared for this
21:09:39 <slaweq> ups, this link is long
21:09:41 <slaweq> sorry
21:09:45 <njohnston> probably need a tinyurl for that
21:10:10 <slaweq> njohnston: https://tinyurl.com/vezk6n6
21:10:15 <slaweq> here it is :)
21:10:22 <njohnston> slaweq: thanks!
21:11:01 <slaweq> and the last one for today:
21:11:05 <slaweq> Voting for "V" release name is now open: http://lists.openstack.org/pipermail/openstack-discuss/2019-December/011477.html
21:11:05 <bcafarel> maybe worth updating https://docs.openstack.org/neutron/latest/contributor/dashboards/index.html with it?
21:11:22 <slaweq> bcafarel: very good point
21:11:26 <slaweq> will You do it?
21:11:43 <bcafarel> count me in, I'll send that tomrrow morning
21:11:50 <slaweq> bcafarel++ thx
21:12:05 <slaweq> ok, that's all announcements from me for today
21:12:18 <slaweq> anything else You want to announce to the team maybe?
21:13:42 <slaweq> ok, if not, lets go to the next topic
21:13:44 <slaweq> #topic Blueprints
21:13:58 <slaweq> Ussuri-1 BPs: https://launchpad.net/neutron/+milestone/ussuri-1
21:14:10 <slaweq> we will not have any of them for U-1
21:14:21 <slaweq> so I will update them for U-2 at the end of this week
21:14:43 <slaweq> good news is that each of them has got assigned someone
21:15:04 <mlavalle> my goal is to get https://blueprints.launchpad.net/neutron/+spec/tagging-on-post done by early January
21:15:19 <slaweq> great mlavalle, would be great
21:15:45 <mlavalle> and I am going to take over this one: https://blueprints.launchpad.net/neutron/+spec/multiple-segment-per-network-per-host
21:16:03 <mlavalle> it doesn't seem that wwriverrat is making any progress with it
21:16:43 <slaweq> yes, there is no any progress on it since months
21:17:13 <mlavalle> I will work on that one after the tags for kuryr
21:17:23 <slaweq> great, thx mlavalle
21:18:39 <slaweq> about Convergence of ML2+OVS+DVR and OVN we are making progress, ralonsoh, lucasgomes and maciejjozefczyk are working fast to do it quickly
21:19:00 <slaweq> so I'm pretty sure this should be done before U-2
21:19:25 <slaweq> other 3 were waiting for neutron-lib release as api-def was merged for them recently
21:19:34 <slaweq> so should be progressing soon too I hope
21:19:48 <slaweq> and that's all from my side about BPs
21:21:05 <slaweq> if there is no any other updates, lets move on
21:21:37 <slaweq> #topic Community goals
21:22:10 <slaweq> I just today restarted work on neutron-tempest-plugin ipv6-only job, so I don't have too much update about it yet
21:22:21 <slaweq> njohnston: any updates about dropping py27 support?
21:22:40 <slaweq> Etherpad for it is at https://etherpad.openstack.org/p/neutron-train-zuulv3-py27drop
21:23:22 <njohnston> almost no activity on https://etherpad.openstack.org/p/neutron-train-zuulv3-py27drop - I see one item for networking-sfc, but things seem a little slow. I know I am probably not going to engage this too deeply until January so we might not get a lot of movement on it until then.
21:24:40 <slaweq> yes, there is not much working time this year :)
21:25:02 <bcafarel> one general note we will hit a bit for now is openstack-python-jobs-neutron still includes py27 jobs (found while cleaning networking-sfc)
21:25:46 <bcafarel> though with U-1 almost past us, that is something we can change now I think
21:25:50 <bcafarel> ?
21:26:17 <njohnston> I agree, I think there is no reason not to remove that
21:27:13 <slaweq> yep, looking at http://codesearch.openstack.org/?q=openstack-python-jobs-neutron&i=nope&files=&repos= I don't see any lib using it
21:27:34 <slaweq> if I'm not mistaken, only projects which can drop py27 support in phase-1
21:27:42 <slaweq> so we should be good to remove that even now
21:28:24 <bcafarel> ok I'll find where it is defined and send patch for that
21:29:03 <njohnston> bcafarel: https://opendev.org/openstack/openstack-zuul-jobs/src/branch/master/zuul.d/project-templates.yaml#L343
21:29:22 <slaweq> thx bcafarel
21:29:28 <bcafarel> njohnston++ thanks :)
21:30:26 <slaweq> ok, lets move on to the next topic
21:30:28 <slaweq> #topic Bugs
21:30:45 <slaweq> amotoki was omn bug deputy last week but I don't see any summary from him
21:31:13 <mlavalle> I didn't see any either
21:31:15 <slaweq> do You have any bugs You want to discuss with the team?
21:34:12 <slaweq> if not, I would like to talk about next bug deputy round
21:34:24 <slaweq> this week yamamoto is on bug deputy and he is already aware of this
21:34:32 <slaweq> next week will be rubasov
21:34:44 <slaweq> and than we will finish whole round
21:35:17 <slaweq> so I prepared schedule for new round on https://wiki.openstack.org/wiki/Network/Meetings#Bug_deputy
21:35:44 <njohnston> looks good
21:35:50 <slaweq> there is Christmas time comming so maybe some people would like to switch with someone else their round
21:36:03 <slaweq> I know that bcafarel can't do it now, right?
21:36:52 <bcafarel> right Dec-23 and Dec-30 I will most probably not be of much help (even if the weeks should be quiet)
21:37:33 <slaweq> so is there anyone who would switch with bcafarel maybe?
21:38:44 <mlavalle> I'll switch with him
21:39:01 <bcafarel> mlavalle my hero :)
21:39:05 <slaweq> thx mlavalle
21:39:16 <slaweq> so I will update schedule with additional notes
21:39:29 <mlavalle> ok
21:39:48 <bcafarel> and I will have a $beverage ready for next face to face meeting
21:40:03 <mlavalle> no problem whatsoever
21:40:05 <slaweq> if anyone else have any conflict with this schedule, please let me know
21:40:26 <slaweq> ok, lets move on now
21:40:30 <slaweq> #topic performance subteam
21:40:37 <slaweq> mlavalle: Your turn :)
21:40:54 <mlavalle> I Haven't done much over the past couple of weeks
21:41:00 <mlavalle> so no update to report
21:41:09 <mlavalle> the only thing I want to mention is:
21:41:19 <mlavalle> http://lists.openstack.org/pipermail/openstack-discuss/2019-December/011358.html
21:41:40 <mlavalle> I'll follow up with Erik
21:41:46 <mlavalle> that's all I have today
21:42:04 <slaweq> thx, I pointed him to You in this thread even :)
21:42:15 <slaweq> thx for taking care of it
21:42:35 <slaweq> ok, next topic
21:42:36 <slaweq> #topic neutron-lib
21:42:52 <slaweq> last week I said that we should get 4 patches merged and than do release of neutron-lib
21:43:06 <slaweq> list of patches is on https://wiki.openstack.org/wiki/Network/Meetings#Neutron-lib.2C_planned_refactoring_and_other_impacts
21:43:15 <slaweq> 3 of those 4 are merged now
21:43:26 <slaweq> and those 3 are api definitions for new API extensions
21:43:34 <slaweq> 4th one has still some -1
21:43:52 <slaweq> so I decided to propose new release today to let people work on those 3 RFEs
21:44:09 <slaweq> release is proposed here: https://review.opendev.org/#/c/697956/
21:44:45 <slaweq> if You think we should wait for any other patch, please let me know, I will -W this release patch now
21:47:47 <njohnston> cool
21:48:01 <slaweq> so I guess, it's fine for You to release it now :)
21:48:50 <slaweq> and that's all what I have for today
21:49:01 <slaweq> #topic On Demand Agenda
21:49:10 <slaweq> do You have anything else You want to talk today?
21:49:18 <mlavalle> one thing
21:49:53 <mlavalle> I addressed slaweq and bcafarel comments in https://review.opendev.org/#/c/695834 and https://review.opendev.org/#/c/649373
21:49:58 <mlavalle> please take look
21:50:16 <bcafarel> nice, one that can probably go in soon then
21:50:20 <slaweq> mlavalle: sure, I will do it tomorrow morning
21:52:34 <slaweq> ok, I think we are good for today than
21:52:45 <slaweq> thx for attending the meeting and see You all online
21:52:48 <slaweq> o/
21:52:51 <mlavalle> o/
21:52:51 <slaweq> #endmeeting