14:00:53 <haleyb> #startmeeting networking
14:00:53 <opendevmeet> Meeting started Tue Oct 31 14:00:53 2023 UTC and is due to finish in 60 minutes.  The chair is haleyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:53 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:53 <opendevmeet> The meeting name has been set to 'networking'
14:00:55 <mlavalle> o/
14:01:52 <haleyb> #topic announcements
14:01:57 <rubasov> o/
14:01:58 <haleyb> hi everyone
14:02:31 <haleyb> last week was the PTG, wanted to thank everyone that attended and contributed
14:02:34 <lajoskatona> o/
14:03:04 <frickler> \o
14:03:05 <lajoskatona> thanks for organizing and moderating it
14:03:09 <haleyb> i'm working on a write-up today, for anyone that missed it the etherpad is at https://etherpad.opendev.org/p/oct2023-ptg-neutron
14:03:48 <mtomaska> o/ late
14:04:37 <haleyb> is there anything people wanted to discuss regarding last week's meetings?
14:05:02 <haleyb> i have started pushing updates to metadata patches as we discussed
14:05:17 <mlavalle> great meeting. you did a great job leading it
14:05:42 <jlibosva> +1
14:05:57 <haleyb> mlavalle: thanks, had some good mentors :)
14:06:55 <haleyb> ok, if nothing else we can move on
14:07:09 <haleyb> #topic bugs
14:07:17 <haleyb> https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/EDUK7TCVSYDKSV2LOZ3XR3D4G2P6BFFF/
14:07:25 <haleyb> mlavalle was bug deputy last week
14:08:52 <haleyb> was a light week. i do see patches were proposed for all the High bugs, thanks!
14:09:24 <haleyb> the two Medium ones need owners, i'll mention them
14:09:44 <haleyb> #link https://bugs.launchpad.net/neutron/+bug/2040517
14:09:51 <haleyb> host not removed from table ml2_vxlan_endpoints with the agent delete
14:10:28 <haleyb> ykarel: you had filed this, can you pick it up?
14:11:02 <mtomaska> I can take it if ykarel does not have cycles
14:11:41 <mlavalle> I don't think ykarel is available today. he is on abusiness trip
14:12:05 <haleyb> mtomaska: thanks, feel free to assign it to yourself
14:12:11 <mtomaska> ACK
14:12:31 <haleyb> other bug
14:12:36 <haleyb> #link https://bugs.launchpad.net/neutron/+bug/2041612
14:12:43 <haleyb> [n-d-r] DRAgent removed from bgp speaker automatically
14:13:12 <haleyb> racosta: you filed this, are there any questions we can help with?
14:14:07 <mlavalle> if he is not online today, we can bring it up to him on Friday, during the drivers meeting
14:14:20 <haleyb> ack
14:14:32 <mlavalle> we are going to discuss a bunch of related RFEs and specs
14:14:42 <racosta> I don't know, would it be an alternative to skip the n-d-r type agent from reschedue process?
14:15:35 <frickler> is this about scheduling speaker to agents?
14:15:48 <frickler> I created the static scheduler to resolve that
14:16:43 <racosta> yeap, static scheduler could be a good alternative
14:16:44 <frickler> I was a bit confused because the bug mentions l3 agent, which is a completely different thing
14:18:09 <frickler> racosta: well we have that, see https://review.opendev.org/c/openstack/neutron-dynamic-routing/+/815265 and some later fixes for it
14:19:00 <frickler> my plan was also to deprecated and finally remove all other options, as IMO they don't make sense
14:19:54 <racosta> I'll check it, the initial problem was found with the network agent rescheduler - removing the speaker from the DRAgent.
14:20:41 <haleyb> racosta: https://bugs.launchpad.net/neutron/+bug/1920065 was the original bug/rfe filed for reference, if it solves your problem we can close the other one
14:20:41 <racosta> I believe that static scheduler can solve this issue.
14:21:21 <racosta> ok, thanks frickler and haleyb
14:21:27 <haleyb> ack, thanks
14:22:02 <haleyb> that was it for new bugs
14:22:26 <haleyb> as i mentioned at the PTG, i was going to do a weekly query on total neutron bugs
14:23:16 <haleyb> we're up to 764 from 760 last week, but we had 4 new this week so expected increase
14:24:05 <haleyb> i think with people working on patches this week that number should decrease
14:24:09 <lajoskatona> haleyb: could you please share the filter here?
14:24:39 <lajoskatona> just to see the same thing :-)
14:24:42 <haleyb> lajoskatona: sure, i did put a link in https://wiki.openstack.org/wiki/Network/Meetings as well
14:24:47 <haleyb> #link https://bugs.launchpad.net/neutron/?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=
14:24:47 <haleyb> on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on
14:25:19 <haleyb> hmm, that was too long, will use a shortener next time
14:25:38 <lajoskatona> haleyb: thanks, I concat these :-)
14:26:33 <haleyb> any other bugs to talk about?
14:27:01 <haleyb> oh, and is there a CI meeting today or maybe not with yatin offline
14:28:11 <lajoskatona> good question
14:28:39 <mlavalle> no, ykarel sent an email on 10/20 where he steted: "...next Neutron CI Meeting will be on 07th November, 2023"
14:28:39 <haleyb> i don't see anything in the meeting minutes
14:28:53 <haleyb> ah, thanks i didn't see that
14:29:00 <lajoskatona> mlavalle: cool, thanks for reminder
14:30:35 <haleyb> so this weeks bug deputy was supposed to be ralonsoh, but he is out, does anyone have a problem if i just move everyone up a week? that would mean rubasov has this week
14:30:51 <rubasov> okay for me
14:30:53 <haleyb> if not i can just cover this week if you promise not to file many bugz
14:31:26 <mlavalle> fine with me
14:31:39 <lajoskatona> +1 from me
14:32:25 <haleyb> rubasov: ack, i will just move rodolfo to the bottom and push everyone up a week
14:32:40 <lajoskatona> no, first week on `24 I will be off, but that can be handled offline
14:33:37 <haleyb> lajoskatona: sure, we can always do a swap with someone, i might also be out that week
14:33:52 <lajoskatona> haleyb: ack
14:34:33 <haleyb> #action haleyb to update bug deputy calendar
14:35:13 <haleyb> #topic specs
14:35:56 <haleyb> we discussed one of the n-d-r specs last week, i will put it on the agenda for this weeks drivers meeting
14:36:07 <haleyb> #link https://review.opendev.org/c/openstack/neutron-specs/+/899210
14:36:13 <mlavalle> and I think it is ready to go
14:36:35 <mlavalle> I'll review it again today or tomorrow
14:36:41 <haleyb> oh yeah, i hadn't even looked so don't need to discuss further
14:37:14 <mlavalle> slaweq +2ed it yesterday and I was about to look at it, but racosta made some minor changes after slaweq's suggestions
14:37:38 <haleyb> if i don't see any other RFEs i will cancel drivers meeting by thursday
14:37:41 <haleyb> mlavalle: ack, thanks!
14:37:41 <mlavalle> so I decided to wait for zuul's +1
14:39:06 <haleyb> #topic community_goals
14:39:54 <haleyb> the RBAC change for tags merged, will cross that off the list
14:40:39 <haleyb> and from the PTG meetings, deprecating the neutron client code in horizon is on the list now
14:41:10 * haleyb thinks he remembered that correctly
14:41:16 <lajoskatona> yes, you are right
14:41:56 <mlavalle> +1
14:42:07 <haleyb> lajoskatona: thanks, please ping if you need any reviews
14:42:42 <lajoskatona> ack, I will
14:43:21 <haleyb> moving on
14:43:28 <haleyb> #topic on_demand
14:43:47 <haleyb> any additional things to discuss?
14:44:39 <haleyb> ok, crickets means we're done
14:44:41 <adamoswick> It's my first time in this meeting so I'm not sure if this is the right time to discuss. Would I be able to nudge someone to get some reviews on a couple of changes?
14:45:31 <haleyb> adamoswick: sure, which ones?
14:45:36 <adamoswick> Specifically If90762fc22583502d03b7d58f87656b9cd8b8403 & Ibfc1be4a8c243bb04bf90dec3759d66b587c9634 if possible
14:45:54 * haleyb might be guilty of not getting to reviews the past week
14:46:08 <haleyb> adamoswick: can you give the review http link?
14:46:23 <adamoswick> https://review.opendev.org/c/openstack/neutron/+/892537 & https://review.opendev.org/c/openstack/neutron/+/890543
14:47:54 <lajoskatona> I try to check them too (perhaps just next week)
14:48:07 <frickler> haleyb: searching for the change-id in the gerrit search field works fine, too (just as a side note. linking the reviews directly sure is the more common solution)
14:48:35 <haleyb> i can look at the first again, i see rodolfo had a -1 on the second
14:48:53 <mlavalle> yeap, just enter https://review.opendev.org/q/<change-id>
14:48:54 <haleyb> frickler: right, it's more for the meeting notes
14:49:14 <frickler> ack
14:49:23 <adamoswick> Thanks all. I think I've covered Rodolfo's comment but left it unresolved in case he wanted more details. He's not come back just yet
14:50:12 <mlavalle> I'll also look at them over the next few days. In my pile now
14:50:28 <haleyb> adamoswick: he is on extended leave so we'll just have to get other eyes on them
14:51:09 <haleyb> but thanks for bringing them up, and feel free to just ping in the channel if you don't want to wait for the meeting
14:51:53 <adamoswick> The rescheduling you did earlier made me think he might have been out. That's great and noted for future on the other channel. Thanks
14:52:16 <mlavalle> it is this same channel
14:53:26 <haleyb> ok, anything else for on demand?
14:53:45 <lajoskatona> nothing from me
14:54:11 <haleyb> don't eat too much candy, leave it for the kids :)
14:54:18 <haleyb> #endmeeting