14:00:54 <haleyb> #startmeeting networking
14:00:54 <opendevmeet> Meeting started Tue Nov  7 14:00:54 2023 UTC and is due to finish in 60 minutes.  The chair is haleyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:54 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:54 <opendevmeet> The meeting name has been set to 'networking'
14:00:54 <obondarev> o/
14:01:06 <bcafarel> o/
14:01:24 <haleyb> fwiw i like the summertime meeting time better :)
14:01:37 <slaweq> o/
14:01:37 <mtomaska> +1
14:01:40 <lajoskatona> +1
14:01:56 <haleyb> #topic announcements
14:02:24 <haleyb> sorry, i've been slow to get my PTG meeting notes out, will do that today
14:03:15 <haleyb> https://releases.openstack.org/caracal/schedule.html
14:03:48 <haleyb> we are actually coming up to the C-1 milestone next week
14:04:13 <haleyb> November 16, 2023
14:04:31 <lajoskatona> does it mean new release of anything? I always forget the meaning behind these things
14:05:10 <opendevreview> yatin proposed openstack/neutron stable/yoga: [Stable Only] Fix parent for nftables job  https://review.opendev.org/c/openstack/neutron/+/900295
14:07:09 <haleyb> lajoskatona: that is a good question and i will have to defer to look later, but from my memory the first one isn't as critical as the others
14:07:11 <lucasagomes> haleyb, hey there, yes!
14:07:30 <lucasagomes> haleyb, I can do it this week, yes
14:07:59 <haleyb> but if we want to do a release of say neutron-lib, this would be a good time to get that done
14:08:03 <lajoskatona> haleyb: ack, anyway if there is an urgent thingthe release team send out a warning mail :P
14:08:37 <haleyb> it also brings up the point of getting releases of the stable branches done, i believe that is typically done near the beginning of each month (if necessary)
14:09:07 <lajoskatona> +1
14:10:02 <haleyb> and so i remember, last cycle did re have a release liaison?
14:11:18 <opendevreview> yatin proposed openstack/neutron stable/yoga: [Stable Only] Fix parent for nftables job  https://review.opendev.org/c/openstack/neutron/+/900295
14:11:19 <haleyb> crickets, so i guess not
14:11:45 <lajoskatona> :-)
14:11:52 <haleyb> #action (haleyb) determine release liaison for Caracal
14:12:12 <haleyb> alright, moving on
14:12:15 <haleyb> #topic bugs
14:12:51 <slaweq> haleyb sorry, I was in the other meeting in same time - I can continue helping as release liaison if You want
14:13:01 <haleyb> rubasov was the deputy last week, lucasagomes will do it this week
14:13:55 <haleyb> slaweq: ack, thanks that would be great. do you subscribe to the -releases repo changes or just wait? just wondering if i should subscribe but a lot of extra emails...
14:14:06 <haleyb> wait for a ping i mean
14:14:28 <slaweq> no, I was always just waiting
14:14:53 <slaweq> I'm not 100% sure but I think that release liaison and PTL are added to the changes as reviewers automatically
14:15:18 <haleyb> great, if not i'm sure they'll find me
14:15:26 <slaweq> ++
14:15:35 <haleyb> lucasagomes: thanks for taking bugs on this week
14:15:42 <haleyb> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/VU7MQD4DDNACD6EYEJ5KEQ5FFQS56YDC/
14:16:21 <haleyb> it was a light week for bugs last week, there are only 2 requiring attention
14:16:31 <haleyb> #link https://bugs.launchpad.net/neutron/+bug/2041861
14:16:45 <haleyb> [ovn] instance in a shared network owned by another project is unreachable via floating IP
14:16:53 <haleyb> oh, actually, i think this can be closed
14:17:19 <haleyb> i think they configured OVN to use vxlan instead of geneve
14:18:20 <haleyb> if the submittor doesn't respond to the additional questions from bence we can close next week
14:18:53 <haleyb> the second is
14:18:58 <haleyb> #link https://bugs.launchpad.net/neutron/+bug/2042647
14:19:04 <haleyb> doc: Options described in "DHCP High-availability" are outdated
14:19:52 <haleyb> low-hanging fruit if anyone wants to pick that up
14:20:50 <haleyb> moving on
14:22:02 <haleyb> my weekly bug query shows we've crept up to 767 from 764, i think with the number of patches in-flight that number should come down, plus i think there were 4 new ones filed today
14:22:27 <haleyb> i have a topic in open discussion about reviews so can talk about that then
14:23:04 <haleyb> there is a current gate blocker though
14:23:19 <haleyb> #link https://bugs.launchpad.net/neutron/+bug/2042939
14:23:36 <haleyb> sqlalchemy-master jobs broken with ValueError: invalid literal for int() with base 10: '0b1'
14:23:44 <haleyb> only seems to be affecting that job
14:24:27 <haleyb> has anyone started looking at that yet?
14:25:22 <slaweq> I can try to check it this week
14:25:35 <ykarel> yes ^ is the only job in gate, there are others but those are periodic/experimental
14:25:59 <ykarel> for quick fix we can just drop that from the check queue as discussed last time when enabling this job
14:26:14 <slaweq> or mark as non-voting temporary
14:26:17 <ykarel> and then check for actual fix
14:26:22 <haleyb> ykarel: right, we can make it non-voting if it's out of our control
14:26:23 <ykarel> yes that should also work
14:26:29 <ykarel> +1
14:26:53 <haleyb> i just didn't know if it was a bug in our code somehow
14:28:18 <haleyb> #action change sqlalchemy-master job to non-voting while looking into failure
14:28:29 <ykarel> i didn't digged yet but the trace itself coming from oslo.db/utils and triggered by sqlalchemy commit to update version to non-numeric
14:29:13 <haleyb> ykarel: ack, so not in neutron
14:29:19 <haleyb> ah, just saw this in oslo channel
14:29:23 <haleyb> #link https://bugs.launchpad.net/oslo.utils/+bug/2042886
14:29:54 <haleyb> sqlalchemy 2.1.0b1 was released, and that suffix is the problem
14:30:11 <ykarel> yeap
14:30:13 <opendevreview> Slawek Kaplonski proposed openstack/neutron master: Make job openstack-tox-py310-with-sqlalchemy-master non-voting temporary  https://review.opendev.org/c/openstack/neutron/+/900322
14:30:39 <slaweq> ^^ makes openstack-tox-py310-with-sqlalchemy-master job non-voting in check queue
14:30:58 <haleyb> slaweq: thanks
14:31:18 <ykarel> thx slaweq
14:31:23 <haleyb> any other bugs to discuss?
14:32:04 <haleyb> #topic specs
14:32:24 <haleyb> #link https://review.opendev.org/q/project:openstack%252Fneutron-specs+status:open
14:32:54 <haleyb> there are currently 3 open specs
14:33:11 <haleyb> the first has had many reviews
14:34:06 <haleyb> the OVN interconnect had a comment by otherwiseguy, don't see him online
14:35:44 <lajoskatona> very interesting discussion, good to see
14:36:34 <haleyb> racosta_: i saw your response but only quickly
14:38:07 <haleyb> i guess we can have the discussion in the spec, please comment there if you are interested in this topic
14:39:08 <haleyb> and there will be a drivers meeting this Friday at 14:00 UTC to discuss others
14:39:15 <haleyb> #link https://wiki.openstack.org/wiki/Meetings/NeutronDrivers
14:39:48 <haleyb> lets move on then
14:39:51 <haleyb> #topic community_goals
14:41:17 <slaweq> no big updates on the S-RBAC topic this week
14:41:24 <slaweq> just that https://review.opendev.org/c/openstack/neutron-tempest-plugin/+/899467 was merged
14:41:52 <haleyb> great
14:42:29 <haleyb> lajoskatona: anything on neutronclient? need any reviews?
14:42:46 <lajoskatona> nothing
14:43:11 <lajoskatona> I have to go to the horizon as we discussed during the PTG with them
14:43:39 <haleyb> right
14:43:50 <haleyb> ok, moving on
14:43:54 <haleyb> #topic on_demand
14:44:09 <mlavalle> I have a quick topic
14:44:14 <haleyb> go ahead
14:44:46 <mlavalle> The OVN router flavors patch is now complete and passing all the tests: https://review.opendev.org/c/openstack/neutron/+/883988
14:45:19 <mlavalle> I'll be updating the document included in the patch and the commit message later today
14:45:27 <mlavalle> and it will be good for reviews
14:46:23 <mlavalle> EOM
14:46:34 <haleyb> i just added myself will try to look this week
14:46:50 <mlavalle> haleyb: just wait for the latest revision today
14:47:01 <haleyb> mlavalle: ack
14:47:02 <mlavalle> Thanks!
14:47:53 <haleyb> the other large changeset we have in flight is also for OVN, the BFD/ECMP changes
14:47:57 <haleyb> #link https://review.opendev.org/c/openstack/neutron/+/893025
14:48:26 <haleyb> there's still about 10 to go, i'll be reviewing those in the next week as well
14:49:18 <haleyb> and i had added a related topic - review days
14:49:46 <haleyb> if i'm remembering from the PTG correctly, we talked about maybe having something like this
14:50:30 <opendevreview> Luis Tomas Bolivar proposed openstack/ovn-bgp-agent master: Add support at NB BGP Driver for exposing OVN LBs  https://review.opendev.org/c/openstack/ovn-bgp-agent/+/899120
14:50:34 <lajoskatona> +1
14:50:41 <haleyb> and when i looked at the number of patches we have in flight (at least my own) it seemed focusing on merging would get us two things
14:51:06 <haleyb> 1) bugs will get closed, since a lot are bug fixes (and trickle down to stable)
14:51:29 <haleyb> 2) less things to have to rebase and re-review
14:52:26 <haleyb> not sure what others think, but it would make me feel better
14:52:36 <ykarel> +1 sounds good
14:53:21 <lajoskatona> agree
14:54:37 <haleyb> i will look at the calendar and propose a couple of times next week, for me the beginning of US thanksgiving week would work (november 20-21) but there's others
14:55:11 <haleyb> I had nothing else
14:55:31 <lajoskatona> yeah, let's try it and we can revisit, kind of retro what we did and achieved and adapt
14:56:26 <haleyb> right, it's almost like a code sprint from the "old days"
14:56:45 <lajoskatona> :-)
14:57:10 <haleyb> ykarel: and there is a CI meeting at top of hour, correct?
14:57:26 <ykarel> yeap in 3 minutes video https://meetpad.opendev.org/neutron-ci-meetings
14:57:47 <haleyb> sorry i took the whole hour, lets end so we can join that
14:57:51 <haleyb> #endmeeting