14:00:20 <haleyb> #startmeeting networking
14:00:20 <opendevmeet> Meeting started Tue Nov 21 14:00:20 2023 UTC and is due to finish in 60 minutes.  The chair is haleyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:20 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:20 <opendevmeet> The meeting name has been set to 'networking'
14:00:21 <elvira> o/
14:00:23 <ykarel> o/
14:00:24 <obondarev> o/
14:00:26 <rubasov> o/
14:00:29 <bcafarel> o/
14:00:32 <mlavalle> o/
14:01:31 <haleyb> good crowd :)
14:01:33 <haleyb> #topic announcements
14:01:52 <haleyb> Last week was the C-1 milestone
14:02:05 <haleyb> Releases for neutron-lib, os-ken, python-neutronclient and ovsdbapp have happened, thanks for all the reviews!
14:02:28 <lajoskatona> o/
14:03:25 <haleyb> Reminder that drivers meeting for this Friday (11/24) is cancelled
14:03:55 <haleyb> Review days - talked last week about setting aside 2-3 days at intervals (every other month?) to get some in-flight reviews merged. Will help with our bug backlog
14:04:05 <haleyb> #link https://doodle.com/meeting/organize/id/dN8opRDa
14:04:14 <haleyb> So far 4 people have added their availability, please add your time if you can!
14:05:07 <haleyb> the vote is evenly split between next week and the one after so need a tiebreaker
14:05:24 <haleyb> if none i will just pick one
14:06:48 <ykarel> voted
14:07:21 <haleyb> Only other announcement I had was about the new eom policy
14:07:25 <haleyb> ykarel: thanks!
14:08:02 * haleyb is looking for email to list about it
14:08:32 <haleyb> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/message/ZYAZG43BLJJVXCYZVPYQX5733BYDVVNL/
14:08:44 <haleyb> that was an update that helps describe it more
14:09:24 <haleyb> based on that, we wanted to do a final release for stable/yoga
14:09:52 <haleyb> #link https://etherpad.opendev.org/p/neutron-stable-yoga-eom has a list of unmerged changes, of which there are few
14:10:47 <haleyb> And actually coreycb_ did propose releases from yoga to 2023.2
14:10:51 <lajoskatona> do we have a strict time to be ready with it?
14:10:51 <haleyb> #link https://review.opendev.org/c/openstack/releases/+/901058
14:11:27 <haleyb> lajoskatona: i don't see a date in the email
14:12:04 <haleyb> but i would think by end of this cycle
14:12:08 <bcafarel> https://review.opendev.org/q/project:openstack/neutron+branch:stable/yoga+status:open does not look to bad (one WIP, one small doc, and https://bugs.launchpad.net/neutron/+bug/2030804 fix)
14:12:18 <lajoskatona> ok, but as I see only 1 patch is hanging: https://review.opendev.org/c/openstack/neutron/+/893777
14:12:22 <haleyb> slaweq: has the timeline come up at TC meeting?
14:12:57 <bcafarel> he's off today
14:12:58 <lajoskatona> ahh, ok, so 3 open patches
14:12:59 <haleyb> lajoskatona: ack, and i think that one needs an update since master has not merged yet
14:14:01 <lajoskatona> ok, so in worst case if the eom is urgent we can just say that it will not included
14:14:48 <haleyb> lajoskatona: right, i'll look into it to see if there is a deadline
14:15:10 <haleyb> #action haleyb to see what yoga-eom deadline is
14:15:54 <lajoskatona> thanks
14:16:24 <haleyb> we actually merged a lot of stable backports the past couple weeks which is good
14:16:32 <haleyb> ok, any other announcements?
14:16:50 <haleyb> #topic bugs
14:17:23 <haleyb> jlibosva was the deputy last week, isabek is this week, elvira next week
14:17:40 <elvira> ack o>
14:17:42 <haleyb> is that still good for future deputies?
14:17:49 <jlibosva> there was one critical bug but it was taken care of by Yatin
14:18:48 <haleyb> right, neutron-lib master job breakage, thanks ykarel for fixing that
14:19:49 <haleyb> Current bug count this week: 760, down 6 from last week :)
14:20:11 <haleyb> so trend is good
14:20:28 <haleyb> any other bugs need discussion?
14:21:11 <haleyb> #topic specs
14:22:37 <haleyb> racosta: did you get any other comments on the OVN-IC spec since last week?
14:23:42 <haleyb> #link https://review.opendev.org/c/openstack/neutron-specs/+/891204
14:24:35 * haleyb just realized he never clicked Reply so now my comment is attached
14:25:00 <haleyb> we will follow-up in the spec
14:25:15 <haleyb> #topic community_goals
14:25:47 <haleyb> i saw lajoskatona pushed a WIP for neutronclient deprecation in horizon
14:25:53 <haleyb> #link https://review.opendev.org/c/openstack/horizon/+/891205
14:26:01 <lajoskatona> yes I finally got to that one again
14:26:12 <lajoskatona> I still have to work on unit tests
14:26:22 <lajoskatona> tha patch actually vocers network and subnet operations
14:26:37 <lajoskatona> It seems that it is possible to do it in smaller steps
14:26:49 <lajoskatona> like first network and subnet after something else
14:27:08 <haleyb> lajoskatona: what is 'vocers' ?
14:27:46 <racosta> Hi haleyb, sorry for the delay. No updates on OVN-IC spec, just waiting for new comments.
14:27:47 <ykarel> may be covers
14:28:15 <ykarel> vocers -> covers :)
14:28:23 <haleyb> right :)
14:28:26 <lajoskatona> yes, sorry covers
14:29:28 <haleyb> ok, i'm watching it now, i actually have some downstream code that needs similar changes :)
14:29:49 <haleyb> racosta: ack, i had actually forgotten to send mine
14:30:30 <haleyb> ok, moving on
14:30:43 <lajoskatona> haleyb: I can't call it fun to find what need to be changed in html or js if I change something in python
14:31:19 <haleyb> lajoskatona: python is more fun than js for sure imo
14:31:45 <lajoskatona> :-)
14:31:58 <haleyb> #topic on_demand
14:32:14 <haleyb> the only carry-over from last week is the VPNaaS for OVN change
14:32:19 <haleyb> #link https://review.opendev.org/c/openstack/neutron-vpnaas/+/765353
14:33:00 <haleyb> i was able to get through it and bodo pushed an update to address my comments
14:33:16 <haleyb> hopefully we can get that merged soon
14:33:56 <haleyb> anyone have another topic?
14:34:15 <mlavalle> Just to remind the team that OVN router flavors are ready for reviews: https://review.opendev.org/c/openstack/neutron/+/883988
14:35:08 <lajoskatona> good job mlavalle, I try to find some time to check it
14:35:37 <haleyb> mlavalle: ack, will put that on my list for next week, thanks for getting it done!
14:35:55 <mlavalle> haleyb: and yes, I'm making my way slowly throug the VPNaaS patch
14:36:15 * haleyb should have noted he is out the rest of this week for the US holiday, returning Monday
14:36:46 <haleyb> hopefully there are no fires
14:37:03 * mlavalle I'll also be off starting tomorrow coming back on Tuesday
14:37:16 <lajoskatona> +1, enjoy your holiday :-)
14:37:22 <haleyb> ykarel: CI meeting today?
14:37:30 <haleyb> lajoskatona: thanks
14:37:52 <ykarel> haleyb, yes in 23 minutes, video
14:38:42 <haleyb> ack, will try and attend
14:39:02 <ykarel> +1
14:39:15 <haleyb> if nothing else everyone can have 20 minutes back, thanks for attending and have a good week!
14:39:29 <mlavalle> o/
14:39:30 <haleyb> #endmeeting