14:00:09 <haleyb> #startmeeting networking
14:00:09 <opendevmeet> Meeting started Tue Nov 28 14:00:09 2023 UTC and is due to finish in 60 minutes.  The chair is haleyb. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:09 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:09 <opendevmeet> The meeting name has been set to 'networking'
14:00:12 <elvira> o/
14:00:33 <obondarev> o/
14:00:40 <mlavalle> \o
14:01:06 <ykarel> o/
14:01:10 <rubasov> o/
14:01:34 <haleyb> alright lets get started
14:01:38 <haleyb> #topic announcements
14:02:19 <haleyb> according to https://releases.openstack.org/caracal/schedule.html we are past the C-1 milestone
14:02:21 <lajoskatona> o/
14:02:55 <haleyb> C-2 milestone is Jan 8-12 which will come up quickly
14:03:41 <haleyb> Reminder: If you have a topic for the drivers meeting on Friday, please add it to the wiki @ https://wiki.openstack.org/wiki/Meetings/NeutronDrivers
14:03:51 <haleyb> there are currently no topics in the queue
14:04:33 <haleyb> Review days - talked last week about setting aside 2-3 days at intervals to get some in-flight reviews merged
14:04:38 <haleyb> #link https://doodle.com/meeting/organize/id/dN8opRDa
14:04:59 <haleyb> 5 people added their availability, with December 1st and 8th working for everyone, are people OK splitting across a week?
14:05:34 <haleyb> or if back-to-back is better i would propose December 7/8
14:05:59 * haleyb taps microphone to see if people are awake :)
14:06:08 <lajoskatona> yes sir
14:06:14 <frickler> I'm not directly involved, but splitting to allow authors to react sounds nice
14:06:15 <lajoskatona> for me either can work
14:06:18 <mlavalle> the split is fine
14:06:28 <lajoskatona> good reasoning, than split it
14:07:52 <haleyb> alright, i was thinking the same thing - so anyone that added their name, or anyone that needs reviews, try and set aside time this Friday and next for them
14:08:00 <haleyb> time in-between to fix-up and rebase, etc
14:08:16 <haleyb> #action haleyb to reply to ML thread with this info
14:08:52 <frickler> fnordahl: ^^ that might be interesting for your series, too
14:09:34 <haleyb> any other announcements?
14:10:10 <haleyb> #topic bugs
14:10:35 <haleyb> obondarev was deputy last week, isabek is this week, elvira next week
14:10:44 <haleyb> #link https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/W4JIPTXHVIN54T2FOPEYO6AGREF4JPCC/
14:11:34 <haleyb> 4/5 bugs were picked-up and have patches
14:11:52 <isabek> o/
14:11:55 <haleyb> so thanks for picking them up
14:12:09 <haleyb> isabek: are you ok being bug deputy this week?
14:12:22 <isabek> sure
14:12:33 <haleyb> ack, thanks!
14:12:50 <elvira> there are some PH on Spain next week, I will be out from wednesday until end of week :(
14:13:09 <bcafarel> late o/
14:13:36 <elvira> I don't mind taking a look mon-tue and then on Mondaywhen I get back. Whatever is best for you folks
14:14:25 <haleyb> elvira: ack, i can watch for critical things the end of the week, unless someone wants to switch?
14:15:34 <lajoskatona> I can switch
14:15:46 <lajoskatona> my week would be the first of 24, and I am off that week
14:16:03 <haleyb> elvira: does that work? i can update if so
14:16:39 <elvira> I will also be off but I will have the laptop really nearby so no problem for me!!
14:16:42 <elvira> It works better
14:16:44 <elvira> :)
14:16:56 <lajoskatona> thanks, than I will be deputy next week
14:17:03 <haleyb> sold, will update
14:17:18 <haleyb> so the one bug in question is
14:17:23 <haleyb> #link https://bugs.launchpad.net/neutron/+bug/2044215
14:17:44 <haleyb> dns: Keyword is replaced by project_name instead of project_id
14:18:00 <haleyb> i don't exactly understand it either, submitter asked for more information
14:18:38 <haleyb> if it makes sense to anyone please feel free to add comments
14:19:20 <haleyb> are there any other bugs someone wants to discuss?
14:19:29 <gtema> https://bugs.launchpad.net/neutron/+bug/1975828
14:19:49 <gtema> sorry for jumping in: please check the last comment. Sadly bug expired, but I posted update recently
14:20:23 <gtema> there is huge difference in API when listing ports (from project with 1500 ports) between admin and user call
14:20:37 <gtema> and I ended up in thinking that it is policy evaluation engine
14:20:59 <haleyb> gtema: thanks for bringing this up
14:21:16 <haleyb> so when you say policy i'm assuming rbac?
14:21:25 <gtema> yes
14:22:38 <haleyb> we can un-expire it, is there anyone that has cycles to look into it?
14:23:00 <haleyb> rodolfo is out for a while
14:23:24 <opendevreview> Luis Tomas Bolivar proposed openstack/ovn-bgp-agent master: Avoid race when deleting VM with FIP  https://review.opendev.org/c/openstack/ovn-bgp-agent/+/901963
14:23:33 <fnordahl> frickler: (indeed, I will read up on the e-mail thread, and I'm available until Dec 15th so hopefully we can get some ground covered before then!)
14:23:54 <opendevreview> Miguel Lavalle proposed openstack/neutron master: Router flavors and service type for OVN  https://review.opendev.org/c/openstack/neutron/+/883988
14:24:03 <opendevreview> Merged openstack/ovn-bgp-agent master: Ensure withdrawn events are only processed in relevant nodes  https://review.opendev.org/c/openstack/ovn-bgp-agent/+/901962
14:24:43 <haleyb> gtema: i will change the status just not sure if anyone can pick it up
14:25:31 <opendevreview> Luis Tomas Bolivar proposed openstack/ovn-bgp-agent stable/2023.2: Ensure withdrawn events are only processed in relevant nodes  https://review.opendev.org/c/openstack/ovn-bgp-agent/+/902065
14:25:43 <gtema> ok. I will try myself to play deeper with it. It looks like there is no caching when policies are being evaluated. Just wanted to know whether somebody knows something about it
14:26:29 <haleyb> sorry i don't, first time i had seen it
14:26:56 <haleyb> last thing on topic of bugs
14:27:02 <gtema> ok, thks anyway
14:27:36 <haleyb> Current bug count this week: 762, up 2 from last week - so good we really didn't increase
14:28:12 <haleyb> #topic specs
14:28:22 <haleyb> #link https://review.opendev.org/q/project:openstack%252Fneutron-specs+status:open
14:29:10 <haleyb> i see racosta has uploaded a new version of the OVN-IC spec, i have not had time to review yet
14:29:16 <haleyb> #link https://review.opendev.org/c/openstack/neutron-specs/+/891204
14:29:22 <haleyb> will review today
14:30:18 <haleyb> and the other two (BGP related) also had updates
14:30:51 <haleyb> hopefully people will get around to reviews :)
14:31:51 <haleyb> moving on...
14:31:55 <haleyb> #topic community_goals
14:33:00 <haleyb> lajoskatona: think you're the only one with a goal on the list, neutronclient deprecation
14:33:08 <haleyb> #link https://review.opendev.org/c/openstack/horizon/+/891205
14:33:19 <lajoskatona> yes, I am strugling with the one horizon patch
14:33:32 <lajoskatona> to fix failing tests
14:33:41 <lajoskatona> so slow progression
14:34:25 <haleyb> thanks for taking on the work to begin with
14:34:52 <haleyb> #topic on_demand
14:35:21 <lajoskatona> I added a topic for OpenAPI
14:35:32 <lajoskatona> the mail from gtema: https://lists.openstack.org/archives/list/openstack-discuss@lists.openstack.org/thread/BU5JH7FJ5VPS75QWPW47IYSZOFDI5R2W/
14:35:54 <gtema> right, thanks
14:36:19 <gtema> I can give some more infos on the topic, but few more links to be more preciese
14:36:26 <haleyb> "Neutron is very special"
14:36:34 <lajoskatona> :-)
14:36:43 <haleyb> gtema: sure, go ahead
14:37:09 <gtema> https://github.com/gtema/openstack-openapi/blob/main/specs/network/v2.yaml - this is a spec that I was able to generate from neutron sources
14:37:30 <gtema> https://github.com/gtema/openstack-codegenerator/blob/main/codegenerator/generator/openapi/neutron.py - this is the code I generated it with
14:37:51 <gtema> https://gtema.github.io/openstack-openapi/network.html - current draft for rendering spec in the OpenStack style
14:37:57 <gtema> everything is a work in progress
14:38:30 <gtema> but generally the question nr 1) is Neutron team interested in having openapi doc produced from sources so that api-ref can be actually deprecated as such
14:38:37 <lajoskatona> is this for the API or for what we have in SDK?
14:38:46 <gtema> and also all clients/sdks/etc can be generated by various tools
14:39:04 <lajoskatona> ok so this is for the APi which we have in n-lib
14:39:13 <gtema> well, this is currently not connected with SDK directly, but rather extracted from Neutron source and api-ref html
14:39:18 <haleyb> #link https://docs.openstack.org/api-ref/network/v2/index.html
14:39:33 <haleyb> should be similar to that i would guess
14:40:05 <gtema> right, this is going to be rendered this style, but maybe more modern. This is not a point
14:40:25 <slaweq> what about APIs provided by e.g. stadium projects? I don't see them in this example at all
14:40:50 <gtema> right, at the moment I took pure "neutron" and messed with what I could find
14:41:14 <gtema> vpnaas is also not there and that was a question towards you
14:41:49 <gtema> https://github.com/gtema/openstack-codegenerator/blob/main/codegenerator/generator/openapi/neutron.py#L79 - this is how I setup the neutron to access api router and inspect everything what it knows about
14:41:50 <slaweq> even for just neutron, APIs of running server may be different depending on enabled service plugins, mechanism drivers, etc. (as You already mentioned in the email) so will it be possible to somehow generate complete list of APIs always?
14:42:19 <gtema> that is the point - I need help in getting the configuration that enables "everything"
14:43:32 <lajoskatona> I dont think that is possible at least for all the stadiums in one setup
14:43:34 <gtema> second question would be: is it possible to alter exposed routes to not to expose things which are not working
14:44:09 <gtema> i.e. you see in the spec there is POST for /availability-zones or /auto-allocateted-topology
14:44:32 <gtema> this is because in reality those are exposed but if you try invoking them you will get weird validation errors, but not 404
14:46:18 <gtema> also, I found way to "convert" api_definition into the json schema, but there are certain limitations there and not all resources are having it at all, so that requires hardcoding
14:48:12 <gtema> lajoskatona - if it is not possible to have everything running at once (and this is why I stopped attempting that) we could try different approach of generating spec in few runs with different configs
14:48:19 <haleyb> i'm not sure i'm the best one to help, but my very generic question is there something neutron can change to make this work easier?
14:48:30 <lajoskatona> gtema: ack
14:48:38 <opendevreview> Merged openstack/ovn-bgp-agent master: Avoid race when deleting VM with FIP  https://review.opendev.org/c/openstack/ovn-bgp-agent/+/901963
14:49:16 <gtema> haleyb: yes, there are certain things, but first I would like to know whether I have Neutron support generally in this initiative
14:50:30 <opendevreview> Luis Tomas Bolivar proposed openstack/ovn-bgp-agent stable/2023.2: Avoid race when deleting VM with FIP  https://review.opendev.org/c/openstack/ovn-bgp-agent/+/902067
14:51:19 <haleyb> gtema: i would support it, what do others think? and where do you think it falls on the scale of small/medium/large so we don't overcommit?
14:51:55 <slaweq> generally I like that idea and I can try to help if I will have some cycles (but that may be hard currently)
14:52:16 <slaweq> so gtema if You will need any help, please ping me - I will try to help when possible
14:52:23 <lajoskatona> +1 from me, I can help also for the stadiums for example
14:52:28 <gtema> perfect. Thanks a lot.
14:52:57 <gtema> so from the gestimate: I think initially it is a small effort just to analyse and find ways for workarounds
14:53:31 <gtema> once that is done in next steps those workarounds may be moved to neutron code so that generation is more reliable, that may be medium
14:53:47 <gtema> but I really don't expect it to be a large stuff
14:54:47 <gtema> ok, thanks on the topic
14:55:01 <lajoskatona> thanks for working on this topic
14:55:02 <haleyb> gtema: ack, thanks, sounds good to me
14:56:11 <haleyb> any other topics for discussion?
14:56:15 <mlavalle> Just remind the team that router flavors with L3 OVN is ready for reviews: https://review.opendev.org/c/openstack/neutron/+/883988
14:56:36 <haleyb> mlavalle: thanks!
14:56:40 <mlavalle> I just rebased it
14:56:49 <haleyb> ykarel: and we have CI meeting today?
14:57:00 <ykarel> yes in 4 minutes over IRC
14:57:22 <lajoskatona> ack
14:57:41 <haleyb> ok, thanks for attending everyone
14:57:46 <haleyb> #endmeeting