18:06:06 <SumitNaiksatam> #startmeeting Networking FWaaS
18:06:07 <openstack> Meeting started Wed Feb  5 18:06:06 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:06:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:06:11 <openstack> The meeting name has been set to 'networking_fwaas'
18:06:22 <SumitNaiksatam> #topic temptest testing
18:06:33 <beyounn> hi
18:06:51 <SumitNaiksatam> SridarK did some great work over the past few days testing FWaaS and VPNaaS
18:07:01 <SumitNaiksatam> beyounn: hi
18:07:11 <SumitNaiksatam> SridarK: do you have the link handy to the wiki page you posted?
18:07:31 <SridarK> SumitNaiksatam: https://wiki.openstack.org/wiki/Quantum/FWaaS/Testing
18:07:42 <SumitNaiksatam> SridarK: thanks, also do you want to give a quick update to the team on the work you did?
18:07:52 <SridarK> Sure
18:08:06 <SridarK> basic VPNaaS & FWaaS integration looks good
18:08:16 <SridarK> outlined in the wiki
18:08:40 <SridarK> also ran tempest API tests with baseline and FWaaS enabled
18:08:46 <SridarK> no changes
18:08:58 <SridarK> still trying to run the full suite
18:09:06 <SumitNaiksatam> SridarK: great
18:09:17 <SridarK> run into some issues there - WIP
18:09:26 <SumitNaiksatam> SridarK: would it be possible to document what you running in the tempests tests
18:09:27 <pcm_> SridarK: nice!
18:09:35 <SridarK> surely
18:09:46 <SumitNaiksatam> SridarK: no necessarily the output, but what scripts you are running
18:09:50 <SridarK> will add the tempest runs as another section in the wiki
18:09:59 <SumitNaiksatam> SridarK: or what subset of tests you are running
18:10:14 <SumitNaiksatam> SridarK:  that was other members can perhaps try and reproduce as well
18:10:15 <SridarK> basically ran all the network API tests
18:10:24 <SumitNaiksatam> *way
18:10:45 <SridarK> sure will do SumitNaitsatam:
18:10:57 <SumitNaiksatam> SridarK: great, thanks for your hard work on this
18:11:05 <SridarK> No worries at all
18:11:12 <SridarK> Thats all on this topic
18:11:34 <SumitNaiksatam> for all those whoever at the neutron IRC meeting on last Monday, we brought this up with the PTL
18:11:51 <SridarK> i should also thank pcm_ for pointing me to the VPNaaS setup magic
18:11:52 <SumitNaiksatam> but we did not get a clear direction whether fwaas will be enabled right away at the gate or not
18:12:08 <pcm_> SridarK: np
18:12:16 <SumitNaiksatam> pcm_: thanks so much, greatly appreciated!
18:12:32 <SumitNaiksatam> pcm_: please continue helping and participating ;-P
18:12:49 <pcm_> SumitNaiksatam: sure. trying to keep VPN and FW in sync :)
18:12:57 <SumitNaiksatam> pcm_: absolutely
18:13:09 <SumitNaiksatam> so regarding the gate, we will wait watch
18:13:27 <SumitNaiksatam> i saw some merges starting to go through
18:13:39 <SumitNaiksatam> i am not sure if this is on account of the fixes for the kernel issue
18:14:18 <SumitNaiksatam> but, we seem to be making progress, so i think once we get more stable and predictable, i think we check back with the PTL on this
18:15:17 <SumitNaiksatam> once fwaas is enabled on the gate, the tempest test patches which have been posted by yair can be reviewed
18:15:54 <SumitNaiksatam> we probably need to invite the tempest folks including miguel to this meeting to sync up
18:16:05 <SumitNaiksatam> anyone else has any more thoughts on this?
18:16:45 <SumitNaiksatam> gduan beyounn: do you have any dependency to run your 3rd party testing on the tempest tests?
18:16:57 <SumitNaiksatam> i mean fwaas tempest tests
18:17:15 <RajeshMohan> SridarK: Can you document how to run fwaas tempest?
18:17:27 <gduan> I am having an error running tempest
18:17:34 <RajeshMohan> SridarK: We can try to run some part in parallel
18:17:34 <gduan> Seems to be a known bug
18:17:36 <gduan> ImportError: cannot import name all
18:17:47 <SridarK> RajeshMohan: surely
18:18:14 <SridarK> speaking of parallel, i ran things serially
18:18:18 <gduan> I will try to figure it out today
18:18:18 <SridarK> :-)
18:18:29 <RajeshMohan> SridarK: :-)
18:18:35 <SridarK> just to make sure we did not have any synchronization issues
18:18:55 <SumitNaiksatam> gduan: if its a known issue its fine
18:18:57 <SridarK> After whick i started running all things
18:19:08 <SridarK> we can sync up offline
18:19:35 <SumitNaiksatam> gduan: i was specifically asking about fwaas tempest tests, which currently we don't have (patches posted) but might be needed for your driver
18:20:02 <SumitNaiksatam> gduan: anyway, we can sync up offline if that becomes an issue
18:20:08 <SumitNaiksatam> ok moving on
18:20:17 <SumitNaiksatam> oh before that
18:20:29 <SumitNaiksatam> SridarK: whats the plan for the next week
18:20:30 <SumitNaiksatam> ?
18:20:46 <SumitNaiksatam> SridarK: are you running the pending tests?
18:21:02 <SridarK> I want to try to wrap up the complete runs
18:21:09 <SumitNaiksatam> SridarK: great
18:21:13 <SridarK> not sure how relevant all of that will be
18:21:24 <SridarK> need to get on the CLI work soon after
18:21:52 <SumitNaiksatam> #action Sridar to quickly wrap pending run of tests, and document running tempests tests
18:22:11 <SumitNaiksatam> SridarK: i think even if you do the documentation on running the tests, others can also pick up the work
18:22:25 <SumitNaiksatam> #topic service_type framework
18:22:28 <SridarK> will do that right away
18:22:39 <SumitNaiksatam> SridarK: thanks much
18:22:44 <SumitNaiksatam> #link https://review.openstack.org/#/c/60699/
18:22:59 <SumitNaiksatam> gduan: i did a recheck on your patch yesterday
18:23:18 <gduan> SumitNaiksatam: Thanks
18:23:22 <SumitNaiksatam> gduan: the fix for the bug which your patch was failing on was fortunately merged
18:23:34 <SumitNaiksatam> gduan: so your jenkins likes your patch now :-)
18:23:45 <gduan> SumitNaiksatam: right. seems all passed except non-voting ones
18:24:23 <SumitNaiksatam> gduan: i am still not convinced about the point regarding the uncommented configuration in the neutron.conf
18:25:04 <SumitNaiksatam> gduan: we might have to make devstack changes regardless
18:25:36 <gduan> SumitNaiksatam: Ok
18:25:38 <SumitNaiksatam> gduan: but this particular configuration should not have to be left uncommented in the neutron.conf if its already the default
18:25:56 <SumitNaiksatam> gduan: but perhaps you have a different perspective
18:26:12 <SumitNaiksatam> gduan: i was following the precedence which has been set with lbaas
18:26:43 <gduan> SumitNaiksatam: right. I think another reviewer also asked me to add a line there
18:26:50 <SumitNaiksatam> gduan: apart from that, are there any other issues?
18:27:03 <gduan> SumitNaiksatam: no
18:27:34 <SumitNaiksatam> gduan: ok good, perhaps you can ping nachi and enikanorov__ to take a look
18:27:56 <gduan> SumitNaiksatam: Sure
18:28:10 <SumitNaiksatam> SridarK RajeshMohan beyounn can also please review gduan's patch and provide comments?
18:28:19 <SridarK> sure
18:28:37 <RajeshMohan> SumitNaiksatam:Will do
18:28:38 <SumitNaiksatam> we need to push this patch forward as a team, since RajeshMohan's patch depends on this
18:28:57 <SumitNaiksatam> SridarK RajeshMohan: thanks
18:29:27 <SumitNaiksatam> gduan: so you will check if any devstack changes need to be made?
18:29:41 <SumitNaiksatam> gduan: and accordingly follow up
18:29:42 <gduan> SumitNaiksatam: I will
18:30:10 <SumitNaiksatam> gduan: to test this, were you using the an unmodified devstack install, or were you making any local changes?
18:31:01 <gduan> SumitNaiksatam: I did change neutron.conf and restart neutron
18:31:28 <SumitNaiksatam> gduan: ok, to add the fwaas service type configuration
18:31:38 <gduan> SumitNaiksatam: so I think we need make the reference driver as default setting is q_fwaas is enabled
18:31:50 <SumitNaiksatam> gduan: yeah, that was my thinking
18:32:01 <gduan> SumitNaiksatam: Will do
18:32:20 <SumitNaiksatam> gduan: thanks much, good to get this change in the devstack queue at the earliest
18:33:16 <gduan> SumitNaiksatam: OK
18:34:14 <SumitNaiksatam> gduan: no horizon changes, right?
18:35:07 <SumitNaiksatam> gduan: also, any doc changes?
18:35:07 <gduan> SumitNaiksatam: no. Unless we want to add that option somehow
18:35:14 <SumitNaiksatam> gduan: i don't think so
18:35:18 <SumitNaiksatam> gduan: but documentation?
18:35:20 <gduan> SumitNaiksatam: agree
18:35:34 <gduan> SumitNaiksatam: A wiki page?
18:35:52 <SumitNaiksatam> gduan: no i meant the admin guide, in the FWaaS section
18:36:12 <SumitNaiksatam> gduan: if we were mentioning the fwaas driver configuration before, we will need to update that
18:36:20 <SumitNaiksatam> gduan: i think we were
18:37:02 <SumitNaiksatam> gduan: should be a quick change, will give you exposure to the documentation side of things as well :-)
18:37:43 <SumitNaiksatam> RajeshMohan: any other dependency your patch on has no gduan's (apart from it having to merge)?
18:37:51 <gduan> SumitNaiksatam: OK. I will find it out
18:38:09 <SumitNaiksatam> gduan: thanks
18:38:44 <SumitNaiksatam> ok moving on
18:38:55 <SumitNaiksatam> #topic Service Insertion and Firewall
18:39:05 <SumitNaiksatam> #link https://review.openstack.org/#/c/62599/
18:39:24 <SumitNaiksatam> RajeshMohan: any updates on the patch?
18:39:58 <SumitNaiksatam> RajeshMohan: i believe the patch needs to be rebased and revived?
18:40:18 <RajeshMohan> SumitNaiksatam: Yes
18:40:21 <SumitNaiksatam> RajeshMohan: in addition to the changes we had discussed
18:40:57 <SumitNaiksatam> RajeshMohan: any new issues or are you good on that?
18:41:28 <RajeshMohan> SumitNaiksatam: I am mainly focusing on moving to new patch but could not put enough time on it last week
18:41:36 <SumitNaiksatam> RajeshMohan: ok
18:42:03 <RajeshMohan> SumitNaiksatam: I got caught on some internal tasks. I will rebase (to gdaun's patch) and post the new patch
18:42:03 <SumitNaiksatam> btw, i forgot to add a couple of action items earlier
18:42:11 <SumitNaiksatam> RajeshMohan: great thanks
18:42:23 <SumitNaiksatam> so from the previous topic -
18:42:47 <SumitNaiksatam> #action gduan to post devstack patch for driver configuration, check documentation impact
18:43:06 <SumitNaiksatam> #action gduan to follow up with other reviewers, mainly nati_ueno and enikanorov__
18:43:17 <SumitNaiksatam> ok coming back to this topic
18:43:33 <SumitNaiksatam> lets quickly discuss the Client and the CLI
18:43:42 <SumitNaiksatam> SridarK: you have a start on this?
18:44:07 <SridarK> RajeshMohan: and i had discussion on Fri
18:44:13 <SumitNaiksatam> SridarK: ok
18:44:28 <SridarK> i shd get started on this today / tormorrow
18:44:57 <enikanorov__> gduan: i'll review
18:45:09 <SumitNaiksatam> SridarK: possible to quickly update here? and perhaps capture high level details in a wiki page?
18:45:13 <SumitNaiksatam> enikanorov__: thanks
18:46:16 <SumitNaiksatam> i would also like to set aside some time to discuss the horizon changes
18:46:33 <SumitNaiksatam> perhaps a separate meeting
18:46:38 <SridarK> will do so
18:46:49 <SumitNaiksatam> i would like to get input from everyone on that
18:47:13 <SumitNaiksatam> RajeshMohan: more specifically from you, since you want to be able to support L2 insertion use case as well
18:47:15 <SridarK> wanted to circulate the potential CLI options to discuss with the team first
18:47:28 <RajeshMohan> SumitNaiksatam:ok
18:47:42 <SumitNaiksatam> RajeshMohan: so horizon should not just have the provision for the router context i believe
18:47:46 <SumitNaiksatam> SridarK: sure
18:48:03 <RajeshMohan> SumitNaiksatam:agree
18:48:53 <SumitNaiksatam> SridarK: it will be good to have the CLI examples in the wiki page
18:49:17 <SumitNaiksatam> #action SridarK RajeshMohan to capture CLI proposal for firewall insertion in wiki
18:49:22 <gduan> RajeshMohan: we'd like to see the L2 senario too
18:49:28 <SridarK> Yes once we have some discussions and are in agreement will put it on to th wiki
18:49:30 <SumitNaiksatam> SridarK: sorry to many action items for you :-P
18:49:38 <SridarK> no worries
18:50:04 <SridarK> L2 is important for us as well
18:50:06 <SumitNaiksatam> gduan: yeah, lets all discuss the CLI and horizon options (keep an eye for the wiki that SridarK  will post on the CLI/client)
18:50:25 <SumitNaiksatam> RajeshMohan SridarK: anything more to discuss on this?
18:50:36 <SridarK> nothing from me
18:50:53 <SumitNaiksatam> RajeshMohan: as with the service type patch, we will probably need devstack changes as well?
18:51:08 <SumitNaiksatam> RajeshMohan: or we will plan to keep the default to insertion on all routers?
18:52:11 <RajeshMohan> SumitNaiksatam: we should avoid devstack changes
18:52:33 <RajeshMohan> SumitNaiksatam: given the time
18:53:57 <SumitNaiksatam> RajeshMohan: ok, as long we are consistent with the understanding of the default configuration
18:54:14 <SumitNaiksatam> RajeshMohan: but i think we will need to update the documentation
18:54:29 <SumitNaiksatam> RajeshMohan: we can revisit this once we make progress with the patch
18:54:51 <SumitNaiksatam> RajeshMohan: the documentation changes are only relevant after the patch is merged
18:55:01 <RajeshMohan> SumitNaiksatam: sure. if we have time, we can attempt to do devstack as well
18:55:14 <SumitNaiksatam> #action RajeshMohan to scope out documentation changes for firewall insertion patch
18:55:35 <RajeshMohan> SumitNaiksatam: ok
18:56:05 <SumitNaiksatam> #topic Custom objects
18:56:21 <SumitNaiksatam> Yi, there?
18:56:30 <SumitNaiksatam> i think yi dropped off
18:56:43 <SumitNaiksatam> gduan: anything you wanted to update or bring up on his behalf?
18:56:58 <gduan> SumitNaiksatam: no
18:57:12 <SumitNaiksatam> #topic Open Discussion
18:57:34 <SumitNaiksatam> btw, just a reminder, the feature proposal freeze deadline is Feb 18th
18:57:56 <SumitNaiksatam> in case we want to propose anything new
18:58:38 <SumitNaiksatam> i am not sure if the client/CLI is covered by this freeze
18:58:57 <SumitNaiksatam> but we need to post a patch regardless to go with the firewall insertion patch
18:59:09 <SumitNaiksatam> folks, anything else?
18:59:23 <SridarK> yes agreed will assume that Feb 18 holds for CLI as well
18:59:32 <SumitNaiksatam> SridarK: great, thanks
18:59:56 <SumitNaiksatam> okay, thanks all!
19:00:00 <SumitNaiksatam> #endmeeting