18:43:54 <SumitNaiksatam> #startmeeting Networking FWaaS
18:43:55 <openstack> Meeting started Wed May  7 18:43:54 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:43:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:43:58 <openstack> The meeting name has been set to 'networking_fwaas'
18:44:11 <SumitNaiksatam> so we discussed the priorities over the last week
18:44:22 <sballe> SumitNaiksatam, I'll stay for this one :-)
18:44:35 <SumitNaiksatam> sballe: sure, most welcome :-)
18:44:43 <sballe> SumitNaiksatam, thx :)
18:45:35 <SumitNaiksatam> #info etherpad for summit: https://etherpad.openstack.org/p/juno-fwaas
18:45:44 <SridarK> SumitNaiksatam: have put in some basic stuff
18:45:49 <SumitNaiksatam> SridarK: thanks much for the updates!
18:46:10 <SumitNaiksatam> #topic Integration with Flavor Framework
18:46:13 <SridarK> we can update on the specific BP links shortly
18:46:33 <SumitNaiksatam> gduan: you are going to take this up, or enikanorov will do it?
18:46:49 <SumitNaiksatam> i am guessing enikanorov is swamped
18:46:52 <enikanorov> i think STF is still pending
18:47:02 <SumitNaiksatam> enikanorov: i agree
18:47:05 <enikanorov> that needs to be merged to start working with flavors integration
18:47:17 <SumitNaiksatam> enikanorov: ok, so we dont have consensus on that?
18:47:31 <SridarK> enikanorov: we will also have more discussion on this in ATL on STF ?
18:47:33 <SumitNaiksatam> enikanorov: sorry, i forgot to bring it up in the adv services meeting!
18:47:38 <enikanorov> i think we do. gduan: could you update the patch with new version?
18:48:06 <enikanorov> SridarK: i think i'll cover  it briefly on design track
18:48:07 <gduan> enikanorov: you mean sync?
18:48:16 <SumitNaiksatam> enikanorov: i believe from the last meeting, the PTL agreed to the STF direction?
18:48:31 <enikanorov> gduan: i don't remember the most recent version, so did you remove provider attr from the public API?
18:48:49 <gduan> enikanorov: ok. not yet. I will do that
18:49:00 <enikanorov> gduan: ok, that was the most important change
18:49:27 <gduan> enikanorov: sure. will do it today/tomorrow and submit spec too
18:49:29 <enikanorov> SumitNaiksatam: i think Kyle agreed, but markmcclain's concerns need to be addressed
18:49:31 <enikanorov> (if any)
18:49:50 <SumitNaiksatam> enikanorov: ok, i think we need to get a move on
18:49:58 <SridarK> SumitNaiksatam: one sec
18:50:15 <SumitNaiksatam> enikanorov: if required lets have a separate meeting and plough through any objections
18:50:22 <SridarK> SumitNaiksatam: i guess we keep the same BP
18:50:44 <SumitNaiksatam> SridarK: we can keep the same bp, but we will need to create a bp spec in review
18:50:45 <enikanorov> SumitNaiksatam: okay
18:50:57 <enikanorov> SumitNaiksatam: i'll talk with Mark
18:51:17 <SridarK> SumitNaiksatam: ok
18:51:19 <SumitNaiksatam> enikanorov: we can invite the PTL, markmcclain1 and whoever else is interested
18:51:32 <SumitNaiksatam> enikanorov: thanks
18:51:36 <SridarK> SumitNaiksatam: this will be good
18:51:46 <SumitNaiksatam> SridarK: good point to bring up from process perspective
18:52:16 <SumitNaiksatam> so once the STF issue is settled, who is doing the flavor’s patch for FWaaS?
18:53:05 <SumitNaiksatam> ok perhaps we need to get STF patch in first
18:53:16 <SumitNaiksatam> gduan: you need to file a new bp for STF, right?
18:53:31 <SumitNaiksatam> gduan: assumign we have thumbs up for using STF
18:53:48 <gduan> SumitNaiksatam: just spec for review, right?
18:53:55 <SumitNaiksatam> gduan: yeah
18:54:05 <gduan> SumitNaiksatam: will do it today
18:54:12 <gduan> SumitNaiksatam: but it will be very short
18:54:15 <SumitNaiksatam> gduan: thanks!
18:54:21 <SumitNaiksatam> gduan: yes sure
18:54:28 <SumitNaiksatam> enikanorov: btw, is there a new spec for STF?
18:54:44 <SumitNaiksatam> enikanorov: you mentioned changes earlier, where have those been made?
18:54:48 <enikanorov> SumitNaiksatam: not yet, haven't managed to prepare it
18:54:53 <SumitNaiksatam> enikanorov: ah ok
18:55:01 <SumitNaiksatam> enikanorov: but you have a patch in review?
18:55:18 <enikanorov> SumitNaiksatam: i meant the changes of gduan's patch
18:55:24 <SumitNaiksatam> enikanorov: ok
18:55:28 <enikanorov> where public STF attributes need to be removed
18:55:48 <SumitNaiksatam> enikanorov: ah got it, to prepare it for flavors integration
18:56:30 <SumitNaiksatam> gduan: so no dependency for you as far as this is concerned
18:57:45 <SumitNaiksatam> so lets get the STF in first, and circle back to the flavors patch
18:57:59 <SumitNaiksatam> #topic FWaaS Service Insertion
18:58:15 <SumitNaiksatam> so we have to create a bp for this as well
18:58:36 <SumitNaiksatam> and it will have a dependency on the service insertion stuff discussed earlier
18:58:51 <SumitNaiksatam> we also need to check with kanzhe if he is planning to add support for this
18:58:55 <SumitNaiksatam> in fwaas
18:59:23 <SumitNaiksatam> but this is our priority for juno to be able to insertion on a specific router
18:59:36 <SridarK> SumitNaiksatam: ok was just going to ask if that will only cover the base infrastructure or have a sample implementation
18:59:57 <SumitNaiksatam> #action SumitNaiksatam to check with Kanzhe on service insertion support for fwaas
19:00:03 <SridarK> SumitNaiksatam: If Kanzhe does that - we will get it for free :-)
19:00:17 <SumitNaiksatam> SridarK: yeah that was my understanding :-)
19:00:53 <SridarK> SumitNaiksatam: so we should not refer to the old BP on this in the ether pad - i will remove that
19:01:01 <SumitNaiksatam> ok
19:01:04 <SumitNaiksatam> let be there for now
19:01:09 <SridarK> ok
19:01:14 <SumitNaiksatam> since there is no insertion bp
19:01:23 <SridarK> ok got it
19:01:29 <SumitNaiksatam> in fact let the old one be there, and we can add a second one
19:01:37 <SridarK> ok
19:01:40 <SumitNaiksatam> it will help people to know the history
19:01:46 <SumitNaiksatam> SridarK: thanks for bringing that up
19:02:00 <SridarK> np
19:02:10 <SumitNaiksatam> #topic FWaaS Service Objects
19:02:19 <SumitNaiksatam> beyounn: we are on track for this?
19:02:34 <SumitNaiksatam> beyounn: submit the bp in gerrit that is?
19:03:21 <SumitNaiksatam> gduan: can you check with beyounn?
19:03:40 <SumitNaiksatam> we need the bp to be in gerrit before the summit, so that we can discuss
19:04:22 <SumitNaiksatam> #topic FWaaS Zones
19:04:36 <SumitNaiksatam> SridarK: i know you have been busy with the critical bug
19:04:53 <SridarK> SumitNaiksatam: working on the write up based on last weeks discussions
19:05:01 <SumitNaiksatam> SridarK: ok
19:05:10 <SridarK> will have it gerrit in tne next day or two
19:05:33 <SumitNaiksatam> SridarK: lets also keep an eye on the service insertion discussion since these are interpendent
19:05:49 <SumitNaiksatam> SridarK: i would recommend first putting in google doc
19:05:55 <SridarK> SumitNaiksatam: yes very much so - will indicate dependency on that
19:06:04 <SumitNaiksatam> SridarK:  it might be faster and easier to draw diagrams
19:06:06 <SridarK> SumitNaiksatam: ok that makes more sense
19:06:15 <SridarK> will do that
19:06:24 <SumitNaiksatam> SridarK: you can then fill the gerrit template at leisure
19:06:32 <SridarK> sounds good
19:06:51 <SumitNaiksatam> SridarK: we want validate the proposal first
19:07:11 <SridarK> ok we can discuss first then
19:07:25 <SumitNaiksatam> SridarK: i know we spent a lot of time earlier on this, but i still dont have a crisp idea in my mind
19:07:53 <SumitNaiksatam> SridarK gduan: one question i have though, is it always possible to “infer” zones?
19:08:11 <SridarK> SumitNaiksatam: ok and in any case there are the dependencies and that influences a lot of how we specify
19:08:40 <SridarK> SumitNaiksatam: hmm! infer - i am not sure we can do that always
19:08:49 <SumitNaiksatam> meaning if the particular firewall backend implementation always requires a zones configuration, can the driver map the neutron constructs to a zone?
19:08:56 <SumitNaiksatam> SridarK: ok
19:09:09 <SumitNaiksatam> SridarK: its ok if we cannot handle all the cases
19:09:26 <SridarK> SumitNaiksatam: u are thinking of the default case kind of scenario ?
19:09:37 <SumitNaiksatam> SridarK: yeah
19:10:10 <SridarK> SumitNaiksatam: that i think we can do by having something like a any zone to any zone
19:10:20 <SumitNaiksatam> SridarK: ah ok
19:10:43 <SumitNaiksatam> SridarK: i was hoping a little more specific than that, but i myself dont have a clear idea in mind
19:10:52 <SumitNaiksatam> SridarK:  so i am just loud thinking
19:10:53 <SridarK> i probab did not say that very well but basically like a regular firewall
19:11:07 <SumitNaiksatam> SridarK: ok
19:11:21 <SridarK> SumitNaiksatam: will clarify that in the doc
19:11:34 <SumitNaiksatam> SridarK: do we know if any of the vendor folks who use zones are going to be around for the discussion?
19:12:15 <SridarK> SumitNaiksatam: not sure on that - i am trying to troll our mktg guys for some user scenarios that they can share
19:12:23 <SumitNaiksatam> SridarK: :-)
19:12:37 <SumitNaiksatam> SridarK: if they dont want it, we are off the hook?!? :-P
19:13:05 <SumitNaiksatam> moving on
19:13:09 <SumitNaiksatam> #topic FWaaS Ceilometer Requirements
19:13:10 <SridarK> SumitNaiksatam: i think i need to rephrase my ask in that way - i am sure i will get a quick response :-)
19:13:19 <SumitNaiksatam> SridarK: :-)
19:13:34 <SumitNaiksatam> SridarK: is prad around?
19:13:57 <SumitNaiksatam> you have updated the etherpad with the requirements
19:14:08 <SridarK> yes added the basic ones
19:14:19 <SumitNaiksatam> my understanding was the same in speaking to him
19:14:21 <SridarK> i will need to also reflect the usage - metrics that we can do
19:14:38 <SumitNaiksatam> who is filing the bp for this?
19:14:40 <SridarK> or rather we dont have to do anything for that
19:14:57 <SridarK> He has a BP on the Ceilometer side
19:15:03 <SumitNaiksatam> will prad have the bandwidth to do it in neutron?
19:15:08 <SumitNaiksatam> at least file the bp
19:15:10 <SridarK> not sure on that
19:15:17 <SridarK> will follow up on that
19:15:23 <SumitNaiksatam> i would rather prefer that the requirements are driven from ceilometer
19:15:46 <SumitNaiksatam> i mean someone from that team files the bp on the neutron side as well
19:16:08 <SridarK> yes makes sense - will let him know and we can prioritize the implementation based on bandwidth
19:16:10 <SumitNaiksatam> i believe RajeshMohan mentioned he would have time to pursue this if needed
19:16:15 <SumitNaiksatam> SridarK: thank
19:16:18 <SumitNaiksatam> s
19:16:23 <SridarK> ok cool
19:16:44 <SumitNaiksatam> #topic Vendor drivers
19:17:02 <SumitNaiksatam> gduan: there?
19:17:30 <SridarK> Hmm seems like gduan dropped off
19:17:56 <SridarK> But he did mention that they may be doing a refactor of the existing
19:17:59 <SridarK> impl
19:18:09 <SumitNaiksatam> ok, i wanted to track the bp
19:18:19 <SumitNaiksatam> it needs to be added
19:18:33 <SumitNaiksatam> I also see Cisco driver
19:18:37 <SumitNaiksatam> who is doing it?
19:18:53 <SumitNaiksatam> i mean who is creating the bp for it?
19:18:58 <SridarK> Yes i will file the BP and push for Gerrit review
19:19:03 <SumitNaiksatam> SridarK:  ok good
19:19:19 <SridarK> on implementation perhaps others will join in as well not clear
19:19:31 <SumitNaiksatam> SridarK: yes, good, better to get help on that
19:19:39 <SumitNaiksatam> SridarK: we will need you on core fwaas
19:19:55 <SridarK> SumitNaiksatam: :-)
19:20:18 <SumitNaiksatam> SridarK: though it should be made clear that blueprints expire at the end of the release cycle
19:20:33 <SumitNaiksatam> at least thats my current understanding
19:20:36 <SridarK> SumitNaiksatam: may need some vendor extensions on that BP will get ur thoughts on that offline
19:20:45 <SridarK> SumitNaiksatam: ok
19:21:32 <SumitNaiksatam> SridarK:  ok sure
19:21:37 <SumitNaiksatam> #topic open discussion
19:21:58 <SumitNaiksatam> i think we will have our plates overflowing with the above in Juno
19:22:14 <SridarK> SumitNaiksatam: yes i think Juno will be a tight release
19:22:19 <SumitNaiksatam> so i think this is a good plan to be discussed in the summit
19:22:33 <SridarK> look fwd to that - it will be good to have something shipped in Juno
19:22:35 <SumitNaiksatam> SridarK:  yeah i dont know how far we can get with the above
19:22:53 <SumitNaiksatam> i guess it all depends on the reviewer turn around!
19:23:03 <SridarK> SumitNaiksatam: we will give it our best push
19:23:10 <SumitNaiksatam> SridarK: absolutely (for a change) ! :-)
19:23:33 <SumitNaiksatam> also we have to go through two rounds of reviews
19:23:41 <SumitNaiksatam> one for the bp and one for the code
19:23:48 <SridarK> With the BP reviews - it is good to get folks plugged in early and hopefully will help on the code reviews
19:23:56 <SumitNaiksatam> hopefully the bp review wont take the entire cycle :-P
19:24:01 <SridarK> :-)
19:24:14 <SumitNaiksatam> alrighty lets wrap it!
19:24:21 <SridarK> SumitNaiksatam: sounds good
19:24:25 <SumitNaiksatam> anything else?
19:24:31 <SridarK> no nothing
19:24:37 <SridarK> see u at ATL
19:24:52 <SridarK> will send u email on the zones doc
19:24:57 <SumitNaiksatam> SridarK gduan beyounn sballe: thanks for joining, see you in ATL
19:24:58 <SumitNaiksatam> bye
19:25:01 <SumitNaiksatam> #endmeeting