18:42:04 <SumitNaiksatam> #startmeeting Networking FWaaS
18:42:04 <openstack> Meeting started Wed Jun 11 18:42:04 2014 UTC and is due to finish in 60 minutes.  The chair is SumitNaiksatam. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:42:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:42:07 <openstack> The meeting name has been set to 'networking_fwaas'
18:42:21 <SumitNaiksatam> #info agenda https://wiki.openstack.org/wiki/Meetings/FWaaS
18:42:30 <SumitNaiksatam> #topic bugs
18:42:48 <SumitNaiksatam> SridarK: thanks for the terrific work on following up with the bugs
18:42:57 <badveli> hello all, i would be participating in the meeting
18:43:27 <SumitNaiksatam> badveli: welcome!
18:43:33 <badveli> thanks sumit
18:43:33 <SumitNaiksatam> #link https://bugs.launchpad.net/neutron/+bug/1310857
18:43:36 <SridarK> SumitNaiksatam: no worries, thanks to enikanorov: for fixing the last one
18:43:41 <SridarK> badveli: hi
18:43:43 <SumitNaiksatam> enikanorov: thanks
18:43:48 <SumitNaiksatam> SridarK: link?
18:44:17 <badveli> hello sridark
18:44:33 <enikanorov> I need to say that fwaas team need to revisit and clarify state transitions for firewall objects
18:44:46 <SumitNaiksatam> enikanorov: explain?
18:44:49 <enikanorov> that was my impression from fixing that gate issue with firewalls
18:45:17 <SridarK> enikanorov: this is also an artifact of the being installed on all routers in the tenant
18:45:28 <enikanorov> SumitNaiksatam: logic around state transitions is not always clear, it also not quite clear which objects could be updated/deleted from DB in which states
18:45:30 <SridarK> at least this previous issue
18:45:42 <SumitNaiksatam> SridarK: yes, i responded to the private email thread yesterday saying pretty much the same
18:46:09 <SumitNaiksatam> enikanorov: okay, i thought we only have state/status for the firewall resources
18:46:26 <SumitNaiksatam> enikanorov: and that has a well defined state transition
18:46:35 <enikanorov> hmm, ok
18:46:44 <enikanorov> anyway i have changed it a little bit
18:46:47 <enikanorov> with my latest fix
18:46:54 <SumitNaiksatam> enikanorov: happy to revisit and fix anything that you may have discovered is inconsistent
18:47:01 <SumitNaiksatam> enikanorov: link?
18:47:09 <enikanorov> 1 sec
18:47:14 <SumitNaiksatam> enikanorov: sure
18:47:23 <enikanorov> SumitNaiksatam: https://review.openstack.org/#/c/98956/
18:47:30 <SumitNaiksatam> enikanorov: thanks
18:48:34 <SumitNaiksatam> enikanorov: i will take a look, this was approved before i noticed it (i am on personal leave right now)
18:48:52 <SumitNaiksatam> SridarK: you seemed to have +1'ed
18:48:55 <enikanorov> btw, SridarK thanks for your recent comment, it explains the issue to me
18:49:11 <enikanorov> because I was confused of tempest-side of it
18:49:43 <enikanorov> (tempest test waits for firewall to become ACTIVE, but apparently some other router appears and agent changes the status again)
18:49:45 <SridarK> SumitNaiksatam: yes - i think this is good as with the timing on us being joined at the hip with routers getting added
18:50:02 <SridarK> enikanorov: yes
18:50:20 <enikanorov> SumitNaiksatam: btw I have not yet congratulated you (about the reason of your personal leave :P )
18:50:35 <SumitNaiksatam> enikanorov: np, thanks :-)
18:50:36 <enikanorov> so my congratulations! :)
18:50:52 <SumitNaiksatam> enikanorov: thanks, quite unexpected, so still coping with it
18:51:04 <SumitNaiksatam> i mean, unexpected because it was early
18:51:15 <SumitNaiksatam> 5 weeks early
18:51:18 <SumitNaiksatam> anyway
18:51:28 <SumitNaiksatam> so i was again looking at: https://bugs.launchpad.net/neutron/+bug/1310857
18:51:38 <enikanorov> i see, it's almost always unexpected (in general) :)
18:51:46 <SumitNaiksatam> enikanorov: hahaha :-)
18:51:55 <enikanorov> (even if you're expecting it)
18:52:00 <SumitNaiksatam> enikanorov: yeah
18:52:12 <garyduan> enikanorov: nice one
18:52:18 <SumitNaiksatam> the above is the only high priority bug
18:52:30 <SumitNaiksatam> and the review has been sitting for some time
18:52:55 <SridarK> yes more comments were added
18:53:10 <SumitNaiksatam> SridarK garyduan can you also look at: https://review.openstack.org/#/c/90575/
18:53:13 <SumitNaiksatam> SridarK: thanks
18:53:22 <SumitNaiksatam> we need to contact the patch author
18:53:23 <garyduan> I will
18:53:36 <SumitNaiksatam> and possilbly markmcclain since he has -2
18:54:58 <garyduan> I reported one bug in Horizon in firewall configuration page
18:55:10 <SumitNaiksatam> garyduan: thanks, sorry i did not respond to that
18:55:17 <SumitNaiksatam> garyduan: is it getting attention?
18:55:26 <garyduan> thanks for SridarK to locate a reviewer for it
18:55:41 <SumitNaiksatam> garyduan: if not we can ping akihiro
18:55:49 <SumitNaiksatam> amotoki: there?
18:55:50 <garyduan> The comment is to add test cases
18:56:06 <SumitNaiksatam> garyduan: link to review patch?
18:56:15 <garyduan> https://review.openstack.org/#/c/96654/
18:57:42 <SumitNaiksatam> i took the liberty of adding amotoki to the review
18:57:55 <SumitNaiksatam> garyduan: let us know if you dont get attention
18:58:05 <SumitNaiksatam> thanks to abishek for reviewing
18:58:08 <garyduan> SumitNaiksatam: thanks
18:58:17 <SridarK> Sorry guys got bounced out
18:58:25 <SumitNaiksatam> SridarK: np
18:58:33 <SridarK> garyduan: so u got the review
18:58:37 <SumitNaiksatam> SridarK garyduan: any other bugs of immediate concern?
18:58:46 <SumitNaiksatam> SridarK: i have added amotoki as well
18:58:56 <SridarK> SumitNaiksatam: ok
18:58:56 <garyduan> SridarK: yes, thanks. KC also reviewed it.
18:59:07 <garyduan> no
18:59:09 <SridarK> garyduan: ok
19:00:03 <SumitNaiksatam> garyduan: ah nice to see KC particpating
19:00:10 <SumitNaiksatam> we dont have a patch for https://review.openstack.org/#/c/90575/
19:00:45 <SumitNaiksatam> it has been claimed
19:00:49 <SumitNaiksatam> but i dont see a patch
19:01:07 <SumitNaiksatam> that said, this is working as designed
19:02:35 <SumitNaiksatam> sorry i pasted the wrong link
19:02:52 <SumitNaiksatam> i meant to say we dont have a patch for: #link https://bugs.launchpad.net/neutron/+bug/1323299
19:03:09 <SumitNaiksatam> #link SumitNaiksatam SridarK to check with owner of https://bugs.launchpad.net/neutron/+bug/1323299
19:03:25 <SumitNaiksatam> #action SumitNaiksatam SridarK to check with owner of https://bugs.launchpad.net/neutron/+bug/1323299
19:03:54 <SumitNaiksatam> #action SumitNaiksatam SridarK garyduan to review https://review.openstack.org/#/c/90575/
19:04:53 <SumitNaiksatam> enikanorov: you assigned this to yourself: #link https://bugs.launchpad.net/neutron/+bug/1327057
19:05:04 <SumitNaiksatam> enikanorov: are you planning on posting a patch?
19:05:09 <enikanorov> SumitNaiksatam: sure
19:05:24 <SumitNaiksatam> enikanorov: i mean i was just asking
19:05:46 <SumitNaiksatam> enikanorov: i know you are swamped
19:05:58 <SumitNaiksatam> enikanorov: if you dont have time let us know
19:06:00 <enikanorov> but i'm still able to make some progress :)
19:06:44 <SumitNaiksatam> enikanorov: nice :-)
19:07:00 <SumitNaiksatam> ok we have few more bugs which we have not triaged, will do that
19:07:18 <SumitNaiksatam> #action SumitNaiksatam to triage “undecided” bugs
19:08:03 <SumitNaiksatam> #topic Juno Plan
19:08:06 <SumitNaiksatam> #link https://wiki.openstack.org/wiki/Neutron/FWaaS/JunoPlan
19:08:39 <SumitNaiksatam> SridarK_ garyduan yisun prad: i dont see that the above ^^^ has been updated
19:09:18 <SumitNaiksatam> sorry, SridarK seems to have updated
19:09:46 <badveli> sumit, can i look at 1327057
19:09:49 <SumitNaiksatam> garyduan: i believe you are blocked on flavors discussion
19:10:14 <SumitNaiksatam> badveli: sure, can you coordinate with enikanorov
19:10:24 <badveli> i can work with enikanorov
19:10:25 <garyduan> SumitNaiksatam: right.
19:10:55 <garyduan> badveli is sitting next to me. :-)
19:10:58 <SumitNaiksatam> badveli: i am sorry, i couldn’t decipher your name from the nick
19:11:08 <SumitNaiksatam> garyduan: ah ok
19:11:34 <badveli> sumit my name is vishnu, will follow up with enikanorov
19:11:37 <SumitNaiksatam> garyduan: can you formally introduce badveli to the team? :-)
19:11:40 <garyduan> Yi also updated his blueprint about Service Object and patch
19:11:50 <SumitNaiksatam> badveli: Vishnu welcome again
19:12:04 <SridarK> sorry guys some issue with my machine and keep getting bounced -
19:12:07 <SumitNaiksatam> garyduan: one sec we will come to the individual blueprint
19:12:08 <badveli> thanks sumit
19:12:14 <SumitNaiksatam> SridarK: np
19:12:23 <SridarK> not sure if u asked me something
19:12:27 <SumitNaiksatam> SridarK: we assigned you an action item nevertheless :-P
19:12:37 <SridarK> SumitNaiksatam: :-)
19:12:42 <garyduan> Vishnu will work with me and Yi, focusing on FWaaS effort
19:12:55 <prad> SumitNaiksatam, So regarding metering work i have the initial draft of the spec on ceilometer side https://review.openstack.org/#/c/95779/5 .. For HitCounts, Is Rajesh planning to look at it?
19:12:59 <SumitNaiksatam> garyduan: thanks, thats great
19:13:20 <SumitNaiksatam> prad: nice, can you please udpate the wiki page with the link
19:13:23 <prad> SumitNaiksatam, if you guys have time, would probably useful for us to meet up separate and decide whats feasible on FWaaS side for juno-2
19:13:25 <SridarK> prad: did u bring up the issue we discussed in the morn
19:13:31 <SumitNaiksatam> i believe rajesh is not around
19:13:37 <prad> SumitNaiksatam, ok
19:13:44 <SumitNaiksatam> prad: we can discussion here or in a separate meeting
19:13:47 <SumitNaiksatam> prad: please go ahead
19:14:04 <prad> for one metric we discussed was the usage at the summit.. and i was looking to do that based on create/update events
19:14:15 <SumitNaiksatam> prad: ok
19:15:01 <prad> but on ceilometer side, it would be tricky to handle these samples over a period of time
19:15:05 <prad> even with a transformer
19:15:10 <SumitNaiksatam> #action prad to update https://wiki.openstack.org/wiki/Neutron/FWaaS/JunoPlan with spec links
19:15:33 <prad> as we need to grab a definite amount of samples to conclusive determine the usage and there is a chance collector service went down loosing samples
19:15:42 <SumitNaiksatam> prad: one sec, from a process perspective, we will need specs for any work that needs to be done on the neutron side
19:15:52 <prad> so in the spec above, i dint add the usage, but would like to see the feasibility
19:16:01 <SumitNaiksatam> prad: we can coordinate with Rajesh as to who should do it, you or him
19:16:07 <SumitNaiksatam> prad: if you want to do it, thats great
19:16:08 <prad> sure
19:16:23 <SumitNaiksatam> prad: sorry, i interrupted you on the usage part
19:16:37 <prad> SumitNaiksatam, if we can get the bw/connections info similar to how LBaaS is giving us on FWaaS side, that would be a goos start
19:16:52 <prad> if you see the metrics table in the spec, i have some info there
19:17:00 <SumitNaiksatam> #action prad to sync up with RajeshMohan on hit counts, perhpaps suggest a separate meeting with the fwaas team
19:17:11 <SumitNaiksatam> prad: that is tough
19:17:26 <prad> ok
19:17:32 <SumitNaiksatam> prad: link to metrics?
19:18:01 <prad> SumitNaiksatam, https://review.openstack.org/#/c/95779/5/specs/juno/ceilometer-meter-fwaas.rst
19:18:05 <SumitNaiksatam> #topic Ceilometer requirements
19:18:14 <SumitNaiksatam> #link https://review.openstack.org/#/c/95779/5/specs/juno/ceilometer-meter-fwaas.rst
19:18:43 <SumitNaiksatam> SridarK garyduan yisun: you have thoughts on capturing the usage?
19:18:56 <prad> SumitNaiksatam, also i see a few api calls that are already there on neutron side.. like list_firewall, list_fw_rule and list_fw_policy which would be useful in general to track a fw existence and bill users
19:19:07 <SumitNaiksatam> prad: sure
19:19:39 <prad> SumitNaiksatam, so i can at least get started on implementing one of two on these lines.. the big ones are connections and bw
19:19:59 <SumitNaiksatam> prad: ok thats good to hear, for that you dont need anything more on the fwaas side?
19:20:01 <garyduan> Probably not all counters can be retrieved easily from iptables
19:20:10 <SumitNaiksatam> garyduan: yeah, my thinking too
19:20:32 <SumitNaiksatam> garyduan: can we come up with something that is reasonable, perhaps not as detailed?
19:20:39 <SumitNaiksatam> * but perhaps
19:20:46 <prad> SumitNaiksatam, for connections and bw.. i do need a call similar to retrieve_pool_stats on lbaas side
19:21:01 <SumitNaiksatam> prad: yeah, sure i got that
19:21:18 <SumitNaiksatam> prad: that will require more discussion
19:21:24 <prad> sure understand
19:21:30 <SumitNaiksatam> prad: can we say that you have three sets of requirements
19:21:55 <SumitNaiksatam> prad: there is one set which is already satisfied by the list_* calls
19:22:18 <prad> SumitNaiksatam, yea other two are usage and stats
19:22:19 <SumitNaiksatam> prad: then there is the second one for which you need to support with the hit counts
19:22:26 <prad> yep
19:22:37 <SumitNaiksatam> prad: and the third is the connection/bandwith tracking
19:22:52 <SumitNaiksatam> prad: ok
19:23:07 <SumitNaiksatam> prad: i think we will tackle them in that priority
19:23:21 <SumitNaiksatam> prad: i find it difficult that we will get to the last one in Juno
19:23:27 <prad> yea ..i can get the first implemented on ceilometer side without waiting
19:23:32 <SumitNaiksatam> prad: ok good
19:23:41 <SumitNaiksatam> prad: thanks for the udpate
19:24:07 <prad> sure, if we can coordinate with Rajesh soon it would be helpful to make the plan clear for fwaas side
19:24:11 <prad> sure
19:24:14 <SumitNaiksatam> and for joining the meeting, to make progress it will be nice if you can participate in these meetings, so we can give you the support you need
19:24:27 <prad> SumitNaiksatam, will do sir
19:24:33 <SridarK> SumitNaiksatam: i will also reach out to Rajesh to check
19:24:36 <SumitNaiksatam> prad: sure, i can send out the email today (unless you or SridarK want to do it)
19:24:41 <SumitNaiksatam> SridarK: sure go ahead
19:24:45 <SumitNaiksatam> lets move on
19:24:51 <prad> thx
19:24:56 <SumitNaiksatam> #topic Service objects
19:25:06 <SumitNaiksatam> i think we can go a little over with our meeting time
19:25:11 <SumitNaiksatam> yisun: there?
19:25:32 <SumitNaiksatam> i know i asked a bunch of questions and yisun posted a new patch set
19:25:36 <garyduan> He is in meeting
19:25:41 <SumitNaiksatam> garyduan: ok
19:25:43 <SridarK> I have been reviewing also
19:25:49 <SumitNaiksatam> garyduan: you can proxy
19:25:52 <SumitNaiksatam> SridarK: absolutely
19:26:03 <SumitNaiksatam> SridarK: but i think you are in agreement with the spec
19:26:03 <SridarK> i am ok - just need clarification on service obj to service group
19:26:14 <SridarK> yes
19:26:24 <SridarK> now we are thinking 1 : 1
19:26:26 <SumitNaiksatam> whereas i am still having a bit of an issue with there being so much overlap with the firewall rule
19:26:46 <SridarK> but can we effect a 1 : many (serve obj : src grp) later on
19:26:47 <garyduan> Sridar, Yi and me had some discussion on the spec, and we are in agreement
19:27:00 <SridarK> will there be a backwards compatibility issue ?
19:27:01 <SumitNaiksatam> i am not sure that the neutron core team is going to be happy with the subsets of the attributes being defined in different places
19:27:38 <garyduan> Service group is optional
19:27:44 <SumitNaiksatam> i am trying to come up with a more concrete suggestion
19:27:49 <SumitNaiksatam> garyduan: that is fine
19:27:56 <SumitNaiksatam> garyduan: but concern still stand
19:27:58 <SumitNaiksatam> stands
19:28:01 <garyduan> current way of inputting protocol and port are still allowed
19:28:10 <SumitNaiksatam> garyduan: i agree and understand
19:28:26 <SumitNaiksatam> garyduan: i am trying to figure out if we can reuse existing definitions
19:28:42 <SumitNaiksatam> does that make sense to the you guys or its just me?
19:28:55 <SridarK> SumitNaiksatam: by existing what do u mean ?
19:29:05 <garyduan> SumitNaiksatam: reuse?
19:29:08 <SumitNaiksatam> SridarK: attributes in the firewall rule
19:29:33 <SridarK> SumitNaiksatam: hmm - u mean just add to the rule directly ?
19:29:36 <SumitNaiksatam> i am not comfortable with the same attributes being defined in many difrerent places
19:29:57 <SumitNaiksatam> SridarK: yeah, i am trying to think what is the good way to do that
19:30:21 <garyduan> SumitNaiksatam: you mean allowing protocol/port and service group at the same time?
19:30:59 <SumitNaiksatam> garyduan: i am saying that there is lot of overlap between the firewall_rule and the service_object
19:31:59 <garyduan> Can we say, the current model is experimental, and we can plan to face out protocol/port setting in firewall rule?
19:32:27 <SridarK> Hmm! so one will always need to use a service group ?
19:32:34 <SumitNaiksatam> garyduan: that will be challenging
19:32:50 <SumitNaiksatam> SridarK: yeah good point, thats the concern
19:32:52 <garyduan> SridarK: service group and object
19:33:15 <garyduan> There will be predefined objects
19:33:31 <SridarK> I guess with service groups - most vendor implementions do have this overlap
19:33:39 <SumitNaiksatam> can service object use a firewall_rule?
19:34:04 <SumitNaiksatam> ignore if thats a dumb question
19:34:40 <garyduan> I am not sure. I will have to ask Yi
19:34:53 <SumitNaiksatam> garyduan:  ok
19:35:10 <SumitNaiksatam> #topic FWaaS and DVR
19:35:29 <SumitNaiksatam> did yisun manage to send the email to the mailing list
19:35:55 <SumitNaiksatam> unfortunately, i could not respond to the thread he started in the team
19:35:57 <garyduan> He has been in the DVR meeting
19:36:02 <SumitNaiksatam> garyduan: ok good
19:36:11 <SumitNaiksatam> garyduan: and how is that shaping up?
19:36:30 <SumitNaiksatam> garyduan: do we have consensus on an approach?
19:36:44 <garyduan> There is a way to support FWaaS with DVR
19:36:56 <SumitNaiksatam> #action yisun to update team on FWaaS/DVR support
19:36:58 <garyduan> but performance and packet flow is quite complicated
19:37:04 <garyduan> so still in discussing
19:37:06 <SumitNaiksatam> garyduan: great, thats good to hear
19:37:54 <SumitNaiksatam> #action garyduan to check with yisun if service_objects can reuse firewall_rules in some way
19:38:40 <SumitNaiksatam> #topic Open Discussion
19:38:41 <garyduan> by reusing, you mean translate existing protocol/ports to service object?
19:38:48 <SumitNaiksatam> #undo
19:38:49 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x23b9f90>
19:39:18 <SumitNaiksatam> garyduan: i meant that we dont have to repeat the overlapping attributes in two places
19:39:43 <SridarK> really sorry guys i am having terrible connectivity today
19:40:03 <garyduan> SumitNaiksatam: I will discuss that with Yi
19:40:03 <badveli> goal of the service object much more than the firewall rule
19:40:13 <SumitNaiksatam> SridarK: np, you got back in time before we have you the next action item ;-P
19:40:21 <badveli> if we go through the bp
19:40:22 <SumitNaiksatam> badveli: i agree
19:40:28 <SridarK> :-)
19:40:30 <SumitNaiksatam> badveli: i dont dispute that
19:40:50 <SridarK> but we still want to anchor to the FW rule ?
19:41:09 <SumitNaiksatam> SridarK: i am just thinking loud
19:41:09 <garyduan> yes.
19:41:10 <badveli> this is used to group
19:41:37 <badveli> as per the bp
19:41:38 <SridarK> SumitNaiksatam: no good - best to hash out now
19:41:46 <SumitNaiksatam> SridarK garyduan badveli: brain wave (based on what SridarK just said), what if we do attribute extension for firewall_rule?
19:42:24 <SridarK> oh just have an extension for this new attribute ?
19:42:30 <badveli> but the service group can be thaught of like a container
19:42:32 <SumitNaiksatam> SridarK: yeah
19:42:37 <badveli> and be used by the firewall
19:42:44 <badveli> rule
19:42:57 <SumitNaiksatam> badveli: ah good point
19:43:02 <SumitNaiksatam> let me think a little more
19:43:25 <SridarK> SumitNaiksatam: yes i agree with badveli - i think that is the intent
19:43:28 <SumitNaiksatam> #action SumitNaiksatam to explore if any attribute extension can be used to support service_object
19:43:48 <SridarK> SumitNaiksatam: perhaps we can also continue more discussion offline
19:43:53 <SumitNaiksatam> badveli SridarK: i agree my suggestion was turning the model on its head
19:43:55 <garyduan> sure
19:43:58 <SumitNaiksatam> SridarK:  yes
19:44:08 <SumitNaiksatam> so we are 3 mins over time
19:44:21 <SumitNaiksatam> #topic Open Discussion
19:44:31 <SumitNaiksatam> SridarK: we dont have zones spec, so i skipped
19:44:34 <SridarK> SumitNaiksatam: i will get a zones review out real soon
19:44:35 <SumitNaiksatam> anything else?
19:44:39 <SumitNaiksatam> SridarK: thanks much
19:44:50 <SridarK> nothing much else
19:44:52 <SumitNaiksatam> SridarK:  but we really appreciate that you are prioritizing attention to the bugs
19:45:08 <SridarK> SumitNaiksatam: no worries - it has been "interesting" :-)
19:45:16 <SumitNaiksatam> SridarK: we need to fix the existing issues even as we plan for new features
19:45:30 <SumitNaiksatam> SridarK: i am sure, but happy that you are “enjoying” it :-)
19:45:35 <SridarK> SumitNaiksatam: agree
19:45:49 <SumitNaiksatam> garyduan prad badveli: anything else you want to discuss?
19:45:56 <SridarK> SumitNaiksatam: perhaps i should not have said that :-)
19:46:16 <SumitNaiksatam> SridarK: no i put words into your mouth :-P
19:46:16 <SridarK> prad: we will follow up more on this metering too
19:46:22 <SridarK> :-)
19:46:58 <SumitNaiksatam> btw, i just wanted to say thanks all for your support in the past few days, it was challenging to say the least, and it continues to be so
19:47:19 <SridarK> SumitNaiksatam: is this time from the morning ur "relaxation" ?
19:47:23 <SridarK> :-)
19:47:28 <SumitNaiksatam> :-)
19:47:36 <SridarK> now u have to get back to some really hard work now
19:47:41 <SumitNaiksatam> i am not so much concerned about my relaxation
19:47:43 <SridarK> :-)
19:47:48 <SumitNaiksatam> SridarK: :-)
19:47:58 <SumitNaiksatam> all right thanks all, lets call it a wrap for today
19:48:06 <SridarK> Ok bye all
19:48:10 <SumitNaiksatam> lots of AIs to deal with :-P
19:48:13 <SumitNaiksatam> #endmeeting